[xml2rfc] XML2RFC Mite Report?

hsantos at isdg.net (hector santos) Sun, 16 April 2006 22:05 UTC

From: hsantos at isdg.net (hector santos)
Date: Sun, 16 Apr 2006 22:05:42 +0000
Subject: [xml2rfc] XML2RFC Mite Report?
Message-ID: <008401c661dc$62248de0$0201a8c0@hdev1>
X-Date: Sun Apr 16 22:05:42 2006

I don't enough about XML2RFC or XSLT to tell to tell where exactly this
little mite begins, if any, but this is what I see:

I created a list with a sub-list with the desired output:

    1. Item1

    2. Item2

         a. subitem1
         b. subitem2
         c. subitem3

    3. Item3

    4. Item4

This is done with:

  <t><list style="numbers">
    <t>Item1<vspace blankLines="1" /></t>
    <t>Item2<vspace blankLines="1" />
        <list style="letters">
        <t>Subitem1</t>
        <t>Subitem2</t>
        <t>Subitem3<vspace blankLines="1" /></t>
        </list></t>
    <t>Item3<vspace blankLines="1" /></t>
    <t>Item4</t>
  </list></t>

When viewed with XXE menu option: XML2RFC | HTML Preview via XSL, the above
spacing is correct.

When viewed with the web site HTML converters: it appears as such:

    1. Item1

    2. Item2

         a.
            subitem1
         b.
            subitem2
         c.
            subitem3

    3. Item3

    4. Item4

Note the linefeeds.

However, if I change the inner list to symbols, then it is correct:

    1. Item1

    2. Item2

         o subitem1
         o subitem2
         o subitem3

    3. Item3

    4. Item4

Note: In text mode, this linefeed problem with lettered list is not seen.

---
Hector