[Atp] Mohamed Boucadair's Block on charter-ietf-atp-00-00: (with BLOCK and COMMENT)
Mohamed Boucadair via Datatracker <noreply@ietf.org> Mon, 12 January 2026 12:53 UTC
Return-Path: <noreply@ietf.org>
X-Original-To: atp@ietf.org
Delivered-To: atp@mail2.ietf.org
Received: from [10.244.6.11] (unknown [4.156.85.76]) by mail2.ietf.org (Postfix) with ESMTP id 4AD11A663DA4; Mon, 12 Jan 2026 04:53:37 -0800 (PST)
MIME-Version: 1.0
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: 8bit
From: Mohamed Boucadair via Datatracker <noreply@ietf.org>
To: The IESG <iesg@ietf.org>
X-Test-IDTracker: no
X-IETF-IDTracker: 12.55.0
Auto-Submitted: auto-generated
Precedence: bulk
Message-ID: <176822241710.649226.16928297986729251748@dt-datatracker-5656579b89-r5kdq>
Date: Mon, 12 Jan 2026 04:53:37 -0800
Message-ID-Hash: 4BDNYB6LDDRJNDOMQ3HX3OVMK7YRIEEP
X-Message-ID-Hash: 4BDNYB6LDDRJNDOMQ3HX3OVMK7YRIEEP
X-MailFrom: noreply@ietf.org
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: atp-chairs@ietf.org, atp@ietf.org
X-Mailman-Version: 3.3.9rc6
Reply-To: Mohamed Boucadair <mohamed.boucadair@orange.com>
Subject: [Atp] Mohamed Boucadair's Block on charter-ietf-atp-00-00: (with BLOCK and COMMENT)
List-Id: Authenticated Transfer <atp.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/atp/VUs9ZPxdU4dwAAqB2NuWVz6XeOE>
List-Archive: <https://mailarchive.ietf.org/arch/browse/atp>
List-Help: <mailto:atp-request@ietf.org?subject=help>
List-Owner: <mailto:atp-owner@ietf.org>
List-Post: <mailto:atp@ietf.org>
List-Subscribe: <mailto:atp-join@ietf.org>
List-Unsubscribe: <mailto:atp-leave@ietf.org>
Mohamed Boucadair has entered the following ballot position for charter-ietf-atp-00-00: Block When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.) The document, along with other ballot positions, can be found here: https://datatracker.ietf.org/doc/charter-ietf-atp/ ---------------------------------------------------------------------- BLOCK: ---------------------------------------------------------------------- Hi all, Thanks for the effort to put this charter together. Please find below some comments for discussion: # Clarity: "Account", "streaming", and "network" ## There are parts of the charter text that I think need some clarification. For example, it is not clear what “account” are being discussed here. I understand that these accounts are not application-specific (given that “Any social application semantics” is out of scope). This can be fixed by first introducing the concept (and without assuming familiarity with draft-holmgren-at-repository or the arch spec). ## Likewise, “streaming synchronization protocol" is listed as deliverable but the narrative text does not introduce it. At least, I’m lacking context to understand why the qualifier “streaming” is added here compared to simply reason about “synchronization protocol”. ## What is meant by “network” here? CURRENT: The network will give small independent participants global visibility and distribution without prior coordination Also, how is that related to the “organizational boundaries” mentioned in the following, for example: CURRENT: The protocol enables synchronization of public data across organizational boundaries ## What is a “network transport” in the context of ATP? CURRENT: The streaming protocol should allow for alternative network transports # Manageablity and operation RFC 2418 says the following: To facilitate evaluation of the intended work and to provide on- going guidance to the working group, the charter must describe the problem being solved and should discuss objectives and expected impact with respect to: - Architecture - Operations - Security - Network management - Scaling - Transition (where applicable) The current charter includes requirements about scalability and backward compatibility. However, and given that the “protocol enables synchronization of public data across organizational boundaries”, wouldn’t, e.g. some mechanisms be needed to verify and check correct operation across these boundaries? Other OAM tasks may be needed as well. Also, there might be additional operational considerations to “give small independent participants global visibility and distribution without prior coordination”, etc. I'm not asking to answer these now, but suggest to add a mention that operational (including manageability and OAM in general) applicability will be provided as part of the work. ---------------------------------------------------------------------- COMMENT: ---------------------------------------------------------------------- # I support the points raised by Andy. # Business as usual CURRENT: All existing work must undergo a consensus process Per our process, any work (adoption) is subject to consensus. Is there any reason why this mention is included here? # Centralization considerations: is this about RFC 9518? CURRENT: Privacy and Centralization considerations will be documented (eg, per RFC 6973) and will inform design decisions. Not sure which "Centralization considerations" you have in mind? If you are referring to RFC 9518, then consider citing it. Cheers, Med
- [Atp] Mohamed Boucadair's Block on charter-ietf-a… Mohamed Boucadair via Datatracker
- [Atp] Re: Mohamed Boucadair's Block on charter-ie… Orie
- [Atp] Re: Mohamed Boucadair's Block on charter-ie… Daniel Holmgren
- [Atp] Re: Mohamed Boucadair's Block on charter-ie… mohamed.boucadair
- [Atp] Re: Mohamed Boucadair's Block on charter-ie… Orie