[auth48] Re: AUTH48: RFC-to-be 9966 <draft-ietf-emu-bootstrapped-tls-11> for your review
"Owen Friel (ofriel)" <ofriel@cisco.com> Mon, 18 May 2026 14:56 UTC
Return-Path: <ofriel@cisco.com>
X-Original-To: auth48archive@mail2.ietf.org
Delivered-To: auth48archive@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id 4D13FF0219DB; Mon, 18 May 2026 07:56:57 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=ietf.org; s=ietf1; t=1779116217; bh=qbdMLNKZBUrY1gQNlAncWAivSMVlUAB+qlSphlotyj8=; h=From:To:CC:Subject:Date:References:In-Reply-To; b=vcZIqp/KbR+nLM26bSz4BBSY/8anuNjYObNI7H9CB2kXU+xDAlf7sXOl586gG6nqN WpKxaEKVwvyy2eSeGvimI1eYDvfsQFU064CehwT5544ZGijKrJ6K69fi4Av+TYfuYP DgYAgZTFhRK5mIxO/As2yx2+33VjgGUwxifKhpro=
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -11.886
X-Spam-Level:
X-Spam-Status: No, score=-11.886 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIMWL_WL_MED=-0.001, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, RCVD_IN_DNSWL_MED=-2.3, RCVD_IN_MSPIKE_H4=0.001, RCVD_IN_MSPIKE_WL=0.001, RCVD_IN_VALIDITY_CERTIFIED_BLOCKED=0.001, RCVD_IN_VALIDITY_RPBL_BLOCKED=0.001, SPF_NONE=0.001, T_SPF_HELO_PERMERROR=0.01, USER_IN_DEF_DKIM_WL=-7.5] autolearn=unavailable autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=pass (2048-bit key) header.d=cisco.com
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id pf8BwFQZbrkZ; Mon, 18 May 2026 07:56:56 -0700 (PDT)
Received: from alln-iport-2.cisco.com (alln-iport-2.cisco.com [173.37.142.89]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id 1BCDEF0219BF; Mon, 18 May 2026 07:56:56 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=cisco.com; i=@cisco.com; l=17638; q=dns/txt; s=iport01; t=1779116216; x=1780325816; h=from:to:cc:subject:date:message-id:references: in-reply-to:content-transfer-encoding:mime-version; bh=qbdMLNKZBUrY1gQNlAncWAivSMVlUAB+qlSphlotyj8=; b=jz2SOlJqFEbaJBD3XGcqt5RZGD03NvDayOQjP6ncJurncSe/CG9/2rNT VD4E4W7448zEgRnGWL4Dn6zG2WHMyGfTSeaurpWFFUEXuNUXD/a1biZTo 2Y2/wO2hp2c2B5kQMxK/Dcm43sLWCPCU8z3VRXKI7gH7eNTT4b74qi5iF YZxB28zD4sayP/hsRQYMREBtpHDbrNLLBrSBD/lHeDGruBcehXty4fdJy tH2Z2YVkOulc4Zq3YDS9RGRQ8f1nWZv5cxJ+4tf3KKx3Lw0+z0GjlZPlB OhVxqcOn1ufVd2sIjpiQli2UZ8YcgCKNb7eZhue9Mx/mTQMt68q5DC0SE Q==;
X-CSE-ConnectionGUID: eZxtFmbxTwesfvrQEcR0hg==
X-CSE-MsgGUID: QPfbA74mRpiQ+Os8jF5q8Q==
X-IPAS-Result: A0A7AADPJwtq/4r/Ja0+HB0BAQEBCQESAQUFAWWBFwgBCwGBbSopgQiBIUmEV4NMA4RNX4h5A5FKjFAUgWsPAQEBDQJEDQQBAYUGAhaNHAImNAkOAQIEAwIDAQEBAQEBAQEBAQELAQEFAQEBAgEHBYEOE4YVCDINhloBAQEBAQISEQQNOgQHDAQCAQgRBAEBAwImAgICLxUICAIEAQ0FCBqCYYJzAwECDgZBpisBgT0Ciip6fzOBAYNtQNt+BhSBCy4BhT6DGQEBgXCCTIEhGYR7JxuBSUSBFUKCaD6CYQIBARiBCQQDAQEMBgEHAhqDWTqCLwSCDRVjFxSBZy2DMIFkhzsJSXgcA1ksAVUTFwsHBWFCEDMDIAovLQIUDSIPGgUtHXAMJxIPHRcVHlgbBwUSISpuShxcGgMDDSEkEQMxBCFBOAtGBYF0AoIdGV8jLwNLgS1NAwttPRQjBg4bAwQ6ewWKKBwPgT4QFRULJgYBKhMmBA0aAQoRDgITOzIYOAoFHgEEAQULAY1zhUoSCDiCbEmaP5NZC4EzCoQcjB6ONIc8F4JLgTlNjEYDjUuINoJpZ5kGIoI2izGVNi4PAwqFDQIEAgQFAhABAQaBaDwrPnBwFRohgjMBM1MZD4E2jiEBAiOHOcQTeQI8AQcCBw4CgXOEY4sdAScEcAFgAQE
IronPort-PHdr: A9a23:2Q7cnxDeddT0IH8EqRwsUyQVXRdPi9zP1kY9454jjfdJaqu8us2kN 03E7vIrh1jMDs3X6PNB3vLfqLuoGXcB7pCIrG0YfdRSWgUEh8Qbk01oAMOMBUDhav+/Ryc7B 89FElRi+hmG
IronPort-Data: A9a23:6Bo35aPkxU/AEubvrR3LlsFynXyQoLVcMsEvi/4bfWQNrUokgzUGy 2tLDTrVOPffN2r0fNFxPN608kpTvJHRnNdgGXM5pCpnJ55oRWUpJjg4wmPYZX76whjrFRo/h ykmQoCeaphyFTmE+kvF3oHJ9RFUzbuPSqf3FNnKMyVwQR4MYCo6gHqPocZh6mJTqYb/WVjlV e/a+ZWFZgf4gm4sbgr41orawP9RlKWq0N8nlgRWicBj5Df2i3QTBZQDEqC9R1OQapVUBOOzW 9HYx7i/+G7Dlz91Yj9yuu+mGqGiaue60Tmm0hK6aYD76vRxjnBaPpIACRYpQRw/ZwNlMDxG4 I4lWZSYEW/FN0BX8QgXe0Ew/ypWZcWq9FJbSJSymZT78qHIT5fj6/hcHF0YOIcIxvl6Gm9Q7 8U1IwpVbh/W0opawJrjIgVtrt4oIM+uOMYUvWttiGmAS/0nWpvEBa7N4Le03h9p2ZsIRqmYP ZdEL2M0PHwsYDUXUrsTIJUwhualglH0ciZTrxSeoq9fD237k1ApjOWwaoKJEjCMbfxtkEyx+ T7DxXz4O1I9L4yd52ecokv504cjmgu+Aur+DoaQ/+N2gAHDz3YYCBwIWHOhr/L8h0K/R9VFb UsO9UIGt6Y5sUGnT8X6RTWirnXBsxIdR91KVeog52mwJrH8+Q2VAC0ACzVGctFj7JZwTj0x3 VjPlNTsbdByjICopbum3u78hRu5ODMeKikJYipscOfPy4CLTF0b5v4XcuteLQ==
IronPort-HdrOrdr: A9a23:GRIe9q6MTxy49SSO6QPXwceCI+orL9Y04lQ7vn2ZFiYlEfBwxv rPoB1E737JYW4qKQ8dcLC7VJVpQRvnhPhICPoqTMaftW7dySSVxeBZnMffKlLbalfDH4JmpM Ndmu1FeaLN5DtB/IjHCWuDYqsdKbC8mcjC65a9vhJQpENRGt1dBmxCe3+m+zhNNXJ77O0CZe KhD6R81l2dUEVSRP6WQlMCWO/OrcDKkpXJXT4qbiRM1CC+yRmTxPrfCRa34jcyOgkj/Z4StU TVmQ3w4auu98q81gLd0GHr6ZFXksvKy9dIBsCA4/JlawkEjDzGWK1RH5m5+BwlquCm71gn1P PWpQ07Ash143TNOkmovBrEwWDboXUTwk6n7WXdrWrooMT/Sj5/IdFGn5hlfhzQ7FdllM1g0Z hMw3mSu/NsfFH9dWXGlp31viNR5w2JSEkZ4KguZrtkINIjgYpq3MgiFYVuYc899WzBmdsa+a JVfbHhDb5tACCnhjbizylS6e3peGgvFRGbRUVHkMmU3z9K2E1d9SIjtZYidrNqzuNgd3GCjN 60b5hAhfVASNQbYrl6A/pEScyrCnbVSRaJK26KJ0/7fZt3cE4lhqSHqYnd3tvaMKAg3d83gt DMQVlYvWk9dwbnDtCPxoRC9lTITH+mVTrgx8lC79wh04eMCYbDIGmGUhQjgsGgq/IQDonSXO uyIotfB7vmIXH1EYhE0gXiU91ZKGUYUscSptEnMmj+6P7jO8nvrKjWYfzTLL3iHXItXX7+GG IKWHzpKMBJ/imQKwnFadjqKgTQk2DEjOZN+fLhjpouIaA2R/hxjjQ=
X-Talos-CUID: 9a23:cBoTRWNIUnkaAu5DVRt36GARENAZbXDGwmnKGmKzMz5pR+jA
X-Talos-MUID: 9a23:XIcZ2wWN4WDcjVDq/AbUijtLa5tt2byvMQMqisUElZSdZRUlbg==
X-IronPort-Anti-Spam-Filtered: true
Received: from rcdn-l-core-01.cisco.com ([173.37.255.138]) by alln-iport-2.cisco.com with ESMTP/TLS/TLS_AES_256_GCM_SHA384; 18 May 2026 14:56:54 +0000
Received: from alln-opgw-1.cisco.com (alln-opgw-1.cisco.com [173.37.147.229]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature RSA-PSS (2048 bits) server-digest SHA256) (No client certificate requested) by rcdn-l-core-01.cisco.com (Postfix) with ESMTPS id B2D38180001C4; Mon, 18 May 2026 14:56:54 +0000 (GMT)
X-CSE-ConnectionGUID: yr3WP2DVSry0aChqedGY3w==
X-CSE-MsgGUID: Nob+uXNISk+Pp/byiXXJJA==
Authentication-Results: alln-opgw-1.cisco.com; dkim=pass (signature verified) header.i=@cisco.com
X-IronPort-AV: E=Sophos;i="6.23,242,1770595200"; d="scan'208";a="74993391"
Received: from mail-dm2pr0701cu00103.outbound.protection.outlook.com (HELO DM2PR0701CU001.outbound.protection.outlook.com) ([40.93.13.67]) by alln-opgw-1.cisco.com with ESMTP/TLS/TLS_AES_256_GCM_SHA384; 18 May 2026 14:56:54 +0000
ARC-Seal: i=1; a=rsa-sha256; s=arcselector10001; d=microsoft.com; cv=none; b=YvaWHjg8Fmv3j26TaQhPK7dhkRwSNDGGi7FbjNE1hZC5UH3MwBtOt68LthACP2O5h0LWdnS8tkfwHHPJ1wdJ0tnWXXzteyXtm91ldrk8CdXgzfvfpcmRm5PRo5Tm4i3OmE5IoPKZorfoGtzoC5jrHPWlmpgdQRKH7wNV0vKoVmGeiS4gXiqlZEXJKuKR2OJE7plOC5C3AWzH7UgH9N+f02DJodYnohQ9ic9XkhTEMK5vfpu+ua0HqZRybWkxUOXkm9Zl35A1syWOhx6nfZBqI1dzDVaaFHZXsnFopw14psjeos9VRGOZxUFaq7osygqlWukHjFypy++8lsSmDNsWzQ==
ARC-Message-Signature: i=1; a=rsa-sha256; c=relaxed/relaxed; d=microsoft.com; s=arcselector10001; h=From:Date:Subject:Message-ID:Content-Type:MIME-Version:X-MS-Exchange-AntiSpam-MessageData-ChunkCount:X-MS-Exchange-AntiSpam-MessageData-0:X-MS-Exchange-AntiSpam-MessageData-1; bh=qbdMLNKZBUrY1gQNlAncWAivSMVlUAB+qlSphlotyj8=; b=mRPkTlN5ELHim432x37wombjKLR5SbB1p4Pn58tQ3jDkf84tVgA+1ZozeDMTG7+70i8io4gFYWE+UKY2q2PYN6RCOJ8ttBLrNlJqR5twstSIBxFHUi+qmCug37PvJLOD+ukx0mq/dd1NVPaD1yoC4hGfN0x6+QuAM2KkUQuLyh2ILrShrMmo2Spq5nYNAXucpcI8114DX0kLoMsnZiirUGPtclcMY9z68fJCwkmKlwxuFqJajoPupg4N6gt3s3bnDdmYgxxHwDW6JxmBl9XfoDgTf0vF17zXXbha06YORcfKwj2rxDuZwYH6SEkwXyYkVyimedgPvvY9VOx3vxdupQ==
ARC-Authentication-Results: i=1; mx.microsoft.com 1; spf=pass smtp.mailfrom=cisco.com; dmarc=pass action=none header.from=cisco.com; dkim=pass header.d=cisco.com; arc=none
Received: from PH0PR11MB5080.namprd11.prod.outlook.com (2603:10b6:510:3f::23) by IA1PR11MB7368.namprd11.prod.outlook.com (2603:10b6:208:420::7) with Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) id 15.21.25.22; Mon, 18 May 2026 14:56:49 +0000
Received: from PH0PR11MB5080.namprd11.prod.outlook.com ([fe80::4b28:eefc:8fda:76ac]) by PH0PR11MB5080.namprd11.prod.outlook.com ([fe80::4b28:eefc:8fda:76ac%6]) with mapi id 15.21.0025.020; Mon, 18 May 2026 14:56:48 +0000
From: "Owen Friel (ofriel)" <ofriel@cisco.com>
To: "rfc-editor@rfc-editor.org" <rfc-editor@rfc-editor.org>, "daniel.harkins@hpe.com" <daniel.harkins@hpe.com>
Thread-Topic: AUTH48: RFC-to-be 9966 <draft-ietf-emu-bootstrapped-tls-11> for your review
Thread-Index: AQHc1srbrpxAbp39IkSzOcZUeu/iC7YT+9gQ
Date: Mon, 18 May 2026 14:56:48 +0000
Message-ID: <PH0PR11MB508081C97B911F27D5FCEAD1DB032@PH0PR11MB5080.namprd11.prod.outlook.com>
References: <20260428045204.1E8462CCE7A@rfcpa.rfc-editor.org>
In-Reply-To: <20260428045204.1E8462CCE7A@rfcpa.rfc-editor.org>
Accept-Language: en-US
Content-Language: en-US
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
x-ms-publictraffictype: Email
x-ms-traffictypediagnostic: PH0PR11MB5080:EE_|IA1PR11MB7368:EE_
x-ms-office365-filtering-correlation-id: 3e2faaef-99b6-452e-0739-08deb4edb028
x-ms-exchange-senderadcheck: 1
x-ms-exchange-antispam-relay: 0
x-microsoft-antispam: BCL:0;ARA:13230040|366016|376014|1800799024|38070700021|22082099003|56012099003|18002099003|3023799003|11063799003;
x-microsoft-antispam-message-info: UrrCPHy7mps5uevFYMstMDGExO6iPInj4nqi7aavq1bDlAJco485m2iQ9p66VgjEKY5jRy6oURmSSQaKIyopQ2w8RckSc8H6fyZmhI9UEtEeBC+GfBNcVZ6pjoSkKkDHrM65aFZnJ66xNJfzoNsCJ30hgoYYHpBsKlXch/R88UtH8irokGFi97AT1YXT5+oR4NTJwYnx8TE27Gy/qZL6FT5L0zkuxzJBHOpBiArheKs2Sx2hitFKxEL3gC8C2PT7pj40wrNTMt4Tsumpb7ZI19D8Xbdj1rXoky28ndKLDva1GGqJSmlZQXzKCVMGHYCEBzsKQGeC3E6htis8q7cTZ/5JeWJSjFkz/5EylhwkiSlKg3r+uBbUGOfgrVXSukoErUdrt00pVQ8geQyeoCFvYB35n1k7fqVWMiXAmf9JoRQVk/CnOmnMeBoMI78v7wlM5RFkK9LcCNQEnbb5auYhe9vKGa3OZgn+Lf98SfQzMx/ibnxko91pncmCY7zGhiTTF2vv4cMEyLqcrkOSng0n7Vmd+jlLBJCZhbVtQUDMa84hY5e4zudRpoEmqvAQ6xd8r07hYFNlgqfENlaD22JoQanoDVabnfgqKj44k8Vr12ng0EiobUbE5Gh4ynUiehuFZCjdAUEYzV1o4KQemhHjOYKraLgSw5gckN3CjypbJLfIdDlqqUpZS74GAGWkstjA+XIHAD1UR5TpGxLbQUhKKw==
x-forefront-antispam-report: CIP:255.255.255.255;CTRY:;LANG:en;SCL:1;SRV:;IPV:NLI;SFV:NSPM;H:PH0PR11MB5080.namprd11.prod.outlook.com;PTR:;CAT:NONE;SFS:(13230040)(366016)(376014)(1800799024)(38070700021)(22082099003)(56012099003)(18002099003)(3023799003)(11063799003);DIR:OUT;SFP:1101;
x-ms-exchange-antispam-messagedata-chunkcount: 1
x-ms-exchange-antispam-messagedata-0: O7TIrDz0nEeVLOKDwM/7/i+lo0WjAc5zPErI0hz10D0b54WyuAJ1/+L46raIiGIQQQvJme86vlmEYAp1sq5U99mfevyD3jx8dzLmpYx5asmr+BZLu2ITdhmHp1ZPnpBv+02hMGcjVmVT6zdQXuV0RQ/HdhRuj2GplSagOv/NvI+466ui172OYSw0ZqAYImGN/eikvmNGJ/v92JN50Dlz0ZzuWlOpfdRfyFbWZidxzWbhxCKhIH0LHpyUbmj+mTUzrKKtLXZpDvso1zpoHnJ7o1p1uj1VgG+wVJAGnMSETyFREZv6+axkg9zia4DmXliyD+0+c1n7aYn3qmC1MZCqakedJNmjbMi6iYIZm3H3ML5D3RqqSF5A0Z9OrQC9t+tsUJVZKqFSYFLeb9ZTOd7z331/mpIC1xRMMgKtwA1K6lbL8+JhRDNL4/5cQZ5fCWshj1kK9LEyG32gUlcmxgaQrPQ36TC1wVArRL6B+d1wk+gYFWUNy7etSObobz7sj7Emexe8dE39+S0MA8hUvgXu3EdYBknXr3uHjjTBK2ibbqQ5tY2M2I9wwE9bM1d2bov3M6E/qCocP5LsYD2Ltgtk9wHhgmVrQRDBo7UU+x+bOQpYcgqKHrN2VHeH/8i2w4nMRGLyXbT9Q5XzaeG1HIyrRLXfDkgqDQmbg7zjSQjWwvfbkB4w5P5WKKlROl6TRj+1PSJivZvTl+yqGHmdtw8MHcEvv15j3n+++HMfJAjNmVAd4oEWTPytYmnje2rXecigD/qdlWY8UC+spFRG3eLz+2jnj0stMh9QCvhMrRqAIvMmMecqvQbA5qjykRzNlTneZ8pC9/HrCe1jCQflwdFdI1X7fpedT+ZVbsNzl32E3Qlsx5lm3u70NLfvwoYfMImxYMj+hicGRbz363qjRKcXlHC7N7VhR377KFyJ5dxCHzxhxTdgrGVuBH7gzOD+IKdohSYwq8pmu/tkkMzUf5rNLi5bphe/KiLJVkbIuQdDaIUedMPcnclSIfDbDJMYgy8ASUc3TCL4GY0lw5JMHWr2QhZV/nwGuXPCP+jphVuYwerfsOfPj84yiZPAGYLouoz8iEdCPFOvIH+TQLZu5+QLmBiiX6cFYiim7LmFYnuDGoYdgBg+8Gf8//JZHpHgkAb7zVPQgerrbEB4nb1f+6sFxz1FTdW5lS3OM9FsOi+N41WeAF95o8TM/9CKnZ3kwsh6ewIiFfqayylt53XXcfc7pZBptaUU1B8BrC8TuHW6dzYMWmmwlHyBOhLVeI5Mz0NblUMES7b3oxCJA8dPonyslNBjr2udVaoOiBb34FmBtf+GkfHuavlsNp3a5TUsfEY8hsQYy/b8eFWvO/1CtbDq4mVhHOOsN7AH4BPryGA8b0FP6h2n8ognxj8nBlbgK4x9G2tiLNl360rXoUdEN+LHH4TwSt5gITWYQPI7H1X3AzbEDwnygrZ6a2ZMbZADcEiwmXVU5sGepF3e2xkkpakImvSoxpdoX0V3AKhmafivaF0lPID3Mu7wEYLLaTuShmSx65ygNZCJNcBoqonX4Yaub0okI4F4NWqBQjSKMSLvMFK/f6JLIRK4c5XCtGkX21wgscdTzpMZkKC9BvoGcT1HkyWcYNe2z2T8Kzf185Vk1PnybutrETWqhnGDi4bNFDmZbrLxuHIVkPQlWV7iEkO0uKbi+NLGNqrbq3fd4pb4hqM2jRz2Wjw4xEigVqMHLCEm
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: base64
MIME-Version: 1.0
X-Exchange-RoutingPolicyChecked: GiPtNZQbEiPBjWXf4tQ0PCJAeEUq/56CAEWClsccr2UYXU+MUEQD4Wmrk9R54dZbG1kxzltkn3iKp+3XH1oJKODoikd87WWhzEqBtnAaL1ZMa25jfzxPoo9tgbdsZOtq0hWrf4R4OpHJpLY8VFy7/ifZb8VXx/hCMbYE3/TD4DMG2hswz2vIaVQfidNz6e8ajHb/q/tCmpslHVcR5hMV3w577+ggXc9MFE4W6yAMZJawVShjNVjqYxF6Xpn1jsTy7SZ+1RYozTCI3uQRFcJNcv/evVuv1/+ccWHl8DtbEfkKrdBowLkrS5zLU1oxZSZQmcog9udGduIgFjZzmyENHA==
X-OriginatorOrg: cisco.com
X-MS-Exchange-CrossTenant-AuthAs: Internal
X-MS-Exchange-CrossTenant-AuthSource: PH0PR11MB5080.namprd11.prod.outlook.com
X-MS-Exchange-CrossTenant-Network-Message-Id: 3e2faaef-99b6-452e-0739-08deb4edb028
X-MS-Exchange-CrossTenant-originalarrivaltime: 18 May 2026 14:56:48.8519 (UTC)
X-MS-Exchange-CrossTenant-fromentityheader: Hosted
X-MS-Exchange-CrossTenant-id: 5ae1af62-9505-4097-a69a-c1553ef7840e
X-MS-Exchange-CrossTenant-mailboxtype: HOSTED
X-MS-Exchange-CrossTenant-userprincipalname: B6c7xgzh6+TWEFn6BpG1lekNcV6j7YIL3UhHNCuG0VgA1hA/2ih66aNA3ujBDR7G89qSZ2qMCumfIHNtpEYPDQ==
X-MS-Exchange-Transport-CrossTenantHeadersStamped: IA1PR11MB7368
X-Outbound-Client-TLS: ANONYMOUS;alln-opgw-1.cisco.com [173.37.147.229];TLSv1.3;TLS_AES_256_GCM_SHA384;256
X-Outbound-SMTP-Client: 173.37.147.229, alln-opgw-1.cisco.com
X-Outbound-Node: rcdn-l-core-01.cisco.com
Message-ID-Hash: EMKXZRV7WVW6F3GWHDIKHCBVASYJCOBS
X-Message-ID-Hash: EMKXZRV7WVW6F3GWHDIKHCBVASYJCOBS
X-MailFrom: ofriel@cisco.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: "emu-ads@ietf.org" <emu-ads@ietf.org>, "emu-chairs@ietf.org" <emu-chairs@ietf.org>, "peter@akayla.com" <peter@akayla.com>, "paul.wouters@aiven.io" <paul.wouters@aiven.io>, "auth48archive@rfc-editor.org" <auth48archive@rfc-editor.org>
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [auth48] Re: AUTH48: RFC-to-be 9966 <draft-ietf-emu-bootstrapped-tls-11> for your review
List-Id: "Archiving AUTH48 exchanges between the RFC Production Center, the authors, and other related parties" <auth48archive.rfc-editor.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/auth48archive/8gZwrFI3gSB5s5pZ9FssjvGY6n8>
List-Archive: <https://mailarchive.ietf.org/arch/browse/auth48archive>
List-Help: <mailto:auth48archive-request@rfc-editor.org?subject=help>
List-Owner: <mailto:auth48archive-owner@rfc-editor.org>
List-Post: <mailto:auth48archive@rfc-editor.org>
List-Subscribe: <mailto:auth48archive-join@rfc-editor.org>
List-Unsubscribe: <mailto:auth48archive-leave@rfc-editor.org>
Hi, Thank you for your review. See inline for [ofriel] Regards, Owen + Dan -----Original Message----- From: rfc-editor@rfc-editor.org <rfc-editor@rfc-editor.org> Sent: Tuesday 28 April 2026 05:52 To: Owen Friel (ofriel) <ofriel@cisco.com>; daniel.harkins@hpe.com Cc: rfc-editor@rfc-editor.org; emu-ads@ietf.org; emu-chairs@ietf.org; peter@akayla.com; paul.wouters@aiven.io; auth48archive@rfc-editor.org Subject: Re: AUTH48: RFC-to-be 9966 <draft-ietf-emu-bootstrapped-tls-11> for your review Authors, While reviewing this document during AUTH48, please resolve (as necessary) the following questions, which are also in the source file. 1) <!--[rfced] Might we remove the abbreviation from the title as it currently doesn't share a 1:1 relationship with the expansion? Or is there a way to match them up? Original: Bootstrapped TLS Authentication with Proof of Knowledge (TLS-POK) Expansion of TLS-POK per the document: TLS Proof of Knowledge --> [ofriel] We are fine with removing TLK-POK from the title 2) <!-- [rfced] Please insert any keywords (beyond those that appear in the title) for use on https://www.rfc-editor.org/search. --> [ofriel] We have no other additions. 3) <!--[rfced] We note that the Terminology section defines "802.1X". However, most uses in the document are actually the citation. Please review and let us know if/how to update. --> [ofriel] We are fine with removing the citation links to 802.1X throughout the doc after the terminology section, and only including 802.1X 4) <!--[rfced] Is there text missing here? Specifically, please focus on the part beginning with "for instance". (Note that RFC 7170 has been obsoleted by RFC 9930.) Original: Devices whose BSK public key can be obtained in an out-of-band fashion and provisioned on the EAP server can perform a TLS-based EAP exchange, for instance Tunnel Extensible Authentication Protocol (TEAP) [RFC7170], and authenticate the TLS exchange using the authentication mechanisms defined in Section 3. --> [ofriel] What about: "Devices whose BSK public key can be obtained in an out-of-band fashion and provisioned on the EAP server can authenticate with the EAP server using the mechanisms defined in Section 3 and Section 4." 5) <!--[rfced] Is the following text a comment? If so, may we request it be updated as follows (as this is in SVG, we assume the authors will update and regenerate. Original: target_kdf = <as per RFC9258> Perhaps: target_kdf = <as per RFC 9258> --> [ofriel] Yes, this can be changed to what you suggest. Do we have to upload a new document? Should we change from SVG to ASCII, would that make things easier? 6) <!--[rfced] Please review the difference between the SVG and ASCII art for Figure 1 with regard to the text immediately under ClientHello. In the ASCII, these are +'s while in the SVG a single line. If an update is necessary, please provide updated artwork.--> [ofriel] We think it should be "+" in the SVG anyway. Can you make that fix for us without us having to rev the doc? Should we change to ASCII? 7) <!--[rfced] Please review the title we added for Figure 2 in Section 4 and let us know if any further updates are necessary. Current: Figure 2: EAP Exchange Using TLS-POK --> [ofriel] Yes, this looks good. 8) <!--[rfced] We note that this document and the registry at https://www.iana.org/assignments/eap-numbers/eap-numbers.xhtml#eap-provisioning-ids both use hyphenated "Method-Type". However, see the use of "Method Type" at https://www.iana.org/assignments/eap-numbers/eap-numbers.xhtml#eap-numbers-4. Should these be made uniform here and at the IANA registry? Note that draft-ietf-emu-eap-arpa-10 now uses "Method Types" to match the "Method Types" registry. --> [ofriel] Yes, change to "Method Types" to align 9) <!-- [rfced] [IEEE802.1X] Please review. This reference currently points to the version of IEEE 802.1X from 2010. This version has been superseded. The newest version - IEEE 802.1X:2020 - was published in 2020. Note that this IEEE Std was also made an international standard - IEEE/ISO/IEC 8802-1X:2021 - in 2021. Should this reference be updated to one of the more current versions? --> [ofriel] Yes, go with the latest and greatest. 10) <!-- [rfced] We had the following questions regarding DPP: a) The [DPP] reference: Please review. We were unable to find a specification from Wi-Fi Alliance with the title "Device Provisioning Profile". We noticed that this document states: Device on-boarding protocols such as the Device Provisioning Profile [DPP], also referred to as Wi-Fi Easy Connect, address this use case but they have drawbacks. And the most current version of Wi-Fi Easy Connect specification states: The terms "Device Provisioning Protocol" and "DPP" found throughout this document are interchangeable with "Wi-Fi Easy Connect". May we update this reference to point to the most current version of the Wi-Fi Alliance "Wi-Fi Easy Connect" specification? Current: [DPP] Wi-Fi Alliance, "Device Provisioning Profile", 2020. Perhaps: [DPP] Wi-Fi Alliance, "Wi-Fi Easy Connect(TM) Specification", Version 3.0, 2022, <https://www.wi-fi.org/system/files/Wi- Fi_Easy_Connect_Specification_v3.0.pdf>. [ofriel] Yes, update to the latest reference. b) Please note that we see both of the following expansions for the DPP abbreviation: Device Provisioning Protocol Device Provisioning Profile Please let us know how to update for uniformity.--> [ofriel] Change to use "Device Provisioning Protocol" throughout. 11) <!--[rfced] We note that RFC 7170 has been obsoleted by RFC 9930. We have updated to the latter. Please let us know any objections. --> [ofriel] Yes, please use RFC 9930. 12) <!--[rfced] We see that the test vectors that exist in the appendices are not formatted in the XML as <sourcecode>. Additionally, as they currently exist, the portion in <tt> extends beyond the 72 character line limit. We suggest reformatting these as <sourcecode> with a type set to test-vectors (or maybe base64?). See https://www.rfc-editor.org/rpc/wiki/doku.php?id=sourcecode-types for more information on <sourcecode> types. --> [ofriel] Makes sense. Do we have anything do to here, or can you take care of this? 13) <!--[rfced] We had the following queries related to abbreviation use: a) We have removed expansions after first use and simply used the abbreviation per the guidance at https://www.rfc-editor.org/styleguide/part2/#exp_abbrev. [ofriel] Yes, this makes sense. b) As the K in BSK stands for "Key", is text like this redundant (more similar instances exist)? Original: Devices whose BSK public key can be obtained ... Same goes for EPSK: Original: ...the server looks up the client's EPSK key... Note also that there are some uses of "bootstrap public key". Please compare and contrast with "Bootstrap Key public key" (or BSK public key) to ensure that these are made uniform if necessary. --> [ofriel] We agree it makes sense to replace the 4 instances of "bootstrap public key" with "BSK public key" Thank you. Megan Ferguson RFC Production Center *****IMPORTANT***** Updated 2026/04/27 RFC Author(s): -------------- Instructions for Completing AUTH48 Your document has now entered AUTH48. Once it has been reviewed and approved by you and all coauthors, it will be published as an RFC. If an author is no longer available, there are several remedies available as listed in the FAQ (https://www.rfc-editor.org/faq/) You and you coauthors are responsible for engaging other parties (e.g., Contributors or Working Group) as necessary before providing your approval. Planning your review --------------------- Please review the following aspects of your document: * RFC Editor questions Please review and resolve any questions raised by the RFC Editor that have been included in the XML file as comments marked as follows: <!-- [rfced] ... --> These questions will also be sent in a subsequent email. * Changes submitted by coauthors Please ensure that you review any changes submitted by your coauthors. We assume that if you do not speak up that you agree to changes submitted by your coauthors. * Content Please review the full content of the document, as this cannot change once the RFC is published. Please pay particular attention to: - IANA considerations updates (if applicable) - contact information - references * Copyright notices and legends Please review the copyright notice and legends as defined in RFC 5378 and the Trust Legal Provisions (TLP – https://trustee.ietf.org/license-info) * Semantic markup Please review the markup in the XML file to ensure that elements of content are correctly tagged. For example, ensure that <sourcecode> and <artwork> are set correctly. See details at <https://authors.ietf.org/rfcxml-vocabulary>. * Formatted output Please review the PDF, HTML, and TXT files to ensure that the formatted output, as generated from the markup in the XML file, is reasonable. Please note that the TXT will have formatting limitations compared to the PDF and HTML. Submitting changes ------------------ To submit changes, please reply to this email using ‘REPLY ALL’ as all the parties CCed on this message need to see your changes. The parties include: * your coauthors * rfc-editor@rfc-editor.org (the RPC team) * other document participants, depending on the stream (e.g., IETF Stream participants are your working group chairs, the responsible ADs, and the document shepherd). * auth48archive@rfc-editor.org, which is a new archival mailing list to preserve AUTH48 conversations; it is not an active discussion list: * More info: https://mailarchive.ietf.org/arch/msg/ietf-announce/yb6lpIGh-4Q9l2USxIAe6P8O4Zc * The archive itself: https://mailarchive.ietf.org/arch/browse/auth48archive/ * Note: If only absolutely necessary, you may temporarily opt out of the archiving of messages (e.g., to discuss a sensitive matter). If needed, please add a note at the top of the message that you have dropped the address. When the discussion is concluded, auth48archive@rfc-editor.org will be re-added to the CC list and its addition will be noted at the top of the message. You may submit your changes in one of two ways: An update to the provided XML file — OR — An explicit list of changes in this format Section # (or indicate Global) OLD: old text NEW: new text You do not need to reply with both an updated XML file and an explicit list of changes, as either form is sufficient. We will ask a stream manager to review and approve any changes that seem beyond editorial in nature, e.g., addition of new text, deletion of text, and technical changes. Information about stream managers can be found in the FAQ. Editorial changes do not require approval from a stream manager. Approving for publication -------------------------- To approve your RFC for publication, please reply to this email stating that you approve this RFC for publication. Please use ‘REPLY ALL’, as all the parties CCed on this message need to see your approval. Files ----- The files are available here: https://www.rfc-editor.org/authors/rfc9966.xml https://www.rfc-editor.org/authors/rfc9966.html https://www.rfc-editor.org/authors/rfc9966.pdf https://www.rfc-editor.org/authors/rfc9966.txt Diff file of the text: https://www.rfc-editor.org/authors/rfc9966-diff.html https://www.rfc-editor.org/authors/rfc9966-rfcdiff.html (side by side) Diff of the XML: https://www.rfc-editor.org/authors/rfc9966-xmldiff1.html Tracking progress ----------------- The details of the AUTH48 status of your document are here: https://www.rfc-editor.org/auth48/rfc9966 Please let us know if you have any questions. Thank you for your cooperation, RFC Editor -------------------------------------- RFC9966 (draft-ietf-emu-bootstrapped-tls-11) Title : Bootstrapped TLS Authentication with Proof of Knowledge (TLS-POK) Author(s) : O. Friel, D. Harkins WG Chair(s) : Joseph A. Salowey, Peter E. Yee Area Director(s) : Deb Cooley, Christopher Inacio
- [auth48] AUTH48: RFC-to-be 9966 <draft-ietf-emu-b… rfc-editor
- [auth48] Re: AUTH48: RFC-to-be 9966 <draft-ietf-e… rfc-editor
- [auth48] Re: AUTH48: RFC-to-be 9966 <draft-ietf-e… Owen Friel (ofriel)
- [auth48] Re: AUTH48: RFC-to-be 9966 <draft-ietf-e… Harkins, Dan
- [auth48] Re: AUTH48: RFC-to-be 9966 <draft-ietf-e… Megan Ferguson
- [auth48] Re: AUTH48: RFC-to-be 9966 <draft-ietf-e… Harkins, Dan
- [auth48] Re: AUTH48: RFC-to-be 9966 <draft-ietf-e… Megan Ferguson
- [auth48] Re: AUTH48: RFC-to-be 9966 <draft-ietf-e… Harkins, Dan
- [auth48] Re: AUTH48: RFC-to-be 9966 <draft-ietf-e… Megan Ferguson
- [auth48] Re: AUTH48: RFC-to-be 9966 <draft-ietf-e… Harkins, Dan
- [auth48] Re: AUTH48: RFC-to-be 9966 <draft-ietf-e… Owen Friel (ofriel)