[auth48] Re: Document intake questions about draft-ietf-oauth-status-list

Sarah Tarrant <starrant@staff.rfc-editor.org> Thu, 11 June 2026 14:26 UTC

Return-Path: <starrant@staff.rfc-editor.org>
X-Original-To: auth48archive@mail2.ietf.org
Delivered-To: auth48archive@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id E6AA2FF5D627 for <auth48archive@mail2.ietf.org>; Thu, 11 Jun 2026 07:26:17 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=ietf.org; s=ietf1; t=1781187977; bh=9RdNUeQoHptlY1RBpN09qArXQa2CPw+zTgY3It1e65E=; h=Subject:From:In-Reply-To:Date:Cc:References:To; b=VZAOH8k2zhQnDUoP4bG0W9bIM4Ht2UUKU9nzX/Yos2+0xCbL95CR04kUvRsa45oLS Pl2DPbwsq43HzNdIK6mRDwlmQqRLEzy/xgRvijKPotqOO61+AHhLanM3WrUEvUerUp fvEYruA1z2Sm2e8fH3k1taav5dwVd3C32K6byNcY=
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -1.89
X-Spam-Level:
X-Spam-Status: No, score=-1.89 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, RCVD_IN_DNSWL_NONE=-0.0001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001, T_FILL_THIS_FORM_SHORT=0.01] autolearn=unavailable autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=pass (2048-bit key) header.d=staff-rfc-editor-org.20251104.gappssmtp.com
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 0mVzfP2-BF2D for <auth48archive@mail2.ietf.org>; Thu, 11 Jun 2026 07:26:17 -0700 (PDT)
Received: from mail-oi1-x232.google.com (mail-oi1-x232.google.com [IPv6:2607:f8b0:4864:20::232]) (using TLSv1.3 with cipher TLS_AES_128_GCM_SHA256 (128/128 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id 7B74BFF5D535 for <auth48archive@rfc-editor.org>; Thu, 11 Jun 2026 07:25:35 -0700 (PDT)
Received: by mail-oi1-x232.google.com with SMTP id 5614622812f47-48611addcfbso3211381b6e.1 for <auth48archive@rfc-editor.org>; Thu, 11 Jun 2026 07:25:35 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=staff-rfc-editor-org.20251104.gappssmtp.com; s=20251104; t=1781187929; x=1781792729; darn=rfc-editor.org; h=to:references:message-id:content-transfer-encoding:cc:date :in-reply-to:from:subject:mime-version:from:to:cc:subject:date :message-id:reply-to; bh=gWbQnATaMO1c8MeBfnVFfD83DHwNHCc+3vaHe/k92jI=; b=RTEEmkSIwe/BubyKjtw0roE+dYmIxh4ydlyUcCUA3xH7Jfh0Avefz99RT5NtP3fdcw EfosmC0VyyBRvEa/+vxNO/IKpJOrelYlaDhb+yX/CbHJ0EATyeBZTO0wHRmIv6m1lLlo erFpuTJRw3AzKdeOlB/bw6oBDpq5e5OQ0O10zNjcV1iAGV/R6ILScsX8POcbovLWg43k dEjOrE6YRFTEAqmlr39W+WFqK+9qqix7uYNE5ZCpEpM1nXQyCf3FlGrYvT4Sn9SXXSMU LJSwLHiPfhemUKXqu2WApXgnO5kBO4OZDNaFbkXy2H7l8xq70skn/BrCDLgJzh09R+F+ VyPg==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20251104; t=1781187929; x=1781792729; h=to:references:message-id:content-transfer-encoding:cc:date :in-reply-to:from:subject:mime-version:x-gm-gg:x-gm-message-state :from:to:cc:subject:date:message-id:reply-to; bh=gWbQnATaMO1c8MeBfnVFfD83DHwNHCc+3vaHe/k92jI=; b=aDIvr4DnDzqnJnh73l4EdLk/lCSakXqJ044PVsGAQFzrGLNeQqc6uwmR88y+Mtrhtt +luiK/plZT7MYk7LJwaUQyS0G4rF0j8LtKVRgXu95MpXfI5idi9AlDNPqNQtl3R1pasA JVKYoOqww/vVmU4/hJ0MQdz8j3jB4tINjB5gZMQr6kU/JkoIH8X+W9pXGuSw0VydlNaa pyJnQaX04s1a9HZ1BPHifGqr78wDIsqHBzkVFV+qXyEUN16R4TJGnzOZca+Ay2EI5xqa A2ZRQlVg5FnkpV/p2cCKrBg3eKxREwbL1XwWQsURZbRyYV9wd1c+CzJopziBsvPQv3w8 XSYA==
X-Forwarded-Encrypted: i=1; AFNElJ9YobPzrj26ve9rwNC8EjIAkefvtg5EXfjwE5VUgi01VeXDFYNMO0ET5jUEDQJpGIIouofK1HNlq8SyBLp5@rfc-editor.org
X-Gm-Message-State: AOJu0YxS/4S7GWjuwG+kMUCAzPM1rHNeHEbSXB1SlU3O20a8J/t7V6c9 m+MVHnCcxVD3QAoEo2/DC4+EEJUvZClo5PpAA+BzCT9WGKFtiHPk6eNeJM56TT8SElCAHA==
X-Gm-Gg: Acq92OHY3UNIUEh3da+Z7tLoj56xbQZtRo4+OXJuRlvxKYz3zlLPNMT22ohWde7AmcH HieMUrs8cTjuw892VZ9u6/m99JGEwcQ2Ne661wVtCkovCVYN1UHriH5GEnSVN1AEbS4TfPozfeE mIKyXyrxult226bXjl9h5H7+eh7PyT6LWA/jfL0VcMsLrY3jOyozKhLs9kK5OaewiRxXuDSenXV vWzTNzJSMgszaDEN9iAqLpFPJzmtoh85E/zq9hrW2kCRxGVAShMhbFjg7CAo3PS+rsNmPv5rL7w QfgzigPC64585Uz5JETqprtMd8DWA/+prfXmxFOAFzB1wnG7ps1dErRYdvltNnidcl01fNeFUN6 GS1rcY+BWXZ2zX1zN1hBDmOH8nkBoGbLq3wqy4HbV2hbC9XvV3a5YIEz20YcSTuXWSZf++Q0T+Q h8J4PZy/UvRSpyv73RjnlONu0f2kh4cSgwfr4OSmF+YEisAoAC/LiTGZ5HrYY6qPq5A9Q=
X-Received: by 2002:a05:6808:1304:b0:484:bbd2:851d with SMTP id 5614622812f47-4871a1b94c5mr2071697b6e.33.1781187929131; Thu, 11 Jun 2026 07:25:29 -0700 (PDT)
Received: from smtpclient.apple ([47.214.10.250]) by smtp.gmail.com with ESMTPSA id 5614622812f47-4865b5a5b5fsm21751924b6e.2.2026.06.11.07.25.27 (version=TLS1_2 cipher=ECDHE-ECDSA-AES128-GCM-SHA256 bits=128/128); Thu, 11 Jun 2026 07:25:28 -0700 (PDT)
Content-Type: text/plain; charset="utf-8"
Mime-Version: 1.0 (Mac OS X Mail 16.0 \(3864.400.21\))
From: Sarah Tarrant <starrant@staff.rfc-editor.org>
In-Reply-To: <4BF5B9A2-DB46-4915-907A-BF8A19EAE1CA@gmx.de>
Date: Thu, 11 Jun 2026 09:25:17 -0500
Content-Transfer-Encoding: quoted-printable
Message-Id: <2678E5DA-5A60-4997-AF04-110BE11BBB3D@staff.rfc-editor.org>
References: <178060863954.12.2812028340188958099@rfc-editor.org> <4BF5B9A2-DB46-4915-907A-BF8A19EAE1CA@gmx.de>
To: Christian Bormann <chris.bormann=40gmx.de@dmarc.ietf.org>, paul.bastian@bdr.de, tobias.looker@mattr.global
X-Mailer: Apple Mail (2.3864.400.21)
Message-ID-Hash: SS7ZL76VE5VDYXGEHS5I346SNEXI4IFZ
X-Message-ID-Hash: SS7ZL76VE5VDYXGEHS5I346SNEXI4IFZ
X-MailFrom: starrant@staff.rfc-editor.org
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: rfc-editor@rfc-editor.org, stndrds-inacio@andrew.cmu.edu, rifaat.s.ietf@gmail.com, debcooley1@gmail.com, auth48archive@rfc-editor.org
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [auth48] Re: Document intake questions about draft-ietf-oauth-status-list
List-Id: "Archiving AUTH48 exchanges between the RFC Production Center, the authors, and other related parties" <auth48archive.rfc-editor.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/auth48archive/LCa_CcFa9NoJVOq4OXiXFJur_Mk>
List-Archive: <https://mailarchive.ietf.org/arch/browse/auth48archive>
List-Help: <mailto:auth48archive-request@rfc-editor.org?subject=help>
List-Owner: <mailto:auth48archive-owner@rfc-editor.org>
List-Post: <mailto:auth48archive@rfc-editor.org>
List-Subscribe: <mailto:auth48archive-join@rfc-editor.org>
List-Unsubscribe: <mailto:auth48archive-leave@rfc-editor.org>

Hi Christian, Paul, and Tobias,

Thank you for your reply! I do have some followup questions/comments:

A) Regarding 3), yes, please! If you want to fix up those lists, please submit a new version to the datatracker. Once you do that, be sure to send me the updated self-contained markdown file as well.

B) Regarding 5), please take another look at the submitted XML file as I found <tt> throughout (e.g., bits, StatusList, lst, aggregation_ur, typ, etc.). If this was done unintentionally, please submit a corrected version that aligns with your intentions. However, if this was intentional, please let us know what patten you followed so that we can help keep the usage consistent in the document.

C) Regarding 6), I'm seeing sourcecode elements in the XML, particularly json, cddl, and (possibly) asn.1. This can get blurred between the markdown and the xml files, as markdown doesn't always have a "type" selected. If it is helpful to think of these elements as "formal language", see: https://authors.ietf.org/formal-languages. We just want to verify that what is in the submitted XML is correct and intentional, so please let us know that.

D) Regarding 7), I'm not able to parse the markdown file at: https://github.com/oauth-wg/draft-ietf-oauth-status-list/blob/main/draft-ietf-oauth-status-list.md?plain=1. It looks like a couple {::include elements were used; so, if you would like to proceed with markdown, we would need a self-contained file.

Sincerely,
Sarah Tarrant
RFC Production Center

> On Jun 11, 2026, at 2:07 AM, Christian Bormann <chris.bormann=40gmx.de@dmarc.ietf.org> wrote:
> 
> Dear RPC team,
> 
> Thanks, below are the answers to the questions:
> 
>> 1) As there may have been multiple updates made to the document during Last Call, 
>> please review the current version of the document: 
>> 
>> * Is the text in the Abstract still accurate?
>> * Are the Authors' Addresses, Contributors, and Acknowledgments 
>> sections current?
> 
> Abstract is still accurate and Author’s names & email addresses are current.
> Acknowledgements should be current as well.
> 
>> 2) Please share any style information that could help us with editing your 
>> document. For example:
>> 
>> * Is your document's format or its terminology based on another document, 
>> WG style guide, etc.? If so, please provide a pointer to that information 
>> (e.g., "This document's terminology should match DNS terminology in 
>> RFC 9499." or "This document uses the style info at 
>> <https://httpwg.org/admin/editors/style-guide>.").
>> * Is there a general pattern of capitalization or formatting of terms that 
>> editors can follow (e.g., "Field names should have initial capitalization." 
>> or  "Parameter names should be in double quotes." or "<tt/> should be used 
>> for token names." etc.)?
> 
> Everything introduced in terminology is capitalised.
> In terms of terminology, RFC9901 (SD-JWT) is an important reference for the issuer-holder-verifier model that we’ve been following for this draft.
> 
>> 3) Please carefully review the entries and their URLs in the
>> References section with the following in mind. Note that we will 
>> update as follows unless we hear otherwise at this time:
>> 
>> * References to obsoleted RFCs will be updated to point to the current 
>> RFC on the topic in accordance with Section 4.8.6 of RFC 7322 
>> (RFC Style Guide).
>> 
>> * References to I-Ds that have been replaced by another I-D will be 
>> updated to point to the replacement I-D.
>> 
>> * References to documents from other organizations that have been 
>> superseded will be updated to their superseding version.
>> 
>> Note: To check for outdated RFC and I-D references, you can use 
>> idnits <https://author-tools.ietf.org/idnits>. You can also help the
>> IETF Tools Team by testing idnits3 <https://author-tools.ietf.org/idnits3/>
>> with your document and reporting any issues to them.
> 
> We found a few smaller issues like sd-jwt vc having published a new version (and I’d assume they will publish another version before IETF Vienna). There also seem to be some minor problems with the txt rendering of lists in the IANA section that I will try to resolve.
> Should we release a new version with those fixes?
> 
>> 4) Is there any text that requires special handling? For example:
>> * Are there any sections that were contentious when the document was drafted?
>> * Are any sections that need to be removed before publication marked as such 
>> (e.g., Implementation Status sections (per RFC 7942)).
>> * Are there any instances of repeated text/sections that should be edited 
>> the same way?
> 
> Document history is present that is marked as “to be removed from the final specification”
> There are some TBD placeholders for IANA registration which need to be adjusted once identifiers are assigned
> 
>> 
>> 5) This document uses one or more of the following text styles.  
>> Are these elements used consistently?
>> 
>> * fixed width font (<tt/> or `)
>> * italics (<em/> or *)
>> * bold (<strong/> or **)
> 
> No
> 
>> 6) This document contains sourcecode: 
>> 
>> * Does the sourcecode validate?
>> * Some sourcecode types (e.g., YANG) require certain references and/or text 
>> in the Security Considerations section. Is this information correct?
>> * Is the sourcecode type indicated in the XML? (See information about 
>> types: https://www.rfc-editor.org/rpc/wiki/doku.php?id=sourcecode-types.)
> 
> No
> 
>> 7)  Would you like to participate in the RPC Pilot Test for editing in kramdown-rfc?
>> If so, please let us know and provide a self-contained kramdown-rfc file. For more
>> information about this experiment, see:
>> https://www.rfc-editor.org/rpc/wiki/doku.php?id=pilot_test_kramdown_rfc.
> 
> If it doesn’t delay publication, sure! Our repository containing the markdown is at https://github.com/oauth-wg/draft-ietf-oauth-status-list It is not a fully self-contained file right now though with the examples in separate files.
> 
>> 
>> 8) Would you like to participate in the RPC Pilot Test for completing Final Review 
>> in GitHub? If so, please let us know and provide all author, AD, and/or document 
>> shepherd GitHub usernames. For more information about this experiment, see:
>> https://www.rfc-editor.org/rpc/wiki/doku.php?id=rpc-github-phase-0-pilot-test.
> 
> Same as 7) 
> 
> https://github.com/oauth-wg/draft-ietf-oauth-status-list
> Author’s GitHub handles: c2bo, paulbastian, tplooker
> AD: debcooley
> Document Shepherd: rifaat-ietf
> 
> (Deb, Rifaat please check, but these seem to be correct?)
> 
>> 9) Is there anything else that the RPC should be aware of while editing this 
>> document?
> 
> 
> Nothing we are aware of
> 
> ---
> 
> Best Regards,
> 
> Paul, Tobias, Christian
> 
> 
>> On 4. Jun 2026, at 23:30, rfc-editor@rfc-editor.org wrote:
>> 
>> Author(s), 
>> 
>> Congratulations, your document has been successfully added to the RFC Editor queue!  
>> The team at the RFC Production Center (RPC) is looking forward to working with you 
>> as your document moves forward toward publication. To help reduce processing time 
>> and improve editing accuracy, please respond to the questions below. Please confer 
>> with your coauthors (or authors of other documents if your document is in a 
>> cluster) as necessary prior to taking action in order to streamline communication. 
>> If your document has multiple authors, only one author needs to reply to this 
>> message.
>> 
>> As you read through the rest of this email:
>> 
>> * If you need/want to make updates to your document, we encourage you to make those 
>> changes and resubmit to the Datatracker. This allows for the easy creation of diffs, 
>> which facilitates review by interested parties (e.g., authors, ADs, doc shepherds).
>> * If you feel no updates to the document are necessary, please reply with any 
>> applicable rationale/comments.
>> 
>> 
>> Please note that the RPC team will not work on your document until we receive a 
>> reply.  We require a reply, even if you don’t have guidance or don’t feel that you 
>> need to make any updates to the document.  After we hear from you, your document 
>> will start moving through the queue. You will be able to review and approve our 
>> updates during Final Review (formerly AUTH48).
>> 
>> Please feel free to contact us with any questions you may have at 
>> rfc-editor@rfc-editor.org.
>> 
>> Thank you!
>> The RPC Team
>> 
>> --
>> 
>> 1) As there may have been multiple updates made to the document during Last Call, 
>> please review the current version of the document: 
>> 
>> * Is the text in the Abstract still accurate?
>> * Are the Authors' Addresses, Contributors, and Acknowledgments 
>> sections current?
>> 
>> 
>> 2) Please share any style information that could help us with editing your 
>> document. For example:
>> 
>> * Is your document's format or its terminology based on another document, 
>> WG style guide, etc.? If so, please provide a pointer to that information 
>> (e.g., "This document's terminology should match DNS terminology in 
>> RFC 9499." or "This document uses the style info at 
>> <https://httpwg.org/admin/editors/style-guide>.").
>> * Is there a general pattern of capitalization or formatting of terms that 
>> editors can follow (e.g., "Field names should have initial capitalization." 
>> or  "Parameter names should be in double quotes." or "<tt/> should be used 
>> for token names." etc.)?
>> 
>> 
>> 3) Please carefully review the entries and their URLs in the
>> References section with the following in mind. Note that we will 
>> update as follows unless we hear otherwise at this time:
>> 
>> * References to obsoleted RFCs will be updated to point to the current 
>> RFC on the topic in accordance with Section 4.8.6 of RFC 7322 
>> (RFC Style Guide).
>> 
>> * References to I-Ds that have been replaced by another I-D will be 
>> updated to point to the replacement I-D.
>> 
>> * References to documents from other organizations that have been 
>> superseded will be updated to their superseding version.
>> 
>> Note: To check for outdated RFC and I-D references, you can use 
>> idnits <https://author-tools.ietf.org/idnits>. You can also help the
>> IETF Tools Team by testing idnits3 <https://author-tools.ietf.org/idnits3/>
>> with your document and reporting any issues to them.
>> 
>> 
>> 4) Is there any text that requires special handling? For example:
>> * Are there any sections that were contentious when the document was drafted?
>> * Are any sections that need to be removed before publication marked as such 
>> (e.g., Implementation Status sections (per RFC 7942)).
>> * Are there any instances of repeated text/sections that should be edited 
>> the same way?
>> 
>> 
>> 5) This document uses one or more of the following text styles.  
>> Are these elements used consistently?
>> 
>> * fixed width font (<tt/> or `)
>> * italics (<em/> or *)
>> * bold (<strong/> or **)
>> 
>> 
>> 6) This document contains sourcecode: 
>> 
>> * Does the sourcecode validate?
>> * Some sourcecode types (e.g., YANG) require certain references and/or text 
>> in the Security Considerations section. Is this information correct?
>> * Is the sourcecode type indicated in the XML? (See information about 
>> types: https://www.rfc-editor.org/rpc/wiki/doku.php?id=sourcecode-types.)
>> 
>> 
>> 7)  Would you like to participate in the RPC Pilot Test for editing in kramdown-rfc?
>> If so, please let us know and provide a self-contained kramdown-rfc file. For more
>> information about this experiment, see:
>> https://www.rfc-editor.org/rpc/wiki/doku.php?id=pilot_test_kramdown_rfc.
>> 
>> 
>> 8) Would you like to participate in the RPC Pilot Test for completing Final Review 
>> in GitHub? If so, please let us know and provide all author, AD, and/or document 
>> shepherd GitHub usernames. For more information about this experiment, see:
>> https://www.rfc-editor.org/rpc/wiki/doku.php?id=rpc-github-phase-0-pilot-test.
>> 
>> 
>> 9) Is there anything else that the RPC should be aware of while editing this 
>> document?
>