[auth48] Re: Document intake questions about draft-ietf-dnsop-ds-automation

Peter Thomassen <peter@desec.io> Tue, 26 May 2026 14:52 UTC

Return-Path: <peter@desec.io>
X-Original-To: auth48archive@mail2.ietf.org
Delivered-To: auth48archive@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id 90E19F542D43; Tue, 26 May 2026 07:52:58 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=ietf.org; s=ietf1; t=1779807178; bh=KXdh/Tyi6Yu1rMWuhJ/qBc4OSZgC4bsjnFwLKptC/gg=; h=Date:Subject:To:Cc:References:From:In-Reply-To; b=JafKmIi2KXQFP6iMhmLQIAG+vwHQ1hJUh5ZOVDUWEyZY5jzD2n0xeAf7rdwQ5viLs 1V3jRCueVnY6dQ0qo3sYRVtnL76Zs4W6CjIc2oJO6pK1Ptv0ht7gH8zxA7LpChSbKN ucGdVqimCST3MTe4luzbySBdhhh5GQn9UFfGHEJY=
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -2.8
X-Spam-Level:
X-Spam-Status: No, score=-2.8 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, RCVD_IN_DNSWL_LOW=-0.7, SPF_HELO_NONE=0.001, SPF_PASS=-0.001] autolearn=ham autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=pass (2048-bit key) header.d=desec.io
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id vcwN0QNF3P9G; Tue, 26 May 2026 07:52:57 -0700 (PDT)
Received: from mail.a4a.de (mail.a4a.de [IPv6:2a01:4f8:10a:1d5c:8000::8]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange ECDHE (P-256) server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id 6B11DF542A12; Tue, 26 May 2026 07:50:22 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; q=dns/txt; c=relaxed/relaxed; d=desec.io; s=20170825; h=Content-Transfer-Encoding:Content-Type:In-Reply-To:From: References:Cc:To:Subject:MIME-Version:Date:Message-ID:Sender:Reply-To: Content-ID:Content-Description:List-Id:List-Help:List-Unsubscribe: List-Subscribe:List-Post:List-Owner:List-Archive; bh=HxJsqJmLuOAIYt8hRiCzdO8mqrBCInbcpszHvponxXQ=; b=KbHnDfVBT+W/2by6NsOcsqcGnj Z4oN9UV0rh82GAQ9QjkAaBfCv2hbeF154nxl6s5BwGmHnH1yeWVA/yruhp9cKdx7kXYDlIjGnlaAH CwHdO4ovd/OD0hNpWfWNOvytIvho5uFEBj1ZJXyYplu30qqgCZNJz1zs8bilR8f2hd/mKK6pf9DBo uoffmgk4v7H31zmhn57E1ymz2oZs0fKv7YT7E2fSjw2SHP00Npl3839uKC/zJVydoZQXWWNzgMtZa ABnt5WXmdRWwf+6zR5akpR6TpC4EoOTT7bj7FoVfEuk1IXRKnuhj+GGp/qem5kQripQudktCzS2Po pIX6kiyQ==;
Received: from [146.247.188.57] (helo=[10.30.0.129]) by mail.a4a.de with esmtpsa (TLS1.3) tls TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256 (Exim 4.97) (envelope-from <peter@desec.io>) id 1wRt6h-00000002aK7-1C3G; Tue, 26 May 2026 16:50:11 +0200
Message-ID: <3643dfd8-775d-44a6-adad-70971b26859d@desec.io>
Date: Tue, 26 May 2026 16:50:10 +0200
MIME-Version: 1.0
User-Agent: Mozilla Thunderbird
To: Sarah Tarrant <starrant@staff.rfc-editor.org>
References: <177948517130.15.2634818382405321985@rfc-editor.org> <f1cbb94a-b19d-4258-bdc1-112396fdbd2e@desec.io> <D133275C-4CC4-43AC-8CE2-04CE071ABE98@staff.rfc-editor.org>
Content-Language: en-US, de-DE
From: Peter Thomassen <peter@desec.io>
Autocrypt: addr=peter@desec.io; keydata= xsFNBFRjVn0BEADXqtra70yxQrT4MQ9DEhN0mxG6XRAOHE6nP18mqxwSlcET7D6w+z3h4ole v0tyvUU02c2wg04X8WVfjoHnAvIa1dfUcNpB1+QmfFsw0xIJlbT1ogHkMiPQqR4ChDvE3ND/ 6YCS5+HT6hY+tfU+hpLsKw4l+u1Pg2NPVLYosET1jU84b7xhFnoicnCV3kUNltLtxLKSBAfk AXtp1AWWKJbfCr3y0qKElMriicoe5DUZfLrZK2iPcWBxh+n7KMO2g7aqx3aQqwW1+S7Sq7Is l6iSurYfIcHb4AfUy4o5nPB8kKACR6BuJmkEQ5WLuTGruWA2fcxaNpICmolMinTzW1CrIjgN PoskMYCNIZ2uWxS6LN8hBiGCRL4h9aL4wuT09SvR13oAPI1HD5ph+mH6wD37/ONBXrdjcFNb 1l/uVkHU/SwwcKDJOsX18T60Ao00fciTbFHgmKtFube0xGK/vjh461TyU+xKD8Orvyeovvxy MzCwM3UVq/dkdG2Ys/7Qy/4bUC1nJEwKlLv7ZTdtSckdoU2M6JpPX6i4KDB2YCMbwtqJ842z 8A/UuE2bL9aDimh/sF8WgPIhlxqF1STNqW1JTIbDPv8HeZnM4nyJOUWStj4uRiETQhBClPLz YWtnR+EUsfbSLy81vfupbMqRasDlt6aASobgn+K7Rb1Xs/mDnwARAQABzSBQZXRlciBUaG9t YXNzZW4gPHBldGVyQGRlc2VjLmlvPsLBeAQTAQIAIgUCVGNWfQIbIwYLCQgHAwIGFQgCCQoL BBYCAwECHgECF4AACgkQ79YUOj7yLS88Dg//SbHnFGrtaImEiM69wyj4GzWnuGk9/upCym/R RzdBALCYHU9FUFFHwusiO9A0pnO8qv/GEtqqTHrcL205a6FTivkdZmOsWuN4oo7r4HBc/taI FLLUDg2wd8q4m4387sYEqrc3olGfyRB6hrMtEWVJLXHJmpcrxAaI1F2QO4Bu7kcdTnyGFz/p ZD8XAof2TWHqJb2ux69DFhiAJeAZlV+h9QrxTedL84l4hq3x1VWsnOEFaCJiThDX920kTnhJ ijrDocgAbmQBCniPACpPHYhBhmCJxfVqgfMuLMNsukOmKxsGcGV6rO1zB5ZUhm3O/Ixk6ow3 6FDKALWihg6Z4P/cJYySMn0iqvHkO8ryT9oJKX//mKaYoF6henXDRLCcRjKwGxFQTEgX+6yc pjgvX3rlypjkPT5ho4yEc5ePkQ2gIIHhvZburm1Zr4nDPx6v8+3XUjpXBRTWQ8/0/h0rtLJe yOPwGJxcfKf/GutTCqiio0mS01mIY9c2i7JWcljlIuSEUit6CHotc5lBOm2GJwguRJG6cXPY SQecwBdcjH3RTzBOv/DN6xWAIV7BmbX/e7DSGAc60mBO1/M0ut+a6CkxRQK8TaE3B3zh1/QO nG0XvtZfIY8ZYdTrdEDSV1Pj5pof/fqhhegHRxN2qi4qIuVcrW0jsUsx10IgAynHR7qQKsvO wU0EVGNWfQEQAPBA8iPCS4ZRX8stW0WuW7579axSq/Luyik4MWDFalt68lzvUbV0f6faN15+ aV7VwMTw3rSa2tP0U8crYAAAZ5NrRHXlYms5BK9vsi1322dAvhyNRawdprP627SO+Ez/84tY xz1X3M9esbN7gpJtHP6mHW76zYpT447v6c2qlbldjobZTDb6kKSGFCIrPJz9M4jVfya+ovxe 2Ab7hn2R0CcyMHATV5g1Ry0XXaj5y3bWypActbG9nflRn3NjhHZynu+WEPDUJCO8kNVNYKOw HObNTeaLvgvU0ONB8pYJv35kDXMhZLwo5MJuJd5i54CXwpo9mECwLJT1RpJi7u98nBrWyyaH s2brG9LPCRKBKOhiHFu57H+cElh+kOvehuS7DFTzjqDwJlkQzP5Hq0G++hZxfdYocKdcdFoh RP3dtDAe+Lfiy9qzJicZ6ACbzoQIN58xj0VWAn1W7SuMErOjv84D/FiXHD2Kxtx09wQl8vH0 Nbh9UgyDBNupToM0ixT+8Ko8eBuYHR53RPxshQhFw4EMIhXiOaxNe1W2Z95QPnYhUGOMoy3I v4fxMQUHa4kZSF2qxsFB1Cxol/aBPGwkwoqUvzp23pLQtJ6youYXtLgvx3pR4L52Q5CUzHMa HvM67XWgW1KqtnvNBXN9PwtDz/a9fQX1YO4CegrXv8C9Ro+LABEBAAHCwV8EGAECAAkFAlRj Vn0CGwwACgkQ79YUOj7yLS8rXA/9EGX2QRfJS94JTdtseu7saTK9a3IKwk6E33GpfXyUVpMt sOqV756XQwULZSWoxInRQtWojA8pQxDUYrbA4MpX0Efr2Dx1xIsJ5F3JajOqViB1SbOD2m0f bxXbcoWKitsKoag2SlvNOd8rD9FcgDvrkacnaQZcZE8DyyGx0JU451tfoD/igu85NZpTDaWG 6fth7QRlxmdGWrGXRdXAP29jq1n0I1wIyF/bXlZ7MXjOSsfyPddzsnHFTvNMZKps0QXNF+hi ESg9chIeo/IFDDVu6pCtm6mftojx84rczTZiNk8r2T3TU4N8uwWtXn/nj9xd61pnxD0xkTPH zxJrCs59WSfYqj3aFNkWO3Lg0/HGnO9wHQKMXcGPsnKITHVzxCNBQtVHomNA7ds6Kt3/WJgS pU2ciICvrpvKgPNWQ0d/SeY3vYIRvDLZ12Svx6M3eXDrsgZOT5be7kGVr3t7dBOYKcRHkZUq kU1kCcgp0vetISVDOc5fkpdUkAtd5/13pIpz4ikVR3OM4Br4XMVShm6RvoP4pyA+ftCi1+bw 0UbRCrnHgnG+wtCf5nMDGVLc04vITnII+ESZqlF02a1IFj0Z2MuQK2Oszl2Nsx/LG60G1e/R pzKEXIIJgHfbwUCWtV1zQu6v9Ng5H8EqVeWcdaPUwSQMGcDg/sPa4s/OxhgrYBg=
In-Reply-To: <D133275C-4CC4-43AC-8CE2-04CE071ABE98@staff.rfc-editor.org>
Content-Type: text/plain; charset="UTF-8"; format="flowed"
Content-Transfer-Encoding: 8bit
Message-ID-Hash: UGC4RCVB3LGSWRYKJCUJ6NDFDAVPTEBG
X-Message-ID-Hash: UGC4RCVB3LGSWRYKJCUJ6NDFDAVPTEBG
X-MailFrom: peter@desec.io
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: rfc-editor@rfc-editor.org, steve.sheng@icann.org, shuque@gmail.com, mohamed.boucadair@orange.com, mjethanandani@gmail.com, auth48archive@rfc-editor.org
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [auth48] Re: Document intake questions about draft-ietf-dnsop-ds-automation
List-Id: "Archiving AUTH48 exchanges between the RFC Production Center, the authors, and other related parties" <auth48archive.rfc-editor.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/auth48archive/dlqaULFya33HXP2Cp9LRDNDFArw>
List-Archive: <https://mailarchive.ietf.org/arch/browse/auth48archive>
List-Help: <mailto:auth48archive-request@rfc-editor.org?subject=help>
List-Owner: <mailto:auth48archive-owner@rfc-editor.org>
List-Post: <mailto:auth48archive@rfc-editor.org>
List-Subscribe: <mailto:auth48archive-join@rfc-editor.org>
List-Unsubscribe: <mailto:auth48archive-leave@rfc-editor.org>

Hi Sarah,

Yes. The document does not use <tt> really, except by incorporation of this term from the referenced RFC.

(Apologies for claiming earlier that <tt> is not used; I had searched in the HTML rendering where that had been transformed into <code>.)

Thanks,
Peter


On 5/26/26 16:46, Sarah Tarrant wrote:
> Hi Peter,
> 
> Thank you for your reply.
> 
> Regarding the test styling question, we only found one instance of "<tt>" in Section 4.2.2. Is this intentional?
> 
> Current (xml: <tt>&lt;info&gt;</tt>):
>     When using the Extensible
>     Provisioning Protocol (EPP) [RFC5730], the domain <info> command
>     described in Section 2.1.1.2 of [RFC9803] can be used by the
>     registrar to obtain the registry's TTL policy.
> 
> Sincerely,
> Sarah Tarrant
> RFC Production Center
> 
>> On May 23, 2026, at 8:09 AM, Peter Thomassen <peter=40desec.io@dmarc.ietf.org> wrote:
>>
>> Dear RFC Editor,
>>
>> On 5/22/26 23:26, rfc-editor@rfc-editor.org wrote:
>>> * If you need/want to make updates to your document, we encourage you to make those
>>> changes and resubmit to the Datatracker. This allows for the easy creation of diffs,
>>> which facilitates review by interested parties (e.g., authors, ADs, doc shepherds).
>>> * If you feel no updates to the document are necessary, please reply with any
>>> applicable rationale/comments.
>>
>> No updates are necessary.
>>
>>> 1) As there may have been multiple updates made to the document during Last Call,
>>> please review the current version of the document:
>>> * Is the text in the Abstract still accurate?
>>> * Are the Authors' Addresses, Contributors, and Acknowledgments
>>> sections current?
>>
>> All correct and current.
>>
>>> 2) Please share any style information that could help us with editing your
>>> document. For example:
>>> * Is your document's format or its terminology based on another document,
>>> WG style guide, etc.? If so, please provide a pointer to that information
>>> (e.g., "This document's terminology should match DNS terminology in
>>> RFC 9499." or "This document uses the style info at
>>> <https://httpwg.org/admin/editors/style-guide>.").
>>
>> The document uses some (but not all) terminology from RFC 7344. For details, see Section 2 of the draft.
>>
>>> * Is there a general pattern of capitalization or formatting of terms that
>>> editors can follow (e.g., "Field names should have initial capitalization."
>>> or  "Parameter names should be in double quotes." or "<tt/> should be used
>>> for token names." etc.)?
>>
>> Not really. Perhaps terms defined in Section 2 could be capitalized throughout, to make them more recognizable.
>>
>>> 3) Please carefully review the entries and their URLs in the
>>> References section with the following in mind. Note that we will
>>> update as follows unless we hear otherwise at this time:
>>> * References to obsoleted RFCs will be updated to point to the current
>>> RFC on the topic in accordance with Section 4.8.6 of RFC 7322
>>> (RFC Style Guide).
>>> * References to I-Ds that have been replaced by another I-D will be
>>> updated to point to the replacement I-D.
>>> * References to documents from other organizations that have been
>>> superseded will be updated to their superseding version.
>>> Note: To check for outdated RFC and I-D references, you can use
>>> idnits <https://author-tools.ietf.org/idnits>. You can also help the
>>> IETF Tools Team by testing idnits3 <https://author-tools.ietf.org/idnits3/>
>>> with your document and reporting any issues to them.
>>> 4) Is there any text that requires special handling? For example:
>>> * Are there any sections that were contentious when the document was drafted?
>>> * Are any sections that need to be removed before publication marked as such
>>> (e.g., Implementation Status sections (per RFC 7942)).
>>> * Are there any instances of repeated text/sections that should be edited
>>> the same way?
>>
>> Sections *.2 corresponds to Appendix A.*, where all recommendations are consolidated for easy orientation during implementation. I've verified corresponding sections are are identical. Any changes made in these sections need to be reflected accordingly.
>>
>>> 5) This document uses one or more of the following text styles.
>>> Are these elements used consistently?
>>> * fixed width font (<tt/> or `)
>>> * italics (<em/> or *)
>>> * bold (<strong/> or **)
>>
>> I don't think it does.
>>
>>> 6) This document is part of Cluster 575:
>>> https://queue.rfc-editor.org/clusters/575/
>>> * To help the reader understand the content of the cluster, is there a
>>> document in the cluster that should be read first? Next? If so, please provide
>>> the order and we will provide RFC numbers for the documents accordingly.
>>> If order is not important, please let us know.
>>
>> The other document is about to be published as RFC 9975, and can be read immediately. This draft just references it as any other RFC (that is, the cluster needs no special handling).
>>
>>> * Is there any text that has been repeated within the cluster document that
>>> should be edited in the same way (for instance, parallel introductory text or
>>> Security Considerations)?
>>
>> No.
>>
>>> * For more information about clusters, see:
>>> https://authors.ietf.org/en/rfc-publication-process#clusters
>>> * For a list of all current clusters, see:
>>> https://queue.rfc-editor.org/clusters/
>>> 7) Is there anything else that the RPC should be aware of while editing this
>>> document?
>>
>> Thank you.
>>
>> Best,
>> Peter
> 
> 

-- 
Like our community service? đź’›
Please consider donating at

https://desec.io/

deSEC e.V.
Möckernstraße 74
10965 Berlin
Germany

Vorstandsvorsitz: Nils Wisiol
Registergericht: AG Berlin (Charlottenburg) VR 37525