[auth48] Re: AUTH48: RFC-to-be 9972 <draft-ietf-grow-bmp-bgp-rib-stats-17> for your review

linchangwang <linchangwang.04414@h3c.com> Thu, 07 May 2026 15:31 UTC

Return-Path: <linchangwang.04414@h3c.com>
X-Original-To: auth48archive@mail2.ietf.org
Delivered-To: auth48archive@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id 43D8BEA9E22F; Thu, 7 May 2026 08:31:40 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=ietf.org; s=ietf1; t=1778167900; bh=LFTflAYT6aSeOuRa3nln7XcGRG590IHp8mRkjLPaJck=; h=From:To:CC:Subject:Date; b=P+HBIqXR6oFDNVxa9i6teZoP5X1s+5szjHOqp1HZyerw8D17+bKuX63Cbrjxl6kJD P82KfGvggj2MxnW3jk7VymQDUgSLNLB8JbKxzI/DGMI+RqWGAPB4X6BKgEH5duFyt4 x7j8mAGLQ41cFmXoDmlcLy+x+kKD5F6YIdHZdBDw=
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -1.698
X-Spam-Level:
X-Spam-Status: No, score=-1.698 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_INVALID=0.1, DKIM_SIGNED=0.1, RCVD_IN_VALIDITY_CERTIFIED_BLOCKED=0.001, RCVD_IN_VALIDITY_RPBL_BLOCKED=0.001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001] autolearn=no autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=neutral reason="invalid (public key: not available)" header.d=h3c.com
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id g-7V7funH9M9; Thu, 7 May 2026 08:31:39 -0700 (PDT)
Received: from h3cspam02-ex.h3c.com (smtp.h3c.com [60.191.123.50]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id 14504EA9E227; Thu, 7 May 2026 08:31:38 -0700 (PDT)
Received: from mail.maildlp.com ([172.25.15.154]) by h3cspam02-ex.h3c.com with ESMTP id 647FTWrm083970; Thu, 7 May 2026 23:29:32 +0800 (+08) (envelope-from linchangwang.04414@h3c.com)
Received: from DAG6EX08-BJD.srv.huawei-3com.com (unknown [10.153.34.10]) by mail.maildlp.com (Postfix) with ESMTP id 1B67E20045AE; Thu, 7 May 2026 23:41:27 +0800 (CST)
Received: from DAG6EX08-BJD.srv.huawei-3com.com (10.153.34.10) by DAG6EX08-BJD.srv.huawei-3com.com (10.153.34.10) with Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) id 15.2.1258.27; Thu, 7 May 2026 23:29:32 +0800
Received: from DAG6EX08-BJD.srv.huawei-3com.com ([fe80::5d6c:b52b:478f:2738]) by DAG6EX08-BJD.srv.huawei-3com.com ([fe80::5d6c:b52b:478f:2738%17]) with mapi id 15.02.1258.027; Thu, 7 May 2026 23:29:31 +0800
From: linchangwang <linchangwang.04414@h3c.com>
To: "rfc-editor@rfc-editor.org" <rfc-editor@rfc-editor.org>, "mukul.srivastava@hpe.com" <mukul.srivastava@hpe.com>, "liuyisong@chinamobile.com" <liuyisong@chinamobile.com>, "lijinming@chinamobile.com" <lijinming@chinamobile.com>
Thread-Topic: AUTH48: RFC-to-be 9972 <draft-ietf-grow-bmp-bgp-rib-stats-17> for your review
Thread-Index: AdzeNjt2dbDtSA1Dnky58/Zw+HNKtQ==
Date: Thu, 07 May 2026 15:29:31 +0000
Message-ID: <c86f4cba5cea426bbaa48a0028eb9b78@h3c.com>
Accept-Language: zh-CN, en-US
Content-Language: zh-CN
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
x-originating-ip: [10.142.192.32]
x-sender-location: DAG2
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: base64
MIME-Version: 1.0
X-DNSRBL:
X-SPAM-SOURCE-CHECK: pass
X-MAIL: h3cspam02-ex.h3c.com 647FTWrm083970
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=h3c.com; s=default; t=1778167782; bh=LFTflAYT6aSeOuRa3nln7XcGRG590IHp8mRkjLPaJck=; h=From:To:CC:Subject:Date; b=dmzE+Oq3Pgv9vFHxrcY9+8XpK0cBcpaFQLyGFGGs+hxqCDJgJHseTY2+sjQg2kmSv NUBmJBAGn/F4wpPgvBIywp+ZEbqJM68STBFWxRyfbhN5+YqEh+nqc23UBPIn30+G+N fDcqsJBCdPpi1f2KHl1BhOraFMQKykEWAY112U/h+28buYNB5tDIGE35UVV4jd0asg bdz/S2aWi+3w8dqywUbAMpFC/rgrEq11f6kTL2y42yJEbdFbzrvy3MpTXVrG+EgKN/ wQ3FEa8Dr9qo9WY+HYq4aujuyL2BoiDXXavi5JdOfqFMTcvnIfYcq88b9geYD1MWlg pTNJUl2j2kwdg==
Message-ID-Hash: F22M7YOZX5GNKVX7EKEIWZOJYAG3COXH
X-Message-ID-Hash: F22M7YOZX5GNKVX7EKEIWZOJYAG3COXH
X-MailFrom: linchangwang.04414@h3c.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: "grow-ads@ietf.org" <grow-ads@ietf.org>, "grow-chairs@ietf.org" <grow-chairs@ietf.org>, "job@sobornost.net" <job@sobornost.net>, "mohamed.boucadair@orange.com" <mohamed.boucadair@orange.com>, "auth48archive@rfc-editor.org" <auth48archive@rfc-editor.org>
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [auth48] Re: AUTH48: RFC-to-be 9972 <draft-ietf-grow-bmp-bgp-rib-stats-17> for your review
List-Id: "Archiving AUTH48 exchanges between the RFC Production Center, the authors, and other related parties" <auth48archive.rfc-editor.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/auth48archive/kiucwmWB-OacUIC9luOBJfWPBeU>
List-Archive: <https://mailarchive.ietf.org/arch/browse/auth48archive>
List-Help: <mailto:auth48archive-request@rfc-editor.org?subject=help>
List-Owner: <mailto:auth48archive-owner@rfc-editor.org>
List-Post: <mailto:auth48archive@rfc-editor.org>
List-Subscribe: <mailto:auth48archive-join@rfc-editor.org>
List-Unsubscribe: <mailto:auth48archive-leave@rfc-editor.org>

Hi,

Thank you for your valuable feedback.
For a detailed response, please see the reply below.

Thanks,
Changwang

-----邮件原件-----
发件人: rfc-editor@rfc-editor.org <rfc-editor@rfc-editor.org>
发送时间: 2026年5月6日 20:15
收件人: mukul.srivastava@hpe.com; liuyisong@chinamobile.com; linchangwang (RD) <linchangwang.04414@h3c.com>; lijinming@chinamobile.com
抄送: rfc-editor@rfc-editor.org; grow-ads@ietf.org; grow-chairs@ietf.org; job@sobornost.net; mohamed.boucadair@orange.com; auth48archive@rfc-editor.org
主题: Re: AUTH48: RFC-to-be 9972 <draft-ietf-grow-bmp-bgp-rib-stats-17> for your review



Authors,

While reviewing this document during AUTH48, please resolve (as necessary) the following questions, which are also in the source file.

1) <!--[rfced] We had the following questions about the Terminology
     section:

a) We notice that some entries in the Terminology section include quotes from their defining documents while others do not.  Should this be made uniform?

  [Changwang] Maintain consistency. Revise as follows:
OLD:
Post-policy Adj-RIB-In:  As defined in Section 2 of [RFC7854].

NEW:
   Post-policy Adj-RIB-In:  As defined in Section 2 of [RFC7854]:

      |  The result of applying inbound policy to an Adj-RIB-In, but
      |  prior to the application of route selection to form the Loc-
      |  RIB.

OLD:
Pre-policy Adj-RIB-Out:  As defined in Section 3 of [RFC8671].

Post-policy Adj-RIB-Out:  As defined in Section 3 of [RFC8671].

NEW:
Pre-policy Adj-RIB-Out:  As defined in Section 3 of [RFC8671]:

      |  The result before applying the outbound policy to an Adj-RIB-
      |  Out.  This normally would match what is in the local RIB.

   Post-policy Adj-RIB-Out:  As defined in Section 3 of [RFC8671]:

      |  The result of applying outbound policy to an Adj-RIB-Out. This
      |  MUST convey to the BMP receiver what is actually transmitted to
      |  the peer.

OLD:
Loc-RIB:  As defined in Section 1.1 of [RFC4271]:

      |  The Loc-RIB contains the routes that have been selected by the
      |  local BGP speaker's Decision Process."  Note that the Loc-RIB
      |  state as monitored through BMP might also contain routes
      |  imported from other routing protocols such as an IGP or local
      |  static routes.
NEW:
  Loc-RIB:  As defined in Section 1.1 of [RFC4271]:

      |  The Loc-RIB contains the routes that have been selected by the
      |  local BGP speaker's Decision Process.

      Note that the Loc-RIB state as monitored through BMP might also
      contain routes imported from other routing protocols such as an
      IGP or local static routes.

OLD:
Route:  As defined in Section 1.1 of [RFC4271].
NEW:
   Route:  As defined in Section 1.1 of [RFC4271]:

      |  A unit of information that pairs a set of destinations with the
      |  attributes of a path to those destinations.


b) We do not see any uses of Monitoring Station in this document.
Please review if updates to the following text should be made.

Original:
The terms "Producer" and "Collector" are equivalent to "Monitored Router" and "Monitoring Station", respectively.

-->
[Changwang] Here it simply means that Collector is equivalent to Monitoring Station, without the need for a Monitoring Station to appear. No modifications are required.


2) <!--[rfced] Do uses of "per-" apply to both AFI and SAFI?  Note that
    more instances occur throughout the document.
【Changwang] Yes, as described in RFC7854/RFC9069, it should be Per-AFI/SAFI.


Note also that, for this instance, as AFI and SAFI are marked as well-known abbreviations, it may actually be easier for the reader if the expansions were removed:

Original:
...Global Statistics and Per-Address Family Identifier (AFI)/Subsequent Address Family Identifier (SAFI) [RFC4760] Statistics.

Perhaps:
...Global Statistics and Statistics per-AFI or per-SAFI (see [RFC4760]).

-->
【Changwang] If directly abbreviated, it is recommended to change it to the following:
NEW:
...Global Statistics and Per-AFI/SAFI [see RFC4760] Statistics.


3) <!--[rfced] Is the switch between singular and plural in these
     sentences intentional?

a) a statistic vs. statistics

Original:
Both a Global Statistic and its corresponding Per-AFI/ SAFI Statistics can be reported simultaneously.

Perhaps:
Both Global Statistics and and their corresponding Per-AFI/ SAFI Statistics can be reported simultaneously.

【Changwang] I agree with the above modifications.

b) AFI/SAFIs

Original:
The Per-AFI/SAFI Statistics apply only to the AFI/SAFIs that a BGP speaker supports and negotiates with its peer.

Perhaps:
The Per-AFI/SAFI Statistics apply only to the AFIs/SAFIs that a BGP speaker supports and negotiates with its peer.

Note: even when not preceded by "Per", it may be beneficial to clarify the use of the slash character.  Are these either/or relationships or and relationships?  If it has a special meaning, it may be good to define AFI/SAFI in the Terminology section.
-->

【Changwang] Please modify as follows:
OLD:
The Per-AFI/SAFI Statistics apply only to the AFI/SAFIs that a BGP speaker supports and negotiates with its peer.

NEW:
The Per-AFI/SAFI Statistics apply only to the AFI/SAFI that a BGP speaker supports and negotiates with its peer.


4) <!--[rfced] We plan to reformat the following text but have waited as
     there were so many uses, we felt it would clutter the diff file.

Original:
...formatted as: 2-byte AFI, 1-byte SAFI, and a 64-bit Gauge.

Perhaps:
...formatted as a 2-byte AFI, a 1-byte SAFI, and a 64-bit Gauge.

Note that we will update the following similar use (many instances
exist) to appear as above unless we hear objection.

Original:
The value is structured as: 2-byte AFI, 1-byte SAFI, followed by a 64-bit Gauge.

Perhaps:
The value is structured as a 2-byte AFI, a 1-byte SAFI, and a 64-bit Gauge.
-->

【Changwang] I agree with the above modifications.


5) <!--[rfced] Should the following update be made?

Original:
The stats type 0 is a 32-counter which is a monotonically increasing number...

Perhaps:
Stats type 0 is a 32-bit counter that is a monotonically increasing number...

-->
【Changwang] I agree with the above modifications.

6) <!--[rfced] We see both "invalidated through the ROA of RPKI" for
     Types 35, 36, 41, and 42 in Section 3.2 and "invalidated after
     verifying route origin AS number through the ROA of RPKI" for the
     same types in Section 8.  Please let us know if/how these should
     be made uniform.
              -->
【Changwang] Change it to be consistent with the definition of Section 8.


7) <!--[rfced] Is there any issue with using both RECOMMENDED and SHOULD
     in the same sentence?

Original:
...it is RECOMMENDED that BMP producers capable of generating both (Types 7 and 18) or (Types 9 and 19) BMP statistics SHOULD transmit both corresponding types simultaneously.

Perhaps:
...it is RECOMMENDED that BMP producers capable of generating both (Types 7 and 18) and (Types 9 and 19) BMP statistics transmit both corresponding types simultaneously.
-->

【Changwang] I agree with the above modifications.

8) <!--[rfced] Please rephrase "absent policy otherwise" in the
     following:

Original:
For backward compatibility, and absent policy otherwise...

Perhaps:
For backward compatibility, and absent any other policy...
-->
【Changwang] I agree with the above modifications.

9) <!--[rfced] This list is not of a parallel structure.  How may we
     update?

Original:
To avoid adversely impacting the restart process, a BMP statistics producer MAY choose to sample this value at a lower frequency, buffer updates, or temporarily suspend reporting for this type during the most critical phases of a switchover.

Perhaps:
To avoid adversely impacting the restart process, a BMP statistics producer MAY choose to sample this value at a lower frequency, sample it at buffer updates, or temporarily suspend reporting for this type during the most critical phases of a switchover.

-->
[Changwang]  "sample..., buffer..., or temporarily suspend..."
NEW:
To avoid adversely impacting the restart process, a BMP statistics producer MAY choose to sample this value at a lower frequency, buffer the updates, or temporarily suspend reporting for this type during the most critical phases of a switchover.


10) <!--[rfced] We had the following questions/comments related to the
     IANA Considerations section:

a) We will communicate any updates to the descriptions of the Stat types to IANA upon the completion of AUTH48.
[Changwang] Agreed.

b) We will update the format of the list to instead appear as a table.
We have kept as is for now in order to facilitate diff review. Please let us know any objections.

-->
[Changwang] Agreed.


11) <!-- [rfced] Would you like the references to be alphabetized or left
     in their current order?
-->
[Changwang] alphabetized.


12) <!--[rfced] We note that the following terms may be used inconsistently throughout the document.  Please review these terms and let us know if/how they may be made consistent.

Stat Type vs. stat type vs. stats type (note RFC 7854 does not use stats type)
[Changwang] Stat Type.

BMP Statistics Report Message vs. BMP statistics message
[Changwang] BMP Statistics Report message.

Statistic vs. statistic (when used by itself)
[Changwang] statistic.

Gauge vs. gauge
[Changwang] Gauge.

Type vs. type (e.g., Type 27 vs. type 27)
[Changwang] Type 27.

statistic type vs. statistics types (various casing) - singular or plural?
-->
[Changwang] statistics types.


13) <!--[rfced] We had the following questions related to abbreviation use throughout the document:

a) We see several instances of AS number.  May we make these ASN instead (for Autonomous System Number)?

-->
[Changwang] Agreed, please make the changes uniformly.

14) <!-- [rfced] Please review the "Inclusive Language" portion of the
     online Style Guide
     <https://www.rfc-editor.org/styleguide/part2/#inclusive_language>
     and let us know if any changes are needed.  Updates of this
     nature typically result in more precise language, which is
     helpful for readers.

Note that our script did not flag any words in particular, but this should still be reviewed as a best practice.
-->
[Changwang] Reviewed, no modifications needed.


Thank you.

Megan Ferguson
RFC Production Center

*****IMPORTANT*****

Updated 2026/05/06

RFC Author(s):
--------------

Instructions for Completing AUTH48

Your document has now entered AUTH48.  Once it has been reviewed and approved by you and all coauthors, it will be published as an RFC.
If an author is no longer available, there are several remedies available as listed in the FAQ (https://www.rfc-editor.org/faq/)

You and you coauthors are responsible for engaging other parties (e.g., Contributors or Working Group) as necessary before providing your approval.

Planning your review
---------------------

Please review the following aspects of your document:

*  RFC Editor questions

   Please review and resolve any questions raised by the RFC Editor
   that have been included in the XML file as comments marked as
   follows:

   <!-- [rfced] ... -->

   These questions will also be sent in a subsequent email.

*  Changes submitted by coauthors

   Please ensure that you review any changes submitted by your
   coauthors.  We assume that if you do not speak up that you
   agree to changes submitted by your coauthors.

*  Content

   Please review the full content of the document, as this cannot
   change once the RFC is published.  Please pay particular attention to:
   - IANA considerations updates (if applicable)
   - contact information
   - references

*  Copyright notices and legends

   Please review the copyright notice and legends as defined in
   RFC 5378 and the Trust Legal Provisions
   (TLP – https://trustee.ietf.org/license-info)

*  Semantic markup

   Please review the markup in the XML file to ensure that elements of
   content are correctly tagged.  For example, ensure that <sourcecode>
   and <artwork> are set correctly.  See details at
   <https://authors.ietf.org/rfcxml-vocabulary>.

*  Formatted output

   Please review the PDF, HTML, and TXT files to ensure that the
   formatted output, as generated from the markup in the XML file, is
   reasonable.  Please note that the TXT will have formatting
   limitations compared to the PDF and HTML.


Submitting changes
------------------

To submit changes, please reply to this email using ‘REPLY ALL’ as all the parties CCed on this message need to see your changes. The parties
include:

   *  your coauthors

   *  rfc-editor@rfc-editor.org (the RPC team)

   *  other document participants, depending on the stream (e.g.,
      IETF Stream participants are your working group chairs, the
      responsible ADs, and the document shepherd).

   *  auth48archive@rfc-editor.org, which is a new archival mailing list
      to preserve AUTH48 conversations; it is not an active discussion
      list:

     *  More info:
        https://mailarchive.ietf.org/arch/msg/ietf-announce/yb6lpIGh-4Q9l2USxIAe6P8O4Zc

     *  The archive itself:
        https://mailarchive.ietf.org/arch/browse/auth48archive/

     *  Note: If only absolutely necessary, you may temporarily opt out
        of the archiving of messages (e.g., to discuss a sensitive matter).
        If needed, please add a note at the top of the message that you
        have dropped the address. When the discussion is concluded,
        auth48archive@rfc-editor.org will be re-added to the CC list and
        its addition will be noted at the top of the message.

You may submit your changes in one of two ways:

An update to the provided XML file
 — OR —
An explicit list of changes in this format

Section # (or indicate Global)

OLD:
old text

NEW:
new text

You do not need to reply with both an updated XML file and an explicit list of changes, as either form is sufficient.

We will ask a stream manager to review and approve any changes that seem beyond editorial in nature, e.g., addition of new text, deletion of text, and technical changes.  Information about stream managers can be found in the FAQ.  Editorial changes do not require approval from a stream manager.


Approving for publication
--------------------------

To approve your RFC for publication, please reply to this email stating that you approve this RFC for publication.  Please use ‘REPLY ALL’, as all the parties CCed on this message need to see your approval.


Files
-----

The files are available here:
   https://www.rfc-editor.org/authors/rfc9972.xml
   https://www.rfc-editor.org/authors/rfc9972.html
   https://www.rfc-editor.org/authors/rfc9972.pdf
   https://www.rfc-editor.org/authors/rfc9972.txt

Diff file of the text:
   https://www.rfc-editor.org/authors/rfc9972-diff.html
   https://www.rfc-editor.org/authors/rfc9972-rfcdiff.html (side by side)

Diff of the XML:
   https://www.rfc-editor.org/authors/rfc9972-xmldiff1.html


Tracking progress
-----------------

The details of the AUTH48 status of your document are here:
   https://www.rfc-editor.org/auth48/rfc9972

Please let us know if you have any questions.

Thank you for your cooperation,

RFC Editor

--------------------------------------
RFC9972 (draft-ietf-grow-bmp-bgp-rib-stats-17)

Title            : Advanced BGP Monitoring Protocol (BMP) Statistics Types
Author(s)        : M. Srivastava, Ed., Y. Liu, C. Lin, Ed., J. Li
WG Chair(s)      : Paolo Lucente, Job Snijders

Area Director(s) : Mohamed Boucadair, Mahesh Jethanandani


-------------------------------------------------------------------------------------------------------------------------------------
本邮件及其附件含有新华三集团的保密信息,仅限于发送给上面地址中列出的个人或群组。
禁止任何其他人以任何形式使用(包括但不限于全部或部分地泄露、复制、或散发)本邮件中的信息。
如果您错收了本邮件,请您立即电话或邮件通知发件人并删除本邮件!
This e-mail and its attachments contain confidential information from New H3C, which is intended only for the person or entity whose address is listed above.
Any use of the information contained herein in any way (including, but not limited to, total or partial disclosure, reproduction, or dissemination) by persons other than the intended recipient(s) is prohibited.
If you receive this e-mail in error, please notify the sender by phone or email immediately and delete it!