[bess] Re: Éric Vyncke's Discuss on draft-ietf-bess-mvpn-evpn-sr-p2mp-15: (with DISCUSS and COMMENT)
Rishabh Parekh <rishabhp@gmail.com> Fri, 24 October 2025 15:09 UTC
Return-Path: <rishabhp@gmail.com>
X-Original-To: bess@mail2.ietf.org
Delivered-To: bess@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id 0DFD17BB1009 for <bess@mail2.ietf.org>; Fri, 24 Oct 2025 08:09:25 -0700 (PDT)
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -2.098
X-Spam-Level:
X-Spam-Status: No, score=-2.098 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, FREEMAIL_FROM=0.001, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_NONE=-0.0001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001] autolearn=unavailable autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=pass (2048-bit key) header.d=gmail.com
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id qUPhVNFmzZAH for <bess@mail2.ietf.org>; Fri, 24 Oct 2025 08:09:24 -0700 (PDT)
Received: from mail-pl1-x62d.google.com (mail-pl1-x62d.google.com [IPv6:2607:f8b0:4864:20::62d]) (using TLSv1.3 with cipher TLS_AES_128_GCM_SHA256 (128/128 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id 2137C7BB0FF0 for <bess@ietf.org>; Fri, 24 Oct 2025 08:09:24 -0700 (PDT)
Received: by mail-pl1-x62d.google.com with SMTP id d9443c01a7336-290d4d421f6so20222435ad.2 for <bess@ietf.org>; Fri, 24 Oct 2025 08:09:24 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20230601; t=1761318563; x=1761923363; darn=ietf.org; h=cc:to:subject:message-id:date:from:in-reply-to:references :mime-version:from:to:cc:subject:date:message-id:reply-to; bh=YIP+wNmJOyeciBLuQ+IXYNGywXbT8Ul9ZvWjj5CrCSw=; b=NiSz9l+z3hZIbrf9uFpzB+9xrViEYpv2fQm7Ntl2rtnjdUQGkCv5A226RikUWMSdlr GK01dwdBpvDggc2Cx0ye4T1hMeDg7mihspMrR0TWEON9va/tqVV1l5/zexdyphy0u+ff ZubSb95hdQmpKviHKEWZ/to5pSHJ94a0RMSId7AZ4HQiqyGDlkVoEkauXDqZjL327emX yca74BHTby2RKTBEpsRdJl0dqpX/yC3z9BqRuwWmR9502taVzS906CIhbB8F03gGt1kI EpZjI23hFDLzXNWo4nbzG2zzhmJwiMR+a/3zrkim6CkKPUGnQNM6nBNfYo2dL2vkVK6S 590g==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20230601; t=1761318563; x=1761923363; h=cc:to:subject:message-id:date:from:in-reply-to:references :mime-version:x-gm-message-state:from:to:cc:subject:date:message-id :reply-to; bh=YIP+wNmJOyeciBLuQ+IXYNGywXbT8Ul9ZvWjj5CrCSw=; b=xO1VRxH/QNfHavoRSoupVyqMeo+kubpe+lSm+icTNobqrFSYViSCmkigWICPCuvUdj QAZIAuZc3iHEPzkpjyH37waPLsejyGQOU0GGNqVRGCPv8YzoYyg2jB20TMSrclmET9NU kz0VrnEOqPf8ES36IA/SfQRrOYTzB/GoWPviGkPW8nWGXlTXM8ClVvcDH8ybR33B9urC QWw1T2OuDGgNbPZXaRXfxDI/jpnYnfcEvBl4ZiAATDR3F4OUr2l/sjaGyCQfxCC8o5+z mdk+NX0lCpd+vprHBT6syjuKttDxBpJ5R5p6NzU5ENvf4ZD5kYqT94qvVZl03snIp3PR MYMA==
X-Forwarded-Encrypted: i=1; AJvYcCV3d1F53ykZWSLe47c6pu98qfyicfDygostBag8YbogqECHOy/YmGRD8XWfFKSAmzDfjDDO@ietf.org
X-Gm-Message-State: AOJu0Yy9x6X4Lx3CrnrwQb9hJqPa1LWbtf/J/XLet6EERhc6GZdLoclE V2RS+cKyOBAoNphuKMD9D4Zw631U7COdeEFjQkEOSliiIsafouHIEvbCj/Ib3ixu34K7Xxo1s6R ui516J2xq9z1Cn19GkbdreEyd/k7Eee4=
X-Gm-Gg: ASbGncvJlw5lRhPkikZEAm+Tk4mwsA3GIrlq5W5pSbCuXjJ9dmeTp7GOK4q73LtKds4 kaOx1q0sHFdYnu8SWTX8szDj4zdxAbzAEVVbNHj4ZjlPV7/f11xj7YYeQzjmB3rTcO6XrnDnVux Npa8vxZyTpGUVRp9LZLMrqu3tWPKnaXxk3ixV3ErHD+S7Nc8r+TkKCv5WSTfc47sFNpe7PWsTm0 xUAyp4SAJspN+9jUCKtPWOX1LZGBLSJAOUUWX1IX+ftcbVtBq+dHwhQn70MMT6chpIuKX98SIi5 ruaB8w==
X-Google-Smtp-Source: AGHT+IFWLvoL8RuOJPHByZyqBFBl7jRXBRJyQnua+aaf7JmSCGLRgdL89QzWilZNN3c9mhWvWEwGymoCk3+iMnqKCzU=
X-Received: by 2002:a17:903:2f86:b0:27e:ef35:2dbf with SMTP id d9443c01a7336-290caf8319fmr356150585ad.30.1761318562855; Fri, 24 Oct 2025 08:09:22 -0700 (PDT)
MIME-Version: 1.0
References: <176114334449.111349.15108080267647105520@dt-datatracker-675c8fd764-bsflw> <CABjMoXb_8ChYQfY8xX3b968a8CgjbxzK+tz6q-WXZ6FuKsEaSw@mail.gmail.com> <AS1PR07MB85895AED83869D225A4A396AE0F1A@AS1PR07MB8589.eurprd07.prod.outlook.com>
In-Reply-To: <AS1PR07MB85895AED83869D225A4A396AE0F1A@AS1PR07MB8589.eurprd07.prod.outlook.com>
From: Rishabh Parekh <rishabhp@gmail.com>
Date: Fri, 24 Oct 2025 08:09:11 -0700
X-Gm-Features: AS18NWCweWuCsWt6yd6f546waJvCwbc_J2YDEQ5WA0-t5RqVzp_tWiLI9KKu4bI
Message-ID: <CABjMoXYx0CmWvGSNVhsLiTJ5yuxAawxduEzD2MGYdazcpnb5Jw@mail.gmail.com>
To: "Gunter van de Velde (Nokia)" <gunter.van_de_velde@nokia.com>
Content-Type: multipart/alternative; boundary="000000000000467f8d0641e8ef2e"
Message-ID-Hash: 4UIMDPGEGT7DXGNFCYDIPKTEPKJGIUWN
X-Message-ID-Hash: 4UIMDPGEGT7DXGNFCYDIPKTEPKJGIUWN
X-MailFrom: rishabhp@gmail.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-bess.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: Éric Vyncke <evyncke@cisco.com>, The IESG <iesg@ietf.org>, "bess-chairs@ietf.org" <bess-chairs@ietf.org>, "bess@ietf.org" <bess@ietf.org>, "draft-ietf-bess-mvpn-evpn-sr-p2mp@ietf.org" <draft-ietf-bess-mvpn-evpn-sr-p2mp@ietf.org>, "slitkows.ietf@gmail.com" <slitkows.ietf@gmail.com>, "tim@qacafe.com" <tim@qacafe.com>
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [bess] Re: Éric Vyncke's Discuss on draft-ietf-bess-mvpn-evpn-sr-p2mp-15: (with DISCUSS and COMMENT)
List-Id: BGP-Enabled ServiceS working group discussion list <bess.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/bess/OMHi9YbaK5vFdTK2qsyZnCPCv24>
List-Archive: <https://mailarchive.ietf.org/arch/browse/bess>
List-Help: <mailto:bess-request@ietf.org?subject=help>
List-Owner: <mailto:bess-owner@ietf.org>
List-Post: <mailto:bess@ietf.org>
List-Subscribe: <mailto:bess-join@ietf.org>
List-Unsubscribe: <mailto:bess-leave@ietf.org>
Eric To add to Gunter's point, RFC 9252 Transposition scheme (Section 4 <https://www.rfc-editor.org/rfc/rfc9252.html#name-encoding-srv6-sid-informati>) uses "label" fields in other parts of BGP encoding (NLRI, Extended Community) to encode a portion of the SRv6 SID (FUNCT or ARG) to enable efficient BGP update generation and re-use Extended Communities. Rishabh. On Thu, Oct 23, 2025 at 9:54 PM Gunter van de Velde (Nokia) < gunter.van_de_velde@nokia.com> wrote: > Hi Eric, > > > > Circling back to this discussion called out during yesterday’s formal > Telechat. > > > > You’re absolutely right, the “MPLS Label” field isn’t always an actual > label and can sometimes carry SRv6 SID bits instead. The name is definitely > a bit misleading, no argument there. > > > > The PMSI “MPLS Label” field was originally defined in “RFC6514 section > 5”. > > > > “ > > If the MPLS Label field is non-zero, then it contains an MPLS label > > encoded as 3 octets, where the high-order 20 bits contain the label > > value. Absence of an MPLS Label is indicated by setting the MPLS > > Label field to zero. > > “ > > > > The current draft draft-ietf-bess-mvpn-evpn-sr-p2mp reuses the “MPLS > Label” field to encode part of an SRv6 SID for SRv6-based dataplanes, as > explained in Section 5.2. In other words, it extends the original intent of > RFC 6514 with the following procedure: > > > > “ > > - MPLS Label: The high order 20 bits of this field carry the whole or > a portion of the Function part of the SRv6 Multicast Service SID when > ingress replication is used with the Transposition Scheme of encoding as > defined in [RFC9252 <https://www.rfc-editor.org/info/rfc9252>]. When > using the Transposition Scheme, the Transposition Length of SRv6 SID > Structure Sub-Sub-TLV of SRv6 Prefix-SID attribute (see below) MUST be less > than or equal to 20 and less than or equal to the Function Length. When > Transposition scheme is not used, the label field MUST be set to zero and > Transposition Length MUST be zero. > > “ > > > > Finally RFC9252 section 6.3 ( > https://datatracker.ietf.org/doc/html/rfc9252#section-6.3) provides > following SRv6 SID dataplane encoding procedure: > > > > “ > > *MPLS label:* > > This 24-bit field carries the whole or a portion of the Function part of > the SRv6 SID when ingress replication is used and the Transposition Scheme > of encoding (Section 4 > <https://datatracker.ietf.org/doc/html/rfc9252#SIDENCODE>) is used; > otherwise, it is set as defined in [RFC6514 > <https://datatracker.ietf.org/doc/html/rfc6514>]. When using the > Transposition Scheme, the Transposition Length *MUST* be less than or > equal to 24 and less than or equal to the FL. > > “ > > > > @Éric Vyncke <evyncke@cisco.com> your observation is correct. The “MPLS > Label” name is indeed misleading. As I understand it, the current document > is simply reusing the existing “MPLS Label” definition from RFC 9525. From > a process point of view, there doesn’t seem to be a strong reason to block > this document over that. > > > > That said, it’s definitely worth flagging this observation to the BESS WG. > Using a term like “MPLS Label” to carry SRv6 SID bits isn’t ideal, and it > might be good to discuss whether there’s consensus to revisit and adjust > such dataplane-specific naming in the future. Would that work for you to > resolve the DISCUSS? > > > > G/ > > > > > > > > > > *From:* Rishabh Parekh <rishabhp@gmail.com> > *Sent:* Wednesday, October 22, 2025 7:41 PM > *To:* Éric Vyncke <evyncke@cisco.com> > *Cc:* The IESG <iesg@ietf.org>; bess-chairs@ietf.org; bess@ietf.org; > draft-ietf-bess-mvpn-evpn-sr-p2mp@ietf.org; slitkows.ietf@gmail.com; > tim@qacafe.com > *Subject:* Re: [bess] Éric Vyncke's Discuss on > draft-ietf-bess-mvpn-evpn-sr-p2mp-15: (with DISCUSS and COMMENT) > > > > > > *CAUTION:* This is an external email. Please be very careful when > clicking links or opening attachments. See the URL nok.it/ext for > additional information. > > > > Eric, > > Responses inline @ [RP] > > > > Thanks, > > Rishabh. > > > > On Wed, Oct 22, 2025 at 7:29 AM Éric Vyncke via Datatracker < > noreply@ietf.org> wrote: > > Éric Vyncke has entered the following ballot position for > draft-ietf-bess-mvpn-evpn-sr-p2mp-15: Discuss > > When responding, please keep the subject line intact and reply to all > email addresses included in the To and CC lines. (Feel free to cut this > introductory paragraph, however.) > > > Please refer to > https://www.ietf.org/about/groups/iesg/statements/handling-ballot-positions/ > for more information about how to handle DISCUSS and COMMENT positions. > > > The document, along with other ballot positions, can be found here: > https://datatracker.ietf.org/doc/draft-ietf-bess-mvpn-evpn-sr-p2mp/ > > > > ---------------------------------------------------------------------- > DISCUSS: > ---------------------------------------------------------------------- > > > # Éric Vyncke, INT AD, comments for draft-ietf-bess-mvpn-evpn-sr-p2mp-15 > CC @evyncke > > Thank you for the work put into this document. > > Please find below one blocking DISCUSS points (easy to address), some > non-blocking COMMENT points/nits (replies would be appreciated even if > only for > my own education). > > Special thanks to Stéphane Litkowski for the shepherd's write-up including > the > WG consensus *and* the justification of the intended status. > > Please note that Tim Winters is the Internet directorate reviewer (at my > request) and you may want to consider this int-dir review as well when it > will > be available (no need to wait for it though): > > https://datatracker.ietf.org/doc/draft-ietf-bess-mvpn-evpn-sr-p2mp/reviewrequest/22937/ > > I hope that this review helps to improve the document, > > Regards, > > -éric > > ## DISCUSS (blocking) > > As noted in > > https://datatracker.ietf.org/doc/statement-iesg-handling-ballot-positions-20220121/ > , > a DISCUSS ballot is a request to have a discussion on the points below; I > really think that the document would be improved with a change here, but > can be > convinced otherwise. > > ### Sections 3 & 5.2 > > Keeping the field name of "MPLS Label" (singular) is really misleading as > it > can contains SRV6 SID. Did the WG/authors consider updating RFC 6514 to > change > the field name ? > > > > [RP] No, we did not because RFC 9252 Section 6.3 already set a precedent > of using the "MPLS Label" field to transpose some part of the End.DT2M > SID. I can change the title of the Section to "MPLS Label field" and add > clarifying text to the SRv6 sub-section. > > > > > > ---------------------------------------------------------------------- > COMMENT: > ---------------------------------------------------------------------- > > > ## COMMENTS (non-blocking) > > ### Abstract > > s/This document describes/This document specifies/ > > ### Section 1 > > s/allow a Service Provider/allow a network operator/ > > s/This document describes/This document specifies/ > > > > [RP] Done. > > > > > While the statements `The reader is expected...` are valid in a RFC, they > do > not help the IESG review by a non expert. > > > > [RP] Maybe, but much of this document is based on work done in other RFCs > which are a prerequisite for understanding this document. Based on another > comment, I have converted some of this text to a Terminology section, but > the prerequisite understanding is still required. > > > ### Section 3.1.2 > > To be honest, I failed to follow the procedure... A decriptive figure would > help a lot. The same comment for the whole section 4. > > > > [RP] The next revision is going to reorganize and restructure this > document based on Ketan's comments; I hope it will improve readability and > clarity. Section 3.1.2 is based on Section 4 and 6.1.3 of RFC 9252. We have > added a diagram and high level explanation of the solution in Section 2 and > Section 4 (or at least the detailed Auto-Discovery procedures) have been > simplified. > > > > > ### Section 7 > > Please properly define `IMET`. > > No need to define twice the "BUM". > > > > [RP] These are now defined in the Terminology section. > > > > > What is a `NVE`? > > > > [RP] Text related to NVE has been removed in next revision. > > > > > ### Section 8 > > Having a list of implementations is nice, but if the document refers to RFC > 7942, then it should follow section 2 of this RFC rather than having a very > succint description. > > > > [RP] May I ask what is lacking in this section? > > > > ### Section 9 > > Please add also a URI for "SRv6 Endpoint Behaviors" registry. > > > > [RP] Done. > > > > > _______________________________________________ > BESS mailing list -- bess@ietf.org > To unsubscribe send an email to bess-leave@ietf.org > >
- [bess] Éric Vyncke's Discuss on draft-ietf-bess-m… Éric Vyncke via Datatracker
- [bess] Re: Éric Vyncke's Discuss on draft-ietf-be… Rishabh Parekh
- [bess] Re: Éric Vyncke's Discuss on draft-ietf-be… Gunter van de Velde (Nokia)
- [bess] Re: Éric Vyncke's Discuss on draft-ietf-be… Rishabh Parekh
- [bess] Re: Éric Vyncke's Discuss on draft-ietf-be… Eric Vyncke (evyncke)
- [bess] Re: Éric Vyncke's Discuss on draft-ietf-be… Gunter van de Velde (Nokia)
- [bess] Re: Éric Vyncke's Discuss on draft-ietf-be… Zhang, Zhaohui
- [bess] Re: Éric Vyncke's Discuss on draft-ietf-be… Gunter van de Velde (Nokia)
- [bess] Re: Éric Vyncke's Discuss on draft-ietf-be… Eric Vyncke (evyncke)