[bess] Re: Usage of End.DX2 SID in EVPN-VPWS
"Pablo Camarillo (pcamaril)" <pcamaril@cisco.com> Tue, 29 September 2026 16:44 UTC
Received: from alln-iport-7.cisco.com (alln-iport-7.cisco.com [173.37.142.94]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange x25519 server-signature ECDSA (prime256v1) server-digest SHA256) (No client certificate requested) by mx.ietf.org (Postfix) with ESMTPS id D5C8246; Tue, 29 Sep 2026 16:44:57 +0000 (UTC)
Authentication-Results: mx.ietf.org; dkim=pass header.d=cisco.com header.s=iport01 header.b=GnqNO11p; dmarc=pass (policy=reject) header.from=cisco.com; arc=pass ("microsoft.com:s=arcselector10001:i=1"); spf=pass (mx.ietf.org: domain of pcamaril@cisco.com designates 173.37.142.94 as permitted sender) smtp.mailfrom=pcamaril@cisco.com
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=cisco.com; i=@cisco.com; l=20586; q=dns/txt; s=iport01; t=1790700297; x=1791909897; h=from:to:cc:subject:date:message-id:references: in-reply-to:mime-version; bh=l/XcxQ2gaWdH8UXAxZ8T/0mjwkvHh+tBpXnW89qyhtQ=; b=GnqNO11pjjs1u9yF5fA9FZ25EG6QTvj2/g+yYB8Dj3t3hRx6e2N9syIp diiO085/7YM4RV02Dn4eoc3o7voXRKeHzQWc7hncdQYQ95R84HWEPQLdl Qc1EB6SPu9wRRFZD/N/UoOq2O2+hkpBeWqi7+NuVigQ6AOhtpezSzn/d0 Hof5bkrbycPQr8j914wW6wfFtE/N+WbyGHiVzAOO7U2gvGAqpdi2QtNVR DTldaFRZ4sTFWAUsZPz3+O3BMeyN+yy/jQqzzsPqYi3qN9Qp7HuBx+Wqf 4joQTmSVAjPyZl3Pc1/dC1Z5PgfzzZzoHUDEGL/zf8FYf2TKulvHWSwd1 A==;
X-CSE-ConnectionGUID: HYpqkyfxRPK+CY50GHql5A==
X-CSE-MsgGUID: WM2qpz2kTAOnNVBLURK4Dg==
X-IPAS-Result: A0CHAwAH6rtq/5AQJK1agS6BK4E9MSopgQuBERJJiCMDhSuIeQOeGhSBag8BAQEOAT0UBAEBhQUCjggCJjQJDgECBAMCAwEBAQEBAQEBAQEBAQoBAQUBAQECAQcFgQ4Thk8NkBIBAQEBA3kQAgEIEQECAQEBLzEXBggBAQQBDQUIgnuCHVcDAQIOtkYCih14gTSBAVeDFkHcCAaBTYVAgx4BASuBNYJdgSMZhAF7JxuBSUQmb0KCFlM+gmEBAQIBgRcRARIBIx4Yg12CMASCDRV6EhuBP4FNGYhoiQhSciIDJjMsAVUTFwsHBYEjEDMDKi8tI0sFLR1wDCcSDx0XER5YGwYFEiAqQUNdgVo/Ixk2eoEJXoErKWABAg4XRkGCBwKCVIEjXgIBSUMOB0VTCSU+BxJHJiIIEgkBExowC4EhOEEJKD9tPTcGDxkDBIE1BY9UYR6Bc4FKCCICGxkCRgoIKywiBgcBARkaO5J4LwmPPIF8jGSVFwqEHowilXAXhASNFJlXmQgjjWebDgIEAgQFAhABAQaBaDwrPnBwFYMiUxkPji4WgRQBAodcxwZ5AgE6AgcCBw4DC5NmAQE
IronPort-PHdr: A9a23:QnDeBR3dNEebgQxhsmDPmlBlVkEcU/3cNwoR7N8gk71RN/nl9JX5N 0uZ7vJo3xfFXoTevupNkPGe87vhVmoJ/YubvTgcfYZNWR4IhYRenwEpDMOfT0yuBPXrdCc9W s9FUTdY
IronPort-Data: A9a23:B31EHa48DED8+oELwmjJRQxRtG7GchMFZxGqfqrLsTDasY5as4F+v jBJDT2OMvaMMGSjf9t0b461oEgOusXczoJjGwdqqChjZn8b8sCt6fZ1gavT04J+CuWZESqLO u1HMoGowPgcFyGa+1H1dOex9RGQ7InQLpLkEunIJyttcgFtTSYlmHpLlvUw6mJSqYDR7zil5 5Wo/KUzBHf/g2QqajNOuvrawP9SlK2aVA0w7wRWic9j5Dcyp1FNZLoDKKe4KWfPQ4U8NoaSW +bZwbilyXjS9hErB8nNuu6TnpoiG+O60aCm0xK6aoD66vRwjnVaPpUTaJLwXXxqZwChxLid/ jniWauYEm/FNoWU8AgUvoIx/ytWZcWq85efSZSzXFD6I0DuKxPRL/tS4E4eHbwA4+VmD3F0z d9bAwFQNj+jnubr6efuIgVsrpxLwMjDNYcbvDRkiDreF/tjGc+FSKTR7tge1zA17ixMNa+BP IxCN3w2MlKZP0En1lQ/UPrSmM+wjXD6eidZrHqepLE85C7YywkZPL3FYIeJK4XVHZsL9qqej l3jpX3hEEsZCPW4zxy72FaRvMyTsSyuDer+E5X9rJaGmma7zGEIEzUXWEe15/6jhSaWQMpFK kob0isjsaZ081akJuQRRDWxpHqC+xpZUN1KHqhit0eGy7Hf5ECSAW1soiN9VeHKffQeHFQC/ lSIhNjuQzdotdWopbi1r994cRva1fApEFI/
IronPort-HdrOrdr: A9a23:dM+/Ua5+hUS8ynNXqQPXwR+CI+orL9Y04lQ7vn2ZFiYlEfBwxv rPoB1E737JYW4qKQ8dcLC7VJVpQRvnhPhICPoqTMaftWjdySWVxe5ZnPHfKlHbaknDH6tmpN hdmstFeZzN5DpB/LvHCWCDer5KrqjkgcWVbKXlvgtQpGpRGthdBnJCe32m+zpNNXF77PQCZf 2hz/sCjQCNPV4QacO2DGQEWe/sm/3n/aiNXTc2QzQcxE2rlz2H1J7WeiL04j4uFx9fy7Yr9m bI1zf++riitP+DzBrd3X/47phdmtfto+EzRPBkjPJ7FhzcziKTIKhxUbyLuz445Mu17kwxrd XKqxA8e+xu9nL4ZAiO0FnQ8jil9Axrx27pyFeej3emi9f+XigGB81Igp8cWgfF6nAnoMp33M twriekXttsfFf9dRbGlp71viJR5xOJSL0Z4LYuZklkIMwjgXlq3NciFQ1uYc099WnBmfAa+a FVfbLhDbBtABCnRkGcmHVzy9qxWXl2NBKHTk8e/vGx6VFt7S1EJ49y/r1Bop/Gn6hNF6Vs9q DKNL9lm6pJSdJTZaVhBP0ZSc/yEWDVRwnQWVjia2gPOZt3c04lkaSHq4kd9aWvYtgF3ZEykJ POXBdRsnMzYVvnDYmL0IdQ+h7ATW2hVXC1o/suq6RRq/n5Xv7mICeDQFchn4+ppOgeGNTSX7 K2NIhNC/HuIGPyEcIQtjeOFKV6OD0bSokYq9w7U1WBrobCLZDrrPXSdLLWKKD2GTgpV2vjCj 8IXST1Js9H8ke3M0WIzST5SjfoYAjy7JhwGK/V86waz5UMLJRFtkwPhVGw9qiwWHR/W2wNDT 1DyZ/c49SGTDONjBP1xnQsPgAYFUpc6qjhVXRRzDV6QX8cWYxzz+miRQ==
X-Talos-CUID: 9a23:l/MmbGzEmdi8Cl6awk2yBgU0K9g8cWzT3E3oAAyTODsxZ52MTQK5rfY=
X-Talos-MUID: 9a23:8VzTqg0TQY3qdXXudy3vXCu8PDUj3IH0EVgfy5Y6ku6CExJaHwqnr2ibTdpy
X-IronPort-Anti-Spam-Filtered: true
Received: from alln-l-core-07.cisco.com ([173.36.16.144]) by alln-iport-7.cisco.com with ESMTP/TLS/TLS_AES_256_GCM_SHA384; 29 Sep 2026 16:44:57 +0000
Received: from alln-opgw-5.cisco.com (alln-opgw-5.cisco.com [173.37.147.253]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature RSA-PSS (2048 bits) server-digest SHA256) (No client certificate requested) by alln-l-core-07.cisco.com (Postfix) with ESMTPS id D6F06180001F5; Tue, 29 Sep 2026 16:44:56 +0000 (GMT)
X-CSE-ConnectionGUID: gbY82Y/DTl2CBrJFnZRlUQ==
X-CSE-MsgGUID: nng+GTBBSuKBxspLx6aAjA==
X-IronPort-AV: E=Sophos;i="6.27,130,1787011200"; d="scan'208,217";a="67336695"
Received: from mail-westus2azon11010056.outbound.protection.outlook.com (HELO CO1PR03CU002.outbound.protection.outlook.com) ([52.101.46.56]) by alln-opgw-5.cisco.com with ESMTP/TLS/TLS_AES_256_GCM_SHA384; 29 Sep 2026 16:44:56 +0000
ARC-Seal: i=1; a=rsa-sha256; s=arcselector10001; d=microsoft.com; cv=none; b=priQPc+1w5YOPjHvrcutQHAepoTPSIRAECEOcHvuHZm4LhMVUbXwcAnY2ZLYNW4ZaAy6GxcX2GrkJiufnIddoPw7NsFh9MWFscah4Af8F9VDphSgujDbYu4zyQWVSoFl3rJKMQwjEdZ2R2GNNsi7xVCCHzvAG3qtt0pxylad1RVWCajOqzjHlb4hi1pJy/K/btEpJ0tCN3/kPB2K7hftxxVNhPQOppV1HRJHhbMwLog+OdZScJapgvj4SFBzGZ2nxb1+jX7GCfPtsHrYgJUE8P41+abT2/GOElAAbBoLfo45jh7Z9YuX7mXWDgqhQWEb2K+L67Yrx2HEl1SMcKdBNQ==
ARC-Message-Signature: i=1; a=rsa-sha256; c=relaxed/relaxed; d=microsoft.com; s=arcselector10001; h=From:Date:Subject:Message-ID:Content-Type:MIME-Version:X-MS-Exchange-AntiSpam-MessageData-ChunkCount:X-MS-Exchange-AntiSpam-MessageData-0:X-MS-Exchange-AntiSpam-MessageData-1; bh=l/XcxQ2gaWdH8UXAxZ8T/0mjwkvHh+tBpXnW89qyhtQ=; b=E/C7tOj26D3tj6A5MWuSv8k6MG04AqhRBf7ZmLw9jtH46p2a2v6PFqDpsD5l9SvLzOJ6xUmbYrzt0Pfvp3Wz3xtCQeJnjnQZio3O/DHmO1TAW8YBQFGvvr6wdAgVwyfzQ0d3mRO1/XjI97MV5Dz66Pyvssjl/kCYtfbL4YP3G2LfR+XFxDrvuBeNySM3QWb/XI/oFOKC1H/h5P/X57eC9Oeq+6yuWX2mOcO2hmcRkZMHcbg8xhOVj+QHZAUE50MX50ZKEbvuIhNT4NqKojEaoYpy4ed/hD3+l4vw8LWclCixYVfy9OY5bBbgtKZm8cxCOuQ32D7tum/ELappP1izHA==
ARC-Authentication-Results: i=1; mx.microsoft.com 1; spf=pass smtp.mailfrom=cisco.com; dmarc=pass action=none header.from=cisco.com; dkim=pass header.d=cisco.com; arc=none
Received: from DM8PR11MB5719.namprd11.prod.outlook.com (2603:10b6:8:10::6) by DM4PR11MB8132.namprd11.prod.outlook.com (2603:10b6:8:17e::13) with Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) id 15.21.451.26; Tue, 29 Sep 2026 16:44:54 +0000
Received: from DM8PR11MB5719.namprd11.prod.outlook.com ([fe80::889d:d063:1254:9087]) by DM8PR11MB5719.namprd11.prod.outlook.com ([fe80::889d:d063:1254:9087%4]) with mapi id 15.21.0451.022; Tue, 29 Sep 2026 16:44:54 +0000
From: "Pablo Camarillo (pcamaril)" <pcamaril@cisco.com>
To: Alexander Vainshtein <Alexander.Vainshtein=40rbbn.com@dmarc.ietf.org>, "spring@ietf.org" <spring@ietf.org>
Thread-Topic: Usage of End.DX2 SID in EVPN-VPWS
Thread-Index: Adz5uPR7fUL5tRVIRvCZZdadAMF0WRKpxyFwAvRj1p0=
Date: Tue, 29 Sep 2026 16:44:52 +0000
Message-ID: <DM8PR11MB5719B52E2804FF4CF38FB6A1C98C2@DM8PR11MB5719.namprd11.prod.outlook.com>
References: <PH0PR03MB63003C7B2328118DE034A087F61B2@PH0PR03MB6300.namprd03.prod.outlook.com> <PH0PR03MB630089DBBA00EF47AD6D9215F6BB2@PH0PR03MB6300.namprd03.prod.outlook.com>
In-Reply-To: <PH0PR03MB630089DBBA00EF47AD6D9215F6BB2@PH0PR03MB6300.namprd03.prod.outlook.com>
Accept-Language: en-US
Content-Language: en-GB
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
x-ms-reactions: allow
x-ms-publictraffictype: Email
x-ms-traffictypediagnostic: DM8PR11MB5719:EE_|DM4PR11MB8132:EE_
x-ms-office365-filtering-correlation-id: 1493ef4f-3302-41f2-ee8d-08df1e48fd02
x-ms-exchange-senderadcheck: 1
x-ms-exchange-antispam-relay: 0
x-microsoft-antispam: BCL:0;ARA:13230040|10070799003|1800799024|23010399003|376014|366016|10067099003|56012099006|11063799006|3023799007|6133799003|4143699003|8096899003|22082099003|18002099003|38070700021;
x-microsoft-antispam-message-info: Wa6d1rMlwQvoVxNgmwwXYdWxAW/8ti8rS88Gzxv3Ayr9FOuEJdRPmajR3sxqloPzPUy/eGwPsPWwEEybzwN9uEdmD2qtmw/55W1wozyV/mKaL/k93acd3mGql3bpINObf3yc4m5EsNaFn3VDLaEYsGLiez1BbmTyKpP3bPbBNjgtNSpPtcvF3yc+TZjhdG4M36vg++M/7GJA8LMoMf22LcO7MF9AOwTfP05Xy68hSDjx4D1HhcipmH8hEzvi8kGucGTGJQNZ5VVc+OFsVx1nxYkpZURLUAjYkahOv8jIO8E+p45z3X8Ua12mseXRfhRGoa+whlc29j/MRHSUxZyF8cQTYOJt8244rsIzNKePMObxtCASykKTBCB5yQJrTgtrmKmq80faaz3bX4mH2vJA0ETcd5aKneZzKCpXetalzQj8EMczdyPsbYuLsOiIdcVOcATeEtn8l7w8DIimnVX3Qmqd041bhTz/yrgFJf38yFVGg6/ldux+LRYVBAaY3S0HZMmeud+W85gb0DhaB9xBPyVoqWjUZ33WVINGoEgo7KavNm2dBqocgUXZILYkA2A6v3ceM0BPuIELnh4svJ+css6k92J5FHXhspvvioxPfTu/gYjZ/BhMIXbSF83gNiMGQpGvzPH1dctbZnnZVAaYxu1JDKr81B62mnPuwLMWa9xMVkPqHJ8I/xuUUuDcLCkJWmK+DdIDMz1VQCqhQtjE8Cu4plJiTrWF/xPKqYDTN7g=
x-forefront-antispam-report: CIP:255.255.255.255;CTRY:;LANG:en;SCL:1;SRV:;IPV:NLI;SFV:NSPM;H:DM8PR11MB5719.namprd11.prod.outlook.com;PTR:;CAT:NONE;SFS:(13230040)(10070799003)(1800799024)(23010399003)(376014)(366016)(10067099003)(56012099006)(11063799006)(3023799007)(6133799003)(4143699003)(8096899003)(22082099003)(18002099003)(38070700021);DIR:OUT;SFP:1101;
x-ms-exchange-antispam-messagedata-chunkcount: 2
x-ms-exchange-antispam-messagedata-0: hlDGaXHDEIxsFIowwFbaASDAu6oh4kqUZi4fokgFkLxZoGcmPh6XZSaFtq7uAE92q2rUiwzOyiPKbYyyRElZ8ULHeufIL0Yar8vCXxCVIND5sssl/Vvjrvqc4mlzWoailCjZccpgN9LUEeEi/3MZFQLJL7/MtBqFiKzjerKP1I9MWqA5TVigMo2e7cQqEuAdz4DBnIvAIGtGaHPcGtQB5muK8uHVuU1Wpl6Tsam7xYllH+AR/yPwuCrpEX3WC0YOsKz84R1PmKoxNmRid4UodKwFrA+K9KG7VRwpDtcZRGZayziw4MTWliF2D6UoiniCVlTjj5uc0MUB/QAHeeV/jekg/ojYW0ILI6wLW48O2ME3nSrBhlZsjeVWA+06HlFL+Ax2MaaibVeYA6g6YrL4cE2r3n7IHcve98ZtUrys+XZ8LJemXvvvHcIVZg3ln9fKAaco7iH82wNpK5Fh+9r6RlV2IBR62l5b5IFvH+o5LVInOjjCdBL2mobb52nLY8jnnbett1fdmQLK/Qefbayc3PT4hGX+mL8Qdr+vkL9/PLMs607VgwwF5KvXzuYhwcrG8zEjl10RXeD7SiqpAXtBixAUVT/ierxAxtPL9XlQ0gpHgkuPFV5jBnfYrW8OD5V+7ijA88qEj1ToxJn8EnWyc79kDJJf88kR0In+oCSI0GRAuufCx+XOSxbHgDjmwJ2pxfrQgt00cpqRLaU/nyTTGYFYOOnl2JQssQL5SIdQbFnGFtA6up7McMds7eMbZQQSQoqRnXuHOF1dVmM3mp/HIAyczolC3l3Ocx7tyHh7zNa35nFOgdZctDT2jGxFqJXRllxfAtVQqCG5E4kwaaSPnHvqqYf7THtsur6SJ8pABoXaAJiN1YL/IqW6elkKx4gJUezMxjHJYjz3tOrA6tmoUFM0SZcn8p7UkmyGtwKombKk1jivu53j5WSmNQLvRQRtynHWFcyjsaAY+iTEsULrQBFflMRBOyBt518NxkYbjZ2AK6arngKl6PKHsUz6FZnu+vaLYfiLyVYMYlJ7b6/sMYiCzpnGIL8kvtaN2FawyPhYZ9VMhz48nUKdireg3k45pacS0JVWu2cjzn/fImrucQdYZ22r5J3TzP7ZWW4pZMSpREVza+m7uMOuzvJFKDdLPjrQb/7xaY5SeS2ztjVI/qpdnCkH9x668xj9h4+2UEWtQRYq6IEK0lH4wYLWvJwzGGylRSLpGskWf+vunF7gGtsebKQ7f84iALea4SDHI5GAxoi/VtXHkYOkj3AqjS/PDh27XxSJJL/GK0uEGrtGIHtLSkuzfGFK6KeM4L00lBHUSReBaYAs+CXow2Pf5EoIAn8/JqCyrUS3owjwBXI347mMKr3sgiNzmGqc9Rl72YpqrmNTFs7J2tjVhhmq5FCPTKN22F13mqx9ba2jLXUok0l44Vp0vqJJUnB7ZQVSBQRjnYI+INL9GebbpwXB7a5ItPH1z79ZftGZwBAB63rr6c0dR/l+hIBPG1Uxldld3B32mBbMKek0gNw20VkMJFJNPtBCaCM2G2V7U5Z+pAoDmQ0wzFnOOsBvyjtVDCandH/hm5GSXOODhnCm1ej+gDCFFC/ufIBOyU3CfS01v1shAxFdNGWQOwpP3llW/hibXPFhGxMcwwRPzS9o5qS/r++Q/zhSDlbeOYUK1DUeJfzqQCCOQbuiYf+K4w6DsXBp09eMsoUxB8V/J6PCM9xCaj4awgxQIOxsFoqiWeWtELl8gADosVmh/xGOFqZxzuFGRzX0b3HRjNxdInhOMOCJ+O5n3nCMA4qA
x-ms-exchange-antispam-messagedata-1: 6RVJo3PpDCQwcQ==
Content-Type: multipart/alternative; boundary="_000_DM8PR11MB5719B52E2804FF4CF38FB6A1C98C2DM8PR11MB5719namp_"
MIME-Version: 1.0
X-Exchange-RoutingPolicyChecked: 4E0C4HeaALD9bTnfuPaSNYVid7PHtS5hppWTgXy9juyTsHg1Q62yFY9Jir/bcory+YrfgHGTaelFHeFpT75wqe30hOhJaVn2YUvcP6PhSO2gOvUR9xEc/OgD1PbMIhkgLzG5goRXVvBZhKVb2prbSyJHKx1V5QbIZ39UJMMKZj/GQ0kIO6cy4xhsU7eLfPyx6ALb9twN6voLSMX7McjyWJzjE0lPjtglZsOiwLGZbdKqq5rU/ZKSuQ+CI3LrtHE6y12D8hvcezhDrB+vsISmNZPT/boCxsMO0N0RrRFlRuvsSLWhAVoJU4fIhxxx2se7RiNl9fma3kGKlRFSD3Xk4A==
X-OriginatorOrg: cisco.com
X-MS-Exchange-CrossTenant-AuthAs: Internal
X-MS-Exchange-CrossTenant-AuthSource: DM8PR11MB5719.namprd11.prod.outlook.com
X-MS-Exchange-CrossTenant-Network-Message-Id: 1493ef4f-3302-41f2-ee8d-08df1e48fd02
X-MS-Exchange-CrossTenant-originalarrivaltime: 29 Sep 2026 16:44:54.0893 (UTC)
X-MS-Exchange-CrossTenant-fromentityheader: Hosted
X-MS-Exchange-CrossTenant-id: 5ae1af62-9505-4097-a69a-c1553ef7840e
X-MS-Exchange-CrossTenant-mailboxtype: HOSTED
X-MS-Exchange-CrossTenant-userprincipalname: 0AMQyHMJJbPoCCG6hOEBLgnOTxtdE/FV/PW80cY8ObLCkUVPgDAUL7bfGhQbSEl3XlgKbvdBuemX17gsI0W5gw==
X-MS-Exchange-Transport-CrossTenantHeadersStamped: DM4PR11MB8132
X-Outbound-Client-TLS: ANONYMOUS;alln-opgw-5.cisco.com [173.37.147.253];TLSv1.3;TLS_AES_256_GCM_SHA384;256
X-Outbound-SMTP-Client: 173.37.147.253, alln-opgw-5.cisco.com
X-Outbound-Node: alln-l-core-07.cisco.com
X-Spamd-Bar: -------
Message-ID-Hash: A4JRL7TPEMMNX53N25R6DSAHNWGBPPAU
X-Message-ID-Hash: A4JRL7TPEMMNX53N25R6DSAHNWGBPPAU
X-MailFrom: pcamaril@cisco.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; loop; banned-address; header-match-bess.ietf.org-0; emergency; member-moderation; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: BESS <bess@ietf.org>
X-Mailman-Version: 3.3.10
Precedence: list
Subject: [bess] Re: Usage of End.DX2 SID in EVPN-VPWS
List-Id: BGP-Enabled ServiceS working group discussion list <bess.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/bess/RyWgf4XnGTu2VJrKTBGiCD0XZAw>
List-Archive: <https://mailarchive.ietf.org/arch/browse/bess>
List-Help: <mailto:bess-request@ietf.org?subject=help>
List-Owner: <mailto:bess-owner@ietf.org>
List-Post: <mailto:bess@ietf.org>
List-Subscribe: <mailto:bess-join@ietf.org>
List-Unsubscribe: <mailto:bess-leave@ietf.org>
Hi Sasha, RFC 8986 specifies the fundamental data-plane pseudocode/primitive endpoint behaviors under nominal operation where the SID and outgoing interface I are active and valid. Interface Failure and Protection: RFC 8986 intentionally does not embed protection, fast reroute (FRR), or multi-homing state machines into the base endpoint definition. Instead, interface failure handling and protection mechanisms are governed by the relevant service layer and fast-convergence specifications (such as EVPN multi-homing in RFC 9252 / BESS SRv6 EVPN and TI-LFA / Egress Protection frameworks). Rerouting / Backup Encapsulation: In an EVPN VPWS or multi-homed active-standby/all-active scenario where interface I fails, an implementation that supports local egress protection / bypass may pre-program a backup path in the FIB. When I goes down, the node can encapsulate the decapsulated Ethernet frame into an SRv6 policy toward the backup PE's Service SID (or alternate interface) prior to control-plane reconvergence. This is an application of standard service-layer protection/FRR on top of the base behavior and is fully compliant with the architecture. Hope this clarifies it. Let us know if you have any further questions. Cheers, Pablo. From: Alexander Vainshtein <Alexander.Vainshtein=40rbbn.com@dmarc.ietf.org> Date: Tuesday, 15 September 2026 at 03:26 To: spring@ietf.org <spring@ietf.org> Cc: BESS <bess@ietf.org> Subject: [bess] Re: Usage of End.DX2 SID in EVPN-VPWS Hi all, A gentle reminder: I have not received feedback from the SPRING WG on my email sent 3 months ago, The question in this email can be re-formulated differently: Suppose that an SID with endpoint with behavior End. DX2 has been defined and associated with the outgoing interface I. As long as I is operationally UP, packets received with this SID as the Destination IPv6 address in the IPv6 header shall be processed as defined in the standard, i.e.: * IPv6 header and all extension headers will be stripped * The resulting Ethernet frame shall be sent "as is: via I The question: How will packets received with this SID as the Destination IPv6 address in the IPv6 header be processed if I is operationally DOWN? Can we say that such packets MUST be discarded? Regards, and lots of thanks in advance, Sasha From: Alexander Vainshtein Sent: Thursday, June 11, 2026 7:10 PM To: spring@ietf.org Cc: BESS <bess@ietf.org> Subject: Usage of End.DX2 SID in EVPN-VPWS Importance: High Hi, I have a question about usage of End.DX2 SID (as defined in Section 4.9 of RFC 8986<https://datatracker.ietf.org/doc/html/rfc8986#section-4.9>in EVPN-VPWS. * The definition of this endpoint behavior says that "The End.DX2 SID MUST be the last segment in an SR Policy, and it is associated with one outgoing interface I" * If the upper-layer header type is Ethernet, the IPv6 header and all extension headers are stripped, and the resulting Ethernet frame is forwarded to the outgoing interface I. EVPN-VPWS as defined in RFC 8214 is explicitly mentioned as one of possible applications in this section, and Section 6.1.2 of RFC 9252<https://datatracker.ietf.org/doc/html/rfc9252#section-6.1.2> explicitly mentions End.DX2 as one of possible behaviors of the SID signaled in per-EVI Ethernet A-D routes (along with End.X2V and End.DT2U). I think that End.X2 behavior as defined above is not compatible with one of the advantageous features of EVPN-VPWS as described in the last para of Section 5 of RFC 8214<https://datatracker.ietf.org/doc/html/rfc8214#section-5>: <quote> Finally, EVPN may employ data-plane egress link protection mechanisms not available in VPWS. This can be done by the primary PE (on local AC down) using the label advertised in the per-EVI Ethernet A-D route by the backup PE to encapsulate the traffic and direct it to the backup PE. <end quote> (For the reference, implementing fast egress protection against AC failure in "classic" VPWS has been defined in RFC 8104). What, if anything, did I miss? Do you think that a new Endpoint behavior should be defined? Regards, and lots of thanks in advance, Sasha Disclaimer This e-mail together with any attachments may contain information of Ribbon Communications Inc. and its Affiliates that is confidential and/or proprietary for the sole use of the intended recipient. Any review, disclosure, reliance or distribution by others or forwarding without express permission is strictly prohibited. If you are not the intended recipient, please notify the sender immediately and then delete all copies, including any attachments.
- [bess] Usage of End.DX2 SID in EVPN-VPWS Alexander Vainshtein
- [bess] Re: Usage of End.DX2 SID in EVPN-VPWS Luc André Burdet
- [bess] Re: Usage of End.DX2 SID in EVPN-VPWS Alexander Vainshtein
- [bess] Re: Usage of End.DX2 SID in EVPN-VPWS Alexander Vainshtein
- [bess] Re: Usage of End.DX2 SID in EVPN-VPWS Alexander Vainshtein
- [bess] Re: Usage of End.DX2 SID in EVPN-VPWS Pablo Camarillo (pcamaril)
- [bess] Re: Usage of End.DX2 SID in EVPN-VPWS Gyan Mishra
- [bess] Re: [EXTERNAL] Re: Re: Usage of End.DX2 SI… Alexander Vainshtein
- [bess] Re: [EXTERNAL] Re: Re: Usage of End.DX2 SI… Jorge Rabadan (Nokia)
- [bess] Re: [EXTERNAL] Re: Re: Usage of End.DX2 SI… Luc André Burdet
- [bess] Re: Usage of End.DX2 SID in EVPN-VPWS Alexander Vainshtein