Re: [C310] * AD - Alvaro Retana, John Scudder, or Martin Vigoureux Re: AUTH48 [LB]: RFC 9035 <draft-ietf-roll-turnon-rfc8138-18.txt> NOW AVAILABLE

"Pascal Thubert (pthubert)" <pthubert@cisco.com> Wed, 21 April 2021 20:17 UTC

Return-Path: <pthubert@cisco.com>
X-Original-To: c310@rfc-editor.org
Delivered-To: c310@rfc-editor.org
Received: from localhost (localhost [127.0.0.1]) by rfc-editor.org (Postfix) with ESMTP id 602FBF407B8; Wed, 21 Apr 2021 13:17:13 -0700 (PDT)
X-Virus-Scanned: amavisd-new at rfc-editor.org
X-Spam-Flag: NO
X-Spam-Score: -107.478
X-Spam-Level:
X-Spam-Status: No, score=-107.478 tagged_above=-999 required=5 tests=[DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=0.01, HTML_MESSAGE=0.01, RCVD_IN_DNSWL_MED=0.01, RCVD_IN_MSPIKE_H3=-0.01, RCVD_IN_MSPIKE_WL=-0.01, SPF_HELO_PASS=0.01, SPF_NONE=0.001, SUBJECT_IN_WHITELIST=-100, URIBL_BLOCKED=0.001, USER_IN_DEF_DKIM_WL=-7.5] autolearn=ham autolearn_force=no
Authentication-Results: rfcpa.amsl.com (amavisd-new); dkim=pass (1024-bit key) header.d=cisco.com header.b=TkU/4LIP; dkim=pass (1024-bit key) header.d=cisco.onmicrosoft.com header.b=oLEqQ+QM
Received: from rfc-editor.org ([127.0.0.1]) by localhost (rfcpa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id ItV5qQvaa1qD; Wed, 21 Apr 2021 13:17:09 -0700 (PDT)
Received: from alln-iport-5.cisco.com (alln-iport-5.cisco.com [173.37.142.92]) by rfc-editor.org (Postfix) with ESMTPS id 9E872F407AF; Wed, 21 Apr 2021 13:17:08 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=cisco.com; i=@cisco.com; l=175637; q=dns/txt; s=iport; t=1619036233; x=1620245833; h=from:to:cc:subject:date:message-id:references: in-reply-to:mime-version; bh=2Etzf1cc60uH0WpX1FZtePWaGu9JgTyRM4aLRcmtBHw=; b=TkU/4LIPZXBH21je5OkznsOBrWyt2BS+Ro27Gsmu8L/YYV1tHUPTNGVH y+aGmcQ51wt2vSeLhEPwiSj+DkN8xq+gQHYD4iv+BVBQNC14dER9kBn64 FBwJw/wd7z/wDhOyExkhWeDNcY3eEciRdDOW0KmSSi8LT4T6vx91RHJgC E=;
X-IPAS-Result: A0BkAwBnh4BgmJJdJa1aHgEBCxIMgzUwIwYoflo2FwEBGIRDg0gDhTmIdQOBDI4gihWBQoERA08FCwEBAQ0BAR0BDAgCBAEBgToBgxUCF4FeAiU4EwIDAQEBAwIDAQEBAQEFAQEBAgEGBBQBAQEBAQEBAWiFUA2GRAEBAQICAQEYAQgEGQEBLAsBCwQCAQgRAwEBASEBAgcCAgIlCx0IAgQOBYJxAYF+VwMvAQ6eCwKKH3p/M4EBggQBAQaBMwGEDg0LghMDBoE6gnmCcVJGAQGGUyccgUlCgRMnHFSBC0oHLz6BBE1NQgECAYEkHAQLJgmCdzaCK4FYAQIOAQlXATUeEAEDKAUFBgsOAlcEGBITCBAkAgckER4BDiYPD4tWhFeDGkKHb40DkWUKgw2WXYY1BCGDUIsBjCuDb4NBglyBb4RckGicQwcBCw0BhEsCBAIEBQIOAQEGgWshgVtwFRohKgFzCoFBUBcCDo4fBwULAgkVbQENgj6FFIVJcwI2AgYBCQEBAwl8iU+BZl4BAQ
IronPort-PHdr: A9a23:IHY++BMf532x/OzN2DEl6nf1WUAX047cNxMJ6pchl7NFe7ii+JKnJ kHE+PFxlzfhVIDA77RPjO+F+6zjWGlV55GHvThCdZFXTBYKhI0QmBBoG8+KD0D3bZuIJyw3F chPThlpqne8N0UGEcPlYxvZpXjhpTIXEw/0YAxyIOm9E4XOjsOxgua1/ZCbYwhBiDenJ71oK xDjpgTKvc5Qioxnec4M
IronPort-HdrOrdr: A9a23:R+1s963DjG0BoYGf4f0SowqjBeB2eYIsi2QD101hICF9Wvez0+ izgfUW0gL1gj4NWHcm3euNIrWEXGm0z/9IyKErF/OHUBP9sGWlaLtj44zr3iH6F0TFmNJ1/Z xLN5JzANiYNzdHpO7x6gWgDpIEyN6I7KiniY7lvghQZCtBApsQiDtRIACdD0FwWU1iDZ02CJ KT6qN81kSdUF4Qadm2AWRAYvjbq7Tw5dzbSDMlJzpi0gmBiju09KX3eiL54j4yWy5CqI1Sil TtvBf+4syYwpSG4z/ak1Te9pFH3Obmo+EzePCkrugwBnHShh2zZIJnMofy/QwdhO208l4lnJ 3tjn4bTr5OwkjcdG20vhfhsjOIuF1FhhOSqi77vVLZrcP0Xz48AcZa7LgpDyfx0VYqv913zc twrgSknqdXFh/JkWDc4NXFRnhR5zKJiEciiuIagjhjV5IfYtZq3PUi1X5Sea1weB7S2cQCKq 1DHcvc7PFZfRexdHbCpFRix9SqQzAaAgqGalJqgL3U7xFm2FRCi2cIzs0WmXkNsLgnTYNf2u jCOqN00JlTU84ta75nDutpe7r1NkX9BTb3dE6CK1XuE68Kf1jXrYTs3bkz7Oa2PLsF0YU1g5 aEdF9Dr2Y9dwbPBKS1rd922yGIZF/4cSXmy8lY6ZQ8kKb7XqDXPSqKT01rnNCnp/kZH83HS/ e+MJ9bGJbYXC/TMLcM+ze7d4hZKHEYXsFQkM08QUiyrsXCLZCvtuGzSoeVGJPdVRIfHk/vCH oKWzb+YO9a6FqwZ3P+iB/NH3fkekn1+4NsALHXltJjjrQlB8lpiEw4mF657saEJXlpqaotZn ZzJ7vhj+e8vmm5/WHB6m1zIRpDBkNJ4LHtOkk64DMiAgfRS/Iuqt+fcWdd0D+sPRlkVf7bFw ZZuhBq466tNoeRwiojEtqjNWqfgxIo1Su3ZqZZvpfGydbue5s+AJpjZbd4Eh/TEQdp3Sxwrn 1YVQMCTkjDNz/nhKm/lqYIDOXHe9QUunbyHedk7Vbk8WSVv4UGW2YSVT/Ga7/nvS8eAx5vwm BX34BaqryagjqrIXY4m40DQS1xQVXSJqlHAgSDbJhTgZbxdmhLPDy3rA3frQ0vcWz38EhXoW rtIUSvCKz2K2sYnGxE2aD3914xTEGhRgZbb3B3tpAVLxWdhl96zfKLaq2v02GYd1sFxaUHPC vYZCYJSzketOyfxVqbni2PGm4hwYhrNuvBDK47e7WWwX+1LpaU/Jt2U8N87dJgNNr0tPUMXv /acwiJLCngA+dB4X3eml81fC11omIji/XmxVns63W5xmc2Bb7XLE59T78WZ9Ga4G6MfYfE7L xpydY0t/C3KGP/d5qPzrzWdSdKLlfLunGtJttY4Kx8rOY3rv9+DpPbWTzH2DVO2wg/Nt79kA cbTL5g6L7MN4dzd6UpCm1k10tskM7KIFogswTwDON7Z10rgnPBN96C4rbDq9MUcwa8jRq1PU Pa/zxW/v/DUSfGyKUTDLgoJ39KLEc783Zv8Yq5BvvtIRTvc/sG+lW0MnWwKuAADKeEHKgdtR Z87ZWDmfSNey/xxQDXun96L8t1ghKaaNL3BBjJH+hCt8G+MxCLhKCh5caoljf5STehcS0j9M V4XF1Vat4GkyUoiY08zzO7RaP2qF80ilc220ATqnf9noy9pHrBFU5IMQfFkoxbUDlaPH+Pl9 nE+4GjpQPAySkA34LCGkdWdsxPHNZVTpGfFVYdFfQt
X-IronPort-Anti-Spam-Filtered: true
X-IronPort-AV: E=Sophos;i="5.82,240,1613433600"; d="scan'208,217";a="701900884"
Received: from rcdn-core-10.cisco.com ([173.37.93.146]) by alln-iport-5.cisco.com with ESMTP/TLS/DHE-RSA-SEED-SHA; 21 Apr 2021 20:17:11 +0000
Received: from mail.cisco.com (xbe-rcd-007.cisco.com [173.37.102.22]) by rcdn-core-10.cisco.com (8.15.2/8.15.2) with ESMTPS id 13LKHAFF026987 (version=TLSv1.2 cipher=AES256-SHA bits=256 verify=OK); Wed, 21 Apr 2021 20:17:11 GMT
Received: from xfe-aln-001.cisco.com (173.37.135.121) by xbe-rcd-007.cisco.com (173.37.102.22) with Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) id 15.2.792.3; Wed, 21 Apr 2021 15:17:10 -0500
Received: from xfe-rcd-003.cisco.com (173.37.227.251) by xfe-aln-001.cisco.com (173.37.135.121) with Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) id 15.2.792.3; Wed, 21 Apr 2021 15:17:10 -0500
Received: from NAM10-DM6-obe.outbound.protection.outlook.com (72.163.14.9) by xfe-rcd-003.cisco.com (173.37.227.251) with Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) id 15.2.792.3 via Frontend Transport; Wed, 21 Apr 2021 15:17:10 -0500
ARC-Seal: i=1; a=rsa-sha256; s=arcselector9901; d=microsoft.com; cv=none; b=hDnJtaxmQ3zDqWp70nb0BkK/TN5aO3bIoCQ10jom+9ldGt3SXsusM7xiObpILIOd8PfaScyGyhkW/qAXgMWhQgNqX4LOEJujUiUGphjwl1dAnDukJ6JRBZlu75beyfGw1vbw7Za/tMyephiaN/6qBrTWf6At9h4eVsSKzP8djynppAfDf7xnSO8ougg97sw7J7RUYVDjqMO1ZWcYCkGh5CWkj/dmF8kAykr85zXWinxKTAk9LBKf8zpJd8rh0bLaB/g+IeULmIfXcEpNRzdWCRZoH1DOHogB+wnV7AyCD5Jbl4lAGVo6Hgvh0ZXQvAxaBYqgDyWclCJ9zMDA02Kuaw==
ARC-Message-Signature: i=1; a=rsa-sha256; c=relaxed/relaxed; d=microsoft.com; s=arcselector9901; h=From:Date:Subject:Message-ID:Content-Type:MIME-Version:X-MS-Exchange-SenderADCheck; bh=2Etzf1cc60uH0WpX1FZtePWaGu9JgTyRM4aLRcmtBHw=; b=Cj/n6DsChC9/dqL9k4CopKAk/qUiuJwhZgNf3S9p9mqK9I0fwA3nEkxrP7wAiar03J7jrk3Og1nOTiQ1idvyLI5P75gI6Epu+jwPkSxz9yaKm9FYI/9z1qtlEmpKbA+/Di6CAJIPDu2GXjytmIJMtK5eRg4VwXrR1QoVv0el5auIYqE7RMt7PS9qO15aVJSN2XDXkGyoqGdlyXHvc1+itPh6may0LINQ328h1vTnOhZvP09uO8nLe8PiOTAHwSAs93g3YoShd4govLl4aySwPt3H324ajL0KEs0gNE077hK3lWj8n2Vk4LDa3bzaG7Txh2k4fHJPWaLz71l0fq58Rw==
ARC-Authentication-Results: i=1; mx.microsoft.com 1; spf=pass smtp.mailfrom=cisco.com; dmarc=pass action=none header.from=cisco.com; dkim=pass header.d=cisco.com; arc=none
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=cisco.onmicrosoft.com; s=selector2-cisco-onmicrosoft-com; h=From:Date:Subject:Message-ID:Content-Type:MIME-Version:X-MS-Exchange-SenderADCheck; bh=2Etzf1cc60uH0WpX1FZtePWaGu9JgTyRM4aLRcmtBHw=; b=oLEqQ+QM7xQtojyjfKROi+OCCGNQfbvLD5oXfF0N0fJh6i2ANgV7ukLOPtDSsPtbSYA8YbhZXoEP2ZP2fAMjvwuU0L49Vpn7wg1vMQ4SbILr3iy7MahJfuGQssXeOD0YcocSuATuugjAaHfliAl/WEBwWE61TOHvBuVXCTxAe+8=
Received: from CO1PR11MB4881.namprd11.prod.outlook.com (2603:10b6:303:91::20) by MW3PR11MB4761.namprd11.prod.outlook.com (2603:10b6:303:53::15) with Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) id 15.20.4042.19; Wed, 21 Apr 2021 20:17:08 +0000
Received: from CO1PR11MB4881.namprd11.prod.outlook.com ([fe80::cd01:ffc9:6592:b1d5]) by CO1PR11MB4881.namprd11.prod.outlook.com ([fe80::cd01:ffc9:6592:b1d5%6]) with mapi id 15.20.4065.020; Wed, 21 Apr 2021 20:17:08 +0000
From: "Pascal Thubert (pthubert)" <pthubert@cisco.com>
To: "Pascal Thubert (pthubert)" <pthubert@cisco.com>
CC: Lynne Bartholomew <lbartholomew@amsl.com>, "roll-chairs@ietf.org" <roll-chairs@ietf.org>, "roll-ads@ietf.org" <roll-ads@ietf.org>, RFC System <rfc-editor@rfc-editor.org>, "c310@rfc-editor.org" <c310@rfc-editor.org>
Thread-Topic: [C310] * AD - Alvaro Retana, John Scudder, or Martin Vigoureux Re: AUTH48 [LB]: RFC 9035 <draft-ietf-roll-turnon-rfc8138-18.txt> NOW AVAILABLE
Thread-Index: AQHXNutNUZhYNAzfREqgcXRtV3ExNw==
Date: Wed, 21 Apr 2021 20:17:08 +0000
Message-ID: <31B66CEE-363E-42AC-8ABC-4994381B0A59@cisco.com>
References: <20210420061049.528EDF407BB@rfc-editor.org> <CO1PR11MB48819350994D2E5521E65FF7D8489@CO1PR11MB4881.namprd11.prod.outlook.com> <CO1PR11MB48818C3B6F12B847FA232166D8489@CO1PR11MB4881.namprd11.prod.outlook.com>, <8C28D06A-678B-4144-BFEE-5EEE08825E3D@amsl.com>, <9C3C4706-F52C-42D1-A376-01B7E1864D36@cisco.com>
In-Reply-To: <9C3C4706-F52C-42D1-A376-01B7E1864D36@cisco.com>
Accept-Language: fr-FR, en-US
Content-Language: fr-FR
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
authentication-results: amsl.com; dkim=none (message not signed) header.d=none;amsl.com; dmarc=none action=none header.from=cisco.com;
x-originating-ip: [2a01:cb1d:4ec:2200:7cda:3816:f84:3d98]
x-ms-publictraffictype: Email
x-ms-office365-filtering-correlation-id: 333b9f17-14c1-4612-778f-08d905027053
x-ms-traffictypediagnostic: MW3PR11MB4761:
x-ms-exchange-transport-forked: True
x-microsoft-antispam-prvs: <MW3PR11MB4761E45D6EF8655BBEEDB463D8479@MW3PR11MB4761.namprd11.prod.outlook.com>
x-ms-oob-tlc-oobclassifiers: OLM:10000;
x-ms-exchange-senderadcheck: 1
x-microsoft-antispam: BCL:0;
x-microsoft-antispam-message-info: YDRp3MgGJyhDcIBxtn5lpO5AhhMUZl9/ExBmmWwcHx4NxV2aK0YKRe1TC6MuyV+tUWTVIQWPfrFzyjyGM1HHAGeGAFONq0leMRi2QCrAOWgduodYucqmsvkAlq6RmGV8h/fttbqlSDc9R+BafJxB/O0Bgq2wYFvYajD07apcDA0uR8k9H3SKUoHetYMgyMwHimU7Y6hWMX8sPDZsrV5SXETUlIVJmUYMvzmVzm7lVHZp4pjgTr4cXRG5m637uM8mLT6xisRP6m0opMNumzif3l9gJyNImGQ2wffY+6zsJT8U4kE7lkIqvC67FjB3k4iJrziRi0IVey4hb7KyTkK/sLel7XMWrqLbzdrQ3MjdvTGze/YhjGO+OQ+oiOCH1jG2mUWEL60Zo8K8104Eo/6l45yAXGqhE0FK4CBJ6JTG3j2/cM9Y4C2VtUYntqSQ9X/hzONbhMY2F8lxiQ4My4R4T4m6wn1cGMKmDL+KGmzyMm1lysqolbP14igYo0ne5kJ1lV++Gs4muS9nnrLws3neERo4TJFz1Z++I6rHhUErgm1vvxzaYfoAAA5a+eE8lnc7CJ0VsxW+8yV+vb8SHQyL0wW86UFI8datCJXVYv6B3qhHa3h8JHyFWymsRdViIlmaeBa0JVeNWIVIBNv//KQcaAF4339Q+5EWhMYBM4Gpx3z/nQEKJUTIzYozV5ei5v6UBlLUiE2D3hlHiCnqX6M538wH+224b2UJaehrUUfeUU4x4d3/q/nHHS4/T0D+DE6Q
x-forefront-antispam-report: CIP:255.255.255.255; CTRY:; LANG:en; SCL:1; SRV:; IPV:NLI; SFV:NSPM; H:CO1PR11MB4881.namprd11.prod.outlook.com; PTR:; CAT:NONE; SFS:(396003)(136003)(346002)(366004)(39860400002)(376002)(83380400001)(71200400001)(30864003)(5660300002)(66446008)(8676002)(6200100001)(8936002)(66476007)(64756008)(66946007)(478600001)(2616005)(6512007)(4326008)(33656002)(6486002)(91956017)(966005)(76116006)(53546011)(38100700002)(186003)(54906003)(122000001)(37006003)(86362001)(316002)(66574015)(36756003)(6506007)(2906002)(6862004)(66556008)(45980500001)(579004)(559001)(244885003); DIR:OUT; SFP:1101;
x-ms-exchange-antispam-messagedata: gp30ZExkSdHZudZVVHMqasS6mwsW2cPM0kWPGxGcydUV+wcospQi0Ik/vbI7wmwpOV58USmq54/1DKKJkWWTHS+e5N4LGh6iVadYLNjF87We/2igk7kA8AUoYFcTfSY7tRcdZ1TfP/h70pPmbQV326GtQmt+Tx+TaDGh9+5507t/NlVvl2g5LwR0tryyEKUCmsvYDGqBjMgA8oU8g1YYjZtkJy4LKWTaOW2NRK74MEobNXTR1nZtohrwAwUaISJt90LcFrCQNED7GKXbY1RquizeHCh20yqfM6rg0nDwWYmm+omQmJRYFbDrF8zsRWaqNSwgSv18AFDxx+LJfN3VH3umXgN5+93z5ktz4lR+Xq8K2beVrw2SDONFyW2i7WiK0PGc3picyefrD5nqZxhcLr9FnB0c5DLN5MmNyoo2hh12kamh43Mxjoty67kxgv3xy3b/bR04/1ne7qyCx1l+1GtZGb4/WRAh5SqTVK8AagB2VutciFLpU0iryEZLl/0sltAkAlU/VVJFzqszF4yJL7zDWH/EaZ8QdPYSFpctvzHuDKnHImO+Q2ZHewQu2BRD/h9bDU9I3eCfHRRpb2Dt3zOguXRrw0F73Gl2qzHnqpR/B1Gj0msAmXHq+lfRQnFKiW8wTYTDLmqvHQY/TWBaMdQ8Jb9Ie/kIwXyuyLRBK1OLPaQBRJvqLSgTdpn1LdTe3dgyBXloFZkjFucdctkl+dbXPq8FzGZDy6dManqAgZDD5khFN508l+4NwiacaBcRCXwyPMWxu8KsOAAAFxCB2w/BNoExRfwf0lEbpZxLh0JUvSjXPMtmlKEsuKaCnsDss48eHhULsjCxHlWe/vm//Ei0hJh0Bo2U49g8Wfyn+2RMz7GNPd1B2a6fs/Z5YulOcZbwP/rUt3WvnFHipZxKzdHCEPalOs1VsJEZ3RlZHv0TnvCwz/3upEZ+3LLuNQh3N8StdwIlLQTv5eJQLtcSwD04hA+LLElXHdzdRc+xAotGztkbMPoVqfi7gbm7y9iJ3hDzthxpVOhEEGe4RKgrK6EeZBMFDdRwf1xQVKy0z9jSTJ7TpI1/7SBB9V/RG3i00jJRiyjCS8Q53W2WUxiFht1/dqGK2ngwyjoJ03UZGh6+OJH8n23aeFKxGGYuvkYfLYamKpVyARA8IS8WgfqSB+Fz+uSojZKqxTwIaob5tfB9/wAln0UF9PFrETHGn+vsUG5+XOtJcpLeDNAvSybg2w49T9SmRJYEOavIAnO8AbkRBksjkZqRVVZEp8fShCGkBSWtYr1S/pKTEowwyD9/gzGYzbduPkqK7pB3/uTz7nMywDzHOc1FpVQ8gHJetF/SA5gEFkzEIvW6O02gJIDbGzKGdQfSKDTCJHDuMPs9G/x0z32RHyHYdYYJyUQWDMq2
Content-Type: multipart/alternative; boundary="_000_31B66CEE363E42AC8ABC4994381B0A59ciscocom_"
MIME-Version: 1.0
X-MS-Exchange-CrossTenant-AuthAs: Internal
X-MS-Exchange-CrossTenant-AuthSource: CO1PR11MB4881.namprd11.prod.outlook.com
X-MS-Exchange-CrossTenant-Network-Message-Id: 333b9f17-14c1-4612-778f-08d905027053
X-MS-Exchange-CrossTenant-originalarrivaltime: 21 Apr 2021 20:17:08.0375 (UTC)
X-MS-Exchange-CrossTenant-fromentityheader: Hosted
X-MS-Exchange-CrossTenant-id: 5ae1af62-9505-4097-a69a-c1553ef7840e
X-MS-Exchange-CrossTenant-mailboxtype: HOSTED
X-MS-Exchange-CrossTenant-userprincipalname: YsD+Us74Er62z6kcybFb1l+1rmYJkCZEsUO3nDXROTL0aT1eV3s2/Q+Ebx8LSn3aFHmarKToh2Ql4/LugJK6dw==
X-MS-Exchange-Transport-CrossTenantHeadersStamped: MW3PR11MB4761
X-OriginatorOrg: cisco.com
X-Outbound-SMTP-Client: 173.37.102.22, xbe-rcd-007.cisco.com
X-Outbound-Node: rcdn-core-10.cisco.com
Subject: Re: [C310] * AD - Alvaro Retana, John Scudder, or Martin Vigoureux Re: AUTH48 [LB]: RFC 9035 <draft-ietf-roll-turnon-rfc8138-18.txt> NOW AVAILABLE
X-BeenThere: c310@rfc-editor.org
X-Mailman-Version: 2.1.29
Precedence: list
List-Id: <c310.rfc-editor.org>
List-Unsubscribe: <https://www.rfc-editor.org/mailman/options/c310>, <mailto:c310-request@rfc-editor.org?subject=unsubscribe>
List-Archive: <http://www.rfc-editor.org/pipermail/c310/>
List-Post: <mailto:c310@rfc-editor.org>
List-Help: <mailto:c310-request@rfc-editor.org?subject=help>
List-Subscribe: <https://www.rfc-editor.org/mailman/listinfo/c310>, <mailto:c310-request@rfc-editor.org?subject=subscribe>
X-List-Received-Date: Wed, 21 Apr 2021 20:17:13 -0000

Hello Lynne

I checked the diffs and found that a sentence that was to be replaced is still there

´A router MUST uncompress a packet that is to be forwarded to an external target. Otherwise, the router MUST forward the packet in the form that the source used, either compressed or uncompressed.

´

That text is replaced by
´

A border router that forwards a packet to an external target MUST uncompress the packet first. In all other cases, a router MUST forward a packet in the form that the source used, either compressed or uncompressed

´

Regards,

Pascal

Le 21 avr. 2021 à 22:10, Pascal Thubert (pthubert) via c310 <c310@rfc-editor.org> a écrit :

Hello Lynne


Dear Pascal and *AD (Alvaro, John, or Martin),

* Alvaro, John, or Martin, although the following update appears to be purely editorial, we must err on the side of caution and ask for your approval, because it changes "MUST ..." to "MUST NOT ..."  Please let us know if this is OK:

There are operations in the inner packet that must be done. Like increasing hop count or changing the 6LoWPAN HC if the source address is compressed based on a MAC address.
The text below meant no RFC 8138 compression on the inner packet, but was not meant to leave the inner packet untouched wrt those operations. So it's better to rephrase a bit
OLD
" A router encapsulating a packet is the originator
of the resulting packet and is responsible for compressing the outer
headers per [RFC8138], but it MUST leave the encapsulated packet as
is.
"
NEW
"
A router encapsulating a packet is the originator
of the resulting packet and is responsible for compressing the outer
headers per [RFC8138], but it MUST NOT perform the compression on
the encapsulated packet.
"

= = = = =

Pascal, thank you for your prompt replies!

We have updated this document per your notes below.

Regarding this item and your reply:

6) <!-- [rfced] Section 3 and Figure 1:  The "<- Flags ->" portion of
Figure 1 appears to encompass five bit positions (0, 1, 2, 3, and 4,
where 'T' is the third position and 'A' is the fifth) instead of four.
So, should "four bit positions" be changed to "five bit positions"?

Also, please compare with Figure 5 in RFC 9010 (which shows "4 bits"),
and let us know if any changes are needed in this document.

Original (best viewed with a fixed-point font such as Courier):
As shown in Figure 1, the Option was originally designed with
4 bit positions reserved for future use as Flags.

 0                   1                   2                   3
 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
|   Type = 0x04 |Opt Length = 14| | |T| |A|       ...           |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+                     +
                                <- Flags ->

       Figure 1: DODAG Configuration Option (Partial View)
-->


RFC 9010 refers to positions that were reserved for future use in RFC
6550.
"A" is also a flag but it was defined in RFC 6550. So it is all
consistent.
But since the text in  RFC 9035 echoes that in RFC 9010, I agree it's
better to align figure 1 to the one in RFC 9010.

We simply removed the "As shown in Figure 1," phrase.  Please let us know if we misunderstood your note and further updates are needed.


This is fine with me


= = = = =

Regarding this item and your reply:

7) <!-- [rfced] This document and the IANA registry
(https://www.iana.org/assignments/rpl/rpl.xhtml#dodag-config-option-fl
ags) don't match for this description. Which one should be used?

This document:
Enable RFC8138 Compression (T)

IANA registry:
Turn on RFC8138 Compression (T)


The best is probably to align to RFC 9008 which uses "enable"


Also, may this description be rephrased to avoid using the RFC number
as an adjective?  If so, we will send a request to IANA to update the
registry accordingly.

Perhaps:
Turn on Compression per RFC 8138 (T)

Or:
Turn on 6LoRH Compression (T)
-->

I like "perhaps" better. There could be other compression, we want to be
specific to RFC 8138.

Apologies, but we are not sure how best to update this document or ask IANA to update their corresponding entry.  We see "RPI 0x23 enable" in RFC 9008.

Would the following capture your intended meaning?

In this document and on <https://www.iana.org/assignments/rpl/rpl.xhtml#dodag-config-option-flags>:
 Enable Compression per RFC 8138 (T)

Yes, perfectly!


= = = = =

Regarding this note from you in reply to our question 8) (quoting of flag names):

Interestingly we do not seem to have attributed a letter to the flag
defined by RFC 9008.
Also I noted that the text " Table 36: DODAG Configuration Option Flag to
Indicate the RPI Flag Day" in RFC 9008 is incorrect. It does *not*
indicate a "flag day" but controls the RPI option type value (of 0x63 vs.
0x23). I guess we need an erratum?

If something in RFC 9008 is incorrect and should be addressed, then yes, an erratum should be filed.

Will do; this is cosmetic so no worries

= = = = =

Regarding this note from you in reply to our question 11):

I guess this is the same exactly as RFC 9010 which was added. The reason
is that we mandate an operation in MOP 7.
That is the agreement with the A-Ds. And yes the sentence is accurate. So
all is good and IANA needs to add the reference to RFC 9035 in
https://www.iana.org/assignments/rpl/rpl.xhtml#mop

Thank you for the explanation.  We have flagged this and will ask IANA to make this update shortly before publication.


Cool

= = = = =

The updated files are posted here.  Please review carefully, and let us know if we missed anything.

 https://www.rfc-editor.org/authors/rfc9035.txt
 https://www.rfc-editor.org/authors/rfc9035.pdf
 https://www.rfc-editor.org/authors/rfc9035.html
 https://www.rfc-editor.org/authors/rfc9035.xml
 https://www.rfc-editor.org/authors/rfc9035-diff.html
 https://www.rfc-editor.org/authors/rfc9035-auth48diff.html

 https://www.rfc-editor.org/authors/rfc9035-alt-diff.html
 https://www.rfc-editor.org/authors/rfc9035-xmldiff1.html
 https://www.rfc-editor.org/authors/rfc9035-xmldiff2.html
 https://www.rfc-editor.org/authors/rfc9035-alt-diff.html

Although several items (above) are pending, we have noted your approval on the AUTH48 status page:

 https://www.rfc-editor.org/auth48/rfc9035

Thanks again!

RFC Editor/lb


All good, Lynne, many many thanks !

Keep safe ;

Pascal


On Apr 20, 2021, at 8:59 AM, Pascal Thubert (pthubert) <pthubert@cisco.com> wrote:

Dear RFC editor

Pleas find my additional editorial changes; I approve the publication of RFC 9035 once they are applied.


There are operations in the inner packet that must be done. Like increasing hop count or changing the 6LoWPAN HC if the source address is compressed based on a MAC address.
The text below meant no RFC 8138 compression on the inner packet, but was not meant to leave the inner packet untouched wrt those operations. So it's better to rephrase a bit
OLD
" A router encapsulating a packet is the originator
of the resulting packet and is responsible for compressing the outer
headers per [RFC8138], but it MUST leave the encapsulated packet as
is.
"
NEW
"
A router encapsulating a packet is the originator
of the resulting packet and is responsible for compressing the outer
headers per [RFC8138], but it MUST NOT perform the compression on
the encapsulated packet.
"



It is not clear below if forwarding is to a next hop or hops away.
Let us clarify that the border router is the one that uncompresses:
OLD
"
A router MUST uncompress a packet that is to be forwarded to an
external target.  Otherwise, the router MUST forward the packet in
the form that the source used, either compressed or uncompressed.
"

NEW
"
A border router that forwards a packet to an external target MUST
uncompress the packet first. In all other cases, a router MUST
forward a packet in the form that the source used, either compressed
or uncompressed.
"


Keep safe;

Pascal



From: "Pascal Thubert (pthubert)" <pthubert@cisco.com>
Subject: RE: AUTH48 [LB]: RFC 9035 <draft-ietf-roll-turnon-rfc8138-18.txt> NOW AVAILABLE
Date: April 20, 2021 at 8:38:01 AM PDT
To: "rfc-editor@rfc-editor.org" <rfc-editor@rfc-editor.org>, "Li Zhao (liz3)" <liz3@cisco.com>
Cc: "roll-chairs@ietf.org" <roll-chairs@ietf.org>, "roll-ads@ietf.org" <roll-ads@ietf.org>, "mariainesrobles@googlemail.com" <mariainesrobles@googlemail.com>, "c310@rfc-editor.org" <c310@rfc-editor.org>

Hello again:

A side note that RFC 6550 uses the term " sub-DODAG ". I think we should stick to it, that is change subdag to sub-DODAG throughout.

Keep safe;

Pascal



-----Original Message-----
From: Pascal Thubert (pthubert)
Sent: mardi 20 avril 2021 14:50
To: rfc-editor@rfc-editor.org; Li Zhao (liz3) <liz3@cisco.com>
Cc: roll-ads@ietf.org; roll-chairs@ietf.org;
mariainesrobles@googlemail.com; c310@rfc-editor.org
Subject: RE: AUTH48 [LB]: RFC 9035 <draft-ietf-roll-turnon-rfc8138-18.txt>
NOW AVAILABLE

Dear RFC Editor

Many thanks for your hard work on this draft!
Li and I exchanged; please find an aggregate of our comments

Let's see below


1) <!-- [rfced] Document title: Should the abbreviated title (which
appears in the PDF in the running header) be updated as follows to
more closely match what's discussed in the text?

Original:
Turn On 6LoRH

Perhaps:
Turn On 6LoRH Compression

Good



Also, we expanded the abbreviations in the full document title.
Please let us know if you prefer the "Perhaps" option below, or
otherwise.

Original:
A RPL DODAG Configuration Option for the 6LoWPAN Routing Header

Currently (full title):
    A Routing Protocol for Low-Power and Lossy Networks (RPL)
Destination-Oriented Directed Acyclic Graph (DODAG) Configuration Option
for the IPv6 over Low-Power Wireless Personal Area Network (6LoWPAN)
                          Routing Header

Perhaps (if "6LoWPAN" is not expanded):
    A Routing Protocol for Low-Power and Lossy Networks (RPL)
Destination-Oriented Directed Acyclic Graph (DODAG) Configuration Option
                for the 6LoWPAN Routing Header
-->

"Perhaps" feels a lot better!


2) <!-- [rfced] Please insert any keywords (beyond those that appear
in the
title) for use on https://www.rfc-editor.org/search -->

IoT, Header Compression, Source Routing Header, Hop-by-Hop Header, RPL
artifacts


3) <!-- [rfced] FYI, instances of "[RFC8138] compression"
have been rephrased as "compression per [RFC8138]" or "6LoRH
compression [RFC8138]" for the sake of clarity.
Please let us know if you prefer otherwise.
-->

I'm good with the change


4) <!-- [rfced] Section 2.1:  Because "References" is generally used
to indicate Normative and Informative References sections in RFCs, we
changed this title to "Related Documents" per RFC 8505 and as was done
in RFC 9010.  Please let us know any objections.

Original:
2.1.  References

Currently:
2.1.  Related Documents -->


Cool


5) <!-- [rfced] Section 2.2:  We had trouble following the use of
"which"
in this definition.  We updated as noted below.  If this is incorrect,
please clarify the text.

Original:
SubDAG:  A DODAG rooted at a node which is a child of that node and a
 subset of a larger DAG

Currently:
SubDAG:  A DODAG rooted at a node, which is a child of that node and
 a subset of a larger DAG -->

RFC 6550 says:
“The sub-DODAG of a node is the set of other nodes whose paths to the
DODAG root pass through that node.  Nodes in the sub-DODAG of a node have
a greater Rank than that node.”

Merging this, I'd rather we use:
"
The sub-DAG of a node is a DODAG rooted at that node that is a subset of a
main DODAG the node belongs to. It is formed by the other nodes in the
main DODAG whose paths to the main DODAG root pass through that node.

"


6) <!-- [rfced] Section 3 and Figure 1:  The "<- Flags ->" portion of
Figure 1 appears to encompass five bit positions (0, 1, 2, 3, and 4,
where 'T' is the third position and 'A' is the fifth) instead of four.
So, should "four bit positions" be changed to "five bit positions"?

Also, please compare with Figure 5 in RFC 9010 (which shows "4 bits"),
and let us know if any changes are needed in this document.

Original (best viewed with a fixed-point font such as Courier):
As shown in Figure 1, the Option was originally designed with
4 bit positions reserved for future use as Flags.

 0                   1                   2                   3
 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
|   Type = 0x04 |Opt Length = 14| | |T| |A|       ...           |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+                     +
                                <- Flags ->

       Figure 1: DODAG Configuration Option (Partial View)
-->


RFC 9010 refers to positions that were reserved for future use in RFC
6550.
"A" is also a flag but it was defined in RFC 6550. So it is all
consistent.
But since the text in  RFC 9035 echoes that in RFC 9010, I agree it's
better to align figure 1 to the one in RFC 9010.




7) <!-- [rfced] This document and the IANA registry
(https://www.iana.org/assignments/rpl/rpl.xhtml#dodag-config-option-fl
ags) don't match for this description. Which one should be used?

This document:
Enable RFC8138 Compression (T)

IANA registry:
Turn on RFC8138 Compression (T)


The best is probably to align to RFC 9008 which uses "enable"


Also, may this description be rephrased to avoid using the RFC number
as an adjective?  If so, we will send a request to IANA to update the
registry accordingly.

Perhaps:
Turn on Compression per RFC 8138 (T)

Or:
Turn on 6LoRH Compression (T)
-->

I like "perhaps" better. There could be other compression, we want to be
specific to RFC 8138.



8) <!-- [rfced] FYI, we have changed from "T" flag (double quotes) to
'T'
flag (single quotes) in keeping with usage in Section 6.2 of RFC 9010.
Please let us know if you prefer otherwise.
-->

You did good. I gave a look at 9008 and 9010 to compare how we did things
there.

Interestingly we do not seem to have attributed a letter to the flag
defined by RFC 9008.
Also I noted that the text " Table 36: DODAG Configuration Option Flag to
Indicate the RPI Flag Day" in RFC 9008 is incorrect. It does *not*
indicate a "flag day" but controls the RPI option type value (of 0x63 vs.
0x23). I guess we need an erratum?


9) <!-- [rfced] Section 3:  Because Section 4.3 of RFC 9008 is
"Updates to RFC 8138: Indicating the Way to Decompress with the New
RPI Option Type", whereas Section 4.1 of is "Updates to RFC 6550", we
changed "4.3" to "4.1" accordingly.  Please let us know if this is not
accurate.

Original:
Section 4.3 of [USEofRPLinfo] updates [RFC6550] to indicate that the
definition of the Flags applies to Mode of Operation (MOP) values
zero
(0) to six (6) only.

Currently:
Section 4.1 of [RFC9008] updates [RFC6550] to indicate that the
definition of the Flags applies to Mode of Operation (MOP) values
zero
(0) to six (6) only. -->


You are correct. That's really " Section 4.1.2 of [RFC9008] updates..."


10) <!-- [rfced] Section 5.3:  We had trouble following the first
sentence in this paragraph, and the second sentence does not parse.
If the suggested text is not correct, please clarify "converged to the
'T' flag unset" and "SHOULD be exposed the node's management
interface".

Original:
When turning [RFC8138] compression off in the network, the Network
Administrator MUST wait until all nodes have converged to the "T"
flag unset before allowing nodes that do not support the compression
in the network.  To that effect, whether the compression is active in
a node SHOULD be exposed the node's management interface.

Perhaps:
When turning 6LoRH compression [RFC8138] off in the network, the
network administrator MUST wait until all nodes have converged to the
point  where their 'T' flags are unset before allowing nodes that do
not  support compression in the network.  Information regarding
whether  compression is active in a node SHOULD be visible to the node's
management interface.

Or:
When turning 6LoRH compression [RFC8138] off in the network, the
network administrator MUST wait until each node has its 'T' flag unset
before allowing nodes that do not support compression in the network.
Information regarding whether compression is active in a node SHOULD
be exposed in the node's management interface.
-->

Please use "Or" that does the trick nicely



11) <!-- [rfced] This sentence appears in the original:
IANA is requested to add [this document] as a reference for MOP 7 in
the RPL Mode of Operation registry.

However, the IANA registry
(https://www.iana.org/assignments/rpl/rpl.xhtml#mop)
doesn't include this document as a reference for value 7:

7   Reserved   [RFC9008][RFC9010]

So, should the sentence be removed, or should the registry be updated?
(See also Section 11.3 of RFC 9008, and Section 12.3 of RFC 9010.)

Also, please review whether this sentence in Section 3 is accurate.
"For a MOP value of 7, [RFC8138] MUST be
used on links where 6LoWPAN Header Compression [RFC6282] applies and
MUST NOT be used otherwise."
-->

I guess this is the same exactly as RFC 9010 which was added. The reason
is that we mandate an operation in MOP 7.
That is the agreement with the A-Ds. And yes the sentence is accurate. So
all is good and IANA needs to add the reference to RFC 9035 in
https://www.iana.org/assignments/rpl/rpl.xhtml#mop


12) <!-- [rfced] Section 7:  We had trouble following this sentence;
are some words missing?  Please clarify "is protected as the rest of
the configuration".

Original (the previous sentence is included for context):
Setting the 'T' flag before all routers are upgraded may cause a loss
of packets.  The new bit is protected as the rest of the
configuration so this is just one of the many attacks that can happen
if an attacker manages to inject a corrupted configuration. -->

OLD
The new bit is protected as the rest of the  configuration so this is just
one of the many attacks that can happen  if an attacker manages to inject
a corrupted configuration

NEW
The new bit benefits from the same protection as the rest of the
information in the DODAG Configuration Option that transports it. Touching
the new bit is just one of the many attacks that can happen  if an
attacker manages to inject a corrupted configuration option in the
network.





13) <!-- [rfced] Section 7:  We had trouble following this paragraph.
If the suggested text is not correct, please clarify "would compress
when that it is not desired" and "both settings, which could raise
attention".

Original:
An attacker may unset the 'T' flag to force additional energy
consumption of child or descendant nodes in its subDAG.  Conversely
it may set the 'T' flag, so that nodes located downstream would
compress when that it is not desired, potentially resulting in the
loss of packets.  In a tree structure, the attacker would be in
position to drop the packets from and to the attacked nodes.  So the
attacks above would be more complex and more visible than simply
dropping selected packets.
The downstream node may have other  parents and see both settings,
which could raise attention.

Suggested:
An attacker may unset the 'T' flag to force additional energy
consumption of child or descendant nodes in its subDAG.  Conversely,
it may set the 'T' flag so that nodes located downstream would
compress packets even when compression is not desired, potentially
causing packet loss.  In a tree structure, the attacker would be in  a
position to drop the packets from and to the attacked nodes.  So,  the
attacks mentioned above would be more complex and more visible  than
simply dropping selected packets.  The downstream node may have  other
parents and see both settings; such a scenario could raise  concerns.
-->


I'm good with "suggested". For the last sentence OLD "
The downstream node may have  other parents and see both settings; such a
scenario could raise  concerns "
I'd rather have
NEW
"
The downstream node may have  other parents and see the bit with both
settings; such an situation may be detected and an alert may be triggered
"

Please let us know when the document is updated and I'll perform a full
review.

Take care,

Pascal

--
c310 mailing list
c310@rfc-editor.org
https://www.rfc-editor.org/mailman/listinfo/c310