[Cats] draft-ietf-cats-metric-definition-13 early Perfmetrdir review
Giuseppe Fioccola via Datatracker <noreply@ietf.org> Wed, 14 October 2026 17:44 UTC
Received: by mx.ietf.org (Postfix) id D1E3D4A; Wed, 14 Oct 2026 17:44:48 +0000 (UTC)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=ietf.org; s=mail; t=1791999888; h=from:from:reply-to:reply-to:subject:subject:date:date: message-id:message-id:to:to:cc:cc:mime-version:mime-version: content-type:content-type: content-transfer-encoding:content-transfer-encoding; bh=DL71m/u9sVLWHChQU4EIUJqHQ2wflB8daJ6ceIMBGoE=; b=Z8TLDXuX6u2bno0cA4fXdnuknaKx9vhQhvt5FulXjZXB2SSu48LMyp7S+wHt/S7p+Qsvzt 8MlUUXAMyOB9uu89ruJNRdb5JHRMCMZas+fPCcdRProh8oWaNlyyUTdkeJ7VSxphuSD5OU N+4+TXQlGPm5AzCdB3Bfr4l6C4SH+4A=
Authentication-Results: ORIGINATING; auth=pass smtp.auth=mail2@ietf.org smtp.mailfrom=noreply@ietf.org
Received: from [10.244.9.5] (gaia.k8s.ietf.org [4.156.85.76]) by mail2.ietf.org (Postfix) with ESMTP id A283D13A9A529; Wed, 14 Oct 2026 10:44:48 -0700 (PDT)
MIME-Version: 1.0
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: 7bit
From: Giuseppe Fioccola via Datatracker <noreply@ietf.org>
To: pm-dir@ietf.org
X-Test-IDTracker: no
X-IETF-IDTracker: 12.80.0
Auto-Submitted: auto-generated
Precedence: bulk
Message-ID: <179199988852.452521.4176169412585789801@dt-datatracker-66f49ddcbd-pbt9f>
Date: Wed, 14 Oct 2026 10:44:48 -0700
Message-ID-Hash: LCDNTAMC7EA2PSTBAKL427A5G5FG2A5G
X-Message-ID-Hash: LCDNTAMC7EA2PSTBAKL427A5G5FG2A5G
X-MailFrom: noreply@ietf.org
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; loop; banned-address; emergency; member-moderation; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: cats@ietf.org, draft-ietf-cats-metric-definition.all@ietf.org
X-Mailman-Version: 3.3.10
Reply-To: Giuseppe Fioccola <giuseppe.fioccola@huawei.com>
Subject: [Cats] draft-ietf-cats-metric-definition-13 early Perfmetrdir review
List-Id: "Computing-Aware Traffic Steering (CATS)" <cats.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/cats/UCd9pcxynHmklaZIQPv0AYvqxok>
List-Archive: <https://mailarchive.ietf.org/arch/browse/cats>
List-Help: <mailto:cats-request@ietf.org?subject=help>
List-Owner: <mailto:cats-owner@ietf.org>
List-Post: <mailto:cats@ietf.org>
List-Subscribe: <mailto:cats-join@ietf.org>
List-Unsubscribe: <mailto:cats-leave@ietf.org>
Document: draft-ietf-cats-metric-definition Title: CATS Metrics Definition Reviewer: Giuseppe Fioccola Review result: Not Ready This document focuses on compute and communication metrics for Computing-Aware Traffic Steering (CATS). It introduces three levels of abstraction: Level 0 (Raw metrics), Level 1 (Metrics combined into categories), Level 2 (A single normalized metric). From a PERFMETRDIR point of view, the document does not standardize performance metrics but it specifies higher-level representations. However, I think that the document is not ready since the description of the metric registry entries of section 6 should be improved. Here are some suggestions for your consideration: - Section 3.2 introduces Level 0 Raw Metrics. I would also mention the network performance metrics, which are described in RFC 7799. - In section 4.1, I would add the metrics type (if the information is available), based on the classification of RFC 7799. The distinction between active, passive and hybrid metrics can be a relevant property. - In section 4.2.1, you could also refer to RFC 5644 in addition to RFC 5835. - Section 6 defines the registry entries but I have some concerns about the current explanation and more details are needed. The naming rule includes the Measurement Method (sections 6.1.3, 6.2.3, 6.3.3, 6.4.3 6.5.3), but it is not fully described. For example, it is not clear to me what the term Passive refers to, is it based on the definitions of RFC 7799 and RFC 10014? - I would also add additional examples for the metrics. Appendix A only includes Level 0 Metric Examples.
- [Cats] draft-ietf-cats-metric-definition-13 early… Giuseppe Fioccola via Datatracker
- [Cats] Re: draft-ietf-cats-metric-definition-13 e… Kehan Yao
- [Cats] Re: draft-ietf-cats-metric-definition-13 e… Giuseppe Fioccola
- [Cats] Re: draft-ietf-cats-metric-definition-13 e… Kehan Yao
- [Cats] Re: draft-ietf-cats-metric-definition-13 e… 韦举重
- [Cats] Re: draft-ietf-cats-metric-definition-13 e… Kehan Yao