[Detnet] AD review of draft-ietf-detnet-controller-plane-framework-11

Ketan Talaulikar <ketant.ietf@gmail.com> Thu, 05 June 2025 05:57 UTC

Return-Path: <ketant.ietf@gmail.com>
X-Original-To: detnet@mail2.ietf.org
Delivered-To: detnet@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id 336EE3124A2C; Wed, 4 Jun 2025 22:57:17 -0700 (PDT)
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -2.098
X-Spam-Level:
X-Spam-Status: No, score=-2.098 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, FREEMAIL_FROM=0.001, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_NONE=-0.0001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001] autolearn=ham autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=pass (2048-bit key) header.d=gmail.com
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id wvdIEYh8Kf8c; Wed, 4 Jun 2025 22:57:16 -0700 (PDT)
Received: from mail-pl1-x635.google.com (mail-pl1-x635.google.com [IPv6:2607:f8b0:4864:20::635]) (using TLSv1.3 with cipher TLS_AES_128_GCM_SHA256 (128/128 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id 901893124A25; Wed, 4 Jun 2025 22:57:16 -0700 (PDT)
Received: by mail-pl1-x635.google.com with SMTP id d9443c01a7336-235e1d710d8so7348205ad.1; Wed, 04 Jun 2025 22:57:16 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20230601; t=1749103035; x=1749707835; darn=ietf.org; h=cc:to:subject:message-id:date:from:mime-version:from:to:cc:subject :date:message-id:reply-to; bh=KZpzSN+SKZ4VyHVnWjsArQ9+0myokfIWa2XhWlhQ/DI=; b=dzjddo+ghcR0DE3Oi4RCUMPdWh/s+16IodTZ7iZKE/HZodkTf3A7wBPhQrnIXiE9Vb UUkl6AG/PPs3cXcQawdKV9IkWA5TGfQb/99ohoRakU6Zs7zJ2cMb6zTsuwT993tc51M3 AUoqKJKsVQTWJG/weyRca/mYMKNLXf8i10H1YP6xUms1nNH8+u+qYEkuAEtynRG+8kWZ olQxkLULQS60bp3uk7lLYas0s3B0cbvspiL6Daesduph7+Yw3kbUbjmO4qmmjx6VUWDo DmMhd999p33pr51TYZ90rqGk2vDgurriCGCMCZquQjnVSIJnGXBeeAzm71HwvIJwZrlC VEVg==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20230601; t=1749103035; x=1749707835; h=cc:to:subject:message-id:date:from:mime-version:x-gm-message-state :from:to:cc:subject:date:message-id:reply-to; bh=KZpzSN+SKZ4VyHVnWjsArQ9+0myokfIWa2XhWlhQ/DI=; b=PMoS/fV8yQSEBObKfclPkcMhP8rRkNpsduhYltMl6/+FSXX4nTg5jSMicq4xbdC1X7 4uTWrDBXZmwrlwbhAtIK4rzbqHQJhhnwAcWKJbSDundR9To7u6JpZmgg6UOUVG3qgXwC E2ooJwONmQkd/2u676RnZFEnqJtQkcIy4+DOIfwcVLkc57hcfAStzj4Diu4o50+22MNF oJ0aJDg/iD476sQqknL5o9hJTJF9BKK99S7INnKrPUH68ihNUiDZahP1jam0Suww92D5 VaGMSwNxjF/SUsqnMvYHyfbWIm7aVh80MfB5UxfJmr1pSm8H/Qic8pxzRJqjrF8bldz1 i9JQ==
X-Gm-Message-State: AOJu0YzhzZaYANW0gLLm0uRzSfIGLh1UlemE14gVwIw+zdEmnjGKPwY/ 536fnro/fcBkDsvZabs3gOQ0PY6aAYWrsq+Y4Q5Ruf4sYw7kJEh6C/vg3iAzG6flPdSzULeopxw Mdy0gX9An6W5WwMOerf+nHLRQBoeqg//IukUP
X-Gm-Gg: ASbGnctKT6nLNnry5uXQZX/SCnZEM2L4+kiYzMe8zD4dKTCso2EM91WYGYZV2AfPc8C wATfMrYYP0nzbeQJjXinwmso5KFPfPcN6SB5Z+cbL88uzHgUYL4TzmKuqNOurXIZfxUbhUeOKqC BF381x2RVuFOAALcy+HAsn/bOWihW30tKh8t5aPoNKWwS01hRGqzUf19oxBEP2YctBlw==
X-Google-Smtp-Source: AGHT+IEMLLVILGrtV3nPmBPOnc4/X177lYvt4zZYfg6GpR1DUTQVZb9H63mWmdvajUa7HAoKs7ndj6zEizpCyWOSQWI=
X-Received: by 2002:a17:903:2887:b0:235:ed01:18cd with SMTP id d9443c01a7336-235ed011a84mr33674575ad.44.1749103035348; Wed, 04 Jun 2025 22:57:15 -0700 (PDT)
MIME-Version: 1.0
From: Ketan Talaulikar <ketant.ietf@gmail.com>
Date: Thu, 05 Jun 2025 11:27:02 +0530
X-Gm-Features: AX0GCFucbBJAf5V-imj-h8Y3mIUlq7_lzvfvkX4nSJgeTy-PJVSdrWUifupfql0
Message-ID: <CAH6gdPyhQ-OuybTrBesfVTM35Xq4gBwUDdxzmv4pT5QM0zSpLA@mail.gmail.com>
To: draft-ietf-detnet-controller-plane-framework@ietf.org
Content-Type: multipart/alternative; boundary="00000000000018fd440636ccc94d"
Message-ID-Hash: PJIJ7QY3PF7OXQBOIWWOPSB2YRNMJU6N
X-Message-ID-Hash: PJIJ7QY3PF7OXQBOIWWOPSB2YRNMJU6N
X-MailFrom: ketant.ietf@gmail.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-detnet.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: detnet@ietf.org
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [Detnet] AD review of draft-ietf-detnet-controller-plane-framework-11
List-Id: Discussions on Deterministic Networking BoF and Proposed WG <detnet.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/detnet/UNLg0flaSWD8Yo5j4Hrfr9h3H_4>
List-Archive: <https://mailarchive.ietf.org/arch/browse/detnet>
List-Help: <mailto:detnet-request@ietf.org?subject=help>
List-Owner: <mailto:detnet-owner@ietf.org>
List-Post: <mailto:detnet@ietf.org>
List-Subscribe: <mailto:detnet-join@ietf.org>
List-Unsubscribe: <mailto:detnet-leave@ietf.org>

Hello Authors/WG,

Thanks for your work on this document. I found it to be very well written
and easy to follow. I believe it will serve as a good foundation for
further work.

The document is mostly ready. I do have a few
comments/suggestions/questions that I am providing below inline in the
idnits output of v11 of the document. Please check for the tag <EoRv11> at
the end of the email and if you don't find it then likely the email has
been truncated; you should then look at the WG mailer archive for the full
version.

Thanks,
Ketan

Detail review follows:

13      Deterministic Networking (DetNet) Controller Plane Framework
14            draft-ietf-detnet-controller-plane-framework-11

<major> The title, abstract, and introduction talk about "controller" while
much of sections 3 and 4 seem open to both (centralized) controller,
distributed control plane or a mix of both. I am left wondering whether
using
"control plane" instead of "controller plane" is a more suitable title ...

152   *  Allow flow instantiation requests to originate in an end
153      application (via an Application Programming Interface (API), via
154      static provisioning, or via a dynamic control plane, such as a
155      centralized SDN controller or distributed signaling protocols.

<nit> please expand SDN

162   *  Also in the case of the DetNet MPLS data plane, support the DetNet
163      service sub-layer, which provides DetNet service functions such as
164      protection and reordering through the use of packet replication,
165      duplicate elimination, and packet ordering functions (PREOF).

<nit> Please put reference to RFC8665 where the PREOF term is defined.

260 3.2.  SDN/Fully Centralized Control Plane

262   In the fully SDN/centralized configuration model, flow/UNI
263   information is transmitted from a Centralized User Controller or from
264   applications via an API/ northbound interface to a Centralized
265   Controlle.  Network node configurations for DetNet flows are

<nit> s/Controlle/Controller

290   1.  Controller collects topology information and DetNet capabilities
291       of the network nodes via an IGP and/or BGP-LS [RFC7752];

<minor> 7752 has been obsoleted by 9552

377 4.3.  PREOF Support

379   DetNet path redundancy is supported via packet replication, duplicate
380   elimination, and packet ordering functions (PREOF).  A DetNet flow is
381   replicated and goes through multiple networks paths to avoid packet
382   loss caused by device or link failures.  In general, current control
383   plane mechanisms that can be used to establish an explicit path,
384   whether distributed or centralized, support point-to-point (P2P) and
385   point-to-multipoint (P2MP) path establishment.  PREOF requires the
386   ability to compute and establish a set of multiple paths (e.g.,
387   multiple LSP segments in an MPLS network) from the point(s) of packet
388   replication to the point(s) of packet merging and ordering.  Mapping

<question> Do these paths need to be disjoint?

403   In traditional MPLS domains, a dynamic control plane using
404   distributed signaling protocols is typically used for the
405   distribution of MPLS labels used for forwarding MPLS packets.  The
406   dynamic signaling protocols most commonly used for label distribution
407   are LDP [RFC5036], RSVP-TE, and BGP [RFC8277] (which enables BGP/
408   MPLS-based Layer 3 VPNs [RFC4384] and Layer 2 VPNs [RFC7432]).

<major> EVPN has been missed which seems quite the popular flavor these days
:-) ... I bring it up because we are talking service labels and their
signaling protocols below. Also pick the best/closest reference (if
possible)
for RSVP-TE.

448   Note that the DetNet MPLS and IP data planes described in [RFC8964]
449   and [RFC8939] were constructed to be compatible with both types of
450   segment routing, SR-MPLS [RFC8660] and SRv6 [RFC8754].

<minor> In addition to RFC8754, please also add RFC8986 for SRv6 - that is
the
spec which introduced the ability to define behaviors and functionalities
that
can be associated with SRv6 SIDs (and which could be leveraged by DetNet).

 473 5.1.1.2.  Passive PM

475   Passive PM monitors the actual service traffic in a network domain in
476   order to measure its performance without having a detrimental affect
477   on the network.  As compared to Active PM, Passive PM is much
478   preferred for use in DetNet domains.

<major> Any reference or pointer to how Passive PM works? Is it by adding
some
OAM bits in the data packets itself, or some other techniques?

511 8.  Security Considerations

513   This document provides a framework for the DetNet controller plane,
514   and does not include any protocol specifications.  Any future
515   specification that is defined to support the DetNet controller plane
516   is expected to include appropriate security considerations.  For
517   overall security considerations of DetNet see [RFC8655] and
518   [I-D.ietf-detnet-security]

<minor> Are there any security requirements or aspects related to DetNet
Control(ler) Plane that should be identified here?

<EoRv11>