[Detnet] Re: response to LS on request for feedback on work items related to deterministic networking in
Janos Farkas <Janos.Farkas@ericsson.com> Fri, 22 November 2024 20:44 UTC
Return-Path: <Janos.Farkas@ericsson.com>
X-Original-To: detnet@ietfa.amsl.com
Delivered-To: detnet@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 531DCC14F6BF for <detnet@ietfa.amsl.com>; Fri, 22 Nov 2024 12:44:42 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -2.253
X-Spam-Level:
X-Spam-Status: No, score=-2.253 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIMWL_WL_HIGH=-0.148, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_BLOCKED=0.001, RCVD_IN_MSPIKE_H2=-0.001, RCVD_IN_VALIDITY_RPBL_BLOCKED=0.001, RCVD_IN_ZEN_BLOCKED_OPENDNS=0.001, SPF_PASS=-0.001, T_SCC_BODY_TEXT_LINE=-0.01, URIBL_BLOCKED=0.001, URIBL_DBL_BLOCKED_OPENDNS=0.001, URIBL_ZEN_BLOCKED_OPENDNS=0.001] autolearn=ham autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (2048-bit key) header.d=ericsson.com
Received: from mail.ietf.org ([50.223.129.194]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id KTmBqCyrlovI for <detnet@ietfa.amsl.com>; Fri, 22 Nov 2024 12:44:38 -0800 (PST)
Received: from EUR03-AM7-obe.outbound.protection.outlook.com (mail-am7eur03on2053.outbound.protection.outlook.com [40.107.105.53]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange ECDHE (P-384) server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id C2693C14F616 for <detnet@ietf.org>; Fri, 22 Nov 2024 12:44:37 -0800 (PST)
ARC-Seal: i=1; a=rsa-sha256; s=arcselector10001; d=microsoft.com; cv=none; b=hhl8VpxIwvFn7B7tFNF3DR0vL7AqesBdqmGQ6usfiqJhZX8Bb0WOK2xReOzfDZePr/TUWlmeEd+2V2TKjZQ7qjuCVBCKa1FICo4drovbOeWtssOtFah3nrSTWtipF07A3yFV3pOS5PubxRMrW/jaXnmugbzqxCP/gFcC4ZHfFSa7pqGZvyjNo7CK556KmnBCDAuJPPwnRaSt6wMOwdXqMSdP5fa82i3NBlCD+uzWgCdo2bHaZCpufdwr0kk9OJ3XnWPh2knwYZbZ5Az+l+AlkGFJLysyZ9NhDmhJLUso5xemKmFSIYZ6Md1CS/jBNIGKqT9+R7qQAj5DDMIp3Bnjfg==
ARC-Message-Signature: i=1; a=rsa-sha256; c=relaxed/relaxed; d=microsoft.com; s=arcselector10001; h=From:Date:Subject:Message-ID:Content-Type:MIME-Version:X-MS-Exchange-AntiSpam-MessageData-ChunkCount:X-MS-Exchange-AntiSpam-MessageData-0:X-MS-Exchange-AntiSpam-MessageData-1; bh=dTXJq8KNxTXKmw0V4NaOiCY+0CJfwPw1kNoFq72ZpW8=; b=wRXxv6oz5gvgQOrV2qSQ5N7ndS9lj4Ewel+cCLe/TzHTuzygieWsyzt6BgKyJlDxZYRQTxUyMWcbSzpyzxfc/he86OZUbxyN/ucQC+HR3ICc1wan+ExsaqksYEFRqW1m7wBCNj9AaBv8BUdo+fDqzNvmKhCSkVgeEdjmVESRc7i3mmfj5cFBbACMjfCd8kgaBH4iCv8jpZcjxy4RRN3tJ7CfGdgHQZdNNe7RUYzySAfqE0DTnAXwgsC9Sjj1uQZSiPRxqAExWqCJ42v5XXCM1NOaQJ3cgAUV6AbmWMNve8uc7wuqtiDZfvSKlhnjlpNSZFb79/hMyRqC374dahaMzQ==
ARC-Authentication-Results: i=1; mx.microsoft.com 1; spf=pass smtp.mailfrom=ericsson.com; dmarc=pass action=none header.from=ericsson.com; dkim=pass header.d=ericsson.com; arc=none
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=ericsson.com; s=selector1; h=From:Date:Subject:Message-ID:Content-Type:MIME-Version:X-MS-Exchange-SenderADCheck; bh=dTXJq8KNxTXKmw0V4NaOiCY+0CJfwPw1kNoFq72ZpW8=; b=GOh1xv+6nPIAUYVoweUItZDI9Sm06+u9dGCZU5O5xiTuyuPAghDZABdKQudOBo9OzsIC2fU9NHvKLrc/L4nSk0gmbrVgmPUGzxoQEBPRY7Bt2TqYjj5PorJEQLTA2KMmyRR4qbTE/UHCdD5Qqe1HQ6hBFmgab2/GttaVUwpA/1pqkP5vnjyzCj5wb8aFfTa0xfK0p8M6zNSnPHDG7YFurZaIInuqZVJNYxLNPVJeRGAAgBl5RsvLqbPa72KPQESaqzltmvSkehuqd2hkAnplL/ErrNxvOJ2e4FvPyb+vZV/xVf3pu7mj+spZrD+lyC5hKsxxzNx8zbOm5288KWWmbA==
Received: from PAWPR07MB10010.eurprd07.prod.outlook.com (2603:10a6:102:38e::5) by AM7PR07MB6278.eurprd07.prod.outlook.com (2603:10a6:20b:13d::19) with Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) id 15.20.8158.27; Fri, 22 Nov 2024 20:44:34 +0000
Received: from PAWPR07MB10010.eurprd07.prod.outlook.com ([fe80::662b:36db:974a:33ca]) by PAWPR07MB10010.eurprd07.prod.outlook.com ([fe80::662b:36db:974a:33ca%5]) with mapi id 15.20.8158.028; Fri, 22 Nov 2024 20:44:34 +0000
From: Janos Farkas <Janos.Farkas@ericsson.com>
To: "detnet@ietf.org" <detnet@ietf.org>
Thread-Topic: response to LS on request for feedback on work items related to deterministic networking in
Thread-Index: AdsxbcHrb4BH9gopQRShqrPqEdV91ALsRbAg
Date: Fri, 22 Nov 2024 20:44:34 +0000
Message-ID: <PAWPR07MB100104DF786653095FE622C5FF2232@PAWPR07MB10010.eurprd07.prod.outlook.com>
References: <PAWPR07MB10010816331C1F249F12858FAF25D2@PAWPR07MB10010.eurprd07.prod.outlook.com>
In-Reply-To: <PAWPR07MB10010816331C1F249F12858FAF25D2@PAWPR07MB10010.eurprd07.prod.outlook.com>
Accept-Language: en-US
Content-Language: en-US
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
authentication-results: dkim=none (message not signed) header.d=none;dmarc=none action=none header.from=ericsson.com;
x-ms-publictraffictype: Email
x-ms-traffictypediagnostic: PAWPR07MB10010:EE_|AM7PR07MB6278:EE_
x-ms-office365-filtering-correlation-id: 2a385be7-911b-4a84-89ae-08dd0b36791e
x-ms-exchange-senderadcheck: 1
x-ms-exchange-antispam-relay: 0
x-microsoft-antispam: BCL:0;ARA:13230040|1800799024|376014|366016|8096899003|38070700018;
x-microsoft-antispam-message-info: 4/M08gerJUF/vTrbe7Tz7db5HeFDV4SQt37/57kjA+vABABySMeKsTHPxhWOx1323TIKRMAW+GFAms9T8M0fKdUlVXQMtoKdHr3oRDjJOAdq29CJdxrpG96L1EpQo4UAZ0RE0dMzzL8aRnCYg38UjpLgCZtUoOtm3zKv3+6Wilvj4qlS0IZYfWjUxJcoxgCIFaCtIrdof/mQf6eEgrG1ZRVexTQMLyf/uOfPydWG7nhNRb67670XQnuj4c+2pVTlmbOwvQD0C11+t1Lcp6iqLcjPb8gr9yMXssvlkCmCGP/xNSDRL/Y/ZA26kM11o4NFxia3FLDq1bwWpodVvnNw8SJqS6FtTtJvA+nmP+cKj7yBUPVs/z+XhL/bYC0qnvG/kPQWewy03QFdJbvZxEShin6I7JCtTUDYuQV4q+Qux7Iuq9PjOHnGDGl8OYQBVyxLaDzK5EQo6pfBie3Xv9WAsGkqApWp9+Bxx3DOUjyuXdxXXwfPT4I2QAC/2qZIizuxkhpiLJwP2RmI1GMMGhjX8jqTB2eQ6Wb+u9fPoekevbsw/x8z22iuDgBISQpElkNQTXB3+1fS90fTtaVCaqV438V8+q/CHKSnp0l+UmCE486uGdkLVi7lJENmbKdq1uui/nznayGM4abPPPu+i6nxTO2rdA2B4kPENb5+MFBCEF0fVVf0r71NSvYvLKGPBkozzSP4T198qOUiUBxTQNdMHt0i7hLEYMv+PLbnzs2iLtDrvOdjr3JoyWR5N5lEHi52Jqxzg1A5KLMjyDVLWfZTAZXK7MaEoCQuQmHtV1WVQe6Xeeq5TOAlP/99Z27PcS+pY9DoCJnYujQkx9nWeAT4C5OqPYJQusi7jvMcaUJouwhH13PaBukXTLYqWClu1s8bIcrxMx7bFBynIXjq+c2z62G6uyKX7gL/5EOoWVdqdyWBWs0vBJ69RJFKQwjcClBhTWsjohXWvTYhHR5yyZvoGeTjbgCyQFuEcLjWQb0lH356fm4nd0D6wUckD9NfL944yRjvbHCoR82OWOGXl0k+fxJo5SBx7xkuyn8r+mTV63jDLboPV1I8Z9SaclPanHIE+2/lvSdit0TE87bEUDQi1Vgvl892LbAaXTc1o9pvQCIWjbZkeJ/llA/F25JnVUVEb38PtSNTR9xRmtJ3YBCOpmlMIFRXXpWUXXHVEAEdcfCGSZIbS4psXqx+Q9nIN8qkb0yp1st1CVnDsERaUTXnrK2scLAuiCr45F+FGYYZRmUrkvi30EMXYW/KRGpzqgvTDAYHUDp/Uc9y8wktcQ0dAAwjFvDLz2zqTkzCEqlFinz74VWbdYI0ilYQGT9zG4w0r0T5THD+SNZ/0S4Ni9dnUG4UNGZ4XHTw4Vj/yytnagI=
x-forefront-antispam-report: CIP:255.255.255.255;CTRY:;LANG:en;SCL:1;SRV:;IPV:NLI;SFV:NSPM;H:PAWPR07MB10010.eurprd07.prod.outlook.com;PTR:;CAT:NONE;SFS:(13230040)(1800799024)(376014)(366016)(8096899003)(38070700018);DIR:OUT;SFP:1101;
x-ms-exchange-antispam-messagedata-chunkcount: 1
x-ms-exchange-antispam-messagedata-0: VKwENVS3ctDvh5Qce+05jFDfTqlJ6gyfzV3uS2stPEJj+vQMdmcr/pRQQUUjkclGuK9jXU5rZ4IxEyH8XZ0tG4okAKByIf3OR4Xxg/SZGvpj58VS71m/R1wWldq7lahNxv0EXbtPuLcnqYLQNe7gBB1Ftolb2l3qOj/KoiAfwcJFvMFMYlEvLjcLLkYd6idXRvo/o69Qo+8DE0SjgZU0dLWQos1s48lqu3f6AtoayPcjpngkaE5fQRmCQkTeABOqfDfqzdyc/OwomTGB52yqZ/CHN7iFWhKN3aqbrNJgWRQtF3hvi6Z9g6/RkY7eHEJiuioPlrr9fTOGGJ1G0/5ZdCVVp/FhoEM9OeawE4vKp+YxRyqjfE1DL5VLxFyUfew7HhbHg0o4vByoD9/GMqw0GEY5TFp3jqRKVCUSDG5Y6g5uV+6UXxQyc2DK3dT+FkXs3KYPu4Om56HRAiGb34t0rQOCJKc0pkjLKWVWiFMuJSfbk+EGjy5/joTXwqfKBuSooo3UhlBjQC0owQ9Sk2SUsj4bn68cgA7ueOzaTC9F9bhTRkD99i+lra/mTtk9EBTBDb3/LUqXEF1wAzTO7dHiLC5jQEgjHwUAtCaS1Ka+M+S27jV3DC7KwUdZ56u0NTufns95SrFdJyEWng55y9iJIGDzLn48kwUo8pZOGiD5I60OW7kmjsRnde174EB+71X4MLDhvuz0VfOWPgytWYJt67+iBXSa8ROOagOqQbJ9V7lCUhZlan+ssHX9MC0K0OqVYGgPmMPEsVOUdmXpHC8QH+F0gd2aXSzZOnq1fDTHzJDz5HRltvxzqmthEvkIK17zhtCG6DKS0M0i9079nbWpGY9JLdY3jXiXMRaY4llCdPsIoYFAZ9QX0jjZN9lZrON7PuVOKJX/IWeoEPq9I/O/wB2DOTWjgFwL0M0DN6Aa1Rw9slEca5+4rRu/4ViygyktFiZb0Hcuzz5rTF9Z3EFdL78oP+5piRYhjUS59ngWb19eRxto4BS6EMYI8J8NoZ0k60yW4AVTQmbn+hagbqsE0mKaQcZkgA/Ph2o48+H0SzAZKVlG55VwLJHwb8Et4AnucDMTKcZkDIT9/4Fs5YJGYFOJLbv7hEt12OMJ2Y5JMavXDYKoeCKu32Ijvc372bM7Hl6BJDrqKaPYFjsFuqijYu47xAIwgX/wghoNOqZi3qeZfyFXo3onqQlj53E1DFVd8QhRhsNw6xrjsWlP228OmQIaGyb/fOJABbB46tTabVDJpgKKmKwC2l7M7xnjAuS8+tJzqqCKp0ieupO6QbMHMpPFdq8fpQr9SQwY0LlPSn0+O5ALBd/DXg4Y0MLP3YzlsAtZ4bHZxjwJIF8rIG9Kphw8va3AT2xFfUzMkidjc7342kd0DzASLFc1eHTmitonzI4oA6osrvy2IzhypWejSJ0ZdR1aYgwBfjRhbVBPoxO0RX37cIJ5XhJFCSQk35NRCitxmFxCSMteKhyE0OzhZDzoZNuC597wENo8cyaHRXCnhyjxDJKw+VqIhwjMvD1JAczGEf2EYIXVfgeV/+xHfY0oPVRS0QV5/awZ6tcad758Lkt7hyuXv8TfwMACoQrv
Content-Type: multipart/alternative; boundary="_000_PAWPR07MB100104DF786653095FE622C5FF2232PAWPR07MB10010eu_"
MIME-Version: 1.0
X-OriginatorOrg: ericsson.com
X-MS-Exchange-CrossTenant-AuthAs: Internal
X-MS-Exchange-CrossTenant-AuthSource: PAWPR07MB10010.eurprd07.prod.outlook.com
X-MS-Exchange-CrossTenant-Network-Message-Id: 2a385be7-911b-4a84-89ae-08dd0b36791e
X-MS-Exchange-CrossTenant-originalarrivaltime: 22 Nov 2024 20:44:34.4291 (UTC)
X-MS-Exchange-CrossTenant-fromentityheader: Hosted
X-MS-Exchange-CrossTenant-id: 92e84ceb-fbfd-47ab-be52-080c6b87953f
X-MS-Exchange-CrossTenant-mailboxtype: HOSTED
X-MS-Exchange-CrossTenant-userprincipalname: XVMfwcURwmNB8KvMxd0IH+ARJl2/6wVqu7Rr7j9Az85GH0i0w0CLASUwKpLucMmm+e7vd7MOBCEVi3ssFhYxceOfEDzh+ZqoM7pw3O1De4E=
X-MS-Exchange-Transport-CrossTenantHeadersStamped: AM7PR07MB6278
Message-ID-Hash: FB6AYJPVZR46KHHSNSKRQZAOC4FDYONO
X-Message-ID-Hash: FB6AYJPVZR46KHHSNSKRQZAOC4FDYONO
X-MailFrom: Janos.Farkas@ericsson.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-detnet.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [Detnet] Re: response to LS on request for feedback on work items related to deterministic networking in
List-Id: Discussions on Deterministic Networking BoF and Proposed WG <detnet.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/detnet/ip_eeVn-8fQfUasXTQ9db4rcLsM>
List-Archive: <https://mailarchive.ietf.org/arch/browse/detnet>
List-Help: <mailto:detnet-request@ietf.org?subject=help>
List-Owner: <mailto:detnet-owner@ietf.org>
List-Post: <mailto:detnet@ietf.org>
List-Subscribe: <mailto:detnet-join@ietf.org>
List-Unsubscribe: <mailto:detnet-leave@ietf.org>
WG, Please find below a slightly refined version of the proposed LS to be sent. Please let us know your comments by the end of November. We want to send the LS response to ITU-T SG13 at the beginning of December. Regards, János >From Group detnet To Group ITU-T-SG-13 Purpose for action Attachments (None) Liaisons referred by this one https://datatracker.ietf.org/liaison/1951/ Body: The Internet Engineering Task Force (IETF) Deterministic Networking (DetNet) Working Group would like to thank ITU-T Study Group 13 for the information provided in liaison statement https://datatracker.ietf.org/liaison/1951/ "LS on request for feedback on work items related to deterministic networking in SG13". The DetNet Working Group focuses on deterministic data paths that operate over Layer 2 bridged and Layer 3 routed segments, where such paths can provide bounds on reordering, latency, loss, and packet delay variation (jitter), and high reliability. DetNet solutions apply to both wireless and wired networks. The Working Group addresses Layer 3 aspects in support of applications requiring deterministic networking. The Working Group collaborates with other IETF Working Groups and the IEEE 802.1 Time-Sensitive Networking (TSN) Task Group, which is responsible for Layer 2 operations, to define a common architecture for both Layer 2 and Layer 3. The Working Group currently focuses on solutions for networks that are under a single administrative control or within a closed group of administrative control; these include not only campus-wide networks but also private WANs. The Working Group is responsible for the overall DetNet architecture and DetNet-specific specifications that encompass the data plane, OAM (Operations, Administration, and Maintenance), time synchronization, management, control, and security aspects which are required to enable a multi-hop path, and forwarding along the path, with the deterministic properties of controlled latency, low packet loss, low packet delay variation, and high reliability. The work applies to point-to-point (unicast) and point-to-multipoint (multicast) flows which can be characterized in a manner that allows the network to 1) reserve the appropriate resources for the flows in advance, and 2) release/reuse the resources when they are no longer required. The work covers the characterization of flows, the encapsulation of frames, the required forwarding behaviors, as well as the state that may need to be established in intermediate nodes. The work also includes detailing the requirements for deterministic networks in various industries. For more information on the Working Group and standards that have been published see: https://datatracker.ietf.org/wg/detnet/about/. The following is a list of documents that the Working Group is actively working on via the standard IETF process (RFC 2026): * draft-ietf-detnet-controller-plane-framework: "Deterministic Networking (DetNet) Controller Plane Framework" * draft-ietf-raw-technologies: "Reliable and Available Wireless Technologies" * draft-ietf-raw-architecture: "Reliable and Available Wireless Architecture" * draft-ietf-detnet-scaling-requirements: "Requirements for Scaling Deterministic Networks" * draft-ietf-detnet-dataplane-taxonomy: "Dataplane Enhancement Taxonomy" Other documents from individual contributors are under consideration, but have not yet been accepted as Working Group documents. A list of those documents can be found at: https://datatracker.ietf.org/wg/detnet/documents/ As a reminder, the IETF is a contribution driven organization, with a formal process defined in RFC 2026 and RFC 8789. Additionally, IETF Working Group process is defined in RFC 2418. Notably, IETF positions require community rough consensus with input from Working Groups via process managed by the Internet Engineering Steering Group (IESG). Without a community consensus process, there is no agreement or concurrence on any topic raised with or to the IETF. This includes Liaison Statements. In our understanding, the scope of ITU-T Y.Det-qos-intwk-wan "Requirements and framework of deterministic QoS interworking mechanism in wide area network including IMT-2020 and beyond" includes functional requirements and framework for deterministic QoS interworking mechanism in wide area network limited to fixed networks such as backbone network or metropolitan area network within a single provider. This scope is within the charter of the DetNet Working Group. We invite contributions from members of your group to our efforts in development of DetNet. If gaps are perceived in meeting requirements, we encourage contributions related to those aspects to the DetNet Working Group. For example, the DetNet Working Group is currently working on a requirements document: draft-ietf-detnet-scaling-requirements: "Requirements for Scaling Deterministic Networks". If your requirements are not covered in this document, then we invite you to contribute your requirements to this document of the DetNet Working Group. From: Janos Farkas <Janos.Farkas=40ericsson.com@dmarc.ietf.org> Sent: Friday, November 8, 2024 1:00 AM To: detnet@ietf.org Subject: [Detnet] response to LS on request for feedback on work items related to deterministic networking in WG, Please find below the line a kick-off for the development of LS 208 we received from ITU-T SG13: https://datatracker.ietf.org/liaison/1951/. As we discussed at the DetNet session today, the LS we received is for action, we should respond. The LS we received includes: "SG13 would like to inform you of a new work item conditionally approved at this meeting: - ITU-T Y.Det-qos-intwk-wan "Requirements and framework of deterministic QoS interworking mechanism in wide area network including IMT-2020 and beyond" (SG13-TD976/WP1) SG13 would like to seek your feedback as to the above work items, in particular with regard to their relation to work conducted by IEEE and IETF, possible overlap with your work, and/or further opportunities for collaboration you see between our organisations." The cited ITU-T Y.det-qos-intwk-wan includes: "1. Scope The scope of this new work item is functional requirements and framework for deterministic QoS interworking mechanism in wide area network limited to fixed networks such as backbone network or metropolitan area network within a single provider." Comments to the draft response LS below are welcome. (the longest paragraph in the draft response below is text from the charter of the DetNet WG) Regards, János >From Group detnet To Group ITU-T-SG-13 Purpose For information Attachments (None) Liaisons referred by this one https://datatracker.ietf.org/liaison/1951/ Body: The Internet Engineering Task Force (IETF) Deterministic Networking (DetNet) Working Group would like to thank ITU-T Study Group 13 for the information provided in liaison statement https://datatracker.ietf.org/liaison/1951/ "LS on request for feedback on work items related to deterministic networking in SG13". The DetNet Working Group focuses on deterministic data paths that operate over Layer 2 bridged and Layer 3 routed segments, where such paths can provide bounds on reordering, latency, loss, and packet delay variation (jitter), and high reliability. DetNet solutions apply to both wireless and wired networks. The Working Group addresses Layer 3 aspects in support of applications requiring deterministic networking. The Working Group collaborates with IEEE802.1 Time-Sensitive Networking (TSN), which is responsible for Layer 2 operations, to define a common architecture for both Layer 2 and Layer 3. The Working Group will initially focus on solutions for networks that are under a single administrative control or within a closed group of administrative control; these include not only campus-wide networks but also private WANs. The Working Group is responsible for the overall DetNet architecture and DetNet-specific specifications that encompass the data plane, OAM (Operations, Administration, and Maintenance), time synchronization, management, control, and security aspects which are required to enable a multi-hop path, and forwarding along the path, with the deterministic properties of controlled latency, low packet loss, low packet delay variation, and high reliability. The work applies to point-to-point (unicast) and point-to-multipoint (multicast) flows which can be characterized in a manner that allows the network to 1) reserve the appropriate resources for the flows in advance, and 2) release/reuse the resources when they are no longer required. The work covers the characterization of flows, the encapsulation of frames, the required forwarding behaviors, as well as the state that may need to be established in intermediate nodes. The work also includes detailing the requirements for deterministic networks in various industries. Please see more in the charter for the Working Group: https://datatracker.ietf.org/wg/detnet/about/. The following is a list of documents that the Working Group is actively working on via the standard IETF process (RFC 2026): * draft-ietf-detnet-controller-plane-framework: "Deterministic Networking (DetNet) Controller Plane Framework" * draft-ietf-raw-technologies: "Reliable and Available Wireless Technologies" * draft-ietf-raw-architecture: "Reliable and Available Wireless Architecture" * draft-ietf-detnet-scaling-requirements: "Requirements for Scaling Deterministic Networks" * draft-ietf-detnet-dataplane-taxonomy: "Dataplane Enhancement Taxonomy" Other documents from individual contributors are under consideration, but have not yet been accepted as Working Group documents. A list of those documents can be found at: https://datatracker.ietf.org/wg/detnet/documents/ As a reminder, the IETF is a contribution driven organization, with a formal process defined in RFC 2026 and RFC 8789. Additionally, IETF Working Group process is defined in RFC 2418. Notably, IETF positions require community rough consensus with input from Working Groups via process managed by the Internet Engineering Steering Group (IESG). Without a community consensus process, there is no agreement or concurrence on any topic raised with or to the IETF. This includes Liaison Statements. In our understanding, the scope of ITU-T Y.Det-qos-intwk-wan "Requirements and framework of deterministic QoS interworking mechanism in wide area network including IMT-2020 and beyond" includes functional requirements and framework for deterministic QoS interworking mechanism in wide area network limited to fixed networks such as backbone network or metropolitan area network within a single provider. This scope is within the charter of the DetNet Working Group. We invite contributions from members of your group to our efforts in development of DetNet. If gaps are perceived in meeting requirements, we encourage contributions related to those aspects to the DetNet Working Group. For example, the DetNet Working Group is currently working on a requirements document: draft-ietf-detnet-scaling-requirements: "Requirements for Scaling Deterministic Networks". If your requirements are not covered in this document, then we invite you to contribute your requirements to this document of the DetNet Working Group.
- [Detnet] response to LS on request for feedback o… Janos Farkas
- [Detnet] Re: response to LS on request for feedba… Janos Farkas