[dhcwg] Re: Actions after the IETF last call of draft-ietf-dhc-rfc8415bis-07

Bernie Volz <bevolz@gmail.com> Mon, 03 February 2025 11:00 UTC

Return-Path: <bevolz@gmail.com>
X-Original-To: dhcwg@ietfa.amsl.com
Delivered-To: dhcwg@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 10C16C1C6340 for <dhcwg@ietfa.amsl.com>; Mon, 3 Feb 2025 03:00:15 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -2.107
X-Spam-Level:
X-Spam-Status: No, score=-2.107 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, FREEMAIL_FROM=0.001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001, T_SCC_BODY_TEXT_LINE=-0.01, URIBL_DBL_BLOCKED_OPENDNS=0.001, URIBL_ZEN_BLOCKED_OPENDNS=0.001] autolearn=ham autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (2048-bit key) header.d=gmail.com
Received: from mail.ietf.org ([50.223.129.194]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id BUd59RR2ijPh for <dhcwg@ietfa.amsl.com>; Mon, 3 Feb 2025 03:00:11 -0800 (PST)
Received: from mail-qk1-x729.google.com (mail-qk1-x729.google.com [IPv6:2607:f8b0:4864:20::729]) (using TLSv1.3 with cipher TLS_AES_128_GCM_SHA256 (128/128 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 2B2B8C1DA2C1 for <dhcwg@ietf.org>; Mon, 3 Feb 2025 03:00:11 -0800 (PST)
Received: by mail-qk1-x729.google.com with SMTP id af79cd13be357-7b6f19a6c04so406037385a.0 for <dhcwg@ietf.org>; Mon, 03 Feb 2025 03:00:11 -0800 (PST)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20230601; t=1738580409; x=1739185209; darn=ietf.org; h=to:in-reply-to:cc:references:message-id:date:subject:mime-version :from:content-transfer-encoding:from:to:cc:subject:date:message-id :reply-to; bh=J8bOHHXX2InoU/Fj/vxciL/l6REyuheA3woS2cJsvZ0=; b=Ov+3Oc0msI4Lq8EwotYAlaO4eVvsBmDpgMxqVM0gjpRJqsh9iJjla10qFQOTcXNsmB md/4WyxeyUAbt2ga4X4cwi3n+LTHkn14D+QJkUmx/tnyPdq94KWn/+hVrCGd1tBusoKy iRtpFjJm9zvpL+sg3ou/+gn1rA20C1BVBl8F5NUjHfh8FSh9hWNkqHHjTZ8EVgT8I7Ws ocW0GNudbG+xHE1ty6sXek53Haw7zmpNqP1VB/NmmLC5ysRAqC3+DiKKm8RAS+NQmEvH 3iv8txVnZ8mMc0CTtu4xa5zFja8mwgKSrMRgGf2mCLx7vms/amoG/M1eSufn28RRrfuo 6QfA==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20230601; t=1738580409; x=1739185209; h=to:in-reply-to:cc:references:message-id:date:subject:mime-version :from:content-transfer-encoding:x-gm-message-state:from:to:cc :subject:date:message-id:reply-to; bh=J8bOHHXX2InoU/Fj/vxciL/l6REyuheA3woS2cJsvZ0=; b=QW535WBYvf+fJsbDnvpLkhuxqGu9Eg5gQxIps3iM0nA/lSE2ARfMBmNtZuhZNEvDs0 XxU0JNFW4oG7YSmyoLJehSfnVwChSZkdXTugSdKcr5W33x/G+UZc1cgnc9GYPiOSGzFD /Fl7CMDybvIY7pGOrVWnC0uh733oqN/eJmK3XLT0QXe7XOhqewLV9v5PKDZYJ8WD1G8n X5cNciyRhpL3V7+8ruE4QNTVyvOn86RKqkME8BTKElZ2SKVNIWOeF0haiVyOGNxHuFgC vHaZozcFu4QHX2PDlBAs+bWBeyxTVsDuckyaSz4pC4EjNP4IRjwr+/y0MZzdw0MBZLmi Yxsw==
X-Forwarded-Encrypted: i=1; AJvYcCUVmAkbDMNmx3VwyzUXvs7wS1P35ZCTGpg5f6+KytEccGiIapmju+lRjQwOzgUUws+nMfSIvQ==@ietf.org
X-Gm-Message-State: AOJu0YzX8CRQOzz52tJlck/2TkcjeoSMNDvJ/Pl7KFNTEUDV+lFuuDgK rPizpQQw98MOPgJ2WU705ypW5k5J7OQeBX0JLYQoY7wIlX+JgcXSt0UX6hs=
X-Gm-Gg: ASbGncvGMjCE5t4zYd1aFs+X8qJkLLLGZoaBM+TxteXNdmcwDHUk+sQQMUBbpElQBez ytr1lTqITJXf3XvdGULKJSnj+PApfDJlkmVesoQS1xUa09ORP7Gdh94E+Rmqd/jbZY4TJF/8Eax uuwt1W2jONIC3/cPfeChZMRWFmtbDmOp6phGOhq8u8PNfCVLDPNoc05tHb7tjOR4tZ8yZsWFFea CUVR5b+VQJJuR4ipBrx+rICXl7gOCqW4/D7V92iq3FTsjgWki+UAihYpNrvqVVIOuGWBE/IBFXg zDrNEvi3vkfyBMXTJnpUrw==
X-Google-Smtp-Source: AGHT+IGQKaWuAM/gJ9a/c8b9SLQBdt0Npzovc9oLYGVyK/vOzIoSIyMK3J660ufyAtWxhSQb3LkCtw==
X-Received: by 2002:a05:620a:40c4:b0:7be:5bc1:9460 with SMTP id af79cd13be357-7bffcd8d8a2mr2930354485a.35.1738580408800; Mon, 03 Feb 2025 03:00:08 -0800 (PST)
Received: from smtpclient.apple ([76.67.3.73]) by smtp.gmail.com with ESMTPSA id af79cd13be357-7c00a8bba69sm516792785a.8.2025.02.03.03.00.07 (version=TLS1_3 cipher=TLS_AES_128_GCM_SHA256 bits=128/128); Mon, 03 Feb 2025 03:00:07 -0800 (PST)
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: quoted-printable
From: Bernie Volz <bevolz@gmail.com>
Mime-Version: 1.0 (1.0)
Date: Mon, 03 Feb 2025 05:59:46 -0500
Message-Id: <520F4431-E847-48EA-9F7D-E346CFA091F1@gmail.com>
References: <668079.1738579092@dyas>
In-Reply-To: <668079.1738579092@dyas>
To: Michael Richardson <mcr+ietf@sandelman.ca>
X-Mailer: iPad Mail (22C161)
Message-ID-Hash: 4IJNQVNJSBWMNTIAT2XBIAK7XEVSCS3D
X-Message-ID-Hash: 4IJNQVNJSBWMNTIAT2XBIAK7XEVSCS3D
X-MailFrom: bevolz@gmail.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-dhcwg.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: Jim Reid <jim@rfc1035.com>, dhcwg@ietf.org
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [dhcwg] Re: Actions after the IETF last call of draft-ietf-dhc-rfc8415bis-07
List-Id: Dynamic Host Configuration <dhcwg.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/dhcwg/zO_YxmKGVAm19VhGs9oSpXkZAoE>
List-Archive: <https://mailarchive.ietf.org/arch/browse/dhcwg>
List-Help: <mailto:dhcwg-request@ietf.org?subject=help>
List-Owner: <mailto:dhcwg-owner@ietf.org>
List-Post: <mailto:dhcwg@ietf.org>
List-Subscribe: <mailto:dhcwg-join@ietf.org>
List-Unsubscribe: <mailto:dhcwg-leave@ietf.org>

There’s a bunch of stuff to work through here … thanks for initiating Michael.

I do want to just add that as this document has had two major reviews (for 3315 and then also for 8415), including many more, I think we should minimize changes unless there are real technical issues. Non technical issues are stylistic issues and will vary by reviewer.

More later, though it may be a few days as traveling.

- Bernie (from iPad)

> On Feb 3, 2025, at 5:38 AM, Michael Richardson <mcr+ietf@sandelman.ca> wrote:
> 
> 
> (I really wish we had done all this work in Markdown, and I wish I had pushed harder
> to do that.  We did that for 8415)
> 
> https://github.com/dhcwg/rfc8415bis/pull/15
> 
> Eric Vyncke (evyncke) <evyncke@cisco.com> wrote:
>> https://datatracker.ietf.org/doc/review-ietf-dhc-rfc8415bis-07-dnsdir-lc-reid-2025-01-12/
>> by Jim Reid [2]
> 
>    jr> Overall, the I-D is in fairly good shape. However there are a few
>    jr> places where the text is clumsy and IMO lacks clarity. There's some
>    jr> unwelcome duplication too. Terms are used inconsistently: server vs
>    jr> DHCP server for instance. I think the document needs to do a better
>    jr> job of making a distinction between DHCP in general and DHCPv6. A
>    jr> technical writer could easily clean up these nits and save the RFC
>    jr> Editor from doing that.
> 
> The RFC editor already kicked that can when they did RFC8415.
> We are aiming for Internet Standard:
>   https://author-tools.ietf.org/diff?doc_1=RFC8415&doc_2=draft-ietf-dhc-rfc8415bis-07&iddiff=1
> 
> Basically I'm reluctang to change too much text, because I think they might
> just want to change it back.
> 
>    jr> My biggest gripe is the section on rate-limiting. I do not understand
>    jr> why relay- and server-side rate limiting could be deemed out of
>    jr> scope. That seems to me to be every bit as important as client-side
> 
> Mostly, DHCPv6 servers (more than DHCPv4) only reply to queries from clients.
> Clients manage retransmissions, with a few things like RECONFIGURE being
> server initiated.  (often not used, not supported...)
> So I'm not sure that there is much that servers can do to further limit
> rates, except I guess they can drop requests from annoying clients.
> 
> Relays can similiarly be lossy if they need to be.
> I don't see a protocol impact of this though.
> 
>    jr> rate limiting. I'm not sure if this counts as a nit or an
>    jr> issue. Either way, this does need to be addressed - or explained if
>    jr> the WG took a consensus decision on that while the doc was under
>    jr> development.
> 
> I'm open to further suggestions.
> 
>    jr> It is confusing (and IMO misleading) to say DHCP in the document when
>    jr> the authors really mean DHCPv6. Although this is explained in the
>    jr> definitions in Section 4.2, that text is easily overlooked. It would
>    jr> be far clearer to say "DHCP" when discussing DHCP in general and use
>    jr> DHCPv4 and DHCPv6 when referring to the specifics of how DHCP is used
>    jr> with these transports.
> 
> I feel like we ligitiated this when the document was developed, and if
> section 4.2 isn't enough, then what would really be enough?
> 
>    jr> Section 5 says "A DHCP client sends messages using a reserved,
>    jr> link-scoped multicast destination address". It's not clear to me
>    jr> where this term is defined. Providing an example might help too.
> 
> okay.
> https://github.com/dhcwg/rfc8415bis/pull/15/commits/bfcb89c6e532acaf4968387a4e94ea6b7301f6c1
> 
>    jr> The first para of 6.1 is clunky. I think the following is clearer:
> 
>    jr>     Stateless DHCP [RFC3736] can be used to obtain host configuration
>    jr> parameters such as a list of NTP or DNS recursive name servers. DHCP
>    jr> leases are not involved in these transactions. Stateless DHCP can be
>    jr> used at any time, typically when a node initially boots.
> 
> https://github.com/dhcwg/rfc8415bis/pull/15/commits/471d288099371333ba9714d9e5accb77cf3d40d0
> 
>    jr> In Sections 6.2 and 6.3, say "DHCPv6 server", not "server".
> 
> okay.
> We say:
>        Therefore, this document mostly replaces
>        "requesting router" with "client" and "delegating router" with
>        "server".
> 
> and I'm not sure what to do here.
>    https://github.com/dhcwg/rfc8415bis/pull/15/commits/157ca2d13b264deae9a839b49277d1f382b31f1e
> 
>    jr> Section 7.1: Are All_DHCP_Servers and All_DHCP_Servers being defined
>    jr> here or do they come from another RFC or an IANA registry?
> 
> how about:
> 
> -        <t>DHCP makes use of the following multicast addresses:</t>
> +        <t><xref target="RFC3315" /> registered the following multicast
> +addresses, and this specification is now authoritative for:</t>
> 
> https://github.com/dhcwg/rfc8415bis/pull/15/commits/a6b1b9b8c1cd6e3e55dd1965155fa12530fc11ce
> 
>    jr> Sections 7.2 and 7.3 seem redundant and unnecessary. Isn't this text
>    jr> already in the base DHCP spec? If so, why repeat it here? What stuff
>    jr> in Section 7 is unique to DHCPv6?
> 
> *THIS* is the new base DHCP spec.
> 
>    jr> The text in 7.4 and 7.5 is garbled IMO. Both could be removed or
>    jr> replaced with a sentence saying the option and status codes used in
>    jr> this I-D are documented in Section 21.
> 
> I don't understand your comment.
> The text seems fine to me.
> 
>    jr> Section 7.6: I'm irritated by introductory text which starts "This
>    jr> section..."
> 
> How about:
> -        <t>This section presents a table of values used to describe the
> +        <t>This table of values used to describe the
> 
> https://github.com/dhcwg/rfc8415bis/pull/15/commits/b4c9d629378bab5bdd91816807b8d9ce389bdff0
> 
>    jr> Section 8 & 9: Are these message formats special in some way? Are
>    jr> they any different from those for "vanilla" DHCP?
> 
> This *is* vanila DHCPv6.  This will be the definitive document (once approved).
> 
>    jr> Section 10: Just say all domain names used in DHCP(v6) MUST be
>    jr> encoded in the format defined in Section 3.1 of RFC1035. The message
>    jr> compression scheme described in Section 4.1.4 of RFC1035 MUST NOT be
>    jr> used.
> 
> I simplified the text slightly, I'm unclear what was wrong with what was said already:
> https://github.com/dhcwg/rfc8415bis/pull/15/commits/acdd5e0c8379f5a1701462532e295bbccbbc634d
> 
>    jr> Section 11: The DUID MUST be globally unique? If so, how? And does
>    jr> global mean global (ie over the whole Internet) or is it just within
>    jr> the scope of a given DHCP server's administrative domain?
> 
> It might not be unique over the whole "Internet", true.
> I think the text is good.
> 
>    jr> Section 11.2: The I-D needs to explain how DUID-LLT collisions get
>    jr> handled even if they're rare events. Do these collisions matter?
> 
> If DUID-LLTs are not unique, then the link-layer address must have also been
> non-unique, and things tend to go badly in other ways at that point.
> We have no way to identify/defend this uniqueness.
> 
>    jr> Section 13 should say "DHCPv6 server" and not "server"
> 
> This is intentional.
> 
>    jr> Section 14.1 "reverts back" is a tautology. The text in this Section
>    jr> is clumsy. I don't like "does not like". :-) How about the following?
> 
>    jr>    A DHCPv6 client MUST limit the rate of DHCP messages it
>    jr> transmits or retransmits. This will minimise the impact of prolonged
>    jr> message bursts or loops, for example when a client rejects a server's
>    jr> response, repeats the request and gets the same server response which
>    jr> again gets rejected by the client.
> 
> https://github.com/dhcwg/rfc8415bis/pull/15/commits/7ad0e9caeb94f74699bac7bb71ce4caba47731b5
> 
>    jr> "A possible default could be 20 packets in 20 seconds." [Citation
>    jr> needed.] Please explain where these numbers come from and why.
> 
> I can not, can someone else?
> 
>    jr> "Rate limiting of forwarded DHCP messages and server-side messages is
>    jr> out of scope for this specification." WHY??? IMO these *have* to be
>    jr> in scope. They're part of the protocol.
> 
> Because servers do not initiate new messages.
> 
>    jr> Section 15: according to the retransmission strategy described below?
> 
> https://github.com/dhcwg/rfc8415bis/pull/15/commits/78f20acc11673d018564da76f45474e22778994e
> 
>    jr> Section 16: I'm even more fed up with introductory text which starts
>    jr> "This section..."
> 
>    jr> The text in Section 16 is confusing and ambiguous. It first says
>    jr> messages containing unknown options can be discarded. Then it says
>    jr> they can't. It's not clear what unknown options "should be ignored as
>    jr> if they were not present" means in practice. Why not just say
>    jr> clients, relay agents, and servers MUST NOT discard messages
>    jr> containing unknown options or interfere with the content of those
>    jr> unknown options?
> 
> I have opened issue
>  https://github.com/dhcwg/rfc8415bis/issues/16
> 
>    jr> Section 18: The para beginning "A DHCP client" seems to be discussing
>    jr> Stateless DHCP but uses different RFC references to those in Section
>    jr> 7. These need to be aligned. There seems to be unnecessary
>    jr> duplication here. There seems to be unnecessary duplication here. :-)
> 
> https://github.com/dhcwg/rfc8415bis/issues/18
> 
>    jr> I *really like* the detailed explanation of how messages are created,
>    jr> transmitted and received in Section 18.2 and 19. It tells
>    jr> implementers how their DHCPv6 server/client/relay is expected to
>    jr> behave.
> 
>    jr> Section 20: Now I'm getting annoyed by introductory text which starts
>    jr> "This section...". Please make this go away.
> 
> https://github.com/dhcwg/rfc8415bis/issues/17
> 
>    jr> Section 20.4.2. Is it wise to insist on HMAC-MD5? See RFC6151.
> 
> 1. *HMAC* constructs are still safe.
> 2. almost nobody deploys this... maybe it should be removed entirely for IS.
> 
> RFC6151 says:
>        It is not urgent to stop using MD5 in other ways, such as HMAC-MD5;
> and it's section 2.3 goes on to confirm.
> 
>    jr> Section 21 repeats option formats documented elsewhere in the
>    jr> I-D. Please put this stuff in exactly one place. There's no need for
>    jr> repetition. There's no need for repetition. :-)
> 
> I think that there is some confusion here.
> I don't find another diagram like that in 21.1.
> What diagram did you see that was duplicated?
> 
>    jr> I'm not sure Section 22 is helpful or germane to the IESG's
>    jr> evaluation. It's harmless though. Of course, it *must* get removed
>    jr> before publication because implementation status info is (a)
>    jr> inappropriate for an RFC; (b) by definition always out of date as
>    jr> implementations come and go.
> 
> The IESG has said it's useful, and since we are going to IS, it's critical
> that we tell them this.
>   NOTE TO RFC EDITOR: Please remove this section before publication.
>   It is intended for the IESG evaluation.
> 
>    jr> Section 24: Now I'm getting angry about introductory text which
>    jr> starts "This section...". :-) Stop it!
> 
> Yes, okay.
> 
> --
> Michael Richardson <mcr+IETF@sandelman.ca>, Sandelman Software Works
> -= IPv6 IoT consulting =-                      *I*LIKE*TRAINS*
> 
> 
> 
> _______________________________________________
> dhcwg mailing list -- dhcwg@ietf.org
> To unsubscribe send an email to dhcwg-leave@ietf.org
> <signature.asc>