Re: [dhcwg] Adoption Call for draft-wkumari-dhc-addr-notification-07- Respond by April, 20 2023
Michael Richardson <mcr+ietf@sandelman.ca> Fri, 07 April 2023 16:05 UTC
Return-Path: <mcr+ietf@sandelman.ca>
X-Original-To: dhcwg@ietfa.amsl.com
Delivered-To: dhcwg@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 7EBDCC1516E1 for <dhcwg@ietfa.amsl.com>; Fri, 7 Apr 2023 09:05:43 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -2.095
X-Spam-Level:
X-Spam-Status: No, score=-2.095 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, RCVD_IN_DNSWL_BLOCKED=0.001, RCVD_IN_ZEN_BLOCKED_OPENDNS=0.001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001, URIBL_BLOCKED=0.001, URIBL_DBL_BLOCKED_OPENDNS=0.001, URIBL_ZEN_BLOCKED_OPENDNS=0.001] autolearn=ham autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (2048-bit key) header.d=sandelman.ca
Received: from mail.ietf.org ([50.223.129.194]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id HR3tvsvE4Mi7 for <dhcwg@ietfa.amsl.com>; Fri, 7 Apr 2023 09:05:38 -0700 (PDT)
Received: from tuna.sandelman.ca (tuna.sandelman.ca [209.87.249.19]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature RSA-PSS (2048 bits) server-digest SHA256) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id A7BDBC14F693 for <dhcwg@ietf.org>; Fri, 7 Apr 2023 09:05:38 -0700 (PDT)
Received: from localhost (localhost [127.0.0.1]) by tuna.sandelman.ca (Postfix) with ESMTP id 1A04F38996; Fri, 7 Apr 2023 12:22:21 -0400 (EDT)
Received: from tuna.sandelman.ca ([127.0.0.1]) by localhost (localhost [127.0.0.1]) (amavisd-new, port 10024) with LMTP id IUN2hb143PvH; Fri, 7 Apr 2023 12:22:20 -0400 (EDT)
Received: from sandelman.ca (obiwan.sandelman.ca [209.87.249.21]) by tuna.sandelman.ca (Postfix) with ESMTP id 5E2F938995; Fri, 7 Apr 2023 12:22:20 -0400 (EDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=sandelman.ca; s=mail; t=1680884540; bh=L2V1gbRG7/RhjeY4dpE+gDMhc4jfvVnaAUUE0XVogMI=; h=From:To:Subject:In-Reply-To:References:Date:From; b=RsVmMhAX0YeGTIYe52LuP7+CJFYXECjLy5P/FQ7xqKNEAEy7FyPC+lxu0xj3/4Ttb fN3lEkd/8Hs8tnKDhuirbR2ODVDhZS7tccFr9yVwqWuFnqu+O68t6LBDe5ToGI/N1o UWf7GC2doDqQGm0D4rZ7WBA++2naXUPz3I43faRvr24CXkfrJByVQyU9R12sIW6pG8 xJ/iPkNRrAWKXtYCYuA23Igt3R1hVcafO7cfUiuVZIE6jpqiFKudPlse75UiP5Qavo inFdfWXmjGfaqxSRgHtmK1zR7m1Osuu8cgOVgd1GrUTOmQKcySzVSUFu/IOtRbChTE kh89daxFyuE1w==
Received: from localhost (localhost [IPv6:::1]) by sandelman.ca (Postfix) with ESMTP id 160A6C7; Fri, 7 Apr 2023 12:05:36 -0400 (EDT)
From: Michael Richardson <mcr+ietf@sandelman.ca>
To: Timothy Winters <tim@qacafe.com>, dhcwg <dhcwg@ietf.org>
In-Reply-To: <CAJgLMKsH9ZqXjwDbYo4izUiOM27tuH_gk_rZPW8H52BawQ48mg@mail.gmail.com>
References: <CAJgLMKsH9ZqXjwDbYo4izUiOM27tuH_gk_rZPW8H52BawQ48mg@mail.gmail.com>
X-Mailer: MH-E 8.6+git; nmh 1.7+dev; GNU Emacs 27.1
X-Face: $\n1pF)h^`}$H>Hk{L"x@)JS7<%Az}5RyS@k9X%29-lHB$Ti.V>2bi.~ehC0; <'$9xN5Ub# z!G,p`nR&p7Fz@^UXIn156S8.~^@MJ*mMsD7=QFeq%AL4m<nPbLgmtKK-5dC@#:k
MIME-Version: 1.0
Content-Type: multipart/signed; boundary="=-=-="; micalg="pgp-sha512"; protocol="application/pgp-signature"
Date: Fri, 07 Apr 2023 12:05:36 -0400
Message-ID: <5948.1680883536@localhost>
Archived-At: <https://mailarchive.ietf.org/arch/msg/dhcwg/zk88HLY6SG2uY3Ce-GoiU2tPC-w>
Subject: Re: [dhcwg] Adoption Call for draft-wkumari-dhc-addr-notification-07- Respond by April, 20 2023
X-BeenThere: dhcwg@ietf.org
X-Mailman-Version: 2.1.39
Precedence: list
List-Id: Dynamic Host Configuration <dhcwg.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/dhcwg>, <mailto:dhcwg-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/dhcwg/>
List-Post: <mailto:dhcwg@ietf.org>
List-Help: <mailto:dhcwg-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/dhcwg>, <mailto:dhcwg-request@ietf.org?subject=subscribe>
X-List-Received-Date: Fri, 07 Apr 2023 16:05:43 -0000
Timothy Winters <tim@qacafe.com> wrote:
> As discussed during IETF-116, I would like initiating a WG call for
> adoption on
> https://datatracker.ietf.org/doc/draft-wkumari-dhc-addr-notification/.
> This starts the call for adoption of this document. Please respond by
> April 20, 2023.
I read the document a few weeks ago, and I like it.
Please adopt it.
} The host MUST only send the ADDR-REG-INFORM message for valid ([RFC4862])
} addresses of global scope ([RFC4007]).
Is this intended to exclude ULA?
} address being registered is "appropriate to the link" as defined by
It seems that this will be in conflict with draft-collink-v6ops-ent64pd,
should it be adopted.
The Security Considerations relating to the AUTH option are... insufficient.
I wish we'd removed it from 8415.
Does the packet need to originate from the IP address which is being
registered?
It would be nice if there was a return reachability challenge (3-way handshake).
Can a host include RFC4704 (Client FQDN) in the same packet to have the
reverse DNS updated?
There is some subtle (emotional?) connection to RFC8505, which I'll try to
resolve in my mind.
--
Michael Richardson <mcr+IETF@sandelman.ca> . o O ( IPv6 IøT consulting )
Sandelman Software Works Inc, Ottawa and Worldwide
- [dhcwg] Adoption Call for draft-wkumari-dhc-addr-… Timothy Winters
- Re: [dhcwg] Adoption Call for draft-wkumari-dhc-a… Sheng Jiang
- Re: [dhcwg] Adoption Call for draft-wkumari-dhc-a… Michael Richardson
- Re: [dhcwg] Adoption Call for draft-wkumari-dhc-a… Ted Lemon
- Re: [dhcwg] Adoption Call for draft-wkumari-dhc-a… Bernie Volz
- Re: [dhcwg] Adoption Call for draft-wkumari-dhc-a… Jen Linkova
- Re: [dhcwg] Adoption Call for draft-wkumari-dhc-a… Lorenzo Colitti
- Re: [dhcwg] Adoption Call for draft-wkumari-dhc-a… Sheng Jiang
- Re: [dhcwg] Adoption Call for draft-wkumari-dhc-a… Jen Linkova
- Re: [dhcwg] Adoption Call for draft-wkumari-dhc-a… Michael Richardson
- Re: [dhcwg] Adoption Call for draft-wkumari-dhc-a… Jen Linkova
- Re: [dhcwg] Adoption Call for draft-wkumari-dhc-a… Michael Richardson
- Re: [dhcwg] Adoption Call for draft-wkumari-dhc-a… Jen Linkova
- Re: [dhcwg] Adoption Call for draft-wkumari-dhc-a… Michael Richardson
- Re: [dhcwg] Adoption Call for draft-wkumari-dhc-a… Lorenzo Colitti
- Re: [dhcwg] Adoption Call for draft-wkumari-dhc-a… Michael Richardson
- Re: [dhcwg] Adoption Call for draft-wkumari-dhc-a… Timothy Winters