[dmarc-ietf] Re: [Technical Errata Reported] RFC9989 (8995)
"John R. Levine" <johnl@iecc.com> Thu, 11 June 2026 08:49 UTC
Return-Path: <johnl@iecc.com>
X-Original-To: dmarc@mail2.ietf.org
Delivered-To: dmarc@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id 2F97DFF3AC6C for <dmarc@mail2.ietf.org>; Thu, 11 Jun 2026 01:49:04 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=ietf.org; s=ietf1; t=1781167744; bh=5k7f4NsKh3EVTRrPsfKcenGMKwwvA011k9cLE4vY/Zo=; h=Date:From:To:Cc:Subject:In-Reply-To:References; b=u5GJo0V4JAnup74wKJVI2b6Vno3BUSkcEUfTl/8XjfUxdKJgA9ujJbl0nAcMJ71np kyIb6FIugjBZch1Z2wYrHIetjFw0gGFJEvYZ/LT66AyPb+uhjq+6aovYJzANc1rmoY E8SzjFkcTadlrGDwGUpDDiC6PFVW6oM1LhNCq5G0=
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -4.401
X-Spam-Level:
X-Spam-Status: No, score=-4.401 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, RCVD_IN_DNSWL_MED=-2.3, SPF_PASS=-0.001] autolearn=unavailable autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=pass (2048-bit key) header.d=iecc.com
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 51dqpIXCg8ME for <dmarc@mail2.ietf.org>; Thu, 11 Jun 2026 01:49:03 -0700 (PDT)
Received: from gal.iecc.com (gal.iecc.com [IPv6:2001:470:1f07:1126:0:43:6f73:7461]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id AEC40FF3AC67 for <dmarc@ietf.org>; Thu, 11 Jun 2026 01:49:03 -0700 (PDT)
Received: (qmail 49556 invoked from network); 11 Jun 2026 08:48:58 -0000
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed; d=iecc.com; h=date:message-id:from:to:cc:subject:in-reply-to:references:mime-version:content-type:content-transfer-encoding; s=c1926a2a767a.k2606; t=1781167728; x=1781513328; bh=5k7f4NsKh3EVTRrPsfKcenGMKwwvA011k9cLE4vY/Zo=; b=NIBF/+0rqwoPbWwC2W7cEVn44b5euLdu7ySyiWLYTo5DBj/3o/a6+omPPbBq2n/y8fRdgXHtJIXuh5bClj7V2WN/NSHPOs2Eenmn3vT2s2yoobjpYr6EfcIgImtg/fbCi3+46B2EmdFjCEmU+hzuRU1YICijoyrvlJv6rqy9P/Pik0c4jhYRcZ5GUTKaBF6iKT9iu9/g16k3+wa+WR+bjXNbkeBkqs7n5OSGaJcuhBuYnnV7pv4tt2DM3b4K25HqFbzjwjeSt6UbCzNgWE6Jxku+RJ0reliOls7eyID7YIUF1nJSgseV3Y9UFpMYCd1Qmx3sSZRg3FQoBsUP1Ei6rg==
Received: from ary.local ([IPv6:2001:470:1f07:1126:0:78:696d:6170]) by imap.iecc.com ([IPv6:2001:470:1f07:1126:0:78:696d:6170]) with ESMTPS (TLS1.3 ECDHE-RSA CHACHA20-POLY1305 AEAD) via TCP6; 11 Jun 2026 08:48:58 -0000
Received: by ary.local (Postfix, from userid 501) id 8998410FBC101; Thu, 11 Jun 2026 10:48:55 +0200 (CEST)
Received: from localhost (localhost [127.0.0.1]) by ary.local (Postfix) with ESMTP id 5833E10FBC0E3; Thu, 11 Jun 2026 10:48:55 +0200 (CEST)
Date: Thu, 11 Jun 2026 10:48:55 +0200
Message-ID: <35f853ca-3b2e-c89e-89ce-4f5633acca44@iecc.com>
From: "John R. Levine" <johnl@iecc.com>
To: Todd Herr <todd@someguyinva.com>, rfc-editor@rfc-editor.org
In-Reply-To: <CAK2M3FCz9CU5rH_8g2dtkx+tL9d2QVMe-Tv_rxgrh+kZhTncxw@mail.gmail.com>
References: <178111540878.11.8024834297384837061@rfc-editor.org> <CAK2M3FCz9CU5rH_8g2dtkx+tL9d2QVMe-Tv_rxgrh+kZhTncxw@mail.gmail.com>
MIME-Version: 1.0
Content-Type: text/plain; charset="utf-8"; format="flowed"
Content-Transfer-Encoding: 8bit
Message-ID-Hash: Y6VLSTPJYTMMZ536ZSVLOW3VTYDYD3CQ
X-Message-ID-Hash: Y6VLSTPJYTMMZ536ZSVLOW3VTYDYD3CQ
X-MailFrom: johnl@iecc.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-dmarc.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: andy@hxr.us, ietf@johnlevine.com, superuser@gmail.com, tjw.ietf@gmail.com, eckelcu@cisco.com, mihalop4@gmail.com, dmarc@ietf.org
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [dmarc-ietf] Re: [Technical Errata Reported] RFC9989 (8995)
List-Id: "Domain-based Message Authentication, Reporting, and Compliance (DMARC)" <dmarc.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/dmarc/jqJRXWudwLezn76yPlzinpdDpCs>
List-Archive: <https://mailarchive.ietf.org/arch/browse/dmarc>
List-Help: <mailto:dmarc-request@ietf.org?subject=help>
List-Owner: <mailto:dmarc-owner@ietf.org>
List-Post: <mailto:dmarc@ietf.org>
List-Subscribe: <mailto:dmarc-join@ietf.org>
List-Unsubscribe: <mailto:dmarc-leave@ietf.org>
Please see my note, There is nothing to fix. On Wed, 10 Jun 2026, Todd Herr wrote: > There is current on-list discussion in the DMARC working group regarding > this issue. > > The discussion is centered on whether this is in fact an erratum in RFC > 9989, or if it is instead a reason to create a new RFC to replace RFC 9989, > along with a working group chartered to take on that work. > > I am personally in the "new RFC and working group to produce it" camp. > > RFC 9989 plainly states in section 3.2.13 that for DMARC purposes, a > non-existent domain is consistent with the term's meaning as described in > RFC 8020. > > Including RFC 99824's definition and its use of NXNAME seems to expand that > definition in RFC 9989, instead of being a correction of an error therein. > > > On Wed, Jun 10, 2026 at 2:16 PM <rfc-editor@rfc-editor.org> wrote: > >> The following errata report has been submitted for RFC9989, >> "Domain-Based Message Authentication, Reporting, and Conformance (DMARC)" >> >> -------------------------------------- >> You may review the report below and at: >> https://errata.rfc-editor.org/eid8995/ >> >> -------------------------------------- >> Type: Technical >> Reported by: Johnathon Mihalop <mihalop4@gmail.com> >> >> Section Appendix A.4. says: >> >> Original Text >> ------------- >> If the response code received for a query for a domain name is NXDOMAIN, >> then the name and all the names under it do not exist. >> >> Corrected Text >> -------------- >> If the response received for a query for a domain name proves that the >> queried name does not exist, then the name and all names under it are >> considered non-existent for the purposes of this specification. This proof >> can be conveyed by an NXDOMAIN response, or by a DNSSEC-validated >> denial-of-existence response that otherwise indicates non-existence of the >> queried name, such as an RFC 9824 Compact Denial response containing the >> NXNAME type in the relevant NSEC bitmap. >> >> Notes >> ----- >> RFC 9824 (Compact Denial of Existence in DNSSEC) is a Proposed Standard >> that defines a way to reduce the size and signing cost of DNSSEC >> denial-of-existence responses. For a non-existent name, Compact Denial can >> return a NODATA-shaped response, i.e. RCODE=NOERROR with an empty Answer >> section, while signalling non-existence using the NXNAME RR type (TYPE128) >> in the NSEC/NSEC3 type bitmap. >> >> RFC 9989 describes non-existent domains only in terms of NXDOMAIN. This is >> incomplete for DNSSEC-validated responses from zones using RFC 9824 Compact >> Denial. A receiver that only treats RCODE=NXDOMAIN as proof of >> non-existence may fail to recognize an RFC 9824 NXNAME denial proof and may >> therefore fail to apply the DMARC np= policy for a non-existent Author >> Domain. >> >> Instructions: >> ------------- >> This erratum is currently posted as "Reported". Please >> use "Reply All" to discuss whether it should be verified or >> rejected. When a decision is reached, the verifying party >> will log in to change the status and edit the report, if necessary. >> >> -------------------------------------- >> RFC9989 (draft-ietf-dmarc-dmarcbis) >> -------------------------------------- >> Title : Domain-Based Message Authentication, Reporting, and >> Conformance (DMARC) >> Publication Date : May 2026 >> Author(s) : T. Herr, Ed., J. Levine, Ed. >> Category : Proposed Standard >> Source : dmarc (art) >> Stream : IETF >> Verifying Party : IESG >> > > > Regards, John Levine, johnl@taugh.com, Primary Perpetrator of "The Internet for Dummies", Please consider the environment before reading this e-mail. https://jl.ly
- [dmarc-ietf] [Technical Errata Reported] RFC9989 … rfc-editor
- [dmarc-ietf] Re: [Technical Errata Reported] RFC9… Todd Herr
- [dmarc-ietf] Re: [Technical Errata Reported] RFC9… John R. Levine
- [dmarc-ietf] Re: [Technical Errata Reported] RFC9… John R Levine