Draft of Revised charter
Olafur Gudmundsson <ogud@ogud.com> Wed, 14 March 2001 23:33 UTC
Received: from psg.com (exim@psg.com [147.28.0.62]) by ietf.org (8.9.1a/8.9.1a) with SMTP id SAA06477 for <dnsext-archive@lists.ietf.org>; Wed, 14 Mar 2001 18:33:23 -0500 (EST)
Received: from lserv by psg.com with local (Exim 3.16 #1) id 14dK0w-000Ftc-00 for namedroppers-data@psg.com; Wed, 14 Mar 2001 14:45:06 -0800
Received: from rip.psg.com ([147.28.0.39] ident=exim) by psg.com with esmtp (Exim 3.16 #1) id 14dK0v-000FtS-00 for namedroppers@ops.ietf.org; Wed, 14 Mar 2001 14:45:05 -0800
Received: from randy by rip.psg.com with local (Exim 3.16 #1) id 14dK0v-000C6V-00 for namedroppers@ops.ietf.org; Wed, 14 Mar 2001 14:45:05 -0800
Date: Wed, 14 Mar 2001 13:47:52 -0500
From: Olafur Gudmundsson <ogud@ogud.com>
X-Sender: ogud@hlid.dc.ogud.com
To: namedroppers@ops.ietf.org
Subject: Draft of Revised charter
Message-ID: <Pine.BSF.4.21.0103141346200.10005-100000@hlid.dc.ogud.com>
MIME-Version: 1.0
Content-Type: TEXT/PLAIN; charset="US-ASCII"
Sender: owner-namedroppers@ops.ietf.org
Precedence: bulk
Comments please
Olafur
DNSEXT DNS Extensions Working group
---------------------------------------------------
Charter
Last Modified: 14-March-2001
Current Status: Active Working Group (being rechartered)
Chair(s):
Randy Bush <randy@psg.com>
Olafur Gudmundsson <ogud@ogud.com>
Internet Area Director(s):
Thomas Narten <narten@raleigh.ibm.com>
Erik Nordmark <nordmark@eng.sun.com>
Internet Area Advisor:
Erik Nordmark <nordmark@eng.sun.com>
Mailing Lists:
General Discussion: namedroppers@ops.ietf.org
To Subscribe: namedroppers-request@ops.ietf.org
Archive: ftp://ftp.ops.ietf.org/pub/lists
Description of Working Group:
DNS is originally specified in
RFC's 1034 and 1035, with subsequent updates. Within the scope of
this WG are protocol issues, including message formats, message
handling, and data formats. New work items and milestones may be added
from time-to-time with the approval of the Working Group and the IESG.
Issues surrounding the operation of DNS, recommendations concerning
the configuration of DNS servers, and other issues with the use of the
protocol are out of this Working Group's charter. These issues are
considered in other venues, such as operational issues in the DNS
Operations Working Group.
Broad topics under consideration in DNSEXT are dynamic update, notify,
zone transfers, security and adjustments to address the requirements
of IPv6 addressing. Other issues that the working group will entertain
are topics related to protocol changes to support for languages that
can not be represented by US-ASCII. Security topics, mostly inherited
from the erstwhile DNS Security Extensions Working Group, will be
addressed in cooperation with the DNS Operations Working Group.
The principal task within this Working Group is to advance several
documents describing proposed extensions to DNS.
Specific work items are:
o Protocol clarifications and corrections for DNSSEC
o DNS clarification and extensions
DNS Server requirments
DNS Resolver requirements
o IPv6 support in DNS records and IPv6 DNS services
o Specification of multicast DNS service
Local link Multicast without DNS servers
Enterprice wide with DNS servers
o Extensions to DNS protocol required for Internationalized
Domain Names.
New work items may be added from time-to-time with the approval of the
Working Group and the IESG.
Goals and Milestones:
Where there is no milestone for a work item mentioned above,
the working group has not yet decided upon the priority for
the item, or, in some cases, whether active work will be undertaken,
and no target milestone has yet been set.
Apr 01 Advance last updates for RFC2535 to IESG
Apr 01 Advance SRV to draft standard. 2
Apr 01 Advance AXFR clarify to IESG
Apr 01 RFC1995bis avanced to Draft standard
Apr 01 Start rewrite of RFC2535 and related docs to reflect updates.
May 01 Advance Notify (RFC19
May 01 Forward Unknown types to IESG
Jun 01 Advance TSIG to Draft standard.
Jun 01 Advance TKEY to Draft standard.
Jun 01 Advance Clarify to Draft Standard
Jul 01 Determine fate of "DNSSEC Opt-in plans"
Jul 01 First WG last call on RFC2535-bis
Jul 01 Advance RFC2308 (Neg Caching) to draft Standard
Sep 01 Dynamic Update-bis advanced to IESG.
Oct 01 Forward RFC2535-bis to IESG.
Oct 01 Advance Secure Update RFC3007-bis to Draft standard.
Dec 01 Forward Server requirements to IESG
Dec 01 Forward Iquery obsolete to IESG.
Feb 02 Forward IPv6 Dynamic update guidelines to IESG.
to unsubscribe send a message to namedroppers-request@ops.ietf.org with
the word 'unsubscribe' in a single line as the message text body.
- Draft of Revised charter Olafur Gudmundsson
- Re: Draft of Revised charter Erik Nordmark