Re: [DNSOP] Review of draft-cheshire-sudn-ipv4only-dot-arpa-06
Mark Andrews <marka@isc.org> Mon, 28 November 2016 20:25 UTC
Return-Path: <marka@isc.org>
X-Original-To: dnsop@ietfa.amsl.com
Delivered-To: dnsop@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id B701A129FBF for <dnsop@ietfa.amsl.com>; Mon, 28 Nov 2016 12:25:08 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -8.398
X-Spam-Level:
X-Spam-Status: No, score=-8.398 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, RCVD_IN_DNSWL_HI=-5, RP_MATCHES_RCVD=-1.497, SPF_PASS=-0.001] autolearn=ham autolearn_force=no
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id rqyT7otgrAVy for <dnsop@ietfa.amsl.com>; Mon, 28 Nov 2016 12:25:07 -0800 (PST)
Received: from mx.ams1.isc.org (mx.ams1.isc.org [IPv6:2001:500:60::65]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 080FB129FAF for <dnsop@ietf.org>; Mon, 28 Nov 2016 12:25:07 -0800 (PST)
Received: from zmx1.isc.org (zmx1.isc.org [149.20.0.20]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by mx.ams1.isc.org (Postfix) with ESMTPS id E1CA01FCAE5; Mon, 28 Nov 2016 20:25:02 +0000 (UTC)
Received: from zmx1.isc.org (localhost [127.0.0.1]) by zmx1.isc.org (Postfix) with ESMTPS id AC582160070; Mon, 28 Nov 2016 20:25:01 +0000 (UTC)
Received: from localhost (localhost [127.0.0.1]) by zmx1.isc.org (Postfix) with ESMTP id 817F216006A; Mon, 28 Nov 2016 20:25:01 +0000 (UTC)
Received: from zmx1.isc.org ([127.0.0.1]) by localhost (zmx1.isc.org [127.0.0.1]) (amavisd-new, port 10026) with ESMTP id 3y_usKk5KYXE; Mon, 28 Nov 2016 20:25:01 +0000 (UTC)
Received: from rock.dv.isc.org (c27-253-115-14.carlnfd2.nsw.optusnet.com.au [27.253.115.14]) by zmx1.isc.org (Postfix) with ESMTPSA id 9FF61160046; Mon, 28 Nov 2016 20:25:00 +0000 (UTC)
Received: from rock.dv.isc.org (localhost [IPv6:::1]) by rock.dv.isc.org (Postfix) with ESMTP id 2BBA85B39A61; Tue, 29 Nov 2016 07:24:55 +1100 (EST)
To: Matthew Pounsett <matt@conundrum.com>
From: Mark Andrews <marka@isc.org>
References: <CAAiTEH8x3=AxGPeZos=cbctDWuFbMnc7Q-E2-8NRc-TXP+fPtg@mail.gmail.com>
In-reply-to: Your message of "Mon, 28 Nov 2016 12:21:31 -0500." <CAAiTEH8x3=AxGPeZos=cbctDWuFbMnc7Q-E2-8NRc-TXP+fPtg@mail.gmail.com>
Date: Tue, 29 Nov 2016 07:24:55 +1100
Message-Id: <20161128202455.2BBA85B39A61@rock.dv.isc.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/dnsop/9yh4jcssgip19ptU42IPZP3LZjQ>
Cc: cheshire@apple.com, dnsop <dnsop@ietf.org>, dschinazi@apple.com
Subject: Re: [DNSOP] Review of draft-cheshire-sudn-ipv4only-dot-arpa-06
X-BeenThere: dnsop@ietf.org
X-Mailman-Version: 2.1.17
Precedence: list
List-Id: IETF DNSOP WG mailing list <dnsop.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/dnsop>, <mailto:dnsop-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/dnsop/>
List-Post: <mailto:dnsop@ietf.org>
List-Help: <mailto:dnsop-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/dnsop>, <mailto:dnsop-request@ietf.org?subject=subscribe>
X-List-Received-Date: Mon, 28 Nov 2016 20:25:09 -0000
In message <CAAiTEH8x3=AxGPeZos=cbctDWuFbMnc7Q-E2-8NRc-TXP+fPtg@mail.gmail.com>, Matthew Pounsett write
s:
> I think this draft is useful and necessary, and that the registration of
> ipv4only.arpa within the SUDN registry is justified by the applicability
> statement of RFC 6761. Having NAT64-unaware recursive servers answer
> authoritatively as they would for other reserved names (e.g. RFC 1918
> address reverse lookups) is a useful optimization, and having NAT64-aware
> servers answer without querying the arpa servers removes a problematic
> external dependency. Furthermore, the inclusion of example.{org,com,net}
> in RFC 6761, which are clearly less special in their technical handling
> than ipv4only.arpa, provides further justification for ipv4only.arpa's
> inclusion in the registry.
No. This requires a much more nuanced approach than "just serve
the specified zone contents" all the time. We need to consider
chains of recursive servers. We need to consider DNSSEC.
Firstly the delegation of ipv4only.arpa needs to be made insecure
before anything else can answer for it. This is basic DNSSEC.
Secondly a recursive server MUST only answer for ipv4only.arpa if
it is resolving the ipv4only.arpa namespace interative. If the
recursive server is configured to get the answers for ipv4only.arpa
solely via another recursive server it MUST NOT be configured to
serve ipv4only.arpa. This allow for a recursive server to be
configure to point to a recursive DNS64 server and the expected
answers be returned to both the original client and all recursive
servers in the chain.
Thirdly RFC 6147 just talks absolute grabage about DNSSEC and what
CD and DO do. There was lots of wishful thinking in the working
group when this was written and it would not listen to reality.
draft-cheshire-sudn-ipv4only-dot-arpa-06 would do best to stay
absolutely silent about DNSSEC and DNS64.
draft-cheshire-sudn-ipv4only-dot-arpa-06 also suggest that recursive
servers respond to 170.0.0.192.in-addr.arpa and 171.0.0.192.in-addr.arpa
if we agree that this needs to be done these names need to be done
as per RFC 6303. Currently there is no delegation for these names.
Mark
> I have one comment and one question on the specifics of the reservations
> considerations sections:
>
> The answers to question 5 for both reservation considerations sections
> seem
> to mix developer and operational considerations for authoritative servers.
> It's my understanding that operational considerations should be handled
> under question 6 .. and in both cases they mostly are. Removing the
> duplicate instructions, and moving the remaining operational notes to
> question 6 would simplify the text. I'm happy to provide suggested text
> if
> that's useful to the authors.
>
>
> Have the authors considered including RFC2119 language in the answers to
> question 6 directing the operators of the arpa and in-addr.arpa zones to
> configure their name servers to answer for these special names? e.g.
> "Operators of the arpa zone MUST configure their servers to answer for
> ipv4only.arpa as defined in RFC7050." .. and a similar statement for the
> reverse lookups.
>
> Although I lean slightly in favour of including such text, I don't have a
> strong opinion either way. The draft indicates an expectation that the
> operators of arpa and in-addr.arpa will configure their servers as
> requested, but for completeness and strict conformance to 6761 it might be
> useful to be more explicit. On the other hand, the IAB statement in 7050
> § 8.3 could be read to be that directive.
>
--
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742 INTERNET: marka@isc.org
- [DNSOP] Review of draft-cheshire-sudn-ipv4only-do… Matthew Pounsett
- Re: [DNSOP] Review of draft-cheshire-sudn-ipv4onl… Mark Andrews
- Re: [DNSOP] Review of draft-cheshire-sudn-ipv4onl… Matthew Pounsett