[DNSOP]Re: Paul Wouters' Discuss on draft-ietf-dnsop-dnssec-bootstrapping-08: (with DISCUSS and COMMENT)
Paul Wouters <paul@nohats.ca> Fri, 17 May 2024 18:46 UTC
Return-Path: <paul@nohats.ca>
X-Original-To: dnsop@ietfa.amsl.com
Delivered-To: dnsop@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 6492CC14F682; Fri, 17 May 2024 11:46:09 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -6.43
X-Spam-Level:
X-Spam-Status: No, score=-6.43 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, RCVD_IN_DNSWL_HI=-5, RCVD_IN_ZEN_BLOCKED_OPENDNS=0.001, SPF_HELO_NONE=0.001, SPF_SOFTFAIL=0.665, URIBL_BLOCKED=0.001, URIBL_DBL_BLOCKED_OPENDNS=0.001, URIBL_ZEN_BLOCKED_OPENDNS=0.001] autolearn=ham autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (1024-bit key) header.d=nohats.ca
Received: from mail.ietf.org ([50.223.129.194]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 7s30VU3xCLfs; Fri, 17 May 2024 11:46:04 -0700 (PDT)
Received: from mx.nohats.ca (mx.nohats.ca [IPv6:2a03:6000:1004:1::85]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 859ECC14F5E8; Fri, 17 May 2024 11:46:02 -0700 (PDT)
Received: from localhost (localhost [IPv6:::1]) by mx.nohats.ca (Postfix) with ESMTP id 4Vgws35VKLzCtm; Fri, 17 May 2024 20:45:59 +0200 (CEST)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=nohats.ca; s=default; t=1715971559; bh=0ZCUzuZE7kGybFurOY+B4awk44y9lr9acZiRcoSRvMw=; h=Date:From:To:cc:Subject:In-Reply-To:References; b=scFtwEncZWsy96luM8VOClqun+Xb7y0ikV+FZ9YkikeXb7ShrK3MwiUdOkFm8QPFu 96jtLPtXuJsjsCWmL05RX8PVLT9yP6YHFt/GCl0HZ+Wru445gBpUfRoM9/YUn7QKmF qMBN891rcmG5aVAyyMjmk5Ab3iv21TguhvgFpF+M=
X-Virus-Scanned: amavisd-new at mx.nohats.ca
Received: from mx.nohats.ca ([IPv6:::1]) by localhost (mx.nohats.ca [IPv6:::1]) (amavisd-new, port 10024) with ESMTP id ugxKhfuv-1sH; Fri, 17 May 2024 20:45:58 +0200 (CEST)
Received: from bofh.nohats.ca (bofh.nohats.ca [193.110.157.194]) (using TLSv1.2 with cipher ADH-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by mx.nohats.ca (Postfix) with ESMTPS; Fri, 17 May 2024 20:45:58 +0200 (CEST)
Received: by bofh.nohats.ca (Postfix, from userid 1000) id 1212411F9BC8; Fri, 17 May 2024 14:45:57 -0400 (EDT)
Received: from localhost (localhost [127.0.0.1]) by bofh.nohats.ca (Postfix) with ESMTP id 0E4AD11F9BC7; Fri, 17 May 2024 14:45:57 -0400 (EDT)
Date: Fri, 17 May 2024 14:45:57 -0400
From: Paul Wouters <paul@nohats.ca>
To: Peter Thomassen <peter@desec.io>
In-Reply-To: <df0d36b9-596c-4419-8e03-0ba04465d896@desec.io>
Message-ID: <1b099313-2266-70c7-837b-9732f2ea9bfb@nohats.ca>
References: <171570741645.58676.5533506627285888134@ietfa.amsl.com> <b984d68a-f565-4178-b575-9fe2261a16a6@desec.io> <81868047-2b70-82d6-760b-7cb1cc898ff6@nohats.ca> <df0d36b9-596c-4419-8e03-0ba04465d896@desec.io>
MIME-Version: 1.0
Content-Type: text/plain; charset="US-ASCII"; format="flowed"
Message-ID-Hash: GN6OGKLA4G4QREBPYNIINNVLZSBWXIVA
X-Message-ID-Hash: GN6OGKLA4G4QREBPYNIINNVLZSBWXIVA
X-MailFrom: paul@nohats.ca
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-dnsop.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: Paul Wouters <paul.wouters@aiven.io>, The IESG <iesg@ietf.org>, draft-ietf-dnsop-dnssec-bootstrapping@ietf.org, dnsop-chairs@ietf.org, dnsop@ietf.org, tjw.ietf@gmail.com
X-Mailman-Version: 3.3.9rc4
Precedence: list
Subject: [DNSOP]Re: Paul Wouters' Discuss on draft-ietf-dnsop-dnssec-bootstrapping-08: (with DISCUSS and COMMENT)
List-Id: IETF DNSOP WG mailing list <dnsop.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/dnsop/v8zx6c2YwtqZrrgu9SnhyYl8OQ4>
List-Archive: <https://mailarchive.ietf.org/arch/browse/dnsop>
List-Help: <mailto:dnsop-request@ietf.org?subject=help>
List-Owner: <mailto:dnsop-owner@ietf.org>
List-Post: <mailto:dnsop@ietf.org>
List-Subscribe: <mailto:dnsop-join@ietf.org>
List-Unsubscribe: <mailto:dnsop-leave@ietf.org>
On Fri, 17 May 2024, Peter Thomassen wrote:
> Proposed text:
>
> # Abstract
>
> OLD
> This document deprecates the DS enrollment methods described in
> Section 3 of RFC 8078 in favor of Section 4 of this document, and
> also updates RFC 7344.
>
> NEW
> This document establishes the DS enrollment method described in
> Section 4 of this document as the preferred method over those from
> Section 3 of RFC 8078. It also updates RFC 7344.
Good for me.
> # Section 2
>
> OLD
> The DS enrollment methods described in Section 3 of [RFC8078] are
> deprecated and SHOULD NOT be used. Child DNS operators and parental
> agents who wish to use CDS/CDNSKEY records for initial DS enrollment
> SHOULD instead support the authentication protocol described in
> Section 4 of this document.
>
> NEW
> The DS enrollment methods described in Section 3 of [RFC8078] are
> less secure than the method described in Section 4 of this document.
> It is therefore RECOMMENDED that Child DNS operators and parental
> agents who wish to use CDS/CDNSKEY records for initial DS enrollment
> instead support the authentication protocol described here.
I would remove the word "instead", as it now doesnt deprecate it.
Otherwise okay.
>> So in that case, I think it would be more clear to rename "Signaling
>> domain" to "Signaling name".
>
> The authors agree with Joe's observations (in a "sibling post" to this
> message), and believe that "domain" is accurate.
Okay, since we have trouble coming up with a better name, let's keep it.
>>> I'm not sure. It's conceivable for a TLD operator to run DNS service for
>>> some of its child zones, and if I recall correctly, some of the smaller
>>> ccTLDs do. In this case, address records of nameservers operated under a
>>> child may be part of the TLD zone (along with the corresponding signaling
>>> names), so the signaling records' signer name is indeed the TLD.
>>
>> But then it is not a domain that can request DS records anyway
>
> That's a misconception; the zone that's authoritative for some the
> *nameserver name* (and, perhaps including the signaling stuff if there's no
> zone cut) is independent of the child that gets bootstrapped (which is often
> under a different parent). It is the latter where DS records are requested.
Ok, let's drop my proposal.
>> (eg like in .de)
>
> Not sure what you mean here; .de does delegations, and also publishes DS
> records. (They want the input to be DNSKEY-style, though, and compute DS
> themselves.)
.de allows direct entries for "simple" domains, eg MX plus "www", to be
hosted by them. It becomes part of the de. TLD itself. Not using
zonecuts at all. I thought that's what you were referring to.
> That adds significant complexity, to defend against a scenario that is simply
> "part of life" in the DNSSEC security model ("there is no way to defend
> against the parent").
We will leave it to dnssec transparency logging to find "deep signs"....
> I am very skeptical of adding mandatory implementation complexity to cover
> something that reaches beyond the DNSSEC security model. If OTOH it were
> optional, I have my doubts that parents would implement it.
Fair.
> Thus: Would it address your concern if we said that QNAME minimization is
> REQUIRED or RECOMMENDED for resolving signaling records? (Which of the two?)
Let's leave it out for now. Or if you want you can add it as
RECOMMENDED, but I think then you'd also need to talk a bunch about
starting from an empty cache and stuff, so I would leave it out
completely.
> OLD
> CDS/CDNSKEY records and corresponding signaling records MUST NOT be
> published without the zone owner's consent. Likewise, the child DNS
> operator MUST enable the zone owner to signal the desire to turn off
> DNSSEC by publication of the special-value CDS/CDNSKEY RRset
> specified in [RFC8078] Section 4. To facilitate transitions between
> DNS operators, child DNS operators SHOULD support the multi-signer
> protocols described in [RFC8901].
>
> NEW
> It is possible to add CDS/CDNSKEY records and corresponding signaling
> records to a zone without explicit knowledge of the domain owner. To
> spare domain owners from being caught off guard by state changes
> induced by this practice, Child DNS operators doing so are advised to
> make this transparent.
Maybe add: ", for example by notifying the domain owner via email".
> When transferring a zone to another DNS operator, the old and new
> child DNS operators need to cooperate to achieve a smooth transition,
> e.g., by using the multi-signer protocols described in [RFC8901]. If
> all else fails, the domain owner might have to request the removal of
> all DS records (e.g., by using the special-value CDS/CDNSKEY RRset
> specified in [RFC8078] Section 4) and have the transfer performed
> insecurely (see [I-D.hardaker-dnsop-intentionally-temporary-insec].)
If the current DNS hoster does not cooperate, It would not let you use CDS/CDNSKEY,
so I wouldn't mention 8078.
So I believe with this we addressed all concerns, and if a new draft is
published I will update by DISCUSS ballot to Yes.
Paul
- [DNSOP]Paul Wouters' Discuss on draft-ietf-dnsop-… Paul Wouters via Datatracker
- [DNSOP]Re: Paul Wouters' Discuss on draft-ietf-dn… Peter Thomassen
- [DNSOP]Re: Paul Wouters' Discuss on draft-ietf-dn… Peter Thomassen
- [DNSOP]Re: Paul Wouters' Discuss on draft-ietf-dn… Warren Kumari
- [DNSOP]Re: Paul Wouters' Discuss on draft-ietf-dn… Paul Wouters
- [DNSOP]Re: Paul Wouters' Discuss on draft-ietf-dn… jabley
- [DNSOP]Re: Paul Wouters' Discuss on draft-ietf-dn… Peter Thomassen
- [DNSOP]Re: Paul Wouters' Discuss on draft-ietf-dn… Peter Thomassen
- [DNSOP]Re: Paul Wouters' Discuss on draft-ietf-dn… Paul Wouters
- [DNSOP]Re: Paul Wouters' Discuss on draft-ietf-dn… Peter Thomassen
- [DNSOP]Re: Paul Wouters' Discuss on draft-ietf-dn… Peter Thomassen