[dnssd] Re: [DNSOP] dnssd request for Assignment in the Underscored and Globally Scoped DNS Node Names

Ted Lemon <mellon@fugue.com> Fri, 02 October 2026 18:15 UTC

Received: from fhigh-a2-smtp.messagingengine.com (fhigh-a2-smtp.messagingengine.com [103.168.172.153]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange x25519 server-signature ECDSA (prime256v1) server-digest SHA256) (No client certificate requested) by mx.ietf.org (Postfix) with ESMTPS id C9D2C42 for <dnssd@ietf.org>; Fri, 02 Oct 2026 18:15:49 +0000 (UTC)
Authentication-Results: mx.ietf.org; dkim=pass header.d=fugue.com header.s=fm3 header.b=RmgKcQKS; dkim=pass header.d=messagingengine.com header.s=fm1 header.b=iP3BInIi; spf=pass (mx.ietf.org: domain of mellon@fugue.com designates 103.168.172.153 as permitted sender) smtp.mailfrom=mellon@fugue.com; dmarc=pass (policy=none) header.from=fugue.com
Received: from phl-compute-01.internal (phl-compute-01.internal [10.202.2.41]) by mailfhigh.phl.internal (Postfix) with ESMTP id DE4EC140003A for <dnssd@ietf.org>; Fri, 2 Oct 2026 14:15:43 -0400 (EDT)
Received: from phl-frontend-04 ([10.202.2.163]) by phl-compute-01.internal (MEProxy); Fri, 02 Oct 2026 14:15:43 -0400
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=fugue.com; h=cc :cc:content-type:content-type:date:date:from:from:in-reply-to :in-reply-to:message-id:mime-version:references:reply-to:subject :subject:to:to; s=fm3; t=1790964943; x=1791051343; bh=Q4CitOyeXx 5myHmXztYphsyqpKusgOcbyYuAi3cISCk=; b=RmgKcQKSWma4A4yso5svvPtj4t dcsvQ1Mll9EOdFNom2fE5TDq1OApRYL7V7mpB9XVMChDj30t7Mb7fbdj+bvS1lQC tKXLewR1KcYTcC5BfRevBUCCpwS3YprOCKbRePIRNGyTgKwElZLen8MwCQ/ph2Qc CF9VwgzVLgUm+rYx3iwNf1jwz7dl4+OH+B/cZBT81Gecpc03nBv7sJZw7cfkLRDa V7rS5RuweQOe9bsqY386PY4rhcsZH8gLKO3KZq6kQYnkoNP4RzXqCbuG/P/lwcSO gD1Y5X1I0rUd28tjiowG0u/V95YSbc62CQ0nMhLHFZTERBMNPc/Z4v5hrdPg==
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d= messagingengine.com; h=cc:cc:content-type:content-type:date:date :feedback-id:feedback-id:from:from:in-reply-to:in-reply-to :message-id:mime-version:references:reply-to:subject:subject:to :to:x-me-proxy:x-me-sender:x-me-sender:x-sasl-enc; s=fm1; t= 1790964943; x=1791051343; bh=Q4CitOyeXx5myHmXztYphsyqpKusgOcbyYu Ai3cISCk=; b=iP3BInIiZSZeSR6EFB3FP1+5ImnmIVSgpaxM+SXTwn0HpsIIKxQ 0OacCKtBLAQY4yNaD/x6ti9LcKzOLXiCAWpdQebB66vaH5TKYItpJw16kp3Bw7ec 3W3uCKrOSOPIDnIam7QXVKFw+pY5TjEI2MAWMDM036wT1WTwtteZgprZbXnxrFSX Iuuum/x1eWnEcxQrp698klpZQxsv8wTubzSD/kyBh8e+RAbw+m6eDHM2I68lpPlE FmG0gOVv6C2mdwUEGf1OQ9vVfnM4k04Uj6Bh7QCIl0+jsJ/8Zpz/OmiPQY1PwI+d FUccObCzi9gm6+fJLaqTGvdUhSkhi5xY6eA==
X-DKIM2-Info: draft=ietf-dkim-dkim2-spec-06; repo=github.com/dkim2wg/interop; date=2026-09-30; sw=lmtpprox; action=sign d=fugue.com a=rsa-sha256;
DKIM2-Signature: i=1; m=1; t=1790964943; d=fugue.com; mf=PG1lbGxvbkBmdWd1ZS5jb20+; rt=PGRuc3NkQGlldGYub3JnPg==; s=fm3:rsa-sha256:IxSL96r0W4gTOrxMU6fIneR2Ps39qfFHKm7yVq7dx9gmjuG EmHOJlbQKZl+EV4D4ZBYJ5/fpkGVMMO+ma/Lt+k3TeT9FD/i4TO/11E1RC0obyQZ OaQQTk3rXTF6k6l/MsNdyJcIy9LCjLqy7hE+HrwbNNK7NV2k2wX83Yl779cigK1G kkZ19N4KhA2ui5NvHiMgDsLvN3kNYIYF4Y7Vprr07G9T858EsTLSXc2G5urRFKr1 afwlh8bk/LldhJQD2/tsFY3k0oKbudhXZBuXWgdEyZ9D0GXfOJgNquyAe+5fkiM5 vQdpJ5siV+udA7/0ayO4AudcWWrZuyuuZJHQykw==;
X-DKIM2-Info: draft=ietf-dkim-dkim2-spec-06; repo=github.com/dkim2wg/interop; date=2026-09-30; sw=lmtpprox; action=mi-m=1; hc=11; hn=cc,content-type,date,feedback-id,from,in-reply-to,message-id, mime-version,references,subject,to;
Message-Instance: m=1; h=sha256:5mQRo2+ssdbk8zv2HuRq+4podwIWG1VDmMgZThq7AJE=:QXsF3blmY1qhrIQsZkD1kx0o6KAU8Lw2U/MCOH2fodk=;
X-ME-Sender: <xms:z_S_akenvAaRlwkOX5zTXqfnCeFAxPTi3cw6SjmH6OCE7oQZpDJFYA> <xme:z_S_atr64tXUERng8os20COk8L6ZmvyU4jNIeoXZ-fA584LDmFzkRSgpZh5i4xRwX MhxaJHHfu0sxjJSQJHLIsHnYOsWn5l5ZNNXnH4OJwzgn1Z-P2BKlNlZ>
X-ME-Received: <xmr:z_S_ai6zeoCdP_A3j-8aH5bdpRLl4E28BEI61phvigZ5UoKCJ4_31rH5XmOBu7kujoWDv65AGeu1b5dwzENSRlIuHUTWZ76QeJehUdkR>
X-ME-Proxy-Cause: dmFkZTGaBiKINaI5mH9iJHTjG02K2W/VmEFJ3LX6pmckb3fuyw4rH+3vTJqwvbLZ9GCb8x j8QMfroAapxhqYmaxdsuKAFcKJZAkAkRYA50l6Sf8efhtr5WdWhepxnm4RY3/+0noRvJVJ uwFR8+4t8f5qz6mTwCCHFE4/I4Zr8qGIUhaFzheEWi16K9DChAagBqq1DgEcyIqKeSse8T 8Pt0yxz2t/rDph2y+UZueLer5MNot0619XpUqV6Zj04QG6LF/cDuM6QRdCoVtfmfr3KOE1 FzWAlUVABPrQHsLL1oYu6sRU0dnCFzNQ1MrWvPQXqb8tvtIeol29xt9U+DTr2CHFgkMiNv 91BHWktefC4O/i49/0wei5V4hATxp/DkRpBJCGxOxK43ihz1kB5KuD5nTFHR+dc4HyLDrf DEecfUKAe75eD2btzN5B5HSHe9saUQkXeVoa/moDRAKr58tEwmM2vB9elsIT+p0XrfcyTL fCKt5EwR0lSnLzUJpj9REYc1szB6OoE/rQ46Qu9oeYiHob27a6oJoMbcObOpWzJ4W7i8iE eWwSgtu42adtjo+7VzG4NOZ8iw8VQX51dsp17XgFK/yLmf+el81mn0CBipT4FkAvIxHoom bwdtQH6Tu4ulkR3ezHyonHXKyMoNkQ2OXR3Yg7PMa0sr+JRYNetB2ywtKppw
X-ME-Proxy: <xmx:z_S_ajoibOwVPvigfRDAgHSh7PyyhUUlMJWpe8RDmEINbomn-26JPQ> <xmx:z_S_akgqpBRUv0w9mvfUH52iAGpwarze7cPczZ30DEA-fxIstF3vyw> <xmx:z_S_atIx1Lw2wHQQTr_ZMCrWRM-f33lUM87jT5tsdWliMRiyrsC4IA> <xmx:z_S_akDshoL4qSElDGpyGA0hP1aFFFq5Jj2gc6INuoCbK1WzA21cwA> <xmx:z_S_age6yaq_4-6TwWGQFG4LUDRlFmyY3Avf6uJ3GrsH-gOoyww3dH1M>
Feedback-ID: i1136489e:Fastmail
Received: by mail.messagingengine.com (Postfix) with ESMTPA; Fri, 2 Oct 2026 14:15:43 -0400 (EDT)
From: Ted Lemon <mellon@fugue.com>
Message-Id: <0CF2B149-3BE7-4955-9550-8A38B6F6F302@fugue.com>
Content-Type: multipart/alternative; boundary="Apple-Mail=_A8D329A6-936E-4406-A04F-9C6CC3B38412"
Mime-Version: 1.0 (Mac OS X Mail 16.0 \(3901.200.66\))
Date: Fri, 02 Oct 2026 20:15:30 +0200
In-Reply-To: <126b2251-76cf-fda4-ad03-28bb71872325@nohats.ca>
To: Paul Wouters <paul@nohats.ca>
References: <126b2251-76cf-fda4-ad03-28bb71872325@nohats.ca>
X-Mailer: Apple Mail (2.3901.200.66)
X-Spamd-Bar: -
Message-ID-Hash: 43VAAE4FSXK2YQ42M4FUHVXFY7NTZBP4
X-Message-ID-Hash: 43VAAE4FSXK2YQ42M4FUHVXFY7NTZBP4
X-MailFrom: mellon@fugue.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; loop; banned-address; header-match-dnssd.ietf.org-0; header-match-dnssd.ietf.org-1; emergency; member-moderation; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: dnssd@ietf.org, dnsop <dnsop@ietf.org>
X-Mailman-Version: 3.3.10
Precedence: list
Subject: [dnssd] Re: [DNSOP] dnssd request for Assignment in the Underscored and Globally Scoped DNS Node Names
List-Id: "Discussion of extensions to DNS-based service discovery for routed networks." <dnssd.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/dnssd/3dW66mHIMA9udd7f8YWVAS9vAAI>
List-Archive: <https://mailarchive.ietf.org/arch/browse/dnssd>
List-Help: <mailto:dnssd-request@ietf.org?subject=help>
List-Owner: <mailto:dnssd-owner@ietf.org>
List-Post: <mailto:dnssd@ietf.org>
List-Subscribe: <mailto:dnssd-join@ietf.org>
List-Unsubscribe: <mailto:dnssd-leave@ietf.org>

No, the expectation is that DNSSD works both with DNS and mDNS, and hence with domains other than .local. You can see this e.g. in RFC9665, which provides a way to deliver automatic DNS-SD within arbitrary DNS zones. RFC6763 specifically recommends RFC6335 as the source for how to register service types.

Bear in mind that although the content of RFC6762 and RFC6763 were finished around the year 2000 (plus or minus), they took a long time to get through the IETF publication process, and as a result, it was necessary to provide alternative resources until that happened. I believe that's what the www.dns-sd.org/servicetypes <https://www.dns-sd.org/servicetypes> page is about.

> On 2 Oct 2026, at 19:43, Paul Wouters <paul=40nohats.ca@dmarc.ietf.org> wrote:
> 
> 
> Dear DNS and DNS-SD experts :)
> 
> The Designated Experts for the Underscored and Globally Scoped DNS Node
> Names IANA Registry (RFC 8552) received a request to register a new
> entry to be used with DNS-SD. See:
> 
> https://www.iana.org/assignments/dns-parameters#underscored-globally-scoped-dns-node-names
> https://www.rfc-editor.org/info/rfc8552/
> 
> 
> The question is, I believe that all DNS-SD entries are under a
> parental underscore domain that is not global (eg _xmpp._tcp.local or
> _printer._udp.local). As such, I believe entries meant for DNS-SD
> are unrelated to the Underscored and Globally Scoped DNS Node
> Names IANA Registry and should not (need not?) be registered there.
> 
> Or if phrased differently, you wouldn't put DNS-SD entries in your
> public forward DNS zone that is hosted on the internet.
> 
> That said, there is obviously the possibility of DNS-SD names clashing
> too, despite not being a globally scoped dns node name. But perhaps
> the Service Name and Transport Protocol Port Number Registry
> https://www.iana.org/assignments/service-names-port-numbers?search=dns
> would be a better fit for such a registration ?
> 
> I also found https://www.dns-sd.org/servicetypes.html but it seems to
> be closed in favour of the service-name one.
> 
> I am interested in hearing people's view on this.
> 
> Paul
> _______________________________________________
> DNSOP mailing list -- dnsop@ietf.org
> To unsubscribe send an email to dnsop-leave@ietf.org