[Ediint] Re: Structure of an Internet EDI MIME Message

Erik Wramner <erik@wramnerconsulting.se> Wed, 23 September 2026 17:53 UTC

Received: from GV3P280CU013.outbound.protection.outlook.com (mail-swedencentralazlp170100001.outbound.protection.outlook.com [IPv6:2a01:111:f403:c202::1]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange secp256r1 server-signature ECDSA (prime256v1) server-digest SHA256) (No client certificate requested) by mx.ietf.org (Postfix) with ESMTPS id A562A30 for <ediint@ietf.org>; Wed, 23 Sep 2026 17:53:26 +0000 (UTC)
Authentication-Results: mx.ietf.org; dkim=none; arc=pass ("microsoft.com:s=arcselector10001:i=1"); dmarc=none; spf=pass (mx.ietf.org: domain of erik@wramnerconsulting.se designates 2a01:111:f403:c202::1 as permitted sender) smtp.mailfrom=erik@wramnerconsulting.se
ARC-Seal: i=1; a=rsa-sha256; s=arcselector10001; d=microsoft.com; cv=none; b=WeIYqg0gjSwqSbXcxn3Pf2U0+UuLvHp1IBv7Fkri0IIwUCPiuNKp2NJfaHIpddfdZwo3SvMayPrN7Orm8WD/owW9GDVmehzL0W/H1SiUp+dz8gRxeQUopcEG+TOyMSRDk9NB2E1xdnL3u+XmbzaPmuO5UZUPYMO/Aha/5PoRCBvKxAngd2hRucHgjwn0QVEgJ5RgYueVg+MWVSlzJxK08n7Rv+/fpEssa8F94s/dky9WFxZ0nwgKJTru7ztchmg5rAOIP5FiNPz/oPVF1RNojBfdU3Tl7WDlJz2g1wCBkf1xYpvko81jPvQ10ReFKnZ6wVGoa2QtZH7sLqPilkHQBg==
ARC-Message-Signature: i=1; a=rsa-sha256; c=relaxed/relaxed; d=microsoft.com; s=arcselector10001; h=From:Date:Subject:Message-ID:Content-Type:MIME-Version:X-MS-Exchange-AntiSpam-MessageData-ChunkCount:X-MS-Exchange-AntiSpam-MessageData-0:X-MS-Exchange-AntiSpam-MessageData-1; bh=5IyA0352L4955Ev1s7IFsToeb+zcHeY2jtQmYzwQjPI=; b=QT4C+NIkpJaCacvfdy8YQbHjJ8xZSK7pVfk1oRK/OHZwV0jJTXuDnjO98k6s5Wtml5C36oyNKV3js+kFgNQw2RAAvL+vENDNjAf3e00vyvGuBDYWMHVAhlb65TJJ8xDlk1NLJogcSDKzuD5z21mHApn5/paV5ovApvAQCD6zFXlgwybQ9Dae+BFX8czex8UoAa8P54pOPO9ihi/xcJeArDHj4AhgUsdPJWrGFoRDc2ZO8R+SgOQvVEp4+bdDjNzOQDOot2cd7OQSfEji5p/IDdxj2/XEZxI9ElaHIB4AxuIuOa7DWsOU+j5h/6PTXsjxUaCF6S5QJMB0sLb8cS2mQQ==
ARC-Authentication-Results: i=1; mx.microsoft.com 1; spf=pass smtp.mailfrom=wramnerconsulting.se; dmarc=pass action=none header.from=wramnerconsulting.se; dkim=pass header.d=wramnerconsulting.se; arc=none
Received: from GV3P280MB1286.SWEP280.PROD.OUTLOOK.COM (2603:10a6:150:182::11) by MM0P280MB0215.SWEP280.PROD.OUTLOOK.COM (2603:10a6:190:e::8) with Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) id 15.21.451.17; Wed, 23 Sep 2026 17:53:20 +0000
Received: from GV3P280MB1286.SWEP280.PROD.OUTLOOK.COM ([fe80::33b2:d8bb:91a0:f889]) by GV3P280MB1286.SWEP280.PROD.OUTLOOK.COM ([fe80::33b2:d8bb:91a0:f889%5]) with mapi id 15.21.0451.014; Wed, 23 Sep 2026 17:53:19 +0000
From: Erik Wramner <erik@wramnerconsulting.se>
To: Debra Petta <debrap=40drummondgroup.com@dmarc.ietf.org>, Marc Blanchet <marc.blanchet@viagenie.ca>
Thread-Topic: [Ediint] Re: Structure of an Internet EDI MIME Message
Thread-Index: AQHdS3kZWf1HlpBLG0qI/VnUvn6AT7bcYDGAgAALXgCAAAJ0QA==
Date: Wed, 23 Sep 2026 17:53:19 +0000
Message-ID: <GV3P280MB12864AE4C8B3F7AE7E9D14D0BB822@GV3P280MB1286.SWEP280.PROD.OUTLOOK.COM>
References: <GV3P280MB12869D4AC2B73EDF50DA4D97BB832@GV3P280MB1286.SWEP280.PROD.OUTLOOK.COM> <DM4PR11MB6408261B4522F842B285BBF9CC832@DM4PR11MB6408.namprd11.prod.outlook.com> <GV3P280MB128654751637407E61611D44BB832@GV3P280MB1286.SWEP280.PROD.OUTLOOK.COM> <DM4PR11MB640837C6342E34415098AAEACC832@DM4PR11MB6408.namprd11.prod.outlook.com> <VI0P189MB2767E79AE4CAD0D33BC2EA25BE822@VI0P189MB2767.EURP189.PROD.OUTLOOK.COM> <GV3P280MB12862966CEE5FD38293C4748BB822@GV3P280MB1286.SWEP280.PROD.OUTLOOK.COM> <VI0P189MB2767E26EC9FA653572F58333BE822@VI0P189MB2767.EURP189.PROD.OUTLOOK.COM> <GV3P280MB12860721E6B8E3EDBA02BE8CBB822@GV3P280MB1286.SWEP280.PROD.OUTLOOK.COM> <6458B8B9-3993-465E-9FA3-CC043CD2D056@vigilsec.com> <GV3P280MB1286A19A8002BDD853FE2A90BB822@GV3P280MB1286.SWEP280.PROD.OUTLOOK.COM> <DM4PR11MB640875724989A7F3B04D9A20CC822@DM4PR11MB6408.namprd11.prod.outlook.com> <84B79A53-0A58-4502-9F53-69F5084697A5@viagenie.ca> <DM4PR11MB64081BB550B416539BCE50AACC822@DM4PR11MB6408.namprd11.prod.outlook.com>
In-Reply-To: <DM4PR11MB64081BB550B416539BCE50AACC822@DM4PR11MB6408.namprd11.prod.outlook.com>
Accept-Language: en-US
Content-Language: en-US
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
x-ms-publictraffictype: Email
x-ms-traffictypediagnostic: GV3P280MB1286:EE_|MM0P280MB0215:EE_
x-ms-office365-filtering-correlation-id: 86ae89cd-9dde-4d76-677a-08df199b8d65
x-ms-exchange-senderadcheck: 1
x-ms-exchange-antispam-relay: 0
x-microsoft-antispam: BCL:0;ARA:13230040|23010399003|4022899009|366016|1800799024|376014|5023799004|56012099006|3023799007|38070700021|4143699003|22082099003|18002099003|7055299009|10067099003;
x-microsoft-antispam-message-info: YcoLF7rSy5+grXbUI4hE07uP48zaG2L6y1Yo2CYAkCvsS2h02xH2hGVVYuxudstCOnesJoOadPudOCzJZ0wiAwOBZYf3yJbG9h4MsFLp4/RtXzfz3ArmBC3P+vrfS6144ektetrAjm0sVOv1CeH90aQo8dL/66EMQkl2rDdGOuGVDRts2DmuNgafAQCMlqsD9vaXrZ8yh8OMA7UbHqgoo+O94TrS52oIueEFxKXx287Rb3ws+RmdUf1/o2Blhqc0ZwDTZDNpJ8I0ntZiK9yE+lgVPHolSJI/gn1d8UvgWJaMMxm7k8u0/16BIR6L/lkY2sqtqRgStD0jcVXN6EO2FDTm3gH4y+Ndws/WqMA6mcrE143dsIySmjWakxdXAthTQhTWI4iQ4+r2kSE8njQXzqW7DTKuCPT8BlcTRfFjTRVMti4kLdmwWhrcKywRVIKdwtFNnXj1qb1wnIPG3+UGazM9adBTkA1sshfcKYKqoj10MZQoE4OjqjvwrCVNTGImVW0R2HqPwx91/fo9ZGus4OWncouGMDsOWdMwx/yuuUi68zey7uirFKvYJhU6V0GHolgWmacTDXbQGcZMtb4KqHlLOlNxAbU6kIJ8GkPFe6NRYD0nJxG+pJt8piXt2ubmRh6OKK3WI18qX7RNiHbSBksqX7wfv6bidhxMxf4Y2knX5PUp+ihhzJqfzlH1wVN0wgwRTIV3QYpRRZS7hjh0GWB7CFOHjw6gFsAoahRbtP0q3tGhSm0lozhhZWp8GyMl
x-forefront-antispam-report: CIP:255.255.255.255;CTRY:;LANG:en;SCL:1;SRV:;IPV:NLI;SFV:NSPM;H:GV3P280MB1286.SWEP280.PROD.OUTLOOK.COM;PTR:;CAT:NONE;SFS:(13230040)(23010399003)(4022899009)(366016)(1800799024)(376014)(5023799004)(56012099006)(3023799007)(38070700021)(4143699003)(22082099003)(18002099003)(7055299009)(10067099003);DIR:OUT;SFP:1102;
x-ms-exchange-antispam-messagedata-chunkcount: 1
x-ms-exchange-antispam-messagedata-0: xsDtSjgTz+8QzrBJSUjjRfCegBG60C0XQpCb4+o8xyg7qKaHMJa2dV5ocIgcR5CDAhQ5OQ6iE728MufliLVFq2J0LCCrcMjM/bTPxlMROTO60dm+nDfaJhBRx/gSFNcAu2JO9KA8si3SO3QaauWtj93u9Hq9WqvjonOUrmRNExiWflJb/I4ExgsxMW+R7IBBwZF1ffBsOrWvUwQWR2kd4X6mtsO12OAQsLAO9TP1Wt5OUnucLBcT5iz4bwbC0pwtqJn9eOieROpyzjQpFGZEvEIeVLL/2cOLj6EkMp+J8xqUHK3iAA+8ykLxSx8xx6pRVW733udUQQEnNq+RnJmNT3I9msvAnlfdMf8EGJo9/lAHIVauCgTYibVADk2M7rzhCHevRoMbuTsaQnKU7OHavaNjGw/+x1PyEb6Q3sAwu/CJiXX85oRjH8UftKmCMbnCuyoQsmVG6X3H1E3aovkmITMV64LRDAjmtjs0tCNwGCA9oHJdUNIeC2/Ua9i+T/VuNo3Fpr35vFJGYuuBizQsE3UHzGLcugs5ZAqyPWsyAYexm10dqs5zzsnovj8IamkiWx/YdGqWZRMRrfS/jeP+AFamjuwr1EfOrQ/3uE4UITdZdFm+J9U8X2TBAVc7ZI0ZjfhLPFTTWkR3XvBPCTJgBi9jgYXcKG5zlp4fd/4Y6jCgcwLxJfktAK0w8ck1cy3nMdftT+Ta0aA0kH/62rzYsUX14I0Sn9CvP+sDAvL+UiHMY0SzK2VT6wj2YY4Jp5HgDcD809W9IBEjIQw7OvcdUgkqeT2xCCycsY9AsAqDdOrBt7YbaGGM+OpLA+qgxYDUlqqWkOkm44TDLjw85IB61SRAdMoqIZhRqxcHcPHNbF4RvoF9w/1UxlpIdfYBsxESXP+rz8IZ/g6Ng/VHnms6sn0kPekvXRXv9LC1CyxcUTwgK52tg2S5kOFoSzkOvJLVdSr3fh/UgXNbA4YaIGFlvjagBtYg/klqjBNFDhbFiTCsktp+Mr58s12MFFLfc5c6vPJwGbDO+qa3nl7A3qr7rgDO+KdBc9zr49erSyBeGuWiXUL8uJbkE5pYF9oFZYDEeRQelM7wrVGGT1xVGwjqxYKSVJcXbXVeXEaY9y5AyDab2Aequi2zqjDQGJwfidokxKbLngXwG6aiivlsUeqE83Oqk8gRGF5SSRxfAmp7cZ7zoWruR+dQgv5djsOVDiMFSVMwUw7md1mk6MSjfLsPVDnvkKKPXwcMRy/W2MkIBtHEQuWJcvJ7s2u7ONuN1kOtTesE7N6q/X00K7VzY1/E6m4CTB7HwdS/YHU2otmbQGnY93m3G3XkFW4V1C+4Lxv3UEEB/ETOgnhYYG8BjpPiYi1uX0/4YUdBDWoHGDxEcr4/74xEBDgfvHW4u9FIMPd3lsCP/qx/Dfxt2/J54GuHhfy5mWGUTrWo2WMyNDYimbAE6mx9BB/T6kfLdSetsMsVbcunIsC4lOulNHYzRIMBp8vw728yxr/mvQ+GIY34p55gtpeGx37VwaWRsHdr6hNi+iyiwme064m5sOHQ/aXpdvAS/o2EATXVjj8aurrjpROMaBnk3Gltq7gdunvgU+QJ7XeJybGEULL6bk2wN97iuHHJGoJvuJ/7dQq25tN6DfF9Xouzr/gCk89O3ZeWJyh485LTJzMI2SsoIqv5cA2d/sSCsZ+jkzvSpR+fIvrzYf5nhmcwpHcdQon4hTxf4woBa10TBcixhTC6YH+37a7++A==
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: base64
MIME-Version: 1.0
X-OriginatorOrg: wramnerconsulting.se
X-MS-Exchange-CrossTenant-AuthAs: Internal
X-MS-Exchange-CrossTenant-AuthSource: GV3P280MB1286.SWEP280.PROD.OUTLOOK.COM
X-MS-Exchange-CrossTenant-Network-Message-Id: 86ae89cd-9dde-4d76-677a-08df199b8d65
X-MS-Exchange-CrossTenant-originalarrivaltime: 23 Sep 2026 17:53:19.2606 (UTC)
X-MS-Exchange-CrossTenant-fromentityheader: Hosted
X-MS-Exchange-CrossTenant-id: 106c7338-c556-489d-b52a-e87a9f3fb98e
X-MS-Exchange-CrossTenant-mailboxtype: HOSTED
X-MS-Exchange-CrossTenant-userprincipalname: A4xwfIHXSv/qHUNzHbMtlnXoS+OQ1KBb7wgOxKv80j7to5QihB3ZC4t5azy2GpNXlXXGKzqVpOMGD8knQ0ZWd/wAPOo4B18MpZ2+KxwDU4Q=
X-MS-Exchange-Transport-CrossTenantHeadersStamped: MM0P280MB0215
X-Spamd-Bar: -
Message-ID-Hash: JJYHKEX2IONP7KK5VXMJHZACD5BOQLUV
X-Message-ID-Hash: JJYHKEX2IONP7KK5VXMJHZACD5BOQLUV
X-MailFrom: erik@wramnerconsulting.se
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; loop; banned-address; emergency; member-moderation; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: "ediint@ietf.org" <ediint@ietf.org>
X-Mailman-Version: 3.3.10
Precedence: list
Subject: [Ediint] Re: Structure of an Internet EDI MIME Message
List-Id: "Electronic Data Interchange-Internet Integration: Discussions related to modernizing RFC 4130, which defines the AS2 (Applicability Statement 2) messaging standard" <ediint.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/ediint/fkesnDSNmwJTvK-nS66GQMRUPl8>
List-Archive: <https://mailarchive.ietf.org/arch/browse/ediint>
List-Help: <mailto:ediint-request@ietf.org?subject=help>
List-Owner: <mailto:ediint-owner@ietf.org>
List-Post: <mailto:ediint@ietf.org>
List-Subscribe: <mailto:ediint-join@ietf.org>
List-Unsubscribe: <mailto:ediint-leave@ietf.org>

Regarding 4K video MIME types, we have customers using them - a lot. We do support all MIME types except the ones that conflict with AS/2 itself. As we are supposed to deliver the content byte-by-byte exactly as it was received, this is not a problem. I'd like to keep the sentence.

However, I wanted to remove all the "optional RFC3274 (CompressedData)" parts and instead create examples with and without for clarity. I can do the editing if you like, Debra?

I'm still in favor of keeping both compression alternatives and I don't agree on the conclusion. I think the example demonstrated that compressing the signed data (with base64-encoded signature which is what almost everyone is using) actually does produce a smaller message than compressing the content and having the base64 data uncompressed. Furthermore, that example did not include the HTTP headers inside the MIME parts. They compress quite well, so compressing the signed data gets even better. This is not super important, but I think we should keep it as it is. Existing products already support this, and new products will have to do it to handle older AS/2 versions anyway. Having a new AS/2 product that is not able to communicate with old servers would be unacceptable in my book. We can write that new products SHOULD compress the innermost part (content) when sending, but that they MUST handle any order on receive.

-Erik

-----Original Message-----
From: Debra Petta <debrap=40drummondgroup.com@dmarc.ietf.org> 
Sent: Wednesday, 23 September 2026 19:31
To: Marc Blanchet <marc.blanchet@viagenie.ca>; Debra Petta <debrap=40drummondgroup.com@dmarc.ietf.org>
Cc: ediint@ietf.org
Subject: [Ediint] Re: Structure of an Internet EDI MIME Message

Marc, 

I understand your point; however, I would like the rest of the implementors to weigh in before we pull out pieces that may still be needed.
I'd like to review the recording of our interim meeting so I can make notes of what we agreed to.  Is that available somewhere?

Regarding 4K video MIME types, if a vendor has a business need for sending it, there is no reason why AS2 should not support it -- just my opinion.

-Debra

-----Original Message-----
From: Marc Blanchet <marc.blanchet@viagenie.ca>
Sent: Wednesday, September 23, 2026 11:50 AM
To: Debra Petta <debrap=40drummondgroup.com@dmarc.ietf.org>
Cc: ediint@ietf.org
Subject: [Ediint] Re: Structure of an Internet EDI MIME Message

Some notes below.

> Le 23 sept. 2026 à 12:32, Debra Petta <debrap=40drummondgroup.com@dmarc.ietf.org> a écrit :
> 
> Based on all the comments so far, I reworked the content of the entire section (below). 
> The key notes section shows the required and optional content types.
>  Let me know if this is what you had in mind and if more changes are needed before I post a new copy of the draft.
> Also, are the RFCs in this section the correct/latest ones for the modern specification?
>  -Debra
>   4.2.  Structure of an Internet EDI MIME Message
>        No encryption, no signature, no compression
>          - RFC2616/2045 (HTTP/MIME)
>            - RFC1767/RFC3023 (payload content)
>        No encryption, signature, no compression
>          - RFC2616/2045 (HTTP/MIME)
>            - RFC1847 (multipart/signed)
>              - RFC1767/RFC3023 (payload content)
>              - RFC5751 (application/pkcs7-signature)
>        Encryption, no signature, no compression
>          - RFC2616/2045 (HTTP/MIME)
>            - RFC5751 (application/pkcs7-mime) (everything below inside this part is encrypted)
>              - RFC1767/RFC3023  (payload content)
>        Encryption, signature, no compression
>          - RFC2616/2045 (HTTP/MIME)
>            - RFC5751 (application/pkcs7-mime) (everything below inside this part is encrypted)
>              - RFC1847 (multipart/signed)
>                - RFC1767/RFC3023  (payload content)
>                - RFC5751 (application/pkcs7-signature)
>        No encryption, no signature (with optional compression)
>          - RFC2616/2045 (HTTP/MIME)
>            - [optional RFC3274 (CompressedData) (everything below inside this part is compressed)]
>              - RFC1767/RFC3023 (payload content)
>        No encryption, signature (with optional compression before signing)
>          - RFC2616/2045 (HTTP/MIME)
>            - [optional RFC3274 (CompressedData) (everything below inside this part is compressed)]
>              - RFC1847 (multipart/signed)
>                  - RFC1767/RFC3023 (payload content)
>                  - RFC5751 (application/pkcs7-signature)
>        No encryption, signature (with optional compression after signing)
>          - RFC2616/2045 (HTTP/MIME)
>            - RFC1847 (multipart/signed)
>              - [optional RFC3274 (CompressedData) (everything below inside this part is compressed)]
>                - RFC1767/RFC3023 (payload content)
>                - RFC5751 (application/pkcs7-signature)
>        Encryption, no signature (with optional compression)
>           - RFC2616/2045 (HTTP/MIME)
>             - RFC5751 (application/pkcs7-mime) (everything below inside this part is encrypted)
>               - [optional RFC3274 (CompressedData) (everything below inside this part is compressed)]
>                 - RFC1767/RFC3023 (payload content)
>        Encryption, signature (with optional compression before signing)
>          - RFC2616/2045 (HTTP/MIME)
>            - RFC5751 (application/pkcs7-mime) (everything below inside this part is encrypted)
>              - [optional RFC3274 (CompressedData) (everything below inside this part is compressed)]
>                - RFC1847 (multipart/signed)
>                  - RFC1767/RFC3023 (payload content)
>                  - RFC5751 (application/pkcs7-signature)
>        Encryption, signature (with optional compression after signing)
>          - RFC2616/2045 (HTTP/MIME)
>            - RFC5751 (application/pkcs7-mime) (everything below inside this part is encrypted)
>              - RFC1847 (multipart/signed)
>                - [optional RFC3274 (CompressedData) (everything below inside this part is compressed)]
>                - RFC1767/RFC3023 (payload content)
>                - RFC5751 (application/pkcs7-signature)
>        MDN over HTTP, no signature
>          - RFC2616/2045 (HTTP/MIME)
>            - RFC3798 (message/disposition-notification)
>        MDN over HTTP, signature
>          - RFC2616/2045 (HTTP/MIME)
>            - RFC1847 (multipart/signed)
>             - RFC3798 (message/disposition-notification)
>             - RFC5751 (application/pkcs7-signature)
>     *Key Notes*
>       o  RFC 3274 (CompressedData) is the normative reference for compression.
>       o  Compression MAY be combined with signing and/or encryption in either order,
>         but the choice affects what the digital signature covers.
>       o  Many implementations compress before signing and encrypting to maximize size
>         reduction, but compression after signing and before encrypting MUST also be supported.

Well, given that we are talking of a new protocol, therefore a new implementation (that may share code with AS2v1), I would suggest to restrict to only compression before signing and encryption. It makes implementations simpler, easier to test, less error-prone, less config panels, ... therefore costs less. Too many alternatives are often not useful. And as we have discussed, people may have used it (compression after signing/encrypt) in the past without really knowing that it may not be as good as the alternative.


>       o  Although all MIME content types SHOULD be supported, the following
>         MIME content types MUST be supported:

"Although all MIME content types SHOULD be supported": as written, this is impossible, not realistic and essentially dangerous. Do we want to support 4K Video MIME-types?

Suggest to drop that part of the sentence.

Marc.


>              Content-type: multipart/signed
>             Content-Type: multipart/report
>             Content-type: message/disposition-notification
>             Content-Type: application/PKCS7-signature
>             Content-Type: application/PKCS7-mime
>       o  Implementations SHOULD support the following content types based on
>         intended use:
>              Content-Type: application/EDI-X12 (for ANSI X12 EDI)
>             Content-Type: application/EDIFACT (for UN/EDIFACT EDI)
>             Content-Type: application/edi-consent
>             Content-Type: application/XML (for XML-based structured data)
>   From: Erik Wramner <erik@wramnerconsulting.se>
> Sent: Wednesday, September 23, 2026 9:55 AM
> To: Russ Housley <housley@vigilsec.com>
> Cc: Asger Smidt <asm@bizbrains.com>; ediint@ietf.org
> Subject: [Ediint] Re: Structure of an Internet EDI MIME Message 
> Agreed, but at the same time we don’t have to list all the supported content types everywhere. So:
>  RFC1767/RFC3023 (application/EDIxxxx or /xml)  Can either be left as 
> it is or we could replace it with:
>  RFC1767/RFC3023 (content, for example application/xml)  -Erik
>  From: Russ Housley <housley@vigilsec.com>
> Sent: Wednesday, 23 September 2026 16:41
> To: Erik Wramner <erik@wramnerconsulting.se>
> Cc: Asger Smidt <asm@bizbrains.com>; ediint@ietf.org
> Subject: Re: [Ediint] Structure of an Internet EDI MIME Message  I 
> think it is useful to list the MIME content types that MUST be supported, and the say other MIME content type MAY also be supported.  New MIME content types are registered all the time, so it is not practical to support all of them.
>  Russ
>   On Sep 23, 2026, at 6:28 AM, Erik Wramner <erik@wramnerconsulting.se> wrote:
>  Our product supports any data as content. The old specification required support for a few specific types, quote:
>  --
> Although all MIME content types SHOULD be supported, the following MIME content types MUST be supported:
>  Content-type: multipart/signed
> Content-Type: multipart/report
> Content-type: message/disposition-notification
> Content-Type: application/PKCS7-signature
> Content-Type: application/PKCS7-mime
> Content-Type: application/EDI-X12
> Content-Type: application/EDIFACT
> Content-Type: application/edi-consent
> Content-Type: application/XML
> --
>  So, the content type in the example refers to these. We could just write “content” instead.
>  -Erik
>  From: Asger Smidt <asm@bizbrains.com>
> Sent: Wednesday, 23 September 2026 11:32
> To: Erik Wramner <erik@wramnerconsulting.se>
> Cc: ediint@ietf.org
> Subject: RE: Structure of an Internet EDI MIME Message  Actually, now 
> that I think about it:
>  Encryption, no signature, compression
>            - RFC2616/2045 (HTTP/MIME)
>               - RFC5751 (application/pkcs7-mime; smime-type=enveloped-data) (everything below inside this part is encrypted)
>                 - RFC3274 (application/pkcs7-mime; smime-type=compressed-data) (everything below inside this part is compressed)
>                   - RFC1767/RFC3023 (application/EDIxxxx or /xml)  If 
> I’m not mistaken this represents the actual payload, correct? Are there actually any restrictions on which types of payload you are allowed to send via AS2? Looking at this, I would interpret it as saying that you are not allowed to send for instance JSON data via AS2, but I don’t think that is actually an intended restriction. It might be a good idea to somehow make the text distinguish between requirements and examples, because this looks like a definite requirement, but I don’t think it is.
>  /Asger
>  From: Erik Wramner <erik@wramnerconsulting.se>
> Sent: Wednesday, 23 September 2026 10.31
> To: Asger Smidt <asm@bizbrains.com>
> Cc: ediint@ietf.org
> Subject: RE: Structure of an Internet EDI MIME Message  I agree, the 
> reference to HTTP/MIME is good. I have implemented HTTP more than once, but only HTTP 1.0 in the old days. Implementing 1.1 or better is another story entirely, way too much complexity there. This will be done by library code for sure.
>  -Erik
>  From: Asger Smidt <asm@bizbrains.com>
> Sent: Wednesday, 23 September 2026 10:17
> To: Debra Petta <debrap=40drummondgroup.com@dmarc.ietf.org>; Erik 
> Wramner <erik@wramnerconsulting.se>
> Cc: ediint@ietf.org
> Subject: RE: Structure of an Internet EDI MIME Message  Yes, this is 
> much better. It actually shows on which level the encryption takes place instead of at the bottom.
>  I might go so far as to add something like this:
>  Encryption, no signature, compression
>            - RFC2616/2045 (HTTP/MIME)
>               - RFC5751 (application/pkcs7-mime; smime-type=enveloped-data) (everything below inside this part is encrypted)
>                 - RFC3274 (application/pkcs7-mime; smime-type=compressed-data) (everything below inside this part is compressed)
>                   - RFC1767/RFC3023 (application/EDIxxxx or /xml) 
> Implementors usually use standard libraries for basic functionality. I don’t know anyone who has ever actually written an implementation of the HTTP protocol. I certainly haven’t. As such, expecting them to know offhand what a given RFC represents is probably unrealistic, because they rarely, if ever, have to consult actual RFCs in their daily work.
>  /Asger
>  From: Debra Petta <debrap=40drummondgroup.com@dmarc.ietf.org>
> Sent: Tuesday, 22 September 2026 19.44
> To: Erik Wrammer <erik@wramnerconsulting.se>
> Cc: ediint@ietf.org
> Subject: [Ediint] Re: Structure of an Internet EDI MIME Message  OK, 
> thanks Erik.
>  If there are no objections to this example, I replace it with the one in the draft.
>   From: Erik Wramner <erik@wramnerconsulting.se>
> Sent: Tuesday, September 22, 2026 12:21 PM
> To: Debra Petta <debrap@drummondgroup.com>
> Cc: ediint@ietf.org
> Subject: RE: Structure of an Internet EDI MIME Message  Hi Debra,  I 
> think I covered this in my example? To take Asger’s specific case then:
>  Encryption, no signature, compression
>            - RFC2616/2045
>               - RFC5751 (application/pkcs7-mime; smime-type=enveloped-data) (everything below inside this part is encrypted)
>                 - RFC3274 (application/pkcs7-mime; smime-type=compressed-data) (everything below inside this part is compressed)
>                   - RFC1767/RFC3023 (application/EDIxxxx or /xml) 
> Encryption, no signature, no compression
>            - RFC2616/2045
>               - RFC5751 (application/pkcs7-mime; smime-type=enveloped-data) (everything below inside this part is encrypted)
>                  - RFC1767/RFC3023 (application/EDIxxxx or /xml)  The 
> optional compression is split into two examples, one with and one 
> without. Much easier to read. The text “(encrypted)” is removed, but 
> “everything below inside this part is encrypted” added instead. We can 
> remove that if you feel it adds no value.  -Erik
>  From: Debra Petta <debrap@drummondgroup.com>
> Sent: Tuesday, 22 September 2026 18:38
> To: Erik Wramner <erik@wramnerconsulting.se>
> Cc: ediint@ietf.org
> Subject: RE: Structure of an Internet EDI MIME Message  Hi Erik,  I 
> have pasted the snippet of Asger’s original comment here for your review:
>  Another thing about section 4.2 is the way it indicates encryption:
>  >      Encryption, no signature (with optional compression)
> >          - RFC2616/2045
> >            - RFC5751 (application/pkcs7-mime)
> >              - [optional RFC3274 (CompressedData)]
> >                - RFC1767/RFC3023 (application/EDIxxxx or /xml)
> > (encrypted)
>  Here, as with the "Encryption, signature" section above, the layout 
> seems to indicate that encryption takes place in the innermost layer of the message, which is surely the exact opposite of the truth.
>  I will happily admit that maybe I just don't know how to properly 
> read a spec (I am still new to this deep level of the tech stack), but I do not think I am alone in this. When shown a hierarchy with the word "encrypted"
> on the bottom level, I think most people will conclude that that is 
> where the encryption takes place, rather than the top level.
>   From: Erik Wramner <erik@wramnerconsulting.se>
> Sent: Tuesday, September 22, 2026 11:28 AM
> To: ediint@ietf.org
> Subject: [Ediint] Structure of an Internet EDI MIME Message  In the 
> meeting Today, I promised to write something about the MIME structure. I can’t find the original post, but I think I remember what it was about. This is in “4.2.  Structure of an Internet EDI MIME Message”.
>  Simple example for reference:
>        No encryption, signature, no compression
>          - RFC2616/2045
>            - RFC1847 (multipart/signed)
>              - RFC1767/RFC3023 (application/EDIxxxx or /xml)
>              - RFC5751 (application/pkcs7-signature)  Here everything 
> is in plain text, so someone reading the HTTP request can see the XML or other content embedded inside the multipart message. Compare that with:
>        Encryption, no signature, no compression
>          - RFC2616/2045
>            - RFC5751 (application/pkcs7-mime)
>              - RFC1767/RFC3023  (application/EDIxxxx or /xml)
> (encrypted)  Here they want to show the structure in the same way with all the nested MIME types, but they also want to highlight that the content is encrypted and cannot be read if the message is intercepted. In other words, the “(encrypted)” part is just to inform the reader that the given MIME part is not sent in the clear; but encrypted by the enclosing container/envelope. I think this is fine, but it gets confusing when compression is added:
>        Encryption, signature (compression may occur before or after signing)
>          - RFC2616/2045
>            - RFC5751 (application/pkcs7-mime)
>              - [optional RFC3274 (CompressedData) if compress-before-sign]
>                - RFC1847 (multipart/signed) (encrypted)
>                  - [optional RFC3274 (CompressedData) if compress-after-sign]
>                  - RFC1767/RFC3023 (application/EDIxxxx or /xml) (encrypted)
>                  - RFC5751 (application/pkcs7-signature) (encrypted) 
> Not only is it very confusing to have two different compression stages in the same example, but if it says “encrypted” to show that an inner part is encrypted, then it should probably also say “compressed” for all inner parts that are compressed? They are not sent in the clear either, although there is no security.
>  My suggestion is to expand the examples with compression so that they cover the alternatives explicitly and move the “encrypted” part and also show the MIME types for encryption and compression like this:
>        Encryption, signature, compression before signing
>          - RFC2616/2045
>            - RFC5751 (application/pkcs7-mime; smime-type=enveloped-data) (everything below inside this part is encrypted)
>                - RFC1847 (multipart/signed)
>                  - RFC3274 (application/pkcs7-mime; smime-type=compressed-data) (everything below inside this part is compressed)
>                       - RFC1767/RFC3023 (application/EDIxxxx or /xml)
>                  - RFC5751 (application/pkcs7-signature)
>        Encryption, signature, compression after signing
>          - RFC2616/2045
>            - RFC5751 (application/pkcs7-mime; smime-type=enveloped-data) (everything below inside this part is encrypted)
>                - RFC3274 (application/pkcs7-mime; smime-type=compressed-data) (everything below inside this part is compressed)
>                    - RFC1847 (multipart/signed)
>                      - RFC1767/RFC3023 (application/EDIxxxx or /xml)
>                      - RFC5751 (application/pkcs7-signature)  I think 
> this is much clearer. What do you think? I’m also open to removing the “everything below...” texts if it is self-evident. Note that the original example mixed up before and after, if compression is applied before the signature, it must be inside the multipart message rather than outside it. That is fixed in my examples above.
>  (Debra: if the group agrees, I can rewrite all the examples in 4.2 along these lines).
>  -Erik
>  _______________________________________________
> Ediint mailing list -- ediint@ietf.org To unsubscribe send an email to 
> ediint-leave@ietf.org  _______________________________________________
> Ediint mailing list -- ediint@ietf.org To unsubscribe send an email to 
> ediint-leave@ietf.org


_______________________________________________
Ediint mailing list -- ediint@ietf.org
To unsubscribe send an email to ediint-leave@ietf.org _______________________________________________
Ediint mailing list -- ediint@ietf.org
To unsubscribe send an email to ediint-leave@ietf.org