[Emu] Re: AD review draft-ietf-emu-eap-edhoc-06
John Mattsson <john.mattsson@ericsson.com> Wed, 28 January 2026 10:00 UTC
Return-Path: <john.mattsson@ericsson.com>
X-Original-To: emu@mail2.ietf.org
Delivered-To: emu@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id 8D55EAE34F4B; Wed, 28 Jan 2026 02:00:38 -0800 (PST)
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -2.096
X-Spam-Level:
X-Spam-Status: No, score=-2.096 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIMWL_WL_HIGH=-0.001, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, HTML_MESSAGE=0.001, RCVD_IN_MSPIKE_H2=0.001, RCVD_IN_VALIDITY_RPBL_BLOCKED=0.001, RCVD_IN_VALIDITY_SAFE_BLOCKED=0.001, SPF_NONE=0.001] autolearn=ham autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=pass (2048-bit key) header.d=ericsson.com
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id dAKms6ehWPiu; Wed, 28 Jan 2026 02:00:37 -0800 (PST)
Received: from PA4PR04CU001.outbound.protection.outlook.com (mail-francecentralazon11013058.outbound.protection.outlook.com [40.107.162.58]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange ECDHE (P-384) server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id 69D95AE34F44; Wed, 28 Jan 2026 02:00:37 -0800 (PST)
ARC-Seal: i=1; a=rsa-sha256; s=arcselector10001; d=microsoft.com; cv=none; b=KTLBJVCx/bdK5b2DgBVnwszn1RwmSg+ZiEn7JowbiO1WSK63O0JkGIRhE8Qv1bpH4vt7U+V8/KhzBszYOEUI474evReuSfANi/332RExNXMAGdHYHfDImPUmpDAmwV2EM5DIib7QKv16qfzR/ScTyOoUJfzY3I9uOwfrkwVT63bnD2Jcte/wm39aRry7ouvuT+GBbuRj/xL9xRHGRrEcALfTNhs92rJNeUqytFI+YNsVLlnEwv3hNZED/MGSariLeukC8TLQzAAqGNLEnhTxgPXEJ6sOGg6Qj9KRL7h9n0P+mUiMjmsZ4/Lc3FjQFWo6kNzfWSgb6otvdXMB0EtsEQ==
ARC-Message-Signature: i=1; a=rsa-sha256; c=relaxed/relaxed; d=microsoft.com; s=arcselector10001; h=From:Date:Subject:Message-ID:Content-Type:MIME-Version:X-MS-Exchange-AntiSpam-MessageData-ChunkCount:X-MS-Exchange-AntiSpam-MessageData-0:X-MS-Exchange-AntiSpam-MessageData-1; bh=TWX6TxiUtuvC6PI4nNCXubf8TQUoCIYMOuD+hyELkJ0=; b=Xyvn0bLuU02HDHAqjxhZzMbQixyU3MD9CKfe1FTRGATTiKaJwNkEBasnTA1zZ3YU4czXdqX6GgRtbF2ncX81+HG2Ayd0scl98DbJeaqeV5rcpc9ZcO1PS5WRG9OTna3UEkUkuRF3LFiM/bbjeFNpgTc0RQNGrAPGQI7ti4cebgcRtN1qkdUQAfemFo3KIfzVjGWqKyNIikuF2pBJFpm8IEL5vAaw7V9Jssq1+t/6MJiLc6tDihdOJQA37naONrWrrn4emmQNyZLOE92x4/BjjQntN4qcyoRz9n3NqqpIkTJmJ4EyVkz6ZCqAx+wSP2FnxsOmwvLx/xB/ywljt4VOPg==
ARC-Authentication-Results: i=1; mx.microsoft.com 1; spf=pass smtp.mailfrom=ericsson.com; dmarc=pass action=none header.from=ericsson.com; dkim=pass header.d=ericsson.com; arc=none
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=ericsson.com; s=selector1; h=From:Date:Subject:Message-ID:Content-Type:MIME-Version:X-MS-Exchange-SenderADCheck; bh=TWX6TxiUtuvC6PI4nNCXubf8TQUoCIYMOuD+hyELkJ0=; b=iy9n04cuSctYHjdDvsqsiSLwN4RVM0eHbgHJkA3HmglxHk+/BFjTsDk3WkAsOmcm6wfB3Y7zbrfLyu/6/mSI0Zc5GY+X0iefB9Ry9cVg1boQguba9QNyaRY+iDbghR8Aju9/Phv7Sj8t7Bqx4FJ9BPnNpB1ZJfC3nl67Y9XhNSyA5vFlhWBnogj0oZjNa+bN4JtrLVVFUa96kTtA6EvHjqCwoWK4KybSmq7TZ2lR3r4VuRyb8XFgAUNWM9E3GfZsb6e8rlp3j85EJ/Z8JHC2eIfXfajdSJDHgwhqVIB37ZBLVTyAVjoiRCTx5YLl8EE9oye34WQaz8h47ktibbulZA==
Received: from AS5PR07MB10596.eurprd07.prod.outlook.com (2603:10a6:20b:6c5::15) by AM7PR07MB6836.eurprd07.prod.outlook.com (2603:10a6:20b:1bb::7) with Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) id 15.20.9542.16; Wed, 28 Jan 2026 10:00:28 +0000
Received: from AS5PR07MB10596.eurprd07.prod.outlook.com ([fe80::ef82:7cc0:e50:9050]) by AS5PR07MB10596.eurprd07.prod.outlook.com ([fe80::ef82:7cc0:e50:9050%5]) with mapi id 15.20.9542.010; Wed, 28 Jan 2026 10:00:28 +0000
From: John Mattsson <john.mattsson@ericsson.com>
To: Paul Wouters <paul.wouters@aiven.io>, "emu@ietf.org" <emu@ietf.org>
Thread-Topic: AD review draft-ietf-emu-eap-edhoc-06
Thread-Index: AQHcj9yIaCJ12K859kSu3BfoOiRDsLVnVRaz
Date: Wed, 28 Jan 2026 10:00:28 +0000
Message-ID: <AS5PR07MB10596820AC59B8C6DE19034578991A@AS5PR07MB10596.eurprd07.prod.outlook.com>
References: <CAGL5yWZ2nAfDuqEtE91CqZ7ZpLXq5Aj=Bvh4+XksKoYB-o0XWQ@mail.gmail.com>
In-Reply-To: <CAGL5yWZ2nAfDuqEtE91CqZ7ZpLXq5Aj=Bvh4+XksKoYB-o0XWQ@mail.gmail.com>
Accept-Language: en-US
Content-Language: en-GB
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
x-ms-reactions: allow
authentication-results: dkim=none (message not signed) header.d=none;dmarc=none action=none header.from=ericsson.com;
x-ms-publictraffictype: Email
x-ms-traffictypediagnostic: AS5PR07MB10596:EE_|AM7PR07MB6836:EE_
x-ms-office365-filtering-correlation-id: 26bf9330-6c05-40d1-9805-08de5e5410cb
x-ms-exchange-senderadcheck: 1
x-ms-exchange-antispam-relay: 0
x-microsoft-antispam: BCL:0;ARA:13230040|376014|1800799024|366016|38070700021|7053199007|8096899003;
x-microsoft-antispam-message-info: 6DHqGHR0MNRMuUtoxlD2Zgj38YuodH8YO/YHeUlQ+w4pjoY2Wfk1hbXXTkPDojV5TgKlaz0madzrTYrEVPYu0Vc1VbYQUGdppo7XrAnqqrfaG9bVa2L9phwPPTbdqcksHNv8vuZhSGmX5yO62K0TxFhzOKtc/mqJGEKkFhK5/IjOV14uw5PWl1TXaNySdKjV7FouXy6LHoZWioUDWUgQ89yddstAzskKHd9oqa+o5HUUZh1SJhJus/ea7ngQxetPHlUIj10onvWkTuQTK7PsYxUeijwUAb1tyTyfWZH+3IkmW/FLYcx/mjCszWpK4yI5QWERpLwK98r/D0TIMacbk2Y0efuA6ThP/VU16FlyrMIn2anKS0qcQSKxJQ8XcTHOJ82DyWJPYMVZPT6No5t3qUTlKEeUJ3lB4RdzRxbMZQA1XPkhA9qtW7ERS814wCR+dKUUpaGrVMCwy92Naeb/doOw2r/U8hW20ed5R0bIupC4YMHzEeN2RtYTWnHj4Z8L8dq1/kUNhWSOwNg1V+RcUtbKzThU1OAfmas1WJhbfsDVJm4+KpNlq8w2LXfsG3nvwfZ7XOxqsVMODH9OAP0WoNH90Vpwn9uHahWLnzJaeQeBAnf/Jt5hH1m26OP7b+DYGlnfwhPnEcrXJt5svN0D+Nd9b2Aog0dFRdW1CTubqLHMJou3NcjElfg6qkvxY45hYQqIj4crFisIFVpoPQNPFL6P46/n7qFkNmVgBQSoxJaeWDConUyKAni0Ycx60BYJ2jpLn6KVVGfPe8O1i4nQ8vMJXoCitZq/cnHKiu6JpndxlAKJk7Ar2nkvow5UhzkghB8p9bVcAuDxziLQ+fD86Twxf2YfLIqeISDOHGE9DsYjkjEg+D3Vm6hxryPdl9jV6JU0ooJACPh45QU5OwPY951VVoERMt5tI2ZVhjcTYsvbWUkwYRb8ecJmUEauVFDquvTdiiHU+YcTCv/McwP0DUwAfngOjKrHTTsEHvHu6wqabSbkyXJ2uxfPjCcbNdOrsgkAEXZSySv5oxbmbFuBWGHMueXxa/f6K7QWqedhuGF48rzwGl0jJ5M0HwpqbmifAbV87FdP4+2J5Neh3PEaH4oAkmOhgJ+2zJSHZx+OXpjiuGsF5lVjR0Sd+ODRnN5VIYZyUMItK3JbvtzYNBqUxkJ8AwVNIEVy7bAOyX1LIPJUzg0AffFIUyfv4nyb7lQ9DqWthTv6sR5ObomgjZZyD2wvyR5OgcpESeJnkr9B2sAOYJ0FSUzgOqn/0/C9d9oMHFosVAQC/REszuc7/Zrm6hZ56DKtya3TEOn76Gny0d/J9jo5Fe4WxEJh66XiYo5CbSamIOV7Q/MRE8cYcyw1BpPX7vhC2kWjxpFb7iUXL+FsSvs7Kkz5Iyf2xtqF9ir7bcFIkX3fKBV9EGPYrLsfS+GU3J/w4SQMzZaUGR4XGN2KF3VNaQ9hw64b1Swq9dUmHhyiC9TOwjy9lMFMaEzIbQiDEFKMD+1CjP/BtFUpZh9d8OE+EWreNdNdQppYLJb9HS+TPVtUUZOo5q+s0/LvhL6b6spqqEgfVhcCz38YstO3sJ0qts6nrTkYDbD1AGEsec09GgYCiYhOqsimO5QD6oDxCMhtv0BeL+soryIsGVA=
x-forefront-antispam-report: CIP:255.255.255.255;CTRY:;LANG:en;SCL:1;SRV:;IPV:NLI;SFV:NSPM;H:AS5PR07MB10596.eurprd07.prod.outlook.com;PTR:;CAT:NONE;SFS:(13230040)(376014)(1800799024)(366016)(38070700021)(7053199007)(8096899003);DIR:OUT;SFP:1101;
x-ms-exchange-antispam-messagedata-chunkcount: 1
x-ms-exchange-antispam-messagedata-0: hQ/WxPicIamNpzlYsUJBt7LfyQm+oCZfxuAMhASVJR3Mc2K3+bZ4+uXFlqf/t6GYuHpRSwnMPfIHcIOXM/Af4IZWUJwyUorbFw80ArMaV6Sw8YGzFPK5SNE9zvezrQus23Vuc9zmcWXMQZ14vwDwnSkSO6cigCqAcc6ibndclFJesxEOdmxTtFRSmRC8/JHys20JzgtCAbmPxRxJfH0Gl/ydkckWEnaXkQww5iTTdOCIsuOyGWytilAeGqbD8bD5AYbWsK1a5Y8kr/kuDju+sWrX6OcinRYO3LtzHxq0thQ6PpQrDXpmaBKbyunKjtmUsH+GmDwpKmGxJJ+MAsslJ95jHdk5bzH9U84mNrdMgZuyzBdDjiGc9npAXwsu1exPsH3jAN5p3qZBCciOdMLdxXyINKofvjnS7mYPDuIr39+sX8ku/Ep2MXAXKBUQ3VQJ7NpBdg7MfTPkCXg45kp42X/UloAq9ubuA5wlIpazwEj5ikalD5bHIafEf9TmavEEMFNtf2i1NNO7qDKRtKYciriUZjYAVCEK2Y2tjP9ha6GkwgtfcA5igQLoxcKm8+A6nEOOpz229pmphcn4faKMmFmVjMXywfdyRYkISRuugJj9S6//fM08CvuqN2MH+c39YTuFBROWEk6Wdqt6gveTIz5xM8Zz41yMc2mWTcQCSUgxXAudyrqQhpjbbq2rmfoWhbmWMPf/VF14JVjcm1sg8Dh/JJ+r8iIExnaObHlqzSinRo51WovN9aKLK++50WUasHdOWEq8s0iLzhtHuEkt78VjiJ7tHOlqPp6aLGBrH/TntsuGrtcXiH77HMRkf4JVN9Gql7bLe96ZOCZtSUVYODlZTDB8KvdUbFhDQYZ5zZqS0B0+hdefFwHBnObczI8h7bwRyIJhvzM2LNYxDE9Oh1m5pg6lCHEAfpAfLhzNmRfNcvIcBGvilRNrJRF7tp6yNhQXOznKRqSI7T+FogH3dh64ZcZsxYkgDDWVvU/4tCMZ2Lno0eBok622g1s3H0lKgkfLBqw0XLnoVjuj7kE1ymlpZe/XryTcQcLZ3iQGwjGznT8DI24if0jPH2MrbEi8HsfDUdmV8UP804/tpg7EhR8ApoR5ZEVm5zKVhwP3S4uDIfBqPII35ywT/ysf7BVkoBnh843YH4WxmKE6SOvKwIO2T+lqG/EljIoiFeiBD+uDiI+vnZVy6f00e3EO8J+qqvd6COyL7l6Jp9hxCGk4857fdpHvNfx8CP8/ma/Akd4+QrA1i1/ri7KEtrWMWWGKKE1eraEFlIJosJM+LjwdybHCB9akENMkz9JlqTub4JNj2joUAJB4KMHDhC6OQfLLVEkWpRM7+SZ6BvhhCuCcDfEZR6FpbLMmZioXmT+N96haL7FC+Am1436X7P3cKHE2wVZPccLoANW+iPHSx3cu8nB2VXAjpu6Vk7Qd0rPA2lyc0RBLoGZjv/NJpsPMzoZt9eLVKLAG2OSYb7l25kq9JSLPbyW2LUcplLqGRjMpf2B8GaLLU0Ge2jE0jOhr7STTD/Ga7c4LST0ocvpexmhnYQLgy/iLvHmY9ZysjLrujdH7RiMALvurX5sBWHa9F1aQfaUXWkgfaQ90Zm3ozRFmBdOBnU7iRxPYbO2SMZ5DxXKcp5nYRJ0URq8wmRWoRjahgGiFG+1VBK3/R9kd0z8ID2lbNJabiXHD4/GQyH4Ke2Ewuovr/+emKSKP8yM6oEUlD2l+tyuRYLiMz7g+9Q8DNreu73YR6KiRIkd2FTEDDPQ=
Content-Type: multipart/alternative; boundary="_000_AS5PR07MB10596820AC59B8C6DE19034578991AAS5PR07MB10596eu_"
MIME-Version: 1.0
X-OriginatorOrg: ericsson.com
X-MS-Exchange-CrossTenant-AuthAs: Internal
X-MS-Exchange-CrossTenant-AuthSource: AS5PR07MB10596.eurprd07.prod.outlook.com
X-MS-Exchange-CrossTenant-Network-Message-Id: 26bf9330-6c05-40d1-9805-08de5e5410cb
X-MS-Exchange-CrossTenant-originalarrivaltime: 28 Jan 2026 10:00:28.4616 (UTC)
X-MS-Exchange-CrossTenant-fromentityheader: Hosted
X-MS-Exchange-CrossTenant-id: 92e84ceb-fbfd-47ab-be52-080c6b87953f
X-MS-Exchange-CrossTenant-mailboxtype: HOSTED
X-MS-Exchange-CrossTenant-userprincipalname: ldlaoOfcJxiO7SP7ZcssuHg/f70cTlCoPJLIeBXStFfjbo3q4BXIcmpPyNapZRcmM8x8gEXzytj2fZwz36D4V7bWJddHEO0uKBxdbgaARdI=
X-MS-Exchange-Transport-CrossTenantHeadersStamped: AM7PR07MB6836
Message-ID-Hash: 6SYUFU6LXJJUZCX4MRGVHHROLPDQEKR3
X-Message-ID-Hash: 6SYUFU6LXJJUZCX4MRGVHHROLPDQEKR3
X-MailFrom: john.mattsson@ericsson.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-emu.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: "draft-ietf-emu-eap-edhoc@ietf.org" <draft-ietf-emu-eap-edhoc@ietf.org>
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [Emu] Re: AD review draft-ietf-emu-eap-edhoc-06
List-Id: "EAP Methods Update (EMU)" <emu.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/emu/hWHqjBaIgWD_Tz2x7AjYK2anqj8>
List-Archive: <https://mailarchive.ietf.org/arch/browse/emu>
List-Help: <mailto:emu-request@ietf.org?subject=help>
List-Owner: <mailto:emu-owner@ietf.org>
List-Post: <mailto:emu@ietf.org>
List-Subscribe: <mailto:emu-join@ietf.org>
List-Unsubscribe: <mailto:emu-leave@ietf.org>
Hi Paul,
Thanks for the review.
>How does one determine the length of the EDHOC Message Length field?
This is described in the L field.
L: The L flag bits represent the binary encoding of the size of the
EDHOC Message Length, which can range from 0 to 4 bytes. When all
three bits are set to 0, the EDHOC Message Length field is not
present. If the first two bits of the L field are set to 0 and
the last bit is set to 1, then the size of the EDHOC Message
Length field is 1 byte, and so on. Values from 5 to 7 are not
used in this specification.
Based on your question we should probably dd a sentence about this in the description of the “EDHOC Message Length” field. For example:
The EDHOC Message Length field, when present, has a size of one to four octets, as determined by the L flag bits. It is included only when the L flag bits indicate a value greater than zero and specifies the total length of the EDHOC message being fragmented. When fragmentation is not used, this field is omitted.
>I think RFC4137, RFC5216, RFC6677 should probably be normative references ?
I think making 4137 and 6677 normative make sense. I think RFC5216 should stay informative, the EAP-EDHOC packet format is just inspired by the EAP-TLS packet format.
Cheers,
John
From: Paul Wouters <paul.wouters@aiven.io>
Date: Tuesday, 27 January 2026 at 23:30
To: emu@ietf.org <emu@ietf.org>
Cc: draft-ietf-emu-eap-edhoc@ietf.org <draft-ietf-emu-eap-edhoc@ietf.org>
Subject: AD review draft-ietf-emu-eap-edhoc-06
AD review draft-ietf-emu-eap-edhoc-06
The draft looks generally fine and clear. I have one question and
one comment
0 1 2 3
0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
| Code | Identifier | Length |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
| Type | R |S|M| L | EDHOC Message Length ~
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
| EDHOC Data ~
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
Figure 7: EAP-EDHOC Request and Response Packet Format
4.1. EAP-EDHOC Request Packet
The EDHOC Message Length field can have a size of one to four octets
and is present only if the L flag bits represent a value greater than
0. This field provides the total length of the EDHOC message that is
being fragmented. When there is no fragmentation, it is not present.
EDHOC Data:
The EDHOC data consists of the whole or a fragment of the transported EDHOC message.
How does one determine the length of the EDHOC Message Length field?
I think RFC4137, RFC5216, RFC6677 should probably be normative references ?
Paul
- [Emu] AD review draft-ietf-emu-eap-edhoc-06 Paul Wouters
- [Emu] Re: AD review draft-ietf-emu-eap-edhoc-06 John Mattsson
- [Emu] Re: AD review draft-ietf-emu-eap-edhoc-06 Paul Wouters