[Gen-art] Re: [mpls] draft-ietf-mpls-stamp-pw-06 ietf last call Genart review
Rakesh Gandhi <rgandhi.ietf@gmail.com> Tue, 11 August 2026 12:08 UTC
Return-Path: <rgandhi.ietf@gmail.com>
X-Original-To: gen-art@mail2.ietf.org
Delivered-To: gen-art@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id 7EF22127C8D95 for <gen-art@mail2.ietf.org>; Tue, 11 Aug 2026 05:08:27 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=ietf.org; s=ietf1; t=1786450107; bh=LKtU6n9Em6wNoxcoN+mFibu/NOBpJeFZX2eyIJocq1Y=; h=References:In-Reply-To:From:Date:Subject:To:Cc; b=r/qtvef8P5Osca9uFmMUPhRBg9gzYW+XVn+YIg1ITcjV1CnrGlb3pd4IXB4AK2GAL uk2T4bi5jlEEpuLqSAYV93LSrB1hCSBGmYeYeNWWykvC957OA69u1zrBx+3c+10n6C GvzW5RTRI/Y0Oupqmc3W8VMhz8jrfj4paeEprlCY=
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -2.098
X-Spam-Level:
X-Spam-Status: No, score=-2.098 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, FREEMAIL_FROM=0.001, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_NONE=-0.0001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001] autolearn=unavailable autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=pass (2048-bit key) header.d=gmail.com
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id XolXbnaAFxZz for <gen-art@mail2.ietf.org>; Tue, 11 Aug 2026 05:08:27 -0700 (PDT)
Received: from mail-ej1-x635.google.com (mail-ej1-x635.google.com [IPv6:2a00:1450:4864:20::635]) (using TLSv1.3 with cipher TLS_AES_128_GCM_SHA256 (128/128 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id 118E9127C8D74 for <gen-art@ietf.org>; Tue, 11 Aug 2026 05:08:27 -0700 (PDT)
Received: by mail-ej1-x635.google.com with SMTP id a640c23a62f3a-c169ae1cb26so173827766b.1 for <gen-art@ietf.org>; Tue, 11 Aug 2026 05:08:27 -0700 (PDT)
ARC-Seal: i=1; a=rsa-sha256; t=1786450100; cv=none; d=google.com; s=arc-20260327; b=eYRgju9HOwCwVw4ynrurvZPj2ppYSVl0jl5Pl+v9wY752L87cI9NQRwCxxf8ZAKZhv HhQQXmrxs6xUjWXBOKeealW7e4NJ9Rm06qslImRiBrgpLMX+gRr2yFr1vZoe5cRkPnrb RH6nWSGX6X0P/+usihD+ozRswLf480GRYRz0rBwm3e3GWDaGo3rtIIHjr8ON064buUal EKCDzgmY8K/1hPxbEzuL68YOueb0oWBGZFHgBB2Zq4S4nnf7ru/zMYEReIPAPg/4GpKg XHrw6e+fD0c6omGHKOK1MDqYSboL52i2KcFUpnKKnmzVgHE7urkEYL75x2JzlgRLMvKA FvNg==
ARC-Message-Signature: i=1; a=rsa-sha256; c=relaxed/relaxed; d=google.com; s=arc-20260327; h=cc:to:subject:message-id:date:from:in-reply-to:references :mime-version:dkim-signature; bh=pWr+rGp7+fhNCsuIqSxMaLOeRvTXh4cE/BcHebCYNYI=; fh=zQGz7qLg9z1hHQPC1k/ec5ZF6WqX2S6y8hFytoNdhrk=; b=DSEVPwkmS/YBnYifP28lb2iYOFxga7ldQ5OoxZcm6Fp7QFgFOMNl5G9YlRHr78sNbT XanYuofk1Hq7vGUdw2Sj4airb1XjufebeoioFhS0Zsaq0Hts5bsk5zigUHJSRizX+Ee1 VBRXROz5A4YjRGPh1AqzjdmfAQGUSH6vUHY2ipN7bvq30xBfEB39bwQOIJyO1u9varfd iS7Me3N+VwXGEqzCAVCDRuizwm1ksa39NgnIDLfuOo0OL3YaszlsOwAEsXwHRJ4BzC0m n0dO2xjGZlwYt1bUhyjXGp1Kj+6hxqvXWCk6OlZJkOmKLAj3QU7lcYRHQtgUtR56eaU6 niwQ==; darn=ietf.org
ARC-Authentication-Results: i=1; mx.google.com; arc=none
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20251104; t=1786450100; x=1787054900; darn=ietf.org; h=content-type:cc:to:subject:message-id:date:from:in-reply-to :references:mime-version:from:to:cc:subject:date:message-id:reply-to :content-type; bh=pWr+rGp7+fhNCsuIqSxMaLOeRvTXh4cE/BcHebCYNYI=; b=jteEsDwA+nfsSlDuVFBfNr62WtasIik9/wYjqH7Eb/NsfqfLWig9ojJNB82sAyRVDa DnRtZXL0gpgY7/Bc1UBSWvLhSGHdTffhmE4/7FxI37tjrKGXn2wWzWm8aTpKmqLpHYyT fp3UUBzayhuXQt97M39MNTIfQHCInGJK91vU0+YQuMKn+bjvElmb2AwRsqKqGa7hEvzj zU8NJGiXJYovb8ykMYhKRvGopw8DvrjhJlwy/wU9qiHkoTiWNSVrZChMa8PH7Tg/Zwd7 PcvqzkV/8yrF+NXcOqEfD3WQWhJjjprZYG/D/vtGBXT4DApAwnE3SEjOkxUkTdIWIJdi xBkw==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20251104; t=1786450100; x=1787054900; h=content-type:cc:to:subject:message-id:date:from:in-reply-to :references:mime-version:x-gm-gg:x-gm-message-state:from:to:cc :subject:date:message-id:reply-to:content-type; bh=pWr+rGp7+fhNCsuIqSxMaLOeRvTXh4cE/BcHebCYNYI=; b=FAQGnlMxOZq8LVTECYXH/nENKZYRTGM519oXBmpbSLzqe8xUlbZ9iyweCSn88G6rKi qB7cy4Tdfo71suPqg+4ULWY32TJQOjT7OPffky/wnbMN5587QUJZXzzc7xBl+OzAqMVI UsqxChT0Jzm+Nl+8zYErn86f3g6ryAaWSDMe9ic5unenr8r7doXoscbhzzT/A6OJhreO sh3eh4CT3d9j1sKN/cUEO8zGc0CchAKX889kFNlE24DBK0ugng8SP6lqlWgxITEoztYq zUqNZUEzUjkTyv/6/MpgFk2oMaQSqmBnZcBMUahZV05XnrTqrCOMb0iKtrhkkM8Y3WjK HEDA==
X-Gm-Message-State: AOJu0Yxxx4LDT6pG+2ytLaNyp3M249glTl4vQ8LXpx9uVUGbY59tZA7D ISppNNjS4P665Xl10uHHUSgMPsvIsjiLCrwbNIpW2vr+mi7YqLPRuegDsVqDGTkZ+t6j7pyJPL/ hu024j9fLQSWGjr2bMVpmETzLiSZmXA==
X-Gm-Gg: AR+sD11j96ex3aWdAVTSHACEIdZA0xcztz+tdlVMZfFCoxepRovRXwtnRjIO5I4LwsR fuSwjhoUxc2mwafCFTpzAJyw39Jwq6ABoa9ojb0Z3VyhUaYBoO6shtfDOlFOAwSHMiBb1kYfsav K/rjWydHAQzHF/1Nbf/7ieEndXYupj9frkkauBwU4Kx3Dmprf5a6E42qSqIMPMfnOfLLXtbx1Mb fnCHgMjJCE2ByjemMdYQNZVHgF0scaNsu9jJeyQXdKxjorYWUfPJIhe9ofeFdQlg6WOELrFCeXW gUCQXtgrzWza5c8r/9V3iYsTsYgIqNQR24aD1Q9zosDA+kCJ10GsWZ9r4Iq7oh8oU6iSB8Fqi9j RHSfOS8BFfN7kl1TZhoi0R0GaAMPY2A==
X-Received: by 2002:a17:907:3e0e:b0:c19:5bf1:368e with SMTP id a640c23a62f3a-c20e5ed6832mr121551366b.13.1786450100050; Tue, 11 Aug 2026 05:08:20 -0700 (PDT)
MIME-Version: 1.0
References: <178595930274.667.7257862610009551891@dt-datatracker-559c48c7fb-qkhml>
In-Reply-To: <178595930274.667.7257862610009551891@dt-datatracker-559c48c7fb-qkhml>
From: Rakesh Gandhi <rgandhi.ietf@gmail.com>
Date: Tue, 11 Aug 2026 08:08:08 -0400
X-Gm-Features: AUfX_mwvQpXh_E4Y07TWKtvEqKvpesVxA1YsWijOzZPp3fvI49MubO0QzzCACWo
Message-ID: <CAMZsk6cm=Q4-aJO+=xJQuYK-rabEw0ZjEJUS-9gy2hXOue8BmQ@mail.gmail.com>
To: Russ Housley <housley@vigilsec.com>
Content-Type: multipart/alternative; boundary="0000000000009f62390658c45389"
Message-ID-Hash: G4TEC7LH3BQQ6D2KDHPUYET63KHLXTI4
X-Message-ID-Hash: G4TEC7LH3BQQ6D2KDHPUYET63KHLXTI4
X-MailFrom: rgandhi.ietf@gmail.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-gen-art.ietf.org-0; header-match-gen-art.ietf.org-1; header-match-gen-art.ietf.org-2; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: gen-art@ietf.org, draft-ietf-mpls-stamp-pw.all@ietf.org, last-call@ietf.org, mpls@ietf.org
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [Gen-art] Re: [mpls] draft-ietf-mpls-stamp-pw-06 ietf last call Genart review
List-Id: "GEN-ART: General Area Review Team" <gen-art.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/gen-art/4UwSABQp4_6VC_EF9piriavnR50>
List-Archive: <https://mailarchive.ietf.org/arch/browse/gen-art>
List-Help: <mailto:gen-art-request@ietf.org?subject=help>
List-Owner: <mailto:gen-art-owner@ietf.org>
List-Post: <mailto:gen-art@ietf.org>
List-Subscribe: <mailto:gen-art-join@ietf.org>
List-Unsubscribe: <mailto:gen-art-leave@ietf.org>
Thank you Russ for the Gen-ART review and your suggestions. We have posted rev-07 that addresses your comments. Please see replies inline with <RG>... On Wed, Aug 5, 2026 at 3:48 PM Russ Housley via Datatracker < noreply@ietf.org> wrote: > Document: draft-ietf-mpls-stamp-pw > Title: Encapsulation of Simple Two-Way Active Measurement Protocol for > LSPs and > Pseudowires in MPLS Networks Reviewer: Russ Housley Review result: Almost > Ready > > I am the assigned Gen-ART reviewer for this draft. The General Area > Review Team (Gen-ART) reviews all IETF documents being processed > by the IESG for the IETF Chair. Please treat these comments just > like any other last call comments. > > For more information, please see the FAQ at > <https://wiki.ietf.org/en/group/gen/GenArtFAQ>. > > Document: draft-ietf-mpls-stamp-pw-06 > Reviewer: Russ Housley > Review Date: 2026-08-02 > IETF LC End Date: 2026-08-11 > IESG Telechat date: unknown > > Summary: Almost Ready > > Major Concerns: > > None > > Minor Concerns: > > Section 1: The text says: > > PWs are bidirectional in nature. They can be point-to-point or > point-to-multipoint. > > Then, a few paragraphs later it says: > > The STAMP encapsulations for point-to-multipoint LSPs and PWs are > outside the scope of this document. > > It would help the reader to limit the scope at the earlier paragraph. > Something like: > > PWs are bidirectional in nature. PWs can be point-to-point or > point-to-multipoint; however, STAMP encapsulations for > point-to-multipoint PWs are outside the scope of this document. > <RG> Updated. > > Similarly, this scope limitation could be raised earlier in the > Introduction for LSPs. > <RG> Updated. > > Section 2.2: HMAC should expand to Hash-based Message Authentication Code. > <RG> Updated. > > Nits: > > Section 1: s/Section 3, "Generic PW MPLS Control Word" of [RFC4385]/ > /Section 3 of [RFC4385]/ (two places) > <RG> Updated. > > Section 7: s/the 'Security Considerations' Section of [RFC5085]/ > /the security considerations in Section 9 of [RFC5085]/ > <RG> Updated. > > Note: These align with the xml2rfc syntax for cross document references. > > IDnits offers a suggestion: > > == There are 1 instance of lines with non-RFC3849-compliant IPv6 > addresses > in the document. If these are example addresses, they should be > changed. > <RG> This is a well defined address (not an example). Not sure what can be done to address this. Thanks, Rakesh (for authors) > > > > _______________________________________________ > mpls mailing list -- mpls@ietf.org > To unsubscribe send an email to mpls-leave@ietf.org >
- [Gen-art] draft-ietf-mpls-stamp-pw-06 ietf last c… Russ Housley via Datatracker
- [Gen-art] Re: [mpls] draft-ietf-mpls-stamp-pw-06 … Rakesh Gandhi