[Gen-art] Re: 回复: draft-ietf-pce-flexible-grid-16 ietf last call Genart review
Robert Sparks <rjsparks@nostrum.com> Thu, 10 September 2026 17:35 UTC
Return-Path: <rjsparks@nostrum.com>
X-Original-To: gen-art@mail2.ietf.org
Delivered-To: gen-art@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id 07890138832A0; Thu, 10 Sep 2026 10:35:39 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=ietf.org; s=ietf1; t=1789061739; bh=+JuYCJpG3vL4Yp4+2ilNBw1b/qzdt6HFrqwh/wBOBVc=; h=Date:Subject:To:Cc:References:From:In-Reply-To; b=iMxjZ+nz9X3nw7a+IwoUQfdB3zus51OHy7eCTAQXKnOvq/MeL69ihxx2cGn9U01Aj yZU8A0+Fia6Z9AEnEJ7HvIipOJGANPrwMb6xuv+MFHq5g+GfxXxgoT51ys28xRm8Sh q2X4F8HXXEyb1W65pY9rIiTTXElfaFnFsYJNWkwU=
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -2.098
X-Spam-Level:
X-Spam-Status: No, score=-2.098 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, RCVD_IN_VALIDITY_RPBL_BLOCKED=0.001, RCVD_IN_VALIDITY_SAFE_BLOCKED=0.001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001] autolearn=ham autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=pass (2048-bit key) header.d=nostrum.com
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id Cln6MzGhGArm; Thu, 10 Sep 2026 10:35:38 -0700 (PDT)
Received: from magus.nostrum.com (magus.nostrum.com [104.236.102.164]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id F14D61388329B; Thu, 10 Sep 2026 10:35:37 -0700 (PDT)
Received: by magus.nostrum.com (Postfix) id 423DB732115; Thu, 10 Sep 2026 12:35:31 -0500 (CDT)
DKIM-Signature: v=1; a=rsa-sha256; c=simple/simple; d=nostrum.com; s=submissiondev2025; t=1789061731; bh=+JuYCJpG3vL4Yp4+2ilNBw1b/qzdt6HFrqwh/wBOBVc=; h=Date:Subject:To:Cc:References:From:In-Reply-To; b=iUdNryN4PaS3lnlyPATXpfPCsCNOP6v0mozOCrUGt4wWjeJJJP7eRCs4cZ/4ZM96P 16+Dp5mtMZNB/j2MRqeBeO+hQKlqEgLUuUx14Cqt9IMTNLyU3LDPVy2PO6jPNlA9c4 aMw2qvt5+9aV9Y4rRQ6/HXgXo725Cdj9nEVlrg+Wwbh0zYuSzLgLxDbzZJTh0bWJ2o WxcYnOG3xgolbkg786n0M0uPnLzb0JGI0MUqZyIGkRS72hoTqRT5wLtI06fMSATXIK 90NMpkR3R4e6GlOi9kCK5G54h4Ltzywu+dHv+uxAae82HcmHS5bTeSuIKWU7hnm1h8 DLAAmsW97vvVg==
Message-ID: <c36fd747-909d-4152-a9be-76560e152c78@nostrum.com>
Date: Thu, 10 Sep 2026 12:35:30 -0500
MIME-Version: 1.0
User-Agent: Mozilla Thunderbird
To: Zhenghaomian <zhenghaomian@huawei.com>, "gen-art@ietf.org" <gen-art@ietf.org>
References: <178812159313.201842.3460572178676702901@dt-datatracker-6669c7b496-4m6kd> <ceddf913054f4af481cc8279c596ca4c@huawei.com>
Content-Language: en-US
From: Robert Sparks <rjsparks@nostrum.com>
Autocrypt: addr=rjsparks@nostrum.com; keydata= xsDNBFx4PQwBDADIIJqFKIeYNmVR3iH8YnNqwApV+ci83VqFaPg0UXZAZ1utH/2O2LOLJKmV Ol11+lOSfH4OJgpARt37PWbqfG2TzzGfEucRBPMAV8TEDmzKL+7/OUMLEoPeexgxz6ADxK2Q ACKKzHhF30y4fx2fn9rYZrCvYHV9HDKcfFotNLna0U6P6wu70L0mT2hcjQgZ7+8HSZCpK2XG PTya1mEiMklH6+UHfcTLoAxd3chQiseRi19/TQZZCD3LuuaGFWyTIeF9ZNWV9yL0HQeb/XMs tmZnObSSHSUbZwn5PR9Uf+3iW7jdG5JuXBvNbDpAHfLyPXRqxErM/nCLrbwGB6AgNSKFCwkL lb3uxsGFWcOt6sedrjixoVUO2k4zQWVnCUCwFHGrgIxUK24dI8oqydGPctXAKj5VqoCVJBv6 4JxSpiR+V8fl3A8gksBUnuIMLNlRjB5RAgZaSUpaOkXsWUBA8Z75wQWoIzkJIeMm29w2l1kB B9kGMdyiXGr2JV8VQZ4lAscAEQEAAc0kUm9iZXJ0IFNwYXJrcyA8cmpzcGFya3NAbm9zdHJ1 bS5jb20+wsEUBBMBCAA+AhsDBQsJCAcCBhUKCQgLAgQWAgMBAh4BAheAFiEEGNywdGDCHUYB wWN3bipqV3X5ExgFAmf+YFcFCREpvcsACgkQbipqV3X5EximYwv+LojObKPKfx66R9ZmfI3D uB7Sx7X8iYNgNpird/OqHQZcXhQjsv7C26k5y9VMgmU2bibUlm8o/q+kzkpHI9RZ5s27twiR ON1aN8vfzi5iXxY3oKI0sNrZX+gSaAwfNTckDIIdyCKXt/K0i02qHXxe/nke1+JV4uUSDR/e ea3M+cM0MEb25cclmz2Ac9vH/gXCzn9NaEoVOXh6xIztfZYGWtJ8YNVryv2noWumI4dDGPIp +UBgE7gaP/1lXwOurdTvRkDP1+VuVq9qJOGORQZgU6gow/K6ujs0LYPmWzvPbRWxfTd43cQ9 4EbkXUbOiefHdZBWhYxXRc9qahgi4MY10ws9oxn7LKXbWBgx8UltkTmdmbQ6AVV/XxGfaqFC FQPvPGv7qPEowkfwyCl0PV0lqz15A3rE6lhCKFaJM9oYrAWk5S/6qjVs0sgchFhwwGAbYAO0 38AZW+4A96RavAUg2EDxEMycB5Fd6dHuHBnoUC+iQGzRTufheY52gLBgTVOEzsDNBFx4PQwB DAC03e1kk41e9Z9FuVW8UKWIkVUBeH3gfJMsb94d/c0cqBMRw5rulSY7+U76rw4AXo792LZn ydjDfoL0GQxGqkrZh397Sn9P/sLCb5I+wC14251nkmh5tmU2sQqCk+g9nykcE/NJft/zFkeb HHCKAosK6glO+W0YPHc/k7nXt/fLz7dMRpFpmqFXWjeN2VtwKr9znMg9+iX6XfgAJPMdDNH8 fn30Cp5TIsn5WCI70+JztgvfjFhD15Eb3rtDdOfOydjGCV2ZVxfM8ECmc8Z3DrThyiC2M3uo 2Y50rs6MH+TmVCtpHkISnH7B+80Vy2SC60K9l2xgCaezN1SlkQy3ZpprzcDrNTI8FcJa/UUM ayMGvSDGEGuHZRaNUyXP3jQ8oss+067axmNr5vgjpf01kmE1RJtiGEDWmCr8u1SbVQjdax6C pDqq3RKoX2ZVGLtkdDYZbsqSq4TgmFukoijWRbLxsFBdeEgruTViWRw4PKZav0piLxrhHUGI m6F6JFngapUAEQEAAcLA/AQYAQgAJgIbDBYhBBjcsHRgwh1GAcFjd24qald1+RMYBQJn/mEh BQkRKb6VAAoJEG4qald1+RMYaOgL/j06duNc5/OTAzOY3MawOwSPskXHLHiZUYG3TfN9eWYg TNCxTaP7wglLhHOsZF7rIzfPw3IAj9k8lnuLK1Z7C3VaJHQuayzLJ8jAF5gVryrqA/ia552u ejdg3k3OnExZB5Rvm/9joD5TpEa8f8XkLnfl/ez2H1rYR4gCjSIO6Kpi6B7Jxgt5is+HKP1x f/havxpBa/0c8f/9XEIgzQ6G190j4pBym1tzZCOx/NB3kp9oYVXejUwVA+WryJgpHvlzCxUW P7svyD4Mal4cgJCNptQ0Q2y8S4Yf/G+vF8+DVHd9x+xeNRX7USvqlxkpabAjLc3bp/egxFul i7Vb9qhlfcMwzOHrG1u3sYNFuL+hou9nNR5kdWVAVxKw0du9YptGtXlMK9PKlangBbeeNc6f h/wJMnCeITDBWb/Pm3nIstAVnftJSFaMaQwLLlcxCgUS7gD1axzeIGY3XPLnJX6ZjjdHZ5Z7 I8lfj4rMCctcE0pudHYWrhznMBoUaEADjiOpdw==
In-Reply-To: <ceddf913054f4af481cc8279c596ca4c@huawei.com>
Content-Type: text/plain; charset="UTF-8"; format="flowed"
Content-Transfer-Encoding: 8bit
Message-ID-Hash: B3EXHKD5DEBIU4XL2J4ZUSTKRLGHX3YW
X-Message-ID-Hash: B3EXHKD5DEBIU4XL2J4ZUSTKRLGHX3YW
X-MailFrom: rjsparks@nostrum.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-gen-art.ietf.org-0; header-match-gen-art.ietf.org-1; header-match-gen-art.ietf.org-2; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: "draft-ietf-pce-flexible-grid.all@ietf.org" <draft-ietf-pce-flexible-grid.all@ietf.org>, "last-call@ietf.org" <last-call@ietf.org>, "pce@ietf.org" <pce@ietf.org>
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [Gen-art] Re: 回复: draft-ietf-pce-flexible-grid-16 ietf last call Genart review
List-Id: "GEN-ART: General Area Review Team" <gen-art.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/gen-art/Oy-joe8daCyjONVg0MQ-h7whIz4>
List-Archive: <https://mailarchive.ietf.org/arch/browse/gen-art>
List-Help: <mailto:gen-art-request@ietf.org?subject=help>
List-Owner: <mailto:gen-art-owner@ietf.org>
List-Post: <mailto:gen-art@ietf.org>
List-Subscribe: <mailto:gen-art-join@ietf.org>
List-Unsubscribe: <mailto:gen-art-leave@ietf.org>
Hello Haomain - Replies inline: On 9/4/26 9:44 AM, Zhenghaomian wrote: > Hi Robert, > > Thank you for your review. We would like to propose some opinions inline before we update the document. > Please check if these address the comments. Your conversation should be more with the group than with me. Make sure the group agrees this is the way to go. > > Best wishes, > Haomian > > -----邮件原件----- > 发件人: Robert Sparks via Datatracker <noreply@ietf.org> > 发送时间: 2026年8月31日 4:27 > 收件人: gen-art@ietf.org > 抄送: draft-ietf-pce-flexible-grid.all@ietf.org; last-call@ietf.org; pce@ietf.org > 主题: draft-ietf-pce-flexible-grid-16 ietf last call Genart review > > Document: draft-ietf-pce-flexible-grid > Title: PCEP Extension for Flexible Grid Networks > Reviewer: Robert Sparks > Review result: Not Ready > > I am the assigned Gen-ART reviewer for this draft. The General Area Review Team (Gen-ART) reviews all IETF documents being processed by the IESG for the IETF Chair. Please treat these comments just like any other last call comments. > > For more information, please see the FAQ at > > <https://wiki.ietf.org/en/group/gen/GenArtFAQ>. > > Document: draft-ietf-pce-flexible-grid-16 > > Reviewer: Robert Sparks > Review Date: 2026-08-30 > IETF LC End Date: 2026-09-01 > IESG Telechat date: Not scheduled for a telechat > > Summary: Not ready for publication as a Proposed Standard RFC > > It's been awhile since I've tried to load all of PCEP into my head - apologies if any of this off base. > > My primary issue: > > The document is currently using the wrong kind of error, claiming "a PathErr MUST be generated" but what it lays out isn't PCEP - it appears to be taken from RSVP. If I'm right, addressing this will have quite a bit of impact on what's being asked of IANA, and will likely change the prose of the discussions of errors enough that deeper review should wait until after that is addressed. > [Author] This is good catch, but we need to clarify that it's not purely about error handling, as indicated in section 4.1 it just try to illustrate the behavior for PCEs that does not support these attributes. Of course the PCE does not work if the capability and attributes are missing. > After discussion we realized that sending a PathErr is incorrect, and we propose to remove the improper illustration text - including the following text in section 4.1 and the whole section 9.9. > TEXT to be REMOVED: > If a PCE does not support the attribute(s), its behavior is specified below: > > * S bit clear not supported: a PathErr MUST be generated with the Error Code "Routing Problem" (24) with error sub-code "Unsupported Frequency Slot Selection Symmetry value" (TBD3). > > * FSA method not supported: a PathErr MUST be generated with the Error Code "Routing Problem" (24) with error sub-code "Unsupported Frequency Slot Assignment value" (TBD4). Ok with me. Be sure to update the IANA considerations accordingly. > > > Other concerns: > > Consider being a bit more descriptive with where in a PCEP PCRep or PCUpd message the TLV object described in section 5 is intended to occur. I _think_ it's aimed towards hop-by-hop and if so, are length constraints going to be a problem? > [Author] Section 5 indicated the ERO TLV usage in a per hop manner, referencing to RFC5440 (it is a typo to ref RFC5420). The encoding is intended to the RFC7570 hop attributes in section 2.1. Regarding the length, we now have up to 2^16 the length could support 65,535 bytes, to cover the length of link identifier and allocated spectrum. Given each hop could usually cover a distance of 80km and the upper bound of value n would normally be +/- 40, a 16-bit length field could be sufficient. BTW we found a wrong reference to RFC5420, which should be RFC5440. ok > > > Why does the document limit frequency slots to >=193.1 THz? That is, why does section 4.1's discussion of FSA restrict n to be non-negative? RFC7698 does not. > [Author] the value of n could be both positive and negative, including zero, propose to be: > OLD: All the feasible frequency slots are numbered (based on 'n' parameter), and this SA method chooses the available frequency slot with the lowest index, where 'n' is the parameter in f = 193.1 THz + n x 0.00625 THz where 193.1THz is the ITU-T 'anchor frequency' and 'n' is a positive integer including 0 [RFC7698]. > NEW: All the feasible frequency slots are numbered (based on 'n' parameter), and this SA method chooses the available frequency slot with the lowest index, where 'n' is the parameter in f = 193.1 THz + n x 0.00625 THz where 193.1THz is the ITU-T 'anchor frequency' and 'n' is a positive or negative integer including 0 [RFC7698]. ok (note to the IESG - the verbose "positive or negative integer including 0" is how RFC7698 said this). > > > Should these objects be richer in describing the requested slot width? I can see how a minimum width can be expressed as a constraint, but that's not the same as a desired width. > [Author] For flexi-grid the slot width is described by value m, as a multiple of slot width granularity - we could refer to Appendix I of ITU-T G.694.1 as the usage examples. Well, my point is that a _desired_ m is not carried anywhere in the objects sent by the PCC. Am I missing where the protocol you are specifying here allows that? I see where you can declare a minimum m constraint, but that's not the same thing. > > > The text talking about the Count and Link Identifiers fields in section 4.9 reads badly when the link identifiers are the ends of ranges. Consider being more precise about "link identifier record" or something similar.. > [Author] I assume you are referring to figure 3 in section 4.2 and try to understand the comments correctly. Do you mean we need to describe Count/Link Identifiers text according to the action field? Some considerations of proposals are initiated as follow, please let us know your preference or correct us if we get you wrong. > OLD: > * Count: The number of the link identifiers (8 bits). > * Reserved: Reserved for future use (16 bits). It MUST be set to zero by the sender and ignored by the receiver. > * Link Identifiers: Identifies each link ID for which restriction is applied. The length is dependent on the link format and the Count field. See Section 4.3.1 in [RFC8780] for Link Identifier encoding. > > NEW1: > * Count: The number of Link Identifier Records (8 bits). > * Reserved: Reserved for future use (16 bits). It MUST be set to zero by the sender and ignored by the receiver. > * Link Identifiers: Contains one or more Link Identifier Records. The interpretation of each record depends on the Action field: > When Action=0 (Inclusive List), each record consists of a single link identifier. > When Action=1 (Inclusive Range), each record consists of two link identifiers, indicating the start and end of the range (inclusive). I would prefer the form of NEW1 with this change: When Action=1 (Inclusive Range), there are exactly two records, indicating the start and end of the range (inclusive). > > NEW2: > * Count: The number of Link Identifier Records (8 bits). > * Reserved: Reserved for future use (16 bits). It MUST be set to zero by the sender and ignored by the receiver. > * Link Identifiers: Identifies each link ID for which restriction is applied. When the Action field indicates an Inclusive Range (Action=1), this field contains exactly two link identifiers, with the first indicating the start of the range and the second indicating the end of the range (inclusive). The length is dependent on the link format and the Count field. > >
- [Gen-art] draft-ietf-pce-flexible-grid-16 ietf la… Robert Sparks via Datatracker
- [Gen-art] 回复: draft-ietf-pce-flexible-grid-16 iet… Zhenghaomian
- [Gen-art] Re: 回复: draft-ietf-pce-flexible-grid-16… Robert Sparks