[Gen-art] draft-ietf-nfsv4-internationalization-16 ietf last call Genart review

Ines Robles via Datatracker <noreply@ietf.org> Mon, 03 August 2026 20:20 UTC

Return-Path: <noreply@ietf.org>
X-Original-To: gen-art@ietf.org
Delivered-To: gen-art@mail2.ietf.org
Received: from [10.244.21.25] (gaia.k8s.ietf.org [4.156.85.76]) by mail2.ietf.org (Postfix) with ESMTP id 73B10122F58FD; Mon, 3 Aug 2026 13:20:49 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=ietf.org; s=ietf1; t=1785788449; bh=ktH4r0PMPfN5MFZzwNSCPie5O3XtVEJrnCcqkbtbqBs=; h=From:To:Cc:Subject:Reply-To:Date; b=ohbUY5MrrAFsl5KBZ5vTdU+97YzUDQOV0SCMmB4jJf4Cjw7mDXB1Xggm8ksH4ZuQh 7i7bAD5y92z26UCYGDy+0PmudHoLpljeyE/VwaD+m4/2ynRtd9oRGuxsz97lO05rnB p1qlzUqTzi/ZYOnOwTeLcI0pzKIhgPt+NRHhi+NY=
MIME-Version: 1.0
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: 7bit
From: Ines Robles via Datatracker <noreply@ietf.org>
To: gen-art@ietf.org
X-Test-IDTracker: no
X-IETF-IDTracker: 12.69.0
Auto-Submitted: auto-generated
Precedence: bulk
Message-ID: <178578844918.1939264.16591292412541319784@dt-datatracker-d4d6ff9d9-fsx7d>
Date: Mon, 03 Aug 2026 13:20:49 -0700
Message-ID-Hash: DT3NAGVORLHBZIDOHD2NS4SUQDIHGKHT
X-Message-ID-Hash: DT3NAGVORLHBZIDOHD2NS4SUQDIHGKHT
X-MailFrom: noreply@ietf.org
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-gen-art.ietf.org-0; header-match-gen-art.ietf.org-1; header-match-gen-art.ietf.org-2; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: draft-ietf-nfsv4-internationalization.all@ietf.org, last-call@ietf.org, nfsv4@ietf.org
X-Mailman-Version: 3.3.9rc6
Reply-To: Ines Robles <mariainesrobles@googlemail.com>
Subject: [Gen-art] draft-ietf-nfsv4-internationalization-16 ietf last call Genart review
List-Id: "GEN-ART: General Area Review Team" <gen-art.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/gen-art/f79E3smXpcSScHbRLCQ_SqI274M>
List-Archive: <https://mailarchive.ietf.org/arch/browse/gen-art>
List-Help: <mailto:gen-art-request@ietf.org?subject=help>
List-Owner: <mailto:gen-art-owner@ietf.org>
List-Post: <mailto:gen-art@ietf.org>
List-Subscribe: <mailto:gen-art-join@ietf.org>
List-Unsubscribe: <mailto:gen-art-leave@ietf.org>

Document: draft-ietf-nfsv4-internationalization
Title: Internationalization for the NFSv4 Protocols
Reviewer: Ines Robles
Review result: Almost Ready

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at

<https://wiki.ietf.org/en/group/gen/GenArtFAQ>.

Document: draft-ietf-nfsv4-internationalization-16
Reviewer: Ines Robles
Review Date: 2026-08-03
IETF LC End Date: 2026-08-03
IESG Telechat date: Not scheduled for a telechat

Summary:

This document describes the handling of internationalization for all NFSv4
protocols, including NFSv4.0, NFSv4.1, NFSv4.2, their extensions, and future
minor versions. It updates RFC 7530 and RFC 8881.

The document is well written. I have a few minor comments that I believe should
be addressed before publication.

Comments/Questions:

1- It would be helpful to add a section summarizing the updates to RFC 8881,
similar to the section that summarizes the updates to RFC 7530. This would make
it easier for readers to identify the changes introduced by this document.

2- Section 2.2: For the definition of Canonical Equivalence (of strings), it
might be helpful to add a reference to the Unicode definition of canonical
equivalence, for example, Unicode Standard Annex #15, Unicode Normalization
Forms (https://www.unicode.org/reports/tr15/) ?

3- Section 7.1: HEBREW LETTER BET WITH DAGESH (U+FB3) --> HEBREW LETTER BET
WITH DAGESH (U+FB31)

4- Section 7.2: "Servers MAY treat name strings that only differ as to case as
identical when searching for a given file without making any change in the name
presented when the file is created. When the OPTIONAL attributes
case_insensitive and case_preserving are implemented, their values will be true
and false, respectively."

Based on my understanding, case_preserving should be true, not false, since the
capitalization of the name is preserved when the file is created.

Nits:

5- all minor version --> all minor versions

6- each effected --> each affected

7- file name are --> file names are

8- Such file are --> Such file systems are

9- they do not to define --> they do not define

10- can also represented --> can also be represented

11- [RFC8178]) --> [RFC8178]

12- The making this shift --> By making this shift... ?

13- (in Section 7.3)." --> (in Section 7.3).

14- related as to normalization --> related to normalization

15- former chose --> former was chosen

16- earlier version --> earlier versions ?

17- ACTUE --> ACUTE ?

18- use by the server --> used by the server

19- previous implementation --> previous implementations

20- fit it one byte --> fit in one byte

21- "xn--"formed --> missing space

22- ACII --> ASCII

23- There is likely to be few or no implementations --> There are likely to be
few or no implementations

24- there a number of troubling --> there are a number of troubling

25- chances of that occurring is --> chances of that occurring are

26- UTF8-8 --> UTF-8

27- such the determinations --> such determinations

28- other sorts strings --> other sorts of strings

29- In the event that happens --> In the event that this happens

30- information about potential future needs are discussed --> information
about potential future needs is discussed

31- The document alternates between "filesystem" and "file system". It would be
nice to adopt a single form throughout the document.

Thanks for this document,

Ines.