[Gen-art] Re: Gen-ART Last Call review of draft-ietf-core-oscore-groupcomm-26
Paul Kyzivat <pkyzivat@alum.mit.edu> Fri, 05 September 2025 22:19 UTC
Return-Path: <pkyzivat@alum.mit.edu>
X-Original-To: gen-art@mail2.ietf.org
Delivered-To: gen-art@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id 6CED05E42F0E; Fri, 5 Sep 2025 15:19:51 -0700 (PDT)
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -1.998
X-Spam-Level:
X-Spam-Status: No, score=-1.998 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, RCVD_IN_DNSWL_NONE=-0.0001, RCVD_IN_MSPIKE_H2=0.001, RCVD_IN_VALIDITY_RPBL_BLOCKED=0.001, RCVD_IN_VALIDITY_SAFE_BLOCKED=0.001, SPF_PASS=-0.001] autolearn=ham autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=pass (1024-bit key) header.d=alum.mit.edu
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id YcjmfBxxReZu; Fri, 5 Sep 2025 15:19:50 -0700 (PDT)
Received: from NAM10-DM6-obe.outbound.protection.outlook.com (mail-dm6nam10on2043.outbound.protection.outlook.com [40.107.93.43]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange ECDHE (P-384) server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id 84AF65E42F06; Fri, 5 Sep 2025 15:19:50 -0700 (PDT)
ARC-Seal: i=1; a=rsa-sha256; s=arcselector10001; d=microsoft.com; cv=none; b=YYh5r7JbScfyxDmovHyT6VuIuGntCys0Y+k1r3V7AFdhn3o34Dy8TLfWSdUShJWgX3/y2ymWkD1oRFHfooKCJ+NheCpgfc+XeDp5Neva+rcYCqxl2LwKIt5q2cAMZjyyX8NXv8B0m+C+8LFgJV+C1fbTAS4fYcee+uQKzT/HYtimGjCac2N9mjJIC7ZXDQLPftZbVJiPoFeyaSukD8E1iW6ZWDMZyoRTdhuNqFNiyAUowhc+JLevYhrxR0uxOKkFYjx35kCfTyd6sIZjQUwdQbXJsY2Z9tPqRJqCFO8RKehbLoYwWf9rhIhXb2CNM89DYFVG6Mhd4fdBTgr7RxXLwA==
ARC-Message-Signature: i=1; a=rsa-sha256; c=relaxed/relaxed; d=microsoft.com; s=arcselector10001; h=From:Date:Subject:Message-ID:Content-Type:MIME-Version:X-MS-Exchange-AntiSpam-MessageData-ChunkCount:X-MS-Exchange-AntiSpam-MessageData-0:X-MS-Exchange-AntiSpam-MessageData-1; bh=CaWcBHta8t00Sr9+r3+vQqFk40uGY3BgODlAz75RWok=; b=slUDJQ1dL9UjDiWhtmDipOwTRjeUHSHV2t5yId1py0VTgAAUGMShyYY3XmITmaAC3CNPMd4Tc4y5xevT6tK2FaHw7YHz5PlBPa8isG/s4ZICq0NogKjyBi7jEW957jt6kAi5sXuxmvtNQ654gt4bd0JQZaEHq1Xgs1TrKOGU6kDYTMT5SuGyOycgcesuljV1nsq/lu+jTXaZjkZgvQcR+qp1s9kJEP9U/Qtmicy78r403U+HyWH2ycbqd3CKMp7NeaisGwm4ZSXWg07to/BrFhQTbDEGwjW0JKVbvdmULLfRl9m/DSAbqXxmUe1IT3+UMgcJ7FVCzddhHOK+3iUMRg==
ARC-Authentication-Results: i=1; mx.microsoft.com 1; spf=pass (sender ip is 18.7.68.33) smtp.rcpttodomain=ietf.org smtp.mailfrom=alum.mit.edu; dmarc=pass (p=reject sp=reject pct=100) action=none header.from=alum.mit.edu; dkim=none (message not signed); arc=none (0)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=alum.mit.edu; s=selector2; h=From:Date:Subject:Message-ID:Content-Type:MIME-Version:X-MS-Exchange-SenderADCheck; bh=CaWcBHta8t00Sr9+r3+vQqFk40uGY3BgODlAz75RWok=; b=eN7F9qXVSToV4E32HOk9fSI86BSj58wRXx4k9p8F7/lrmClmW8aJvfiwSi5s5G2l2Un/neJUUQlm0ylnssMjOggx34Acu3bPQYCPeDxWKw/M1TIeO0k/0fELYMD4cwuuhUfuY7PjqRMaxYF8005iKhK+X2SY0J79f5EjVDpiF6E=
Received: from BN9PR03CA0082.namprd03.prod.outlook.com (2603:10b6:408:fc::27) by MN0PR12MB6004.namprd12.prod.outlook.com (2603:10b6:208:380::17) with Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) id 15.20.9094.16; Fri, 5 Sep 2025 22:19:41 +0000
Received: from BL6PEPF0001AB74.namprd02.prod.outlook.com (2603:10b6:408:fc:cafe::87) by BN9PR03CA0082.outlook.office365.com (2603:10b6:408:fc::27) with Microsoft SMTP Server (version=TLS1_3, cipher=TLS_AES_256_GCM_SHA384) id 15.20.9094.18 via Frontend Transport; Fri, 5 Sep 2025 22:19:41 +0000
X-MS-Exchange-Authentication-Results: spf=pass (sender IP is 18.7.68.33) smtp.mailfrom=alum.mit.edu; dkim=none (message not signed) header.d=none;dmarc=pass action=none header.from=alum.mit.edu;
Received-SPF: Pass (protection.outlook.com: domain of alum.mit.edu designates 18.7.68.33 as permitted sender) receiver=protection.outlook.com; client-ip=18.7.68.33; helo=outgoing-alum.mit.edu; pr=C
Received: from outgoing-alum.mit.edu (18.7.68.33) by BL6PEPF0001AB74.mail.protection.outlook.com (10.167.242.167) with Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) id 15.20.9094.14 via Frontend Transport; Fri, 5 Sep 2025 22:19:41 +0000
Received: from [192.168.1.215] (c-76-19-71-248.hsd1.ma.comcast.net [76.19.71.248]) (authenticated bits=0) (User authenticated as pkyzivat@ALUM.MIT.EDU) by outgoing-alum.mit.edu (8.14.7/8.12.4) with ESMTP id 585MJd2i009960 (version=TLSv1/SSLv3 cipher=AES128-GCM-SHA256 bits=128 verify=NOT); Fri, 5 Sep 2025 18:19:40 -0400
Message-ID: <5068999c-82b8-4f2b-a5eb-42463dbe0eef@alum.mit.edu>
Date: Fri, 05 Sep 2025 18:19:39 -0400
MIME-Version: 1.0
User-Agent: Mozilla Thunderbird
To: Marco Tiloca <marco.tiloca@ri.se>, "draft-ietf-core-oscore-groupcomm.all@ietf.org" <draft-ietf-core-oscore-groupcomm.all@ietf.org>, "core@ietf.org" <core@ietf.org>
References: <2278577b-c3c0-4744-945e-c81592ddd34f@alum.mit.edu> <GV3P280MB04506A5F81EB69EC160DC9349903A@GV3P280MB0450.SWEP280.PROD.OUTLOOK.COM>
Content-Language: en-US
From: Paul Kyzivat <pkyzivat@alum.mit.edu>
In-Reply-To: <GV3P280MB04506A5F81EB69EC160DC9349903A@GV3P280MB0450.SWEP280.PROD.OUTLOOK.COM>
Content-Type: text/plain; charset="UTF-8"; format="flowed"
Content-Transfer-Encoding: 8bit
X-EOPAttributedMessage: 0
X-MS-PublicTrafficType: Email
X-MS-TrafficTypeDiagnostic: BL6PEPF0001AB74:EE_|MN0PR12MB6004:EE_
X-MS-Office365-Filtering-Correlation-Id: def76073-1158-4ae9-b5d5-08ddecca4f4c
X-MS-Exchange-SenderADCheck: 1
X-MS-Exchange-AntiSpam-Relay: 0
X-Microsoft-Antispam: BCL:0;ARA:13230040|82310400026|41320700013|376014|36860700013|1800799024|13003099007;
X-Microsoft-Antispam-Message-Info: 6+KElcVD+kI6Vdp57JhevGHhQvFJlWvLJq9KInQVYRx9CVEiPrOTADWgeVlkKVhbB6l5/+h3tf9XJNDqmjh6SJMl+isgZpl3jf+ejAOn+Lxug4uae0kYsEv4F3Pl9M7XhHvuLXMPR8k8ZkDazhU9f1KR8XhC0fwoe/FkNfnJfpUU5MVORw+92CK5p3iDu4fpjDGP3p5xkaFy9tJ/EEOSDlRqaDjmCSupj0rkiNygUuKNQH5ykLbBgbr3TaiPrpjVgxtdZtiNh5627r2ewQgoPXTQSgL/nGZxNyQnMNpWnUB5aLUaxHh05v0td8D5aOJVrAaKrLi/qb++boW32HQk36P7TPc5dG6x5XmGxgdbBLm4rI02wqwgr8XD3H1trYWWg3NJImqUdwMe7DB+kxJQiOgnT2CTQU93v+wyR+hU7oQK3doF86UjQbWOwBvnJchs+I6HjXEiDB+XRGM7kCbmTomNjPtg9EKv+EWt9my4HL89KE2TqS7l7irQeNiWMbmEuj8bfO1G6PnicBh2vTVbdo5NnoIBnvaVVKFoe/mK1T9psTO74qEQwU4XK1W4gBUW4qLIzUJFynqbd/TzJe9wYILxm7z9+ywT9mYRbkT8jLsX/ySU/NFcAwUrMe5tCCQhm/iy+O9vIgptpUbGCjfVzzH5HgjlYx1tOjPINdktksH/hRuoLIDU43k4G9xEWXrLoN3wqvdaWaZXtZ7wH8qVAuy9n+M9A/+byO5tywNCiqHGdE2y1ZJpHMN3eu0hMaTDArCWTBjSLC9RsDOUWDEQ/IrTw4yx3jWQbiVdOMx4+Dj1MQCUsGKNZFh9tE0DfQiarCz3Zc2SS5ATq46RG85H/Y12OEDvfRi6Mg29iIY+b3zRzr1YGRaIMDPY6iNY1y3iGK0h90XpzBzg/yr/XLvmDCchhi4M3oIMlW/hVWKLe5MoCMqcn7CKsB7rkKMpmomLTmyhzgmfyVvRLzXq+RNIDCG/4RUM7J3JhMpNuIT594hb7R/phux1IknUok6YGoZjBWlMLUeZnGnocC4wPu+/VAqYj0T/pTL9OnKWSi3Zmv6C5IGuRNu/XxkwxNUq3tycsUD5DgutwoBKXuQ78zAdMuGwOBwpC9PqglX4qRtaNjICv6LPskvEd57P390rHWoq+Ohw/Sg/Q3fjxyuxfi/Y2Bzt4gzuaIVvVpbL1YOevQHdUpgFPkbtZk1FByWOTVfGfpy5tSS469b0fN3acNNSNz43RFJyERHuFvhr7DoioOXi2JvHZ+NP0yH5htsjhEFn57RKCXAxQL+mwQuwrObxo80mDdBK5iwVPXJAVacHJyR+1Ub5+E9YU2DHhIbUs5GodJQoJQ8ukAGFEfN3BmDIek8PVHw0htny+GR7F4LbJR8aCLrpaL3rCwN84SzjMGysEKXu4BBYJCExFo4T5UNS+UVT4gXWRn1900AP6C7+LBMAoC6pSpFc7nqvGUnmI9NxATWQQi5ATRn9Y/xXUpQHDFYR77znX9Hwlnhh7agdzQAoUlGeAyqJrz7+L0i9jNot
X-Forefront-Antispam-Report: CIP:18.7.68.33;CTRY:US;LANG:en;SCL:1;SRV:;IPV:CAL;SFV:NSPM;H:outgoing-alum.mit.edu;PTR:outgoing-alum.mit.edu;CAT:NONE;SFS:(13230040)(82310400026)(41320700013)(376014)(36860700013)(1800799024)(13003099007);DIR:OUT;SFP:1101;
X-OriginatorOrg: alum.mit.edu
X-MS-Exchange-CrossTenant-OriginalArrivalTime: 05 Sep 2025 22:19:41.3119 (UTC)
X-MS-Exchange-CrossTenant-Network-Message-Id: def76073-1158-4ae9-b5d5-08ddecca4f4c
X-MS-Exchange-CrossTenant-Id: 3326b102-c043-408b-a990-b89e477d582f
X-MS-Exchange-CrossTenant-OriginalAttributedTenantConnectingIp: TenantId=3326b102-c043-408b-a990-b89e477d582f;Ip=[18.7.68.33];Helo=[outgoing-alum.mit.edu]
X-MS-Exchange-CrossTenant-AuthSource: BL6PEPF0001AB74.namprd02.prod.outlook.com
X-MS-Exchange-CrossTenant-AuthAs: Anonymous
X-MS-Exchange-CrossTenant-FromEntityHeader: HybridOnPrem
X-MS-Exchange-Transport-CrossTenantHeadersStamped: MN0PR12MB6004
Message-ID-Hash: ME6QCNKFLB7Q537MYJIRKO7532SNXTHR
X-Message-ID-Hash: ME6QCNKFLB7Q537MYJIRKO7532SNXTHR
X-MailFrom: pkyzivat@alum.mit.edu
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-gen-art.ietf.org-0; header-match-gen-art.ietf.org-1; header-match-gen-art.ietf.org-2; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: General Area Review Team <gen-art@ietf.org>, "last-call@ietf.org" <last-call@ietf.org>
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [Gen-art] Re: Gen-ART Last Call review of draft-ietf-core-oscore-groupcomm-26
List-Id: "GEN-ART: General Area Review Team" <gen-art.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/gen-art/p2mG8EymM1YtLq-CAkfdyOs6RbE>
List-Archive: <https://mailarchive.ietf.org/arch/browse/gen-art>
List-Help: <mailto:gen-art-request@ietf.org?subject=help>
List-Owner: <mailto:gen-art-owner@ietf.org>
List-Post: <mailto:gen-art@ietf.org>
List-Subscribe: <mailto:gen-art-join@ietf.org>
List-Unsubscribe: <mailto:gen-art-leave@ietf.org>
Hi Marco, Thanks for addressing my comments. Most seem fine to me, with a couple of exceptions. See below for more discussion. Thanks, Paul On 9/5/25 5:15 PM, Marco Tiloca wrote: > 1) ISSUE > > Section 2.6.2 says: > > "If an implementation's integers support wrapping addition, the > implementation MUST treat the Sender Sequence Number space as exhausted > when a wrap-around is detected." > > I think I understand the issue, but question how it is stated. Just > because the implementation does wrapping addition on integers shorter > than 40 bits, that doesn't mean the implementation isn't capable to > doing proper 40 bit arithmetic. There must be a better way to say this. > Perhaps: > > "An implementation must treat the Sender Sequence Number space as > exhausted when the Sender Sequence Number approaches the maximum value > it can properly increment." > > Also, if an implementation has difficulty handling 40 bit integers, > won't that also be a problem if it *receives* big sequence numbers? > > ==>MT > > Thanks for raising this detail. We have rephrased as below. > > OLD > > If an implementation's integers support wrapping addition, the > implementation MUST treat the Sender Sequence Number space as exhausted > when a wrap-around is detected. > NEW (emphasis mine) > > If an implementation's integers support wrapping addition, the > implementation MUST treat the Sender Sequence Number space as exhausted > when a wrap-around is detected **upon incrementing the value that has > been used as Partial IV**. This doesn't address my issue. The remedy (treat the Sender Sequence Number space as exhausted) is fine. The explanation of the circumstances when it should be applied still seem off the point. I'm not clear what "implementation's integers support wrapping addition" means. Isn't it the converse that is of concern? Namely, if the implementation is *incapable* of properly incrementing a 40-bit integer? And, if hardware doesn't support it, why can't it be done is software? I think it is probably a matter that the implementation may *choose* to limit the sequence number space to less than 40 bits for its own convenience. (Presumably to some more common size, like 32 or 31 bits.) The reason why need not be specified. > On the point raised in the last sentence of the comment, that's not > supposed to be a problem. In the OSCORE option value, the Partial IV can > be up to 40 bits, hence a compliant recipient must be able to handle > that if it happens. > That's simpler than the case discussed above, since it does not involve > arithmetic operations or other manipulation of the Partial IV value. > It's just about taking and using the Partial IV value as-is, in order > to, e.g., perform replay checks against a replay window (see Section > 5.3), build an AEAD nonce (see Section 5.2 of RFC 8613), or build the > external_aad for processing a message (see Section 3.4). I certainly don't understand the details, but when the sender includes a sequentially increasing sequence number in its messages, isn't the recipient expected to check the sequence numbers of received messages, and detect missing messages? That seems to also require the ability to do some arithmetic. If I am off base here, then never mind. > 2) ISSUE > > Section 6 says: > > "An endpoint MUST be able to distinguish between a Security Context to > process OSCORE messages ... and a Group OSCORE Security Context ... To > this end, an endpoint can take into account ... Alternatively, > implementations can ..." > > Why offer alternatives? Why not specify a single unambiguous method? > If there is reason, it would be good to discuss the pros and cons. > > ==>MT > > We have updated the second paragraph of Section 6 "Message Reception" as > below. > > OLD > > To this end, an endpoint can take into account the different > structure of the Security Context defined in Section 2, for example > based on the presence of Signature Algorithm and Pairwise Key Agreement > Algorithm in the Common Context. Alternatively, implementations can use > an additional parameter in the Security Context, to explicitly mark that > it is intended for processing Group OSCORE messages. > > NEW (emphasis mine) > **The way to accomplish this distinction is implementation specific. For > example**, an endpoint can take into account the different structure of > the Security Context defined in Section 2, **e.g.,** based on the > presence of Signature Algorithm and Pairwise Key Agreement Algorithm in > the Common Context. **Alternatively, at the cost of increasing > storage**, implementations can use an additional parameter in the > Security Context, to explicitly mark that it is intended for processing > Group OSCORE messages. OK. That makes sense to me. > 3) MINOR ISSUE > > Section 2.4 says "The authentication credential of the Group Manager > SHOULD be encoded according to that same format." > > There is no discussion of what conditions would justify violating the > SHOULD. Without this, many implementers treat SHOULD as MAY. My general > rule is that every SHOULD must specify that alternative. > > ==>MT > > We have clarified by extending the second paragraph of Section 2.4 > "Authentication Credentials" as below. > > OLD > > The authentication credential of the Group Manager SHOULD be encoded > according to that same format. > > NEW > > The authentication credential of the Group Manager SHOULD be encoded > according to that same format, in order to limit the number of formats > that the group members have to support and handle, unless it is > infeasible or impractical for the particular realization or instance of > the Group Manager to have an own authentication credential encoded in > that same format. That resolves my concern. > 4) MINOR ISSUE > > Section 7.5 specifies External Signature Checkers. But I couldn't find > any explanation of their purpose. > > I leave it to the authors to decide if there ought to be such an > explanation. > > ==>MT > > We have expanded the first paragraph in Section 7.5 "External Signature > Checkers" as below. > > OLD > > When a message is protected in group mode, it is possible for > designated external signature checkers, e.g., intermediary gateways, to > verify the countersignature of the message. > > NEW > > When a message is protected in group mode, it is possible for > designated external signature checkers to verify the countersignature of > the message. For example, an external signature checker can be an > intermediary gateway that intercepts messages protected in group mode > and ensures that they reach the intended recipients only if it > successfully verifies their countersignatures. Thanks. Now I get it. > 5) NIT > > The Abstract uses "CoAP" acronym without expansion. (Its defined in the > Intro.) I think this isn't allowed in abstracts, which often stand > alone. Please expand it in the abstract. > > ==>MT > > We have expanded the first sentence of the abstract as below. > > OLD > This document defines the security protocol Group Object Security for > Constrained RESTful Environments (Group OSCORE), providing end-to-end > security of CoAP messages exchanged between members of a group, e.g., > sent over IP multicast. > > NEW (emphasis mine) > This document defines the security protocol Group Object Security for > Constrained RESTful Environments (Group OSCORE), providing end-to-end > security of **messages exchanged with the Constrained Application > Protocol (CoAP) between members of a group, e.g., sent over IP multicast.** That is good. (That will save you from being called out on it later by an editor.) > 6) NIT: Typo > 7) NIT Thanks. 8) NIT > > The IdNits tool reports a number of issues. Many are spurious, but there > are several downrefs that should be evaluated. > > ==>MT > > The included references are as intended and deemed appropriate. Their > understanding and use are required by the present document in a > normative way. > > Specifically as to RFC 5869, RFC 6979, RFC 7748, RFC 8032, and RFC 9053, > they are all listed in https://datatracker.ietf.org/doc/downref/ > <https://datatracker.ietf.org/doc/downref/> OK. Its a formality to ensure you have considered it. The question will be asked again.
- [Gen-art] Gen-ART Last Call review of draft-ietf-… Paul Kyzivat
- [Gen-art] Re: Gen-ART Last Call review of draft-i… Marco Tiloca
- [Gen-art] Re: Gen-ART Last Call review of draft-i… Paul Kyzivat
- [Gen-art] Re: Gen-ART Last Call review of draft-i… Marco Tiloca
- [Gen-art] Re: Gen-ART Last Call review of draft-i… Paul Kyzivat
- [Gen-art] Re: Gen-ART Last Call review of draft-i… Marco Tiloca
- [Gen-art] Re: Gen-ART Last Call review of draft-i… Paul Kyzivat