[Int-area] Re: Gorry Fairhurst's No Objection on draft-ietf-intarea-v4-via-v6-08: (with COMMENT)

Gorry Fairhurst <gorry@erg.abdn.ac.uk> Thu, 23 July 2026 11:59 UTC

Return-Path: <gorry@erg.abdn.ac.uk>
X-Original-To: int-area@mail2.ietf.org
Delivered-To: int-area@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id 36E1211D56CC9; Thu, 23 Jul 2026 04:59:41 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=ietf.org; s=ietf1; t=1784807981; bh=njoo/b9ErtMvmEKRJWqc+0x5U8797vHKds52hV1niDs=; h=Date:Subject:To:Cc:References:From:In-Reply-To; b=BdfdgdPPtCnEl5K1OK49OqFoSvql1jRsGiqEu3jSprpQ4q2L7o3LbXxlmZyo9474/ DnFrzlkw4yAi6P+EG3AYWGwI90tKHdbM3I2zZ+BpoikcbSV8Pqs0SYjLrO/rUzQ1FM exPbtEyugrHdatul1QRbNGvyyoy0H2LbpW0/AqIo=
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -1.997
X-Spam-Level:
X-Spam-Status: No, score=-1.997 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, HTML_MESSAGE=0.001, RCVD_IN_VALIDITY_CERTIFIED_BLOCKED=0.001, RCVD_IN_VALIDITY_RPBL_BLOCKED=0.001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001] autolearn=ham autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=pass (2048-bit key) header.d=erg.abdn.ac.uk
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id Fcx8qDrtSznz; Thu, 23 Jul 2026 04:59:37 -0700 (PDT)
Received: from pegasus.erg.abdn.ac.uk (pegasus.erg.abdn.ac.uk [137.50.19.135]) by mail2.ietf.org (Postfix) with ESMTP id C7CC111D56CBE; Thu, 23 Jul 2026 04:59:37 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=erg.abdn.ac.uk; s=default; t=1784807971; bh=njoo/b9ErtMvmEKRJWqc+0x5U8797vHKds52hV1niDs=; h=Date:Subject:To:Cc:References:From:In-Reply-To:From; b=BtJv9OXwcVT6D/nvRvICml3ZoZ/LvIPBYbxxsW3VA35NHxWwiBhyDPN1p5m+p7eT1 yvJcrDEytbbSWZtbi/c8nmkanZ2EYBz7QmvkOVPtvXXOT57z8l3yHnXWPLmuuFjMOG k7AYlQ7uvTb2h9O6wHTQPJSPC05bc3oKHK9wc1gYJRxa5ZtUsllwoYmDgCZm0HZYne cx0+skKcT2DE5vb2jW3Fb8UVISgCtIsrKJ/kMqxMYF51QgOTGufN8YvW6b2n3Nk4Do G7aTg+bKkyAWdKL1xSDS8wbYOOcd1guaNwBhnoo9/hPQyrE5TEHd8sJuzk14sZ+FcN UXLJraLA4r/Qg==
Received: from [31.133.133.68] (dhcp-8544.users.meeting.ietf.org [31.133.133.68]) by pegasus.erg.abdn.ac.uk (Postfix) with ESMTPSA id 39F5F1B0067D; Thu, 23 Jul 2026 12:59:24 +0100 (BST)
Content-Type: multipart/alternative; boundary="------------wSsPYN2nFeToH1eX0QYICddN"
Message-ID: <b190a7e0-5243-4d02-9652-fe4c2b7674e2@erg.abdn.ac.uk>
Date: Thu, 23 Jul 2026 13:58:08 +0200
MIME-Version: 1.0
User-Agent: Mozilla Thunderbird
Content-Language: en-GB
To: Warren Kumari <warren@kumari.net>
References: <87fr24i0ph.wl-jch@irif.fr> <9F28DEE7-0747-4195-A778-5ABC627EAA4A@erg.abdn.ac.uk> <CAHw9_iLVEG6wAbh+qMtqUMx_NdKbTkQX7vPN-Q-n+P4LCvpaeQ@mail.gmail.com>
From: Gorry Fairhurst <gorry@erg.abdn.ac.uk>
Organization: UNIVERSITY OF ABERDEEN
In-Reply-To: <CAHw9_iLVEG6wAbh+qMtqUMx_NdKbTkQX7vPN-Q-n+P4LCvpaeQ@mail.gmail.com>
Message-ID-Hash: EIRNK3GLMMIACXFB3THMYYHMP7M4TL53
X-Message-ID-Hash: EIRNK3GLMMIACXFB3THMYYHMP7M4TL53
X-MailFrom: gorry@erg.abdn.ac.uk
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-int-area.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: Juliusz Chroboczek <jch@irif.fr>, The IESG <iesg@ietf.org>, draft-ietf-intarea-v4-via-v6@ietf.org, Int-area@ietf.org, intarea-chairs@ietf.org
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [Int-area] Re: Gorry Fairhurst's No Objection on draft-ietf-intarea-v4-via-v6-08: (with COMMENT)
List-Id: IETF Internet Area WG Mailing List <int-area.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/int-area/jPZT3XPP0K063YpQWfOqylmi28g>
List-Archive: <https://mailarchive.ietf.org/arch/browse/int-area>
List-Help: <mailto:int-area-request@ietf.org?subject=help>
List-Owner: <mailto:int-area-owner@ietf.org>
List-Post: <mailto:int-area@ietf.org>
List-Subscribe: <mailto:int-area-join@ietf.org>
List-Unsubscribe: <mailto:int-area-leave@ietf.org>

On 23/07/2026 12:13, Warren Kumari wrote:
>
>
>
>
> On Tue, Jun 30, 2026 at 4:19 PM, Gorry <gorry@erg.abdn.ac.uk> wrote:
>
>     See below marked [gf]
>
>         On 30 Jun 2026, at 15:05, Juliusz Chroboczek <jch@irif.fr
>         <mailto:jch@irif.fr>> wrote:
>
>         Hello Gorry,
>
>             (1) I expect some of the text ought to be about forwarding
>             rather than routing? - I see Med made many comments,
>
>         Done (following Mohamed's guidance).
>
>             (2) Current text:
>             there is nothing
>             preventing an IPv6 packet from being routed through a next
>             hop with an IPv4 address (in which case the next hop's MAC
>             address will be obtained using ARP), or, conversely, an
>             IPv4 packet from being routed through a next hop with an
>             IPv6 address.
>             - This text seems to detail IPv4, but not the same level
>             of detail for the IPv6 case. This ought also to mention
>             how that uses ND and other methods, to complete the
>             equivalent to arp?
>
>         Done.
>
>             (3) I'd encourage adding a reference for RFC 8899,
>             alongside the existing referene to RFC 4821.
>
>         Done. (I wasn't aware of this spec.)
>
>             (4) The text currently says:
>             "PMTUd may lead to persistent black-holing of IPv4 traffic."
>             - But not if using RFC 8899?
>
>         I think we're in agreement. What we're saying is that while
>         there exist techniques that avoid this issue, since they are
>         not universally deployed, we cannot afford to not send ICMPv4.
>
>         (Aside: I fully agree with you that we should strive to retire
>         RFC 1191. See for example slide 7 of [1]. Aside ends.)
>
>         [1]:
>         https://datatracker.ietf.org/meeting/110/materials/slides-110-babel-babel-source-specific-and-v4-via-v6-02
>         <https://datatracker.ietf.org/meeting/110/materials/slides-110-babel-babel-source-specific-and-v4-via-v6-02>.
>
>
>             (5) Perhaps obvious to some, but to forward IPv6 packets
>             there must be an IPv4 interface MTU of at least 1280 bytes
>             (the minimum for IPv6): Could something be said?
>
>         I think we're in the good case here: if an interface has IPv6
>         enabled, then its MTU must be at least 1280 octets, hence it's
>         fine to install an IPv4 route though it. (If the interface was
>         not provisioned with IPv6, then obviously it won't work to
>         install a v4-via-v6 route through it, since there's no IPv6
>         neighbour discovery protocol.)
>
>             (6) I am curiuous whether thought was given to multicast
>             routing, or whether that was out-of-scope
>
>         I've given a lot of thought to multicast (I blame Tony P.),
>         only to come to the conclusion that it's beyond my
>         intellectual capabilities. So I really have nothing useful to
>         say about multicast.
>
>             I expected something to be said.
>
>         I'm not to keen on speaking about things I don't understand,
>         so if you insist on something being said, I'll need more
>         precise guidance.
>
>     [gf] ~ I would be happy with simply stating (if it is true):
>     — This method does not support multicast forwarding. Or (if more
>     appropriate)
>     — The scope of this specification is unicast forwarding. The
>     specification does not specify support for multicast forwarding.
>
>
> I''ve been noodling on this, and AFAICT, "The scope of this 
> specification is unicast forwarding. The specification does not 
> specify support for multicast forwarding." works.
>
>
>     - or anything similar.
>
>             NiT: There was one use of /don't/ - is it worh making this
>             /do not/?
>
>
> Sure, why not….
> W
>
>
>         Fixed, thanks.
>
>         -- Juliusz
>
>     Thanks for addressing the other comment,
>
>     Gorry
>
>
:-)

Gorry