[Iot-directorate] Iotdir telechat review of draft-ietf-tsvwg-udp-options-dplpmtud-15
Henk Birkholz via Datatracker <noreply@ietf.org> Tue, 25 February 2025 09:28 UTC
Return-Path: <noreply@ietf.org>
X-Original-To: iot-directorate@mail2.ietf.org
Delivered-To: iot-directorate@mail2.ietf.org
Received: from mail2.ietf.org (mail2 [166.84.6.31]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPSA id 4A41EDFE58; Tue, 25 Feb 2025 01:28:37 -0800 (PST)
Received: from [10.244.8.229] (unknown [104.131.183.230]) by mail2.ietf.org (Postfix) with ESMTP id 17E59DFE54; Tue, 25 Feb 2025 01:28:37 -0800 (PST)
MIME-Version: 1.0
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: 7bit
From: Henk Birkholz via Datatracker <noreply@ietf.org>
To: iot-directorate@ietf.org
X-Test-IDTracker: no
X-IETF-IDTracker: 12.37.0
Auto-Submitted: auto-generated
Precedence: bulk
Message-ID: <174047571691.430438.9819833581021431622@dt-datatracker-865df477df-9x8cj>
Date: Tue, 25 Feb 2025 01:28:36 -0800
Message-ID-Hash: G4FP5RBBB46GSJVRZZABB6CTAPOJRXSI
X-Message-ID-Hash: G4FP5RBBB46GSJVRZZABB6CTAPOJRXSI
X-MailFrom: noreply@ietf.org
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: draft-ietf-tsvwg-udp-options-dplpmtud.all@ietf.org, last-call@ietf.org, tsvwg@ietf.org
X-Mailman-Version: 3.3.9rc6
Reply-To: Henk Birkholz <henk.birkholz@ietf.contact>
Subject: [Iot-directorate] Iotdir telechat review of draft-ietf-tsvwg-udp-options-dplpmtud-15
List-Id: Mailing list for the IoT Directorate Members <iot-directorate.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/iot-directorate/SONQT1rjvLJk1K05Lv2kt6ev6og>
List-Archive: <https://mailarchive.ietf.org/arch/browse/iot-directorate>
List-Help: <mailto:iot-directorate-request@ietf.org?subject=help>
List-Owner: <mailto:iot-directorate-owner@ietf.org>
List-Post: <mailto:iot-directorate@ietf.org>
List-Subscribe: <mailto:iot-directorate-join@ietf.org>
List-Unsubscribe: <mailto:iot-directorate-leave@ietf.org>
Reviewer: Henk Birkholz
Review result: Ready with Nits
I am the assigned IoT Directorate reviewer for
I-D.ietf-tsvwg-udp-options-dplpmtud-15 as part of the IoT Directorate's effort
to provide feedback to IoT-related IETF documents before being processed by the
IESG. Document authors, document editors, WG chairs, and area directors should
treat these comments just like any other WG comments.
Summary: This documents specifies how UDP fragmentation can be avoided or
better steered in the Internet, automatically, using a probing mechanism that
is enabled, by an upper layer protocol or by a UDP transport service. The
activity to avoid UDP fragmentation is called Datagram Packetization Layer Path
MTU Discovery (DPLPMTUD). The base concept of DPLPMTUD is specified in RFC 8899
and combined with the "soft control plane" transport options for UDP
illustrated in I-D.ietf-tsvwg-udp-options, thereby concertizing how UDP
fragmentation avoidance works on a "packatization-layer" (PL, see RFC 4821). In
general, the documents applies UDP guidelines from RFC 8085.
The document highlights when to use probe packets with or without application
data and the potential benefits of reducing the need to send additional UDP
datagrams during DPLPMTUD. The documentation is clear and useful for design
considerations in constrained node environments. The examples in Section 6 are
especially helpful to steer corresponding design decisions.
I've not checked the change log.
Nits:
* The Figure is not labeled and referenced in the text (but there's also just
one Figure). * This has already been highlighted, but sometimes phrasing almost
implies normative language, which might make document a tad bit challenging for
implementers to act on; two examples:
* the use of "ought to"
* phrasing, such as "padded to the required probe size"
* The four-byte (maybe avoid the term octet nowadays) token seems to act as a
nonce, but current phrasing (including SecConSec) is already pretty clear how
that works without an explicit reference to nonces.
- [Iot-directorate] Iotdir telechat review of draft… Henk Birkholz via Datatracker