[ippm] Gorry Fairhurst's Discuss on draft-ietf-ippm-asymmetrical-pkts-11: (with DISCUSS and COMMENT)
Gorry Fairhurst via Datatracker <noreply@ietf.org> Mon, 23 February 2026 13:06 UTC
Return-Path: <noreply@ietf.org>
X-Original-To: ippm@ietf.org
Delivered-To: ippm@mail2.ietf.org
Received: from [10.244.6.246] (unknown [4.156.85.76]) by mail2.ietf.org (Postfix) with ESMTP id CE4A0BC29BA1; Mon, 23 Feb 2026 05:06:59 -0800 (PST)
MIME-Version: 1.0
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: 7bit
From: Gorry Fairhurst via Datatracker <noreply@ietf.org>
To: The IESG <iesg@ietf.org>
X-Test-IDTracker: no
X-IETF-IDTracker: 12.59.0
Auto-Submitted: auto-generated
Precedence: bulk
Message-ID: <177185201977.2022033.14585945939255402557@dt-datatracker-6ff7c68975-7k42g>
Date: Mon, 23 Feb 2026 05:06:59 -0800
Message-ID-Hash: RMFXQSDCOMVBYNMYW7UK2YKRKCV6MC4C
X-Message-ID-Hash: RMFXQSDCOMVBYNMYW7UK2YKRKCV6MC4C
X-MailFrom: noreply@ietf.org
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-ippm.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: draft-ietf-ippm-asymmetrical-pkts@ietf.org, ippm-chairs@ietf.org, ippm@ietf.org
X-Mailman-Version: 3.3.9rc6
Reply-To: Gorry Fairhurst <gorry@erg.abdn.ac.uk>
Subject: [ippm] Gorry Fairhurst's Discuss on draft-ietf-ippm-asymmetrical-pkts-11: (with DISCUSS and COMMENT)
List-Id: IETF IP Performance Metrics Working Group <ippm.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/ippm/6P1U17GctWAWtdByAd9hKAvrgsk>
List-Archive: <https://mailarchive.ietf.org/arch/browse/ippm>
List-Help: <mailto:ippm-request@ietf.org?subject=help>
List-Owner: <mailto:ippm-owner@ietf.org>
List-Post: <mailto:ippm@ietf.org>
List-Subscribe: <mailto:ippm-join@ietf.org>
List-Unsubscribe: <mailto:ippm-leave@ietf.org>
Gorry Fairhurst has entered the following ballot position for draft-ietf-ippm-asymmetrical-pkts-11: Discuss When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.) Please refer to https://www.ietf.org/about/groups/iesg/statements/handling-ballot-positions/ for more information about how to handle DISCUSS and COMMENT positions. The document, along with other ballot positions, can be found here: https://datatracker.ietf.org/doc/draft-ietf-ippm-asymmetrical-pkts/ ---------------------------------------------------------------------- DISCUSS: ---------------------------------------------------------------------- Thank you for preparing this document. Thank you for the work that has been put into this document. # DISCUSS Comments Please find below some blocking DISCUSS points (easy to address), some non-blocking COMMENT points/nits (replies would be appreciated even if only for my own education). As noted in https://datatracker.ietf.org/doc/statement-iesg-handling-ballot-positions-20220121/, a DISCUSS ballot is a request to have a discussion on the points below; I really think that the document would be improved with a change here, but can be convinced otherwise. I hope that this review helps to improve the document, and allow me to update my present position: ## (1) I understand the first part, was unsure what was intended by the "focus" in the following sentence: "Multicast traffic is also intrinsically asymmetrical, and focus on the return path is usually limited." - please explain. ## (2) The document text identifies an issue, but I did not see a clear recommendation how this method would avoid or mitigate this: "Section 3.1.5 of [RFC8085] determines that a UDP congestion control SHOULD respond quickly to experienced congestion and account for loss rate and response time when choosing a new rate." * I understand that the method is to be used for testing, but there is no way to derive a new rate each RTT, and hence if inappropriately configured it still could result in significant loss/congestion to flows using the path that is being tested. I think this can be better articulated. * There is no operational guidance to suggest what to do if unexpected levels of loss/congestion are detected. * RFC7497 Paras 2 and 3 of Section 3 provides some text that could also be important. ## (3) The text citing RFC9097 isn't sufficient to protect the path from excessive congestion: "Appendix A of [RFC9097] offers sample pseudocode for a UDP load rate adjustment algorithm with congestion control." * The present text only refers only to the pseudocode. This pseudocode is a helpful and so is a useful reference. However, I expect this to be insufficient to address the congestion control concerns. * The present text does not cite and require section 8.1 of RFC9097, where the Load Rate Adjustment Algorithm is normatively defined. * This or similar sets of requirements could be a useful basis, can this be specified? ---------------------------------------------------------------------- COMMENT: ---------------------------------------------------------------------- # Thanks to Lars Eggert for his TSVART review and to the editors for an update to address these comments. # COMMENTS (non-blocking). ## Section 3.1.1 This does not presently note the impact on the SLA. IAnote be helpful to call this out in section 3.1.1 : e.g. (from [I-D.ietf-ippm-capacity-protocol]): "Service subscribers with limited data volumes who conduct extensive capacity testing might experience the effects of Service Provider controls on their service. Testing with the Service Provider's measurement hosts SHOULD be limited in frequency and/or overall volume" - This could be a particularly important consideration when performing the tests described in this document. Gorry Fairhurst
- [ippm] Gorry Fairhurst's Discuss on draft-ietf-ip… Gorry Fairhurst via Datatracker
- [ippm] Re: Gorry Fairhurst's Discuss on draft-iet… Greg Mirsky
- [ippm] Re: Gorry Fairhurst's Discuss on draft-iet… Gorry Fairhurst
- [ippm] Re: Gorry Fairhurst's Discuss on draft-iet… Greg Mirsky
- [ippm] Re: Gorry Fairhurst's Discuss on draft-iet… Gorry Fairhurst
- [ippm] Re: Gorry Fairhurst's Discuss on draft-iet… mohamed.boucadair
- [ippm] Re: Gorry Fairhurst's Discuss on draft-iet… Greg Mirsky