Re: [IPsec] CHILD_SA and PFS

Tero Kivinen <kivinen@iki.fi> Thu, 22 November 2007 14:44 UTC

Return-path: <ipsec-bounces@ietf.org>
Received: from [127.0.0.1] (helo=stiedprmman1.va.neustar.com) by megatron.ietf.org with esmtp (Exim 4.43) id 1IvDI7-0000vR-Cl; Thu, 22 Nov 2007 09:44:31 -0500
Received: from ipsec by megatron.ietf.org with local (Exim 4.43) id 1IvDI6-0000sr-LU for ipsec-confirm+ok@megatron.ietf.org; Thu, 22 Nov 2007 09:44:30 -0500
Received: from [10.90.34.44] (helo=chiedprmail1.ietf.org) by megatron.ietf.org with esmtp (Exim 4.43) id 1IvDI6-0000qJ-9u for ipsec@ietf.org; Thu, 22 Nov 2007 09:44:30 -0500
Received: from fireball.acr.fi ([83.145.195.1] helo=mail.kivinen.iki.fi) by chiedprmail1.ietf.org with esmtp (Exim 4.43) id 1IvDI5-0000id-Li for ipsec@ietf.org; Thu, 22 Nov 2007 09:44:30 -0500
Received: from fireball.kivinen.iki.fi (localhost [127.0.0.1]) by mail.kivinen.iki.fi (8.13.8/8.12.10) with ESMTP id lAMEiHga020809 (version=TLSv1/SSLv3 cipher=DHE-RSA-AES256-SHA bits=256 verify=NO); Thu, 22 Nov 2007 16:44:17 +0200 (EET)
Received: (from kivinen@localhost) by fireball.kivinen.iki.fi (8.13.8/8.12.11) id lAMEiD23016714; Thu, 22 Nov 2007 16:44:13 +0200 (EET)
X-Authentication-Warning: fireball.kivinen.iki.fi: kivinen set sender to kivinen@iki.fi using -f
MIME-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: 7bit
Message-ID: <18245.38333.693708.194754@fireball.kivinen.iki.fi>
Date: Thu, 22 Nov 2007 16:44:13 +0200
From: Tero Kivinen <kivinen@iki.fi>
To: Yoav Nir <ynir@checkpoint.com>
Subject: Re: [IPsec] CHILD_SA and PFS
In-Reply-To: <CA594A5D-DA36-4667-AB0D-E92B94B8497B@checkpoint.com>
References: <473DC1D4.5070200@certicom.com> <B356D8F434D20B40A8CEDAEC305A1F2404E1AC61@esebe105.NOE.Nokia.com> <4741B094.306@certicom.com> <7C2F574B-93DC-4F9A-BBE0-2B05524A6278@checkpoint.com> <18242.57134.201314.799049@fireball.kivinen.iki.fi> <78C4038C-89E7-48E1-8A0B-BBF26DAD5B32@checkpoint.com> <18244.21780.433641.330743@fireball.kivinen.iki.fi> <CA594A5D-DA36-4667-AB0D-E92B94B8497B@checkpoint.com>
X-Mailer: VM 7.19 under Emacs 21.4.1
X-Edit-Time: 7 min
X-Total-Time: 9 min
X-Spam-Score: 0.0 (/)
X-Scan-Signature: 9ed51c9d1356100bce94f1ae4ec616a9
Cc: ipsec@ietf.org, Pasi.Eronen@nokia.com
X-BeenThere: ipsec@ietf.org
X-Mailman-Version: 2.1.5
Precedence: list
List-Id: Discussion of IPsec protocols <ipsec.ietf.org>
List-Unsubscribe: <https://www1.ietf.org/mailman/listinfo/ipsec>, <mailto:ipsec-request@ietf.org?subject=unsubscribe>
List-Post: <mailto:ipsec@ietf.org>
List-Help: <mailto:ipsec-request@ietf.org?subject=help>
List-Subscribe: <https://www1.ietf.org/mailman/listinfo/ipsec>, <mailto:ipsec-request@ietf.org?subject=subscribe>
Errors-To: ipsec-bounces@ietf.org

Yoav Nir writes:
> PFS is different.  For other attributes, if the SPD entry says you  
> need, say, 3DES, and the other side's SPD entry says AES-128-GCM, then  
> you'll fail every time.  If you succeed, then your policies are matched.

Not really.

If your clients SPD says:

Local		Remote		Action
-----		------		------
192.168.2.1	10.0.0.0/8	PROTECT(ESP,AES)

and the servers SPD says:

Local		Remote		Action
-----		------		------
10.0.0.2	192.168.2.1	PROTECT(ESP,3DES)
10.0.0.0/8	192.168.2.1	PROTECT(ESP,AES)

Then if you happen to send first packet from client to 10.0.0.5
addres, the client will negotiate ESP IPsec SA with AES, and with
traffic selectors TSi = (192.168.2.1-192.168.2.1), TSr =
(10.0.0.0-10.0.0.1, 10.0.0.3-10.0.0.255), as the server will narrow it
down to that when proposed clients traffic selectors.

Now if the either end tries to negotiate SA between 192.168.2.1 and
10.0.0.2 that will fail. 

> With PFS is different.  One side can have an SPD entry saying PFS is a  
> must. The other SPD entry says PFS is must not. At any time except  
> during the initial exchange, this will fail, and rightly so - so the  
> users fix the problem.  But if it's in the initial exchange, it  
> suddenly succeeds. This practically guarantees usability problems for  
> any implementation.

PFS is no different there. It is just like any similar policy mismatch
error. In the case above the user thinks he has ok policy as he can
use most of the services from the office network, but for some reason
he cannot connect to the 10.0.0.2 server, even when everything else
works. 
-- 
kivinen@safenet-inc.com


_______________________________________________
IPsec mailing list
IPsec@ietf.org
https://www1.ietf.org/mailman/listinfo/ipsec