[IPv6]Re: Mail regarding draft-mishra-6man-variable-iids

Mark Smith <markzzzsmith@gmail.com> Thu, 12 September 2024 06:02 UTC

Return-Path: <markzzzsmith@gmail.com>
X-Original-To: ipv6@ietfa.amsl.com
Delivered-To: ipv6@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 33BAAC1CAE69; Wed, 11 Sep 2024 23:02:40 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -0.149
X-Spam-Level:
X-Spam-Status: No, score=-0.149 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, FREEMAIL_FROM=0.001, FREEMAIL_REPLY=1, FROM_LOCAL_NOVOWEL=0.5, GB_SUMOF=5, HK_RANDOM_ENVFROM=0.001, HK_RANDOM_FROM=0.455, RCVD_IN_DNSWL_HI=-5, RCVD_IN_ZEN_BLOCKED_OPENDNS=0.001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001, T_SCC_BODY_TEXT_LINE=-0.01, URIBL_BLOCKED=0.001, URIBL_DBL_BLOCKED_OPENDNS=0.001, URIBL_ZEN_BLOCKED_OPENDNS=0.001] autolearn=no autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (2048-bit key) header.d=gmail.com
Received: from mail.ietf.org ([50.223.129.194]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id EcrJJbBwdLP3; Wed, 11 Sep 2024 23:02:36 -0700 (PDT)
Received: from mail-pj1-x102f.google.com (mail-pj1-x102f.google.com [IPv6:2607:f8b0:4864:20::102f]) (using TLSv1.3 with cipher TLS_AES_128_GCM_SHA256 (128/128 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 5EF40C1840F2; Wed, 11 Sep 2024 23:02:36 -0700 (PDT)
Received: by mail-pj1-x102f.google.com with SMTP id 98e67ed59e1d1-2d8815ef6d2so487299a91.0; Wed, 11 Sep 2024 23:02:36 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20230601; t=1726120956; x=1726725756; darn=ietf.org; h=content-transfer-encoding:cc:to:subject:message-id:date:from :in-reply-to:references:mime-version:from:to:cc:subject:date :message-id:reply-to; bh=gKxuyIRvWJQ+nE0baBArVyUR3tExWCQlvqFXakxJzFU=; b=cVIKSJo7vLu9jJBVe3HjZBIdTgz9V0KKJpyR57TV1SseSqGaeD51vUAzauuXYVXieU dyGWYVqsyra2oMMCRAt/8L/VFlrz70/O71+iSTg6SYJIfsa2ejovLebZERHfxEQMVw3N w8Bv8YMDqR0DrRD8tDyWRgtDq37r0LvhE6Z3553jpqb82FTgw7jCdjpA2ouzllG7NeRb ZLhH3ZpG9b7Vveljxarll3y8iFtir4spI3D0YQhLZDizTYrodsPSssGYvrr3bA2S1A5a 6ElVRefYf8UBpvdlr61xuwsydSL2NpWy65T0AflZApGEYksXYRLli3o4PiQfpeEFmL/v fhKA==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20230601; t=1726120956; x=1726725756; h=content-transfer-encoding:cc:to:subject:message-id:date:from :in-reply-to:references:mime-version:x-gm-message-state:from:to:cc :subject:date:message-id:reply-to; bh=gKxuyIRvWJQ+nE0baBArVyUR3tExWCQlvqFXakxJzFU=; b=mzMu9Q8DydPveRSP0xaMDewVvIHWlWFhQDTnc4ZFY3aoz2/ge0SwgueeZFEMKvM5u8 wGXcTPEivGQB4/KXqMGsEXkVkOjwPHqXfMfDl+b1V0LzgFRUgj77t7HAze3XcfcnQ3zS U570xf1mIKnEpSIbjjAbwXKE4D1xYcNnKT813TFBNkaMUwGeL7/Cb5bLNTwgmgHko5Qk 8GQrWSNbQSMphy97KB0Ie+R3y1yREvvpkgzl6cwPTSIdMn7wHBAOBbYQVpSOJx0+nwE7 DhyRy77C1R9WYkBlFBJ/GU7JuADy7FhNxH+MpdmbVeUg1bKkKAoVWv/BA59pCg7E1Xrj +Myg==
X-Forwarded-Encrypted: i=1; AJvYcCUDxN90OMiJqsw4tLjno40qJ9Wp6Fr0Ratd3soIhVXNsBkfuJDrOtLgJgoRvPNHkyUkeHke6y8n99Zsi4WtJPJ2JbgqVsA6Ko4JdutD2ME4nQ==@ietf.org, AJvYcCV+fUPze+cpz2RRg2z0PgOlFGvzwJQoR4xO5W9AEVVbOvtLWizPfXXZzriUlgHz4rJJEXvk@ietf.org
X-Gm-Message-State: AOJu0YwmUdL5d+kfx+G9nVEKpD3T3+O/OegUf5FIVPd4VaDxScQRgHRN z6j6fmvDo4SIgw6bcZAQoJTvC/1Ff5R2RWKc3sY/uYvpdpaYzRxIZoukUR9R0dfzoZpoHOd0o2o iksD8BjONVzE9n2abMDL57qjfSHI=
X-Google-Smtp-Source: AGHT+IE3HfeY//qRNILFKX+JuqBUzUSlpHnv0Im2GebviwhG9zrqdL5t8C8am+Qob2VlOiVuHIvbNI/E/aEOT+N+ge4=
X-Received: by 2002:a17:90a:46cb:b0:2da:5d71:fbc with SMTP id 98e67ed59e1d1-2db9ffcc71emr1973747a91.16.1726120955453; Wed, 11 Sep 2024 23:02:35 -0700 (PDT)
MIME-Version: 1.0
References: <CAAHCKi8QOfz+SmzYo6S2hPb7_MEtwMqjL+TzTbbJyiGncL-88w@mail.gmail.com> <CABNhwV3P3eeAdAb7Lbr7NygTasvVW7mNwLTwA1nm5OGE0WMGbQ@mail.gmail.com> <CAAHCKi-WZwP6dWsEhA8kr-hJJK-_37vTxq5+hpZCcvSQBt_SbA@mail.gmail.com> <CAO42Z2zJrBbxCv-PRJwC1DBA28D3OLECDG5aAJfQ1VUJyLdRrw@mail.gmail.com> <fb59e788-72ab-4c4d-b55a-dd6402ff5a32@gmail.com>
In-Reply-To: <fb59e788-72ab-4c4d-b55a-dd6402ff5a32@gmail.com>
From: Mark Smith <markzzzsmith@gmail.com>
Date: Thu, 12 Sep 2024 16:02:07 +1000
Message-ID: <CAO42Z2y1u2SWtRzyC2Ee8w39_B1iyr_VD0mKKArtX=vx_oQUAA@mail.gmail.com>
To: Brian E Carpenter <brian.e.carpenter@gmail.com>
Content-Type: text/plain; charset="UTF-8"
Content-Transfer-Encoding: quoted-printable
Message-ID-Hash: PAMFUYDRJGQBQRNPBLGG3BS5LDDUJFAP
X-Message-ID-Hash: PAMFUYDRJGQBQRNPBLGG3BS5LDDUJFAP
X-MailFrom: markzzzsmith@gmail.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-ipv6.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: Nagendra Kumar <nagendrakumar.nainar@gmail.com>, draft-mishra-6man-variable-iids@ietf.org, 6MAN <6man@ietf.org>
X-Mailman-Version: 3.3.9rc4
Precedence: list
Subject: [IPv6]Re: Mail regarding draft-mishra-6man-variable-iids
List-Id: "IPv6 Maintenance Working Group (6man)" <ipv6.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/ipv6/p40ckTiOt92RvsnCXsAQl9rQhYU>
List-Archive: <https://mailarchive.ietf.org/arch/browse/ipv6>
List-Help: <mailto:ipv6-request@ietf.org?subject=help>
List-Owner: <mailto:ipv6-owner@ietf.org>
List-Post: <mailto:ipv6@ietf.org>
List-Subscribe: <mailto:ipv6-join@ietf.org>
List-Unsubscribe: <mailto:ipv6-leave@ietf.org>

Hi Brian,

On Thu, 12 Sept 2024 at 14:44, Brian E Carpenter
<brian.e.carpenter@gmail.com> wrote:
>
> On 12-Sep-24 15:56, Mark Smith wrote:
> > Hi,
> >
> > What evidence is there that this is needed?
> >
> > The claim seems to be that IPv6 address space will run out in the near future, so it is necessary to start using 64 bit IID bits as prefix bits.
>
> No, it's that there are use cases in which subnetting a /64 is necessary as a practical matter. That is an operational assertion, hence the v6ops draft.
>

The "practical" reasons for subnetting a /64 only exist in networks
that have been precious with their IPv6 space, because they're
habitually treating IPv6 address space like they've needed to treat
IPv4's for the past few decades, rather than being objective.

By trying to accommodate those networks we're endorsing their
irrationality about how big IPv6's address space really is, and we're
imposing costs onto those who are being rational. They will be
indirectly bearing the costs of host and router upgrades to support
subdividing 64 bit IIDs, even though they haven't incurred those
costs.

Regards,
Mark.

>     Brian
>
> >
> > Why aren't IANA and the RIRs raising IPv6 address space exhaustion as an issue?
> >
> > Why has a /20 just been allocated for documentation if IPv6 address space is now already precious, despite IPv6 not being deployed as much as IPv4?
> >
> > Regards,
> > Mark.
> >
> >
> > On Thu, 12 Sept 2024, 12:52 Nagendra Kumar, <nagendrakumar.nainar@gmail.com <mailto:nagendrakumar.nainar@gmail.com>> wrote:
> >
> >     Hi Gyan,
> >
> >     Thank you for the response.
> >
> >     Gyan> Correct. The assumption is the key here as in the draft we call “modified host” that are upgraded and support variable IID and that is where the Reserved2 comes into play to signal to hosts the encoded IID length to be generated by the host OS so that the appropriate shorter IID is now generated.
> >
> >     <Nagendra> Do you mean the host may have options to generate IID of varying size and the Reserved2 field based IID length advertisement will help identify the size required?. Or did I misunderstood?. Cant we have the prefix-length field as a way to identify the IID. IOW, (assuming I understood your comment), the host can use the prefix-length field to derive the IID length and can use the local/relevant mechanism to generate the IID of the required size.
> >
> >     Gyan> I agree with what you are saying above except for the fact that the host needs to support generating the shorter IID and must know when to support it which must be signaled by the network so it can accept the PIO and generate the host IPv6 address with variable IID.  AFAIK it is the same reasoning as above mentioned necessity for signaling to the host to variable IID in the Reserved2 field by overriding the “MUST” be ignored behavior for “modified” hosts.
> >
> >     <Nagendra> The "MUST" ignore statement is applicable only if the Prefix-Length + IID-Length is not equal to 128. In a heterogeneous scenario with HostA(modified) and HostB(legacy), I see the below possible options:
> >
> >     Option 1 - Using prefix-length field
> >
> >     Both will receive RA-PIO1 with [prefix1, prefix-length more than 64]. HostB will ignore and HostA will configure the IPv6 addr.
> >     Both will receive RA-PIO2 with [prefix2, prefix-length = 64]. HostB will configure the IP and HostA will decide based on the local config (ignore vs assign IPv6 from this prefix2 as well)
> >
> >     Option 2 - Using Reserved2 field
> >
> >     Both will receive RA-PIO1 with [prefix1, prefix-length = 64, Reserved2=Modified_Flags]. HostB will ignore and HostA will configure the IPv6 addr.
> >     Both will receive RA-PIO2 with [prefix2, prefix-length = 64, Reserved2=0]. HostB will configure the IP and HostA will decide based on the local config (ignore vs assign IPv6 from this prefix2 as well)
> >
> >     I think they both will serve the purpose but the former doesn't need changes to the Reserved field. Please correct me if I am missing something.
> >     Gyan> The details of the IID computation would be as you mentioned a non EUI64 format IID and would support both RFC 4941 privacy extension or RFC 7217 stable IID & RFC 8064.  We can add some more details on this into the draft in the next revision.
> >
> >     <Nagendra> Thanks for the clarification. I noticed some linux variants allow us configuring tokenized IID with subnet-mask. But I wasnt sure how the linux will react if it receives a RA-PIO with prefix-length more than 64.
> >
> >          Gyan> I think that could be possible.  Can you give an example of the use case of how that flexibility would be utilized.
> >
> >     <Nagendra>  In scenarios involving an end host connected to an edge router using P2P, the edge router generating the RA can be configured to use the first IP of the prefix. The host upon receiving the RA will have both the source address of the router and the prefix. It can use any of the remaining address in the prefix.
> >
> >     For example, RtrA----HostB is configured with prefix AAAA:BBBB:CCCC:DDDD:EEEE:1111:2222::/112
> >     RtrA assigns AAAA:BBBB:CCCC:DDDD:EEEE:1111:2222::1 and advertise AAAA:BBBB:CCCC:DDDD:EEEE:1111:2222::/112 with SA = AAAA:BBBB:CCCC:DDDD:EEEE:1111:2222::1. The host can simply choose any other address within the prefix. This may need some mechanism for the host to understand that this is P2P and it is safe to choose another address. A wild thought that popped up while exploring the options.
> >
> >     Thanks,
> >     Nagendra
> >
> >
> >
> >     On Mon, Sep 9, 2024 at 11:07 PM Gyan Mishra <hayabusagsm@gmail.com <mailto:hayabusagsm@gmail.com>> wrote:
> >
> >
> >         Hi Nagendra
> >
> >         Many thanks for your comments.
> >
> >         FYI - I will be starting up some new threads on both 6MAN and v6OPS on the feedback we received during IETF 120.
> >
> >
> >         Responses in-line
> >
> >         On Mon, Sep 9, 2024 at 7:55 PM Nagendra Kumar <nagendrakumar.nainar@gmail.com <mailto:nagendrakumar.nainar@gmail.com>> wrote:
> >
> >             Hi Authors,
> >
> >             We had some use case scenario that we brainstormed recently to use a prefix-length greater than /64. So I spent some time reading this draft and want to share my thoughts as below.
> >
> >
> >              Gyan> Can you elaborate on your use case scenarios?
> >
> >
> >
> >             As per RFC4861, a value of more than 64 in the "Prefix Length" field is technically not a violation. As mentioned in RFC4862 (Section 5.5.3), as long the sum of prefix-length and IID is equal to 128, it is a valid RA. The expectation (or assumption) here is that the host must have the ability to compute a non-EUI-64 format IID of length less than /64 and append to the prefix (of size more than 64) received in the RA.
> >
> >
> >              Gyan> Correct. The assumption is the key here as in the draft we call “modified host” that are upgraded and support variable IID and that is where the Reserved2 comes into play to signal to hosts the encoded IID length to be generated by the host OS so that the appropriate shorter IID is now generated.
> >
> >
> >             So I was wondering why not use the same?. I understand the challenges associated to the backward compatibility. But Tte proposal address the heterogenous scenario involving both supported and unsupported host by assigning 2 prefixes and advertise 2 PIO - one with Reserved2=0 and other with Reserved2=0+IID. I think we can achieve the same without modifying the Reserved2 field. We can advertise 2 RA-PIO with different prefix and different length. Host that does not support IID less than /64 will ignore that prefix and configure the prefix with length /64.
> >
> >
> >              Gyan> I agree with what you are saying above except for the fact that the host needs to support generating the shorter IID and must know when to support it which must be signaled by the network so it can accept the PIO and generate the host IPv6 address with variable IID.  AFAIK it is the same reasoning as above mentioned necessity for signaling to the host to variable IID in the Reserved2 field by overriding the “MUST” be ignored behavior for “modified” hosts.
> >
> >
> >
> >             The draft doesnt mention anything about the IID computation and I assume it is left to the host implementation. Do you have anything in mind or aware of any existing method that might be worth referring here?
> >
> >
> >             Gyan> The details of the IID computation would be as you mentioned a non EUI64 format IID and would support both RFC 4941 privacy extension or RFC 7217 stable IID & RFC 8064.  We can add some more details on this into the draft in the next revision.
> >
> >
> >
> >             I also think there are scenarios where the host connection is P2P and doesnt have more than 1 host connected (and so part of) to the link. Can we use a combination of prefix-length and the source-address of the RA-PIO to let the host choose any address from the prefix other than the router address?.
> >
> >
> >                 Gyan> The details of the IID computation would be as you mentioned a non EUI64 format IID and would support both RFC 4941 privacy extension or RFC 7217 stable IID & RFC 8064.  We can add some more details on this into the draft in the next revision.
> >
> >
> >
> >             Few quick typo noticed are below:
> >
> >             s/Exmaple/Example
> >             s/Terminolgoy/Terminology
> >             s/Modifiled/Modified
> >
> >
> >             Many Thanks!
> >
> >              Gyan
> >
> >
> >
> >             Thanks,
> >             Nagendra
> >             --------------------------------------------------------------------
> >             IETF IPv6 working group mailing list
> >             ipv6@ietf.org <mailto:ipv6@ietf.org>
> >             List Info: https://mailman3.ietf.org/mailman3/lists/ipv6@ietf.org/ <https://mailman3.ietf.org/mailman3/lists/ipv6@ietf.org/>
> >             --------------------------------------------------------------------
> >
> >     --------------------------------------------------------------------
> >     IETF IPv6 working group mailing list
> >     ipv6@ietf.org <mailto:ipv6@ietf.org>
> >     List Info: https://mailman3.ietf.org/mailman3/lists/ipv6@ietf.org/ <https://mailman3.ietf.org/mailman3/lists/ipv6@ietf.org/>
> >     --------------------------------------------------------------------
> >
> >
> > --------------------------------------------------------------------
> > IETF IPv6 working group mailing list
> > ipv6@ietf.org
> > List Info: https://mailman3.ietf.org/mailman3/lists/ipv6@ietf.org/
> > --------------------------------------------------------------------