[Jcardcal] Re: [Technical Errata Reported] RFC7265 (9035)
Andy Newton <andy@hxr.us> Thu, 30 July 2026 19:05 UTC
Return-Path: <andy@hxr.us>
X-Original-To: jcardcal@mail2.ietf.org
Delivered-To: jcardcal@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id 2089F12139C7A for <jcardcal@mail2.ietf.org>; Thu, 30 Jul 2026 12:05:40 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=ietf.org; s=ietf1; t=1785438340; bh=zXlksWZP33X5cgQZcpOqzKWwTigVLd0YLXBkH4Y74xs=; h=Date:Subject:To:Cc:References:From:In-Reply-To; b=DkX3XoHzHDvQ6ocQpFuCrG6FVCHpIt2MOx+oLknTOtZpYir1yhFDXLoCGxKHAwVCG OSMSteoCw3TRla+W/ehWFg1UXPelu2kViNZminaJUbboe+X3gVCNQ5FT4oolFw4oDw 530bDBvTi5+PmKdrdlKFEDhdmAuW0J/psq2vJAWk=
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -1.898
X-Spam-Level:
X-Spam-Status: No, score=-1.898 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, RCVD_IN_DNSWL_NONE=-0.0001, SPF_HELO_NONE=0.001, SPF_NONE=0.001] autolearn=ham autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=pass (2048-bit key) header.d=hxr-us.20251104.gappssmtp.com
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id xFHGANfivuVk for <jcardcal@mail2.ietf.org>; Thu, 30 Jul 2026 12:05:39 -0700 (PDT)
Received: from mail-qk1-x72a.google.com (mail-qk1-x72a.google.com [IPv6:2607:f8b0:4864:20::72a]) (using TLSv1.3 with cipher TLS_AES_128_GCM_SHA256 (128/128 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id A737F12139B02 for <jcardcal@ietf.org>; Thu, 30 Jul 2026 12:05:19 -0700 (PDT)
Received: by mail-qk1-x72a.google.com with SMTP id af79cd13be357-92e602d2c0fso75242185a.0 for <jcardcal@ietf.org>; Thu, 30 Jul 2026 12:05:19 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=hxr-us.20251104.gappssmtp.com; s=20251104; t=1785438319; x=1786043119; darn=ietf.org; h=content-transfer-encoding:content-type:in-reply-to:from :content-language:references:cc:to:subject:user-agent:mime-version :date:message-id:from:to:cc:subject:date:message-id:reply-to :content-type; bh=5/W4T109AMd1oc9JkgkbjHWK33f71R+p6rFGamCc2QU=; b=W7DFHuGQpDySHlPRKRLhfQgc+ijdRl5qFXyai2NlSiTH9ceuAC0acMnafWb//HSTED SKqJYswdgSCRlS/DPnfzHxBOUTUPt5WhISLRPEBB/oAU+a/ZDNsoHwfKktheIs/NY6gI mprdeNvsL85X7f2PA4oSkk7VoLOXPvPucoADwKicpaoUgEY2cxYG235cShiJCu80nbD4 Xo8aU8cpjIGrFKn3XtYIi6TgQVOTzAor4APkuLx3Jq/qD1oN/xz7oIKYQa6wdL5ZEKkR ht5YJ67nwBaaH83okyri3XlUGLCL3uI+AmMmZb23HWOYPJ9ICg9Wy29HI0rDbOxg9Uub IR0Q==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20251104; t=1785438319; x=1786043119; h=content-transfer-encoding:content-type:in-reply-to:from :content-language:references:cc:to:subject:user-agent:mime-version :date:message-id:x-gm-gg:x-gm-message-state:from:to:cc:subject:date :message-id:reply-to:content-type; bh=5/W4T109AMd1oc9JkgkbjHWK33f71R+p6rFGamCc2QU=; b=nxofZ9tgwB9xXSmLxk0c0W7KDuIMIHSyCsz/XMMjlH2NTXRVFyJCEptRikBle8RkZR k3qzHukXcwo/0gjlJnQPlQ0JLcng1T4EmqOLNJdrWUmYd6fGxuIlHUaIbJtIypmzrHGh +3VHNhlPv1SLdwU3K641UzSOrOt/gB1kl0l8YCL0gN0IQmrbtDN/DZBGnDqSzyRqpl82 8U5TcUdwJJALbfXUR8qfqrEevKFAisVLaK0zIIf7DfQQqBMXhh6Lr9+G9BlRj2r/KEqF GgIlY8QLq01VaPOixknVOIfK3su7sdm5pbIexHrqVyDXG1YvXzWsBd2wm5Fgi1e/binw 706g==
X-Forwarded-Encrypted: i=1; AHgh+RohKeI+ZC8JZbOM8iKK2vNDvSBS7v0oh0qU9nOweVdTGgXNIeNQppM+dQB7MbQ0kSflrveMYyPQbg==@ietf.org
X-Gm-Message-State: AOJu0YwtMqi6g8WoWEmxnXhsP5NHtoyqM2jItG8qXqh27FaQwM7LSA7U p5WQ5LFjX6uKQS8mGLaOH0jEHFSjORbB6kLKi9fOs111hE18c++2edtUbzamtMU6JoI=
X-Gm-Gg: AR+sD13ODPS1RuKXQNVoMMBX1B5QMzuKwZzgEQQWhTEZ5Wo1HZsEBJ0L6scQCPwkSaP Od7nO6VVQH3KjBmmY6k3iK8XbPy14GLbYjryF5o1/PuTthcs/8GCyUjHH1jHgG57iYE6RbDlGhv fCQgpUXsTCFUA3rr7jhDOuX5dGcYjlCqTItRy/948aMSm4Jy+s4byxehhgmn0dYBhYPyNKmQrzR 7g+VyfsiI+Suyk9/uE2fKo6h1fF0OwsOrrOAGeSCdDsObhSyoI3RdUezqU+rqG8su+Ig7645y1U geVa54var3xDzk6Jz0EYczrjNLZkWF1/bcNre7UsoMTkFDQqh0HffCk27oKNlz8DxTWZT4rJux8 C21MSWeU1W5zE1qP7bxj91v/vc/qfWi6x2d9DJZy+VsLP1l5jtypgVm6iNvjPxxdgwxgIAWhfJm y6fUxp8rXfb3hvbOS7zrZMgTizgiazkOqyjvPanp9hchCqByZgn89OlNLgpaeuTzlSs8OlULszJ rCZHeLepOnPLLk843VAvwS6paky5Dw0H9VJw4TG7d8cUirxd7wMkYVFIoqHPBIMINmF1Ss6VCFl 9w==
X-Received: by 2002:a05:620a:2b90:b0:925:dce9:4773 with SMTP id af79cd13be357-9348e95e758mr200075285a.35.1785438319120; Thu, 30 Jul 2026 12:05:19 -0700 (PDT)
Received: from [10.47.61.54] (47-236.dc.icann.org. [192.0.47.236]) by smtp.gmail.com with ESMTPSA id af79cd13be357-933d3264577sm474285285a.17.2026.07.30.12.05.18 (version=TLS1_3 cipher=TLS_AES_128_GCM_SHA256 bits=128/128); Thu, 30 Jul 2026 12:05:18 -0700 (PDT)
Message-ID: <027d69cd-1dec-4ce0-a93d-86baa17fe512@hxr.us>
Date: Thu, 30 Jul 2026 15:05:18 -0400
MIME-Version: 1.0
User-Agent: Mozilla Thunderbird
To: rfc-editor@rfc-editor.org, resnick@episteme.net, stpeter@jabber.org, douglm@rpi.edu, mozilla@kewis.ch, cyrus@daboo.name, eckelcu@cisco.com
References: <178490952668.12.3718308207634902951@rfc-editor.org>
Content-Language: en-US
From: Andy Newton <andy@hxr.us>
In-Reply-To: <178490952668.12.3718308207634902951@rfc-editor.org>
Content-Type: text/plain; charset="UTF-8"; format="flowed"
Content-Transfer-Encoding: 8bit
Message-ID-Hash: PALW52M4LBNV62TEKNZSRSHNFM4TV2XJ
X-Message-ID-Hash: PALW52M4LBNV62TEKNZSRSHNFM4TV2XJ
X-MailFrom: andy@hxr.us
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-jcardcal.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: hugo@lysator.liu.se, jcardcal@ietf.org
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [Jcardcal] Re: [Technical Errata Reported] RFC7265 (9035)
List-Id: JSON data formats for vCard and iCalendar WG <jcardcal.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/jcardcal/yA5TIzzzOO6cnViIVZSQHhU9vhY>
List-Archive: <https://mailarchive.ietf.org/arch/browse/jcardcal>
List-Help: <mailto:jcardcal-request@ietf.org?subject=help>
List-Owner: <mailto:jcardcal-owner@ietf.org>
List-Post: <mailto:jcardcal@ietf.org>
List-Subscribe: <mailto:jcardcal-join@ietf.org>
List-Unsubscribe: <mailto:jcardcal-leave@ietf.org>
Hi Authors, I have been burned enough by ABNF erratum that I tend to mark them Hold For Document Update unless somebody can strongly attest that the working group truly meant this at the time of doc approval. What say you? -andy, ART AD On 24-07-2026 12:12 PM, rfc-editor@rfc-editor.org wrote: > The following errata report has been submitted for RFC7265, > "jCal: The JSON Format for iCalendar" > > -------------------------------------- > You may review the report below and at: > https://errata.rfc-editor.org/eid9035/ > > -------------------------------------- > Type: Technical > Reported by: Hugo Hörnquist <hugo@lysator.liu.se> > > Section Appendix A says: > > Original Text > ------------- > param-value = string / param-multi > param-multi = begin-array > [ string *(value-separator string) ] > end-array > > Corrected Text > -------------- > param-value = string / param-multi > param-multi = begin-array > string *(value-separator string) > end-array > > Notes > ----- > The current syntax allows empty parameter arrays, however, iCalendar > (RFC 5545) doesn't support empty arrays, instead treating it as a > single empty string. This breaks the one-to-one mapping between > iCalendar and jCal. > > Compare with the excerpt from RFC 5545 > > param = param-name "=" param-value *("," param-value) > param-value = paramtext / quoted-string > paramtext = *SAFE-CHAR > > Instructions: > ------------- > This erratum is currently posted as "Reported". Please > use "Reply All" to discuss whether it should be verified or > rejected. When a decision is reached, the verifying party > will log in to change the status and edit the report, if necessary. > > -------------------------------------- > RFC7265 (draft-ietf-jcardcal-jcal) > -------------------------------------- > Title : jCal: The JSON Format for iCalendar > Publication Date : May 2014 > Author(s) : P. Kewisch, C. Daboo, M. Douglass > Category : Proposed Standard > Source : jcardcal (app) > Stream : IETF > Verifying Party : IESG
- [Jcardcal] Re: [Technical Errata Reported] RFC726… Andy Newton
- [Jcardcal] Re: [Technical Errata Reported] RFC726… Philipp Kewisch