[Last-Call] Re: Last Call: <draft-ietf-opsawg-rfc5706bis-09.txt> (Guidelines for Considering Operations and Management in IETF Specifications) to Best Current Practice
Jeffrey Haas <jhaas@pfrc.org> Mon, 19 October 2026 13:27 UTC
Received: from prospero.pfrc.org (prospero.pfrc.org [IPv6:2a02:4780:2d:e7d4::1]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange x25519 server-signature ECDSA (prime256v1) server-digest SHA256) (No client certificate requested) by mx.ietf.org (Postfix) with ESMTPS id 82E954B; Mon, 19 Oct 2026 13:27:28 +0000 (UTC)
Authentication-Results: mx.ietf.org; dkim=pass header.d=pfrc.org header.s=prospero20250622 header.b=fu0gr98j; spf=pass (mx.ietf.org: domain of jhaas@pfrc.org designates 2a02:4780:2d:e7d4::1 as permitted sender) smtp.mailfrom=jhaas@pfrc.org; dmarc=pass (policy=none) header.from=pfrc.org
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=pfrc.org; s=prospero20250622; t=1792416441; bh=Bsh6gIGNmmyHn2f6JxEG01G0uDSF/pvM2rtyuR8iU/0=; h=Date:Subject:To:References:From:In-Reply-To:From; b=fu0gr98jKFK74EZlwb/2GTiXlMV5ICAZz0FCuhd3Laf9X+KlFVEaLFZNd2Ejp+klh BLqIHgjI/ykB/BIkNSIlVM4ZwSv3HhFye8n6RUtrppcKtjzP/BJtKyRlAXn7dl9k8B b29eLKteeTjv/PnKcSLTGujvgEVIkHRuHzprjubW8qbEJjqP9ns0hwp7gsVX7+WiYV D/cA1QaINizSCy72EOFUAyogZ82keXJdj6/jPflufa5QE9BmG1T0VjFZlq+C8HdUNo gnXvUbhUh8wI0yFssNMqGNVbZVgFCpzgsknoBRjblZl420ejvOrjDWlNYg5jkDmtvz O5ev+idJ0zMyQ==
Received: from [IPV6:2a06:5900:80d6:e000:5036:870c:fbfa:ee6b] (unknown [IPv6:2a06:5900:80d6:e000:5036:870c:fbfa:ee6b]) by prospero.pfrc.org (Postfix) with ESMTPSA id AA5E48011F; Mon, 19 Oct 2026 13:27:21 +0000 (UTC)
Message-ID: <cbe40ee7-22ea-4e29-80b7-eeead99ab4d5@pfrc.org>
Date: Mon, 19 Oct 2026 14:27:19 +0100
MIME-Version: 1.0
User-Agent: Mozilla Thunderbird
To: last-call@ietf.org, opsawg@ietf.org
References: <179149535840.183753.15372769867083173690@dt-datatracker-678f7b55dd-z6pql>
Content-Language: en-US
From: Jeffrey Haas <jhaas@pfrc.org>
In-Reply-To: <179149535840.183753.15372769867083173690@dt-datatracker-678f7b55dd-z6pql>
Content-Type: text/plain; charset="UTF-8"; format="flowed"
Content-Transfer-Encoding: 8bit
X-Spamd-Bar: -----------------------
Message-ID-Hash: 5HTMXEMKT3QS2EWZXAJB7WWIEJ3WVUT2
X-Message-ID-Hash: 5HTMXEMKT3QS2EWZXAJB7WWIEJ3WVUT2
X-MailFrom: jhaas@pfrc.org
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; loop; banned-address; emergency; member-moderation; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
X-Mailman-Version: 3.3.10
Precedence: list
Subject: [Last-Call] Re: Last Call: <draft-ietf-opsawg-rfc5706bis-09.txt> (Guidelines for Considering Operations and Management in IETF Specifications) to Best Current Practice
List-Id: IETF Last Calls <last-call.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/last-call/kPyq7UBUDeeKlSWIgHe-PtslHi0>
List-Archive: <https://mailarchive.ietf.org/arch/browse/last-call>
List-Help: <mailto:last-call-request@ietf.org?subject=help>
List-Owner: <mailto:last-call-owner@ietf.org>
List-Post: <mailto:last-call@ietf.org>
List-Subscribe: <mailto:last-call-join@ietf.org>
List-Unsubscribe: <mailto:last-call-leave@ietf.org>
This e-mail documents my objections to the publication of this document as an RFC. It repeats points raised during earlier discussions of the document's contents. While I find that the document contains a significant amount of accumulated wisdom, it will result in another bit of bloat-ware being attached to the IETF RFC process. The authors did move much of the "checklist" discussion into a less normative bit of work. However, I still find it likely that future directorates and IESGs will take the presence of such a list and turn it into part of the mandatory process. On the somewhat charitable thought that the future IESG doesn't put us into checklist purgatory, many of the underlying considerations are still problematic for document streams regularly produced by many working groups. Such considerations manifest typically when a set of reviewers are participating in that technology perhaps for the first time as part of last call processes. A perennial example are security reviewers who, not finding the entire landscape of a particular security space addressed in a small "patch" document, nor prior considerations they find satisfactory in prior RFCs, request the entire landscape be addressed in the patch document. Similar considerations may apply for elements such as YANG models that may not have sufficient base coverage in the working group to request the related extension in the patch document. These issues are often summarized as "please stop asking us to boil the ocean to make this one cup of tea". A secondary consideration, especially for patch documents, is in the service of document paucity. Simple and otherwise clear proposals often find themselves lost in a sea of boilerplate. As noted in other last call comments from TSV, when a feature may serve multiple operational scenarios, the simple ideas may find themselves suffocated by trying to address every reviewer's idea of what is an appropriate operational scenario. I will make particular note of the long-standing pattern when drafts accumulate use case scenarios during initial working group discussion - only to have later reviewers, directorates, and the IESG ask for the use cases to be stripped. I find this pattern likely to be repeated for the plethora of operational scenarios many of our features are likely to address. (I would offer the work leading to RFCs 9871 and 9832 in IDR as examples.) I'm supportive of this document being progressed if the mandatory and prescriptive nature of the contents is moved to be advisory procedure. -- Jeff On 10/8/26 22:35, The IESG wrote: > The IESG has received a request from the Operations and Management Area > Working Group WG (opsawg) to consider the following document: > 'Guidelines for Considering Operations and Management in IETF > Specifications' > <draft-ietf-opsawg-rfc5706bis-09.txt> as Best Current Practice > > The IESG plans to make a decision on this document in the coming weeks, and > solicits last-call comments. Please send substantive comments to the > last-call@ietf.org mailing list, with opsawg@ietf.org copied, no later than > 2026-10-22. Please retain the beginning of the Subject line to facilitate > automated sorting. > > Abstract > > New Protocols and Protocol Extensions are best designed with due > consideration of the functionality needed to operate and manage them. > Retrofitting operations and management considerations is suboptimal. > The purpose of this document is to provide guidance to authors and > reviewers on what operational and management aspects should be > addressed when writing documents in the IETF Stream that document a > specification for New Protocols or Protocol Extensions or describe > their use. > > This document obsoletes RFC 5706, replacing it completely and > updating it with new operational and management techniques and > mechanisms. It also updates RFC 2360 to obsolete mandatory MIB > creation. Finally, it introduces a requirement to include an > "Operational Considerations" section in new RFCs in the IETF Stream > that define New Protocols or Protocol Extensions or describe their > use (including relevant YANG Models), while providing an escape > clause if no new considerations are identified. > > > > The file can be obtained via > https://datatracker.ietf.org/doc/draft-ietf-opsawg-rfc5706bis/ > > > No IPR declarations have been submitted directly on this I-D. > > > The document contains these normative downward references. > See RFC 3967 for additional information: > rfc9940: Some Key Terms for Network Fault and Problem Management (Informational - Internet Engineering Task Force (IETF) stream) > > > > > _______________________________________________ > IETF-Announce mailing list -- ietf-announce@ietf.org > To unsubscribe send an email to ietf-announce-leave@ietf.org
- [Last-Call] Re: Last Call: <draft-ietf-opsawg-rfc… S Moonesamy
- [Last-Call] Re: Last Call: <draft-ietf-opsawg-rfc… Jeffrey Haas