[lisp] Re: Gorry Fairhurst's Discuss on draft-ietf-lisp-rfc6831bis-07: (with DISCUSS and COMMENT)

"Vengada Prasad Govindan (venggovi)" <venggovi@cisco.com> Fri, 02 October 2026 09:30 UTC

Received: from alln-iport-1.cisco.com (alln-iport-1.cisco.com [173.37.142.88]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange x25519 server-signature ECDSA (prime256v1) server-digest SHA256) (No client certificate requested) by mx.ietf.org (Postfix) with ESMTPS id 19BBA4B; Fri, 02 Oct 2026 09:30:36 +0000 (UTC)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=dmarc.ietf.org; s=mail; t=1790933436; h=from:from:reply-to:subject:subject:date:date:message-id:message-id: to:to:cc:cc:mime-version:mime-version:content-type:content-type: content-transfer-encoding:content-transfer-encoding: in-reply-to:in-reply-to:references:references; bh=DJN+XT0udL1gP6zz7tZHZGuM4rWJ5XmZQBJnYlJbYPg=; b=OG4iWfSRzFRDWRnLUNsGe99M07vYWOgmZHHRtU5yEMiedbYh9RID8tod3n5L+gJWEJAGyl Y4je6g5rK1UO6TxpxmsrWBOtq4pFSgrUDSOnBMnxU+jL5M1TZlnQgFO5p3LC4cHlrdcKC8 AgkGKdmI0j/rYzgmK6TlelhehaVgIuQ=
Authentication-Results: mx.ietf.org; dkim=fail ("headers rsa verify failed") header.d=cisco.com header.s=iport01 header.b=iWnvqA+9; spf=pass (mx.ietf.org: domain of venggovi@cisco.com designates 173.37.142.88 as permitted sender) smtp.mailfrom=venggovi@cisco.com; dmarc=fail reason="SPF not aligned (relaxed)" header.from=dmarc.ietf.org (policy=none); arc=reject ("signature check failed: fail, {[1] = sig:microsoft.com:reject}")
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=cisco.com; i=@cisco.com; l=16816; q=dns/txt; s=iport01; t=1790933436; x=1792143036; h=from:to:cc:subject:date:message-id:references: in-reply-to:content-transfer-encoding:mime-version; bh=DJN+XT0udL1gP6zz7tZHZGuM4rWJ5XmZQBJnYlJbYPg=; b=iWnvqA+9lSg+PmpusKODCfFe5U73v7vjldczuXmiNLTZhDcI5sPcwSlu EUy8EnzyejUvpohs8B6Jm54jw/Q4CobYQmAf3cLEb3tPpXVx60KUt6X4j DNA8UptttTOCmERGgDYHnRTjEFSqgNngKKKK2254B69qPbYDOrPIbWgSy RZp1+WP05g7/i7+8PghnKpSRrkU14/CjIfqgXy1mJ144hxjyncHTpbiD7 jVqrE17QD3VL0cpPGT8KP5LeoDYRFe7gmXG0iyjgXUBzpw+6TCofqQnZw +RyJGnoS31qCuXgBndmzfIPf2XbAsN8zc5J4zYpgo2+KkQV9fInck6oR8 g==;
X-CSE-ConnectionGUID: 0IApOOg1RSCgcb4yqidjag==
X-CSE-MsgGUID: tbHGU1l3R1+HTNmIlC6cDw==
X-IPAS-Result: A0DkBAAseb9q/5MQJK1QCg6BIIErgW5TgQuBI0mEV4NMA4UriHkDkUmMZYFqDwEBAQ9EDQQBAYUFAhaNcgImNwYOAQIEAwIDAQEBAQEBAQEBAQEBCgEBBQEBAQIBBwWBDhOGTw2QEgEBAQEDIxE/BgwEAgEIEQQBAQMCJgICAi8VCAgCBAENBQgOAwKCaIJ0AwECDqw2AoodeoEygQGDWwcLQdwIBoEfLoVAgwMbAQF0fYJMgSMZO4RBJxuBSUSBFUKCaT6CYQEBA4EoAQcLAQcLERWDRDqCMASCDRV6EoJZBIQNgymLMwlJeHgsAVUTFwsHBWFCQwMqLy0jSwUtHYEjIR0XER5YGwYFEiAqQUNGBBOBWj8jGTZ6gQlegSspYAECDhdGLhWCBwKCVIEjXQIBSUEOB0VTCSU+BxJHJiIIEgkBExowC4EbODwJKD0MFw4MbT03FRkDBDp7BZAvGR6BbhBbBgExDCYEIhkQCBQOJC0MBhM1DQUJEAoCDwELDRc0A5JDFBAKg22QRIk1lCKBPgqEHowihyeIG4YuF4JLgTmNFIcDg1OHO4ZfZ5kII41nlTQsBAQLDQMFhQYCBAIEBQIQAQEGgX4maVgRB3AVGoJUAQEBMVMZD44uFhyIV4ohvGV5PgEHAgcPAoFzkAKBHGABAQ
IronPort-PHdr: A9a23:bEpQBhajgKpdhXjSeurcIZX/LTAchN3EVzX9orIuj7ZIN6O78IunY ArU5O5mixnCWoCIo/5Hiu+Dq6n7QiRA+peOtnkebYZBHwEIk8QYngEsQYaFBET3IeSsbnkSF 8VZX1gj9Ha+WXU=
IronPort-Data: A9a23:1v1+76+KnWChW+LsnVpfDrUDiX+TJUtcMsCJ2f8bNWPcYEJGY0x3m mYaWDjXaf/bYTGjL99+PNnk800DvZ7SydEyTgRprntEQiMRo6IpJzg2wmQcns+2BpeeJK6yx 5xGMrEsFOhtEDmB4E/rbei5xZVF/fngbqLmD+LZMTxGSwZhSSMw4TpugOdRbrRA2bBVOCvT/ 4mtyyHjEAX9gWAtajpOs/vrRC5H5ZwehhtJ5jTSWtgT1LPuvyF9JI4SI6i3M0z5TuF8dsamR /zOxa2O5WjQ+REgELuNyt4XpWVTH9Y+lSDX4pZnc/DKbipq/0Te4Y5nXBYoUnq7vh3S9zxHJ HqhgrTrIeshFvWkdO3wyHC0GQkmVUFN0OevzXRSLaV/wmWeG0YAzcmCA2luHKQA3cF4WFt13 vMTImwcdxGPheu5lefTpulE3qzPLeHiOIcZ/3UlxjbDALN/GdbIQr7B4plT2zJYasJmRKmFI ZFHL2MxKk2cPHWjOX9PYH46tPmlgHbwdCNZgFmUvqEwpWPUyWSd1ZC9boGJJozSFZ89ckCwu mjm0FmgBkogbZ+/9RyA03aH2OTjgnauMG4VPPjinhJwu3Wf3GUdFFgXWEe15P24kVb7QdxUd RxPoyAvtoAz+VClCN7nUHWQoXOfsTYdVsZeVeog52mlzqvP+0OSBmEFVCVpadE6uokxXzNC/ luIhMvBBDFzvvuSU331y1uPhTq2PS5QKSoJYjUJCFJdpdLiu4o0yBnIS76PDZKIszE8Ihmpq xiipykljLJVhskOv5hXN3ie695wjvAlljII2zg=
IronPort-HdrOrdr: A9a23:/3fjUK2tQkpjxe/TtRqkAQqjBb1xeYIsimQD101hICG9Lfbo9P xGzc566farslcssSkb6K690cm7LU819fZOkO8s1MSZLXjbUQyTXc5fBOrZsnHd8kLFh5RgPM tbAsxD4ZjLfCdHZKXBkUeF+rQbsaS6GcmT7I+0oQYOPGRXguNbnntE422gYzRLrXx9dOEE/e 2nl7J6TlSbCBMqR/X+LEMoG8LEoNrGno/nZxkpOz4LgTPlsRqYrJTBP1y9xBkxbxNjqI1OzU H11yDp7KSqtP+2jiTby3LS6Jpunt7gwMtoBcCHiMQZQw+cyzpAYr4PZ5Sy+BQO5M2/4lcjl9 fB5z06Od5o1n/Xdmap5TPwxgjJyl8Vmjzf4G7dpUGmjd3yRTo8BcYEr5leaAHl500pu8w5+L 5X3lieq4FcAXr77WbADpnzJlRXf3iP0D0feN0o/jpiuEwlGeZsRLkkjQdo+VE7bXrHAc4cYb JT5YrnlYZrmBuhHgPkVy9UsZyRd0V2OAuaSU4fvcHQ+T1XkHdli3Y8/qUk7y09HFZXcegZ2w wCWZ4YyY1mX4sYa7lwC/wGRtbyAmvRQQjUOGbXOlj/ErobUki94KIfzY9Frd1CQqZ4hKcaid DEShdVpGQyc0XhBYmH24BK6AnERCG4US72ws9T6pBlsvmkLYCbfBGrWRQriY+tsv8fCsrUV7 K6P49XGebqKS/rFZxS1wPzVpFOIT0VUdETuNw8R1WSy/i7YLHCp6jearLeNbDtGTErVif2BW YCRiH6IIFa4kWiShbD8W7ssrPWCzvCFL5LYdznFrIoufow36V3w30otWg=
X-Talos-CUID: 9a23:qcWVCmEUf8VQAi/DqmI/1WcMPecqK0fm53jbKROpEGdlSrSaHAo=
X-Talos-MUID: 9a23:uzgEkgoY0ScOT8fjFoIezy1oFOhVuqD1MhlOsakgvuiAHnJ7FyjI2Q==
X-IronPort-Anti-Spam-Filtered: true
Received: from alln-l-core-10.cisco.com ([173.36.16.147]) by alln-iport-1.cisco.com with ESMTP/TLS/TLS_AES_256_GCM_SHA384; 02 Oct 2026 09:30:35 +0000
Received: from alln-opgw-4.cisco.com (alln-opgw-4.cisco.com [173.37.147.252]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature RSA-PSS (2048 bits) server-digest SHA256) (No client certificate requested) by alln-l-core-10.cisco.com (Postfix) with ESMTPS id 1E2AF1800054D; Fri, 2 Oct 2026 09:30:35 +0000 (GMT)
X-CSE-ConnectionGUID: FtzEouIuTMCjo+vr4VKwKg==
X-CSE-MsgGUID: GysgAfcBQAu1d8ceEjefnw==
X-IronPort-AV: E=Sophos;i="6.27,136,1787011200"; d="scan'208";a="88470281"
Received: from mail-westusazon11010067.outbound.protection.outlook.com (HELO BYAPR05CU005.outbound.protection.outlook.com) ([52.101.85.67]) by alln-opgw-4.cisco.com with ESMTP/TLS/TLS_AES_256_GCM_SHA384; 02 Oct 2026 09:30:34 +0000
ARC-Seal: i=1; a=rsa-sha256; s=arcselector10001; d=microsoft.com; cv=none; b=fW+drJ9ldlgYFaSyesr0zQto/yyB91ODshySrp16W+GFYk41MTs00JI07wN2iExeic4+5ZtXHVBNLzHIkw+RtnpEiODDfZVvkkjZTH+RhF9q5it/qZ7Ep0YCJeFArT4nszOqDgPAEVuxU3T7U4UqT3+hIk8alhARpaDpUI+jNrJ/lVitdgFM//SSABvw5PcDxQRsSFvSlZbo92XhaQxt7gBRBRyINhHsi13Fu+k3XEUzGLG5tZ2ReEWmt+ht4TfSaxJ8uGeEZZ9JuL5+XGOwvCVgx2oJhVIk7rjUc82Qg5VuAzMI7dxIzfjNemElLCiUEiY3nlps1ZkjABYNGVGJQA==
ARC-Message-Signature: i=1; a=rsa-sha256; c=relaxed/relaxed; d=microsoft.com; s=arcselector10001; h=From:Date:Subject:Message-ID:Content-Type:MIME-Version:X-MS-Exchange-AntiSpam-MessageData-ChunkCount:X-MS-Exchange-AntiSpam-MessageData-0:X-MS-Exchange-AntiSpam-MessageData-1; bh=DJN+XT0udL1gP6zz7tZHZGuM4rWJ5XmZQBJnYlJbYPg=; b=fz1xz1jTyrBXBjAXmh58Kaz0c6Ra3XzwMk43qHHHVP3Y8tvRf1X1OrP4XlVKwiiUqE5PcSGCSuVMtTgW3jGaujk3M/NU/SjfCWHp8D937JNesxwyx8x55Fc1xX7WzK5Tkme1YNc/fG4VeZ157u8vZ73MyzfvhRWYt2cq3ZAWZnPN0PBiYRX8D7sPoJQ7x5S+KFpRkBOWpwwAEiA+ykjYeC1WT0CtUB48pgqCQjr3RIMMdJ6mkOYhzpVaX1g61Fzqjx+SuZy5zEL1LY2qwgQHdtNtrym7LaaPOTemWt3jX3b1K0PSamLzhx3IDr9iFl0hDNNbpn1MBRzJgcuMGZCHhA==
ARC-Authentication-Results: i=1; mx.microsoft.com 1; spf=pass smtp.mailfrom=cisco.com; dmarc=pass action=none header.from=cisco.com; dkim=pass header.d=cisco.com; arc=none
Received: from PH9PR11MB016272.namprd11.prod.outlook.com (2603:10b6:510:3eb::9) by PH3PPFAC6BA7F25.namprd11.prod.outlook.com (2603:10b6:518:1::d42) with Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) id 15.21.451.24; Fri, 2 Oct 2026 09:30:31 +0000
Received: from PH9PR11MB016272.namprd11.prod.outlook.com ([fe80::19ca:366e:8cb8:86a1]) by PH9PR11MB016272.namprd11.prod.outlook.com ([fe80::19ca:366e:8cb8:86a1%4]) with mapi id 15.21.0472.016; Fri, 2 Oct 2026 09:30:31 +0000
From: "Vengada Prasad Govindan (venggovi)" <venggovi@cisco.com>
To: Gorry Fairhurst <gorry@erg.abdn.ac.uk>, The IESG <iesg@ietf.org>
Thread-Topic: Gorry Fairhurst's Discuss on draft-ietf-lisp-rfc6831bis-07: (with DISCUSS and COMMENT)
Thread-Index: AQHdRCl22xo5a3pFC0SD+DW/f1T6r7boP8BA
Date: Fri, 02 Oct 2026 09:30:31 +0000
Message-ID: <PH9PR11MB0162723E0BB55EB13D747F33F2CD892@PH9PR11MB016272.namprd11.prod.outlook.com>
References: <178937726073.564079.16591070949361742981@dt-datatracker-597c8c8754-4t7c8>
In-Reply-To: <178937726073.564079.16591070949361742981@dt-datatracker-597c8c8754-4t7c8>
Accept-Language: en-US
Content-Language: en-US
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
x-ms-publictraffictype: Email
x-ms-traffictypediagnostic: PH9PR11MB016272:EE_|PH3PPFAC6BA7F25:EE_
x-ms-office365-filtering-correlation-id: 911bf9f6-7484-429e-6ff3-08df2067cdbe
x-ms-exchange-senderadcheck: 1
x-ms-exchange-antispam-relay: 0
x-microsoft-antispam: BCL:0;ARA:13230040|1800799024|366016|376014|23010399003|38070700021|56012099006|6133799003|11063799006|10067099003|5023799004|3023799007|22082099003|18002099003;
x-microsoft-antispam-message-info: wPDcISLTO8sFA3fko3lP0JTyZfZkslqytAkhQquDlJnJ27Sir3YPE+wKOFKyqVgBrhvLQsXJKmntqDZgSE9s0P8VAns1Y7JjOsPpo24UXZgZ/vxnq3/UDxin1g2+OhOSA72CbsLKp1j9+OhdAVA8GJUpi+2EUjsq0bVrsep06XgfdKr2nDhsuzJ2qurvL8dfvE3TRjJgMa+/AUMztdUzUFDglf1V13G91PbtEyHYWAA9lqAQkw3vmVQpnux0XN2/0FLGuzEneeGF52VScGMyFslqxMPidv2L4D5HFo+Iq+xPIcv8dkTj7MWmoZcrHC0haTeAyC40s5q8dUDyodds5J7lUko8p04UH833hEc8TqKLevDgeZhn+K9O3qTJDoKZ3mmjKjFuOmA+pFsLoIHfw9VqgYsr5UpDgaSWBHPvzH8lquypMrdRCk9gf3xOnzEdRDPuPhJb9kF6QKmuI/mqOpAWXqqKsuCbZ958dwLj7eGhARrskycfJ0VfQ0RDJ5pz8qP0EeKeFcebJp4YArIx6Krdy75WeHUT+LiYSWmeBSqmp1arfCuifCuCGXYsJZnxqlfZjB1U8vH1m1NffLrfizkn3NaYCDkJdDbu6lHjMqXhRjpPSieQA8UPOdWRB9mAAUHMgD7BYALw6q9ZseoYx5F3wX9oQMD2JZkDdkBvHHGTMyCiH4QNmRAoSC9i7D+IMZwdXd48eKm00QYrhP2ujZtCXT8E+PIgChRoJXfPDHQ=
x-forefront-antispam-report: CIP:255.255.255.255;CTRY:;LANG:en;SCL:1;SRV:;IPV:NLI;SFV:NSPM;H:PH9PR11MB016272.namprd11.prod.outlook.com;PTR:;CAT:NONE;SFS:(13230040)(1800799024)(366016)(376014)(23010399003)(38070700021)(56012099006)(6133799003)(11063799006)(10067099003)(5023799004)(3023799007)(22082099003)(18002099003);DIR:OUT;SFP:1101;
x-ms-exchange-antispam-messagedata-chunkcount: 1
x-ms-exchange-antispam-messagedata-0: x4PQOKTzBHMpCsBVcHa5rPR6rRklkhsCbRIxGNJpAKGaL6N3B7p0RE5CtlkoBjAEk/SZSj2xI4wvtV5p0DwQGUQVNCspO7ctnx3b20jRFI3drcGcsGdQ1emTTRj5X8gdX2D2F6eM90r3GhV++F6AYGfG/AbJlmOKkQFLR/gQVBTTIsp+tsNGU48StXcdc6JQbM10OkA4GmucnH7a4bF0IrBq0Yit/pRT1SlPhBaeM4IH7Bv+d1Dpz9bWOOvg94Nq06EeMqPKg5AL8vzq1HbVGRNTlmZoNkwztYIKXrTP9t9VUH+op2G95kki6DkyspreKq/yvE/knzGQONjd0iOtdkOoXm1Y2cj65xSij3OL4jQxTB2ri/bFwZjlHiTFedX56VzumjvuFCqi9OJytQnN+lt60Akb+FGpl00yYLWZI+Behl8FvKcoTslbENzCYEFpC1BxIUn++ZWEm9oyaDftKhJ9FMGzpUttt/nz/vJxTpvPcpyawHNjHH2OHLFCsmnVhL7sfefg8d3EIEdTv7f77eYyN/QwUQfzPNYfqw8W+BuRexA5sz7vOwYAsCFtO2+XCbtymeU6dI8siF8vEuUpk7tOg05VJDeHuDqtLpbpCF+lsyXihNArYpotSxLN0CA4o1tE0SOMvLY7f4MhmzoBra30FrvdMZjmFb2P5hmraiTMzuZEe12+/pRltuL5dLGN+uF9RgBjDP5XZOzLuuzqKTET1plKJCrWmj6l3TqmJFw3K5Cld9u82lt60oGUIrESe1tmCLcOS6+ASMHDCg6ODY1TfK9axbszyPvf/lci6tSvFzNKWw/Z3Oy/7N39ndG2MeTj4BWB6YHdR66AoVwB25TXBWxKvsuyQ9V8vcJ22fF6cPqWGuyfycKXzCFfLaOOnQlg/cDyAW8nCs7rwdfquh478XwqAmXZ38SxqNnEtu8226K1Tr0UkZVermKpdT/DKxdUW8QTfgPKlpa7aeQn/IynWCokQ/wmwZuRZyxoOEKw82g+t9k6LddUU9O4r1D9t+/uYJTaFOD9+3BBa0KivpTtUfeEhDhGc60EHitpaMwEzD3HTX6LA7o81tkev2sggmIo7q1UQqySQMpGDJdvDtBgbjgeqm/O7LV8f+y4DiLrX+5Jai/VjGMXmDQSY7Csgi6a+rIrxqk9pj5NpdVu4nyqacKUX5EA7Z77PnxCHZJgaDhk7fnABjbdQu93RXEYkaj8u6Yz2NpmHC1aRS9E0s1+tcSpnId7ouCwuneRHubGMEQCdHxYPnwAepWyV/fEfGDOYiFpCVmsrE0Q4NjYnFMc14MF7Rd1/zUYHL3ejQu5yu9aDC6yqUhAyVdXEj1O1GX1p8lnXdYJsZgC8ub6XQGUi2vjg74yhw2HSH04nVHOcXAYyvFpc/IHJCM4xeDCr1hn3CaTSIqGWdSvBHlpdvaYp9RRS73ZERlxwj8l1n5GeRuXnANp1TwEW8qHlyzkU80dGIRO9APB7D2H41NGHgdSwOQgInzs+3E8/pyzd12zQdLUfMNHOxDGayIqRSIBhiV/+x5rmUj4VkyRveUIk+JKODRRisA2K0Pl4LLO5cMSxp2x4lPigszWbvQ6cZ1xi900mniz4WgkwqtgOfPib2arz0DxLq8U6RlfgUIF3/YgJcVbYyis+IByY3OdrXPDrRXpMX888kPzSZ4Mbqrol1RU30kNjjaZEwAeGHlcgVcd7Oj9kTBr4YJqo0EyWc9t
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: base64
MIME-Version: 1.0
X-Exchange-RoutingPolicyChecked: fa1u1fcmLeNyW7yhIWhUHAho2JhLzuqu9Ea1vzYHZFhkUNZLS07Gn4mG3s6opKd/uOvsF2933a0SqWYOA7DbNAaUZMaMxEJD6fMlQdJNKK9qkri7Kros54q8tTHTMcA2YRtKem4KGHmfEabOveyVgz11NXawrHaKksJHaFGQuDgy36SIwk8xB2yR4O8YT3QbpD1dd7kxuBixMCFKnUsY/VHGc50jWCVDrawrMMFf5X9e8Ta3sBkiuBaEXW7SWh+3CLS11kFW9gkTQiGaiK4oLZ0eCPIaqVZCfl56shoHgGTMOZ/btDe5LmIXs6exFOK9p2R2vK1l1rOvJedEKry9Rg==
X-OriginatorOrg: cisco.com
X-MS-Exchange-CrossTenant-AuthAs: Internal
X-MS-Exchange-CrossTenant-AuthSource: PH9PR11MB016272.namprd11.prod.outlook.com
X-MS-Exchange-CrossTenant-Network-Message-Id: 911bf9f6-7484-429e-6ff3-08df2067cdbe
X-MS-Exchange-CrossTenant-originalarrivaltime: 02 Oct 2026 09:30:31.5413 (UTC)
X-MS-Exchange-CrossTenant-fromentityheader: Hosted
X-MS-Exchange-CrossTenant-id: 5ae1af62-9505-4097-a69a-c1553ef7840e
X-MS-Exchange-CrossTenant-mailboxtype: HOSTED
X-MS-Exchange-CrossTenant-userprincipalname: fBDC+uGdq6oQ7bbPnu2CV1ll84lOxA8lWOdGvJSEXzlD3WTq2eMhQyX3xZxn/VL1UIp0VaMLfdzEHJZe61xXxA==
X-MS-Exchange-Transport-CrossTenantHeadersStamped: PH3PPFAC6BA7F25
X-Outbound-Client-TLS: ANONYMOUS;alln-opgw-4.cisco.com [173.37.147.252];TLSv1.3;TLS_AES_256_GCM_SHA384;256
X-Outbound-SMTP-Client: 173.37.147.252, alln-opgw-4.cisco.com
X-Outbound-Node: alln-l-core-10.cisco.com
X-Original-From: "Vengada Prasad Govindan (venggovi)" <venggovi@cisco.com>
X-Spam-Level: **
X-Spamd-Bar: ++
Message-ID-Hash: NFQHJZVPMMGH4RFOWQGUMDN346JLB6NZ
X-Message-ID-Hash: NFQHJZVPMMGH4RFOWQGUMDN346JLB6NZ
X-MailFrom: forwardingalgorithm@dmarc.ietf.org
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; loop; banned-address; header-match-lisp.ietf.org-0; emergency; member-moderation; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: "draft-ietf-lisp-rfc6831bis@ietf.org" <draft-ietf-lisp-rfc6831bis@ietf.org>, "lisp-chairs@ietf.org" <lisp-chairs@ietf.org>, "lisp@ietf.org" <lisp@ietf.org>
X-Mailman-Version: 3.3.10
Precedence: list
Subject: [lisp] Re: Gorry Fairhurst's Discuss on draft-ietf-lisp-rfc6831bis-07: (with DISCUSS and COMMENT)
List-Id: List for the discussion of the Locator/ID Separation Protocol <lisp.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/lisp/NGaW9DoMSCgQkvGutTVyIdLwe1E>
List-Archive: <https://mailarchive.ietf.org/arch/browse/lisp>
List-Help: <mailto:lisp-request@ietf.org?subject=help>
List-Owner: <mailto:lisp-owner@ietf.org>
List-Post: <mailto:lisp@ietf.org>
List-Subscribe: <mailto:lisp-join@ietf.org>
List-Unsubscribe: <mailto:lisp-leave@ietf.org>

Hello Gorry,
Thank you for your detailed review notes, they are very helpful. Please find responses inline with GVP1>
All changes that are accepted has been implemented in ver -09 of the draft (draft-ietf-lisp-rfc6831bis-09)
Thanks
Prasad

-----Original Message-----
From: Gorry Fairhurst via Datatracker <noreply@ietf.org> 
Sent: Monday, September 14, 2026 02:44 PM
To: The IESG <iesg@ietf.org>
Cc: draft-ietf-lisp-rfc6831bis@ietf.org; ggx@gigix.net; lisp-chairs@ietf.org; lisp@ietf.org
Subject: Gorry Fairhurst's Discuss on draft-ietf-lisp-rfc6831bis-07: (with DISCUSS and COMMENT)

Gorry Fairhurst has entered the following ballot position for
draft-ietf-lisp-rfc6831bis-07: Discuss

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)


Please refer to https://www.ietf.org/about/groups/iesg/statements/handling-ballot-positions/
for more information about how to handle DISCUSS and COMMENT positions.


The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-lisp-rfc6831bis/



----------------------------------------------------------------------
DISCUSS:
----------------------------------------------------------------------



# Gorry Fairhurst WIT AD comments

Thank you for the work that has been put into this document.

Please find below some blocking DISCUSS points (easy to address), some
non-blocking COMMENT points/nits (replies would be appreciated even if only for
my own education).

I was initially surprised to see the small difference from RFC 6831 (given that
described an experimental specification with many topics that needed to be
explored) to this as a Proposed Standard. When  I read further, I found very
few normative requirements and recommendations, and I would like to raise this
as the basis of my DISCUSS topics.

## DISCUSS (blocking)

As noted in
https://datatracker.ietf.org/doc/statement-iesg-handling-ballot-positions-20220121/,
a DISCUSS ballot is a request to have a discussion on the points below; I
really think that the document would be improved with a change here, but can be
convinced otherwise.

(1) I see descriptive non-normative sections in a part of the document where I
expected to see normative text. If these sections are normative, then please
explain the requirements and recommendations, if not then please label them as
informative, or better still, move them before the present section 2 text to
clearly show their informative status.

* Section 4: "Basic Overview"
- This seems to be a basic overview, with no normative requirements. Ought this
to be more correctly seen as further introduction and context before what is
currently section 2?
GVP1> Agree, the basic overview has now been rewritten and made normative using requirement specification keywords. I have changed the title of the section to Theory of Operation to reflect the current text.

* Section 5 may also be only informative?
GVP1> There are three changes that has made it normative. From the POV of the reader, the placement of this is very ideal as Section 5. Hence, I changed the text to make it Normative and re-aligned the flow for accommodating unicast underlay as well. I reviewed the new flow and found it satisfactory to me. 

* Section 7: "Multicast Protocol Changes"
- This seems to be argumentation that there are no changes to a set of
supporting protocols. This doesn't seem to provide any normative requirements. 
If that is so, could this be moved before the declaration of the requirements
language in section 2?
---
GVP1> Agreed, there is no normative specification required here. But moving it early to Section 2 would confuse the reader without proper background. If it is absolutely essential, I can find another place (maybe towards the end) but I prefer to retain it if there is no violation of any rule.

(2) I see many places where protocol interactions are discussed and described,
but no normative requirements and recommendations are provided. - I would like
to understand whether the currently protocol specification sufficiently robust
for a PS specification? I expected to see requirements for checks of the
received protocol information, or procedures about what to do if elements are
malformed or not present, but I could not find any (please tell me if I missed
where these were specified).
GVP1> I would request you to revisit this comment since Section 4 (Theory of Operation) and Section 5 (Source Addresses v/s Group addresses). This has now normative language.

* Section 6: "Locator Reachability Implications on LISP-Multicast"
- To me this seems to be normative and have implications on interoperability?
If so, I suggest this would benefit from some RFC-2119 language to define those
normative requirements.
GVP1> Agreed, I used RFC2119 language where required.

* For example, Section 8 offers no interoperability requirements for reception
or processing. Similarly, in Section 9 I could not see any interoperability
requirements defined.
GVP1> ver-08 of the draft was submitted with the Section-8 rewritten with interoperability requirements (using RFC2119 keywords). Sec 9 is more on the operation side, hence there is not much scope for interoperability. Please let me know if you agree with this assessment. However please see below for certain changes in Sec 9.2 

* The discussion in Section 9.2 includes text like: "the number of total
combinations grows beyond comprehension", "To rationalize this combinatorial
nightmare, there are some guidelines that need to be put in place" ... could
this text be rewritten in a style more appropriate for a standard? However, I'd
like to understand how this has progressed from the experimental RFC and what
checks are required and guidance has been derived from the experience.
GVP1> Agreed this section is now reworded to include guidance derived from experience.

* Section 11: "Taking Advantage of Upgrades in the Underlay"  appears to
discuss interoperability recommendations, can these be formalised as RFC
recommendations in this specification?
GVP1> Agree with your observation. I think this can be removed from the Proposed Standard safely without affecting the rest of the document.
---

(3) Section 9.2 seems to offer two solution space options.
- Why are two different options still presented in a proposed standard? I
expected that part of the experiment in the former specification was to
identify a common solution. However, I can understand if the WG was unable to
specify a single design, but then would like to understand if there are
interoperability implications and how is a conformant specification to evaluate
this?
GVP1> Thanks for catching this. Retained only the mandatory option in this case.

Section 9.3. "Making a Multicast Interworking Decision"
- I can understand that an experimental specification identifies areas of
complexity and gaps, but I expected the WG to make a decision rather than
stating this "can be quite complicated, and, if the design is too ambitious,
the dynamics of the protocol could cause a lot of instability." followed by
"sweet spot in the solution space in order to optimize state requirements..."
Can this section be written as a set of requirements and recommendations?
GVP1> Thanks for pointing this out, the discussion on mPETR in the previous sections already take care of the required specification. Removed this subsection as it does not specify anything or add value.

(4) Please explain the MTRACE requirements and how these will be realised.
Section 12: "Mtrace Considerations"
- For me, this text seems hard to realise, please clarify "functionality MUST
be consistent with unicast traceroute", especially when followed in the next
paragraph with a suggestion that there is no current specification for this.
Maybe this is one case where the "MUST" is too strong, and this cannot be an
interoperability requirement? (I see the introduction correctly notes this as
out-of-scope.)
GVP1> I believe this comment has been addressed in ver-08 as part of addressing Ketan's similar comments.

---

I hope that this review helps to improve the document,
GVP1> Sincerely, yes. It did help very much. Thanks 

Regards,

Gorry Fairhurst


----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

COMMENTS (non-blocking)

(1) Since this RFC is progressing from EXP to PS, I expected to understand the
level of maturity of the specification, the experience and specifically the
answers to questions and concerns in the experimental RFC. I may have missed
this, but I did not see this in either the Shepherd writeup, or the new
document text, and it is important to understand the actual maturity and
interoperability experience. I and therefore asking for this here:

* I am unsure what is communicated by the Shepherd Write-up saying
"Implementations are already existing". Which implementations and what level of
interoperability was achieved? What was the deployment experience?
GVP1> Deployment experiences are documented in draft-ietf-lisp-multicast-deploy

* RFC 6831 noted: "further deployment and experimentation would be useful to
understand the real-life performance of the LISP-Multicast solution." Is this
experience sufficient to underpin this elevation to PS? Where is this analysed,
and could this be provided in the current document to explain how this has
replaced an experimental specification?
---
GVP1> Deployment experience is documented in draft-ietf-lisp-multicast-deploy

(2) Missing reference? I found this text, but did not find an explanation or
supporting reference: "Deployments have successfully demonstrated the
successful minimization of multicast state in the underlay."
GVP1> It is present in the previous sentence of the same paragraph. I hope this is sufficient.

(3) I read this text "Issues and concerns about the deployment of LISP for
Internet traffic are discussed in [RFC9300]." However, that document is not
specifically about issues. Without some clarification or reference to a more
specific section, this seems an unhelpful statement, please explain what issues
are to be highlighted.
GVP1>  This is no longer needed in the PS RFC. Removed this sentence. All deployment experiences are documented in the draft-ietf-lisp-multicast-deploy

(4) I read this text" To distinguish if the site can receive dual-stack unicast
packets as
   well as dual-stack multicast packets, the Mpriority value setting
   will be relative to an IPv4 or IPv6 RLOC See [RFC9300] for packet
   format details."
- This was hard to parse, but seemed important, could this be clarified?
GVP1> Reworded this, thanks

(5) For me, the following text seems odd: "There may be a security concern...".
Did the WG see a concern or not? Was this in some deployment scenarios or for
certain uses? The current text seems speculative.
GVP1> Corrected the speculative text, added clarity to mitigate the risk by using allow/ deny access-lists. The Security Considerations section has been rewritten for better clarity

(6) I expected the document to provide requirements and checks of information,
if these were clearly identified, then their security properties ought to be
discussed in section 12.
GVP1> Same comment as above.

(7) NiTs: The following are editorial comments that I hope might improve the
next revision of this document:

/The process is simply to copy/The process is to copy/ - please avoid language
that "sells" the protocol, "simply" seems inappropriate in a PS RFC. /In the
decapsulation case, the ETR simply removes/ - please avoid language that
"sells" the protocol, "simply" seems inappropriate in a PS RFC. 
GVP1> Agreed. All occurrences of the word "simply" are removed
/And to have
the ITR use its own IP address (its RLOC) as the source address./ - This
sentence is incomplete. 
GVP1> Removed in ver-08
/deployed for PIM [RFC7761]/deployed for PIM [RFC7761]./
GVP1> Fixed