[lisp] Gunter Van de Velde's Discuss on draft-ietf-lisp-rfc6831bis-07: (with DISCUSS and COMMENT)
Gunter Van de Velde via Datatracker <noreply@ietf.org> Tue, 15 September 2026 13:14 UTC
Received: by mx.ietf.org (Postfix) id 5BAEF30; Tue, 15 Sep 2026 13:14:23 +0000 (UTC)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=ietf.org; s=mail; t=1789478063; h=from:from:reply-to:reply-to:subject:subject:date:date: message-id:message-id:to:to:cc:cc:mime-version:mime-version: content-type:content-type: content-transfer-encoding:content-transfer-encoding; bh=bq2SEbSpRhwztYScqHOFMWzfv2Ylb8Sasg6QcBVK2EY=; b=AxK5oUIc2ZQt+zHPhEe3RSQaPUMekmWoBtXTYXDYxVaIq0CvdwUDXrioY07++ISHwYoeFH jnDne90cewdroONC6QlycgPrFXwl4sNLKM4Ij+zoM64JWYkc/HNZIM8pFmulGqUtPPbkAD sJtnBJF/Y/+TwerPjU9bBogdktw0k9E=
Authentication-Results: ORIGINATING; auth=pass smtp.auth=mail2@ietf.org smtp.mailfrom=noreply@ietf.org
Received: from [10.244.8.113] (gaia.k8s.ietf.org [4.156.85.76]) by mail2.ietf.org (Postfix) with ESMTP id 28745139628C7; Tue, 15 Sep 2026 06:14:23 -0700 (PDT)
MIME-Version: 1.0
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: 8bit
From: Gunter Van de Velde via Datatracker <noreply@ietf.org>
To: The IESG <iesg@ietf.org>
X-Test-IDTracker: no
X-IETF-IDTracker: 12.75.0
Auto-Submitted: auto-generated
Precedence: bulk
Message-ID: <178947806309.869334.3739334270149909550@dt-datatracker-597c8c8754-4t7c8>
Date: Tue, 15 Sep 2026 06:14:23 -0700
Message-ID-Hash: G7CEOZ5FEPA4F6EF325V25F3BWMQFH5K
X-Message-ID-Hash: G7CEOZ5FEPA4F6EF325V25F3BWMQFH5K
X-MailFrom: noreply@ietf.org
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; loop; banned-address; header-match-lisp.ietf.org-0; emergency; member-moderation; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: draft-ietf-lisp-rfc6831bis@ietf.org, lisp-chairs@ietf.org, lisp@ietf.org
X-Mailman-Version: 3.3.10
Reply-To: Gunter Van de Velde <gunter.van_de_velde@nokia.com>
Subject: [lisp] Gunter Van de Velde's Discuss on draft-ietf-lisp-rfc6831bis-07: (with DISCUSS and COMMENT)
List-Id: List for the discussion of the Locator/ID Separation Protocol <lisp.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/lisp/vsLGKLZ8EnfOjHyniDRKNlJQKFY>
List-Archive: <https://mailarchive.ietf.org/arch/browse/lisp>
List-Help: <mailto:lisp-request@ietf.org?subject=help>
List-Owner: <mailto:lisp-owner@ietf.org>
List-Post: <mailto:lisp@ietf.org>
List-Subscribe: <mailto:lisp-join@ietf.org>
List-Unsubscribe: <mailto:lisp-leave@ietf.org>
Gunter Van de Velde has entered the following ballot position for draft-ietf-lisp-rfc6831bis-07: Discuss When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.) Please refer to https://www.ietf.org/about/groups/iesg/statements/handling-ballot-positions/ for more information about how to handle DISCUSS and COMMENT positions. The document, along with other ballot positions, can be found here: https://datatracker.ietf.org/doc/draft-ietf-lisp-rfc6831bis/ ---------------------------------------------------------------------- DISCUSS: ---------------------------------------------------------------------- # Gunter Van de Velde, RTG AD, comments for review of draft-ietf-lisp-rfc6831bis-07 # The line, if any, numbers used are rendered from IETF idnits tool: https://author-tools.ietf.org/api/idnits?url=https://www.ietf.org/archive/id/draft-ietf-lisp-rfc6831bis-07.txt # Many thanks to Darren Dukes for the RTGDIR review and to Luigi Iannone for the shepherd write-up. # Thanks for this document and great write-up. When reviewing i found one blocking item [DISCUSS#1] and some comments that the authors and working group may want to consider. # [DISCUSS#1] Section 12: the mtrace requirement cannot be implemented Section 12 says that mtrace “MUST” show every hop from receiver to source, immediately followed by a statement that the design remains to be determined. In addition, section 1 also puts detailed mtrace behavior outside scope. An implementation cannot conform to the "MUST" of this undefined requirement. ---------------------------------------------------------------------- COMMENT: ---------------------------------------------------------------------- [COMMENT#1] The abstract says that the specification supports both multicast and unicast underlays, including a mixture of multicast and unicast replication state. However, the exact behavior for those cases seems unclear. for example, when looking at Sections 8.1 and 8.2 only the multicast-underlay forwarding path is discussed and no unicast? [COMMENT#2] is there a reason RFC 9301 is not mentioned? Map-Requests, Map-Replies, Negative Map-Replies, Locator Records, and the multicast priority and weight fields are specified by RFC 9301, not RFC 9300. RFC 9301 therefore is a normative reference. Also have a look at exact field names and align rfc6831bit with rfc9301 names (for example “M Priority” vs “Mpriority”). [COMMENT#3] address-family behavior conflicts with RFC 9300 (see section 9.2) Section 9.2 says multicast ITRs will encapsulate only when the inner and outer headers use the same address family. RFC 9300, Section 5 requires support for all four IPv4/IPv6 inner/outer combinations. This restriction may be a reasonable, but the document currently also says its data plane conforms to RFC 9300 (section 8). [COMMENT#4] I think that in section8.1.1, (RLOC,G) should be (S-RLOC,G-u). [COMMENT#5] Should the reference for M Priority/M Weight policy not be RFC 9301 instead of RFC 6836? [COMMENT#6] Outside of the boilerplate i just spotted 4 uppercase BCP14 language words through the document. Is that intentional for your proposed standard? Brgds, Gunter Van de Velde Routing Area Director
- [lisp] Gunter Van de Velde's Discuss on draft-iet… Gunter Van de Velde via Datatracker
- [lisp] Re: Gunter Van de Velde's Discuss on draft… Vengada Prasad Govindan (venggovi)