[netmod] Re: vendor proprietary YANG modules: how are they named?
Qin Wu <bill.wu@huawei.com> Mon, 10 August 2026 01:06 UTC
Return-Path: <bill.wu@huawei.com>
X-Original-To: netmod@mail2.ietf.org
Delivered-To: netmod@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id 31EFC126DF651 for <netmod@mail2.ietf.org>; Sun, 9 Aug 2026 18:06:58 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=ietf.org; s=ietf1; t=1786324018; bh=PBEKUnujYGX8aEay1vGqTNThDal4i1BPfk7HpRQ3rDc=; h=From:To:Subject:Date; b=Hcc2NR/NVvIXqkqRsIGtN/0iaIF8XI3MbpD8XgnSE8rh0EW1W3BpfPZlO9O4ul0cx AJPMwG1PzkVMUpFDG/KspbMSwJMQqwwteZgleGCPL/4zvw/E6DKFeJmZjNup4t9KIp 8tBHVL5VTZER7kTzJIpY7iBS+XiiHp1Qw5Vs55WE=
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -4.394
X-Spam-Level:
X-Spam-Status: No, score=-4.394 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, RCVD_IN_DNSWL_MED=-2.3, RCVD_IN_MSPIKE_H5=0.001, RCVD_IN_MSPIKE_WL=0.001, RCVD_IN_VALIDITY_RPBL_BLOCKED=0.001, RCVD_IN_VALIDITY_SAFE_BLOCKED=0.001, SPF_HELO_NONE=0.001, SPF_NONE=0.001] autolearn=ham autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=pass (1024-bit key) header.d=huawei.com
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id JfTOPnYFjO82 for <netmod@mail2.ietf.org>; Sun, 9 Aug 2026 18:06:56 -0700 (PDT)
Received: from frasgout.his.huawei.com (frasgout.his.huawei.com [185.176.79.56]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id C5F3F126DF64C for <netmod@ietf.org>; Sun, 9 Aug 2026 18:06:56 -0700 (PDT)
dkim-signature: v=1; a=rsa-sha256; d=huawei.com; s=dkim; c=relaxed/relaxed; q=dns/txt; h=From; bh=PBEKUnujYGX8aEay1vGqTNThDal4i1BPfk7HpRQ3rDc=; b=SD4LazKo0c2M52hWPLhNEfrIvU5U0nHAiegTyT7jiDGVekYO7YtWXCm3YakVpQzJdyndj9LXb 2tCg8DDKGEN6oXAKzydV1CiguELO3BZulSn3NS+eDi8JwhJnBhR6TQJFtrm5ycNek3KLTrKCTVD 2H8wsV6iALYS1sFvoQZo6ek=
Received: from mail.maildlp.com (unknown [172.18.224.107]) by frasgout.his.huawei.com (SkyGuard) with ESMTPS id 4hJGlf6HP2zJ468C; Mon, 10 Aug 2026 09:05:50 +0800 (CST)
Received: from kwepemh500011.china.huawei.com (unknown [7.202.181.142]) by mail.maildlp.com (Postfix) with ESMTPS id 247994058B; Mon, 10 Aug 2026 09:06:43 +0800 (CST)
Received: from kwepemf100004.china.huawei.com (7.202.181.218) by kwepemh500011.china.huawei.com (7.202.181.142) with Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) id 15.2.1544.11; Mon, 10 Aug 2026 09:06:41 +0800
Received: from kwepemf200004.china.huawei.com (7.202.181.230) by kwepemf100004.china.huawei.com (7.202.181.218) with Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) id 15.2.1544.36; Mon, 10 Aug 2026 09:06:41 +0800
Received: from kwepemf200004.china.huawei.com ([7.202.181.230]) by kwepemf200004.china.huawei.com ([7.202.181.230]) with mapi id 15.02.1544.011; Mon, 10 Aug 2026 09:06:41 +0800
From: Qin Wu <bill.wu@huawei.com>
To: Michael Richardson <mcr+ietf@sandelman.ca>, Mahesh Jethanandani <mjethanandani@gmail.com>, netmod <netmod@ietf.org>
Thread-Topic: [netmod] Re: vendor proprietary YANG modules: how are they named?
Thread-Index: Ad0oY2OkX/EM+tuwTsm8AROsSF4mpw==
Date: Mon, 10 Aug 2026 01:06:40 +0000
Message-ID: <adc8389e8bfb4c5e81f917187f33595a@huawei.com>
Accept-Language: zh-CN, en-US
Content-Language: zh-CN
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
x-originating-ip: [10.136.132.204]
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: base64
MIME-Version: 1.0
Message-ID-Hash: JER53M2NWHSRMAXL4R3FSNCPKIAYRMAB
X-Message-ID-Hash: JER53M2NWHSRMAXL4R3FSNCPKIAYRMAB
X-MailFrom: bill.wu@huawei.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-netmod.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [netmod] Re: vendor proprietary YANG modules: how are they named?
List-Id: NETMOD WG list <netmod.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/netmod/6c-iAyon6SO6L3vHCjL8C3aKXwM>
List-Archive: <https://mailarchive.ietf.org/arch/browse/netmod>
List-Help: <mailto:netmod-request@ietf.org?subject=help>
List-Owner: <mailto:netmod-owner@ietf.org>
List-Post: <mailto:netmod@ietf.org>
List-Subscribe: <mailto:netmod-join@ietf.org>
List-Unsubscribe: <mailto:netmod-leave@ietf.org>
Hi, Michael:
Quote text in section 4.1 of RFC9907,
"
All published module names MUST be unique. For a YANG module
published in an RFC, this uniqueness is guaranteed by IANA
(Section 14 of [RFC6020]).
Example modules are non-normative and SHOULD be named with the prefix
"example-".
It is suggested that a stable module name prefix be selected that
represents the entire organization. All normative YANG modules
published by the IETF MUST begin with the prefix "ietf-". All IANA-
maintained YANG modules MUST begin with the prefix "iana-". Another
standards organization, such as the IEEE, might use the prefix
"ieee-" for all YANG modules.
"
For vendor specific module, I think the enterprise or organization-name should be used,
Similar to example modules, organization specific module.
Also see quoted text in section 5.3 of RFC7950
"
XML namespaces for private modules are assigned by the organization
owning the module without a central registry. Namespace URIs MUST be
chosen so they cannot collide with standard or other enterprise
namespaces -- for example, by using the enterprise or organization
name in the namespace.
"
Further see module tag RFC, section 2.2
"
2.2. Vendor Tags
A vendor tag is a tag that has the prefix "vendor:". These tags are defined by the vendor
that implements the module and are not registered; however, it is RECOMMENDED that
the vendor include extra identification in the tag to avoid collisions, such as using the
enterprise or organization name following the "vendor:" prefix (e.g., vendor:example.com:vendor-defined-classifier).
"
It also indicate to use enterprise or organization name for vendor tags, same rule can be applied to modules.
-Qin
-----邮件原件-----
发件人: Michael Richardson [mailto:mcr+ietf@sandelman.ca]
发送时间: 2026年8月10日 5:04
收件人: Mahesh Jethanandani <mjethanandani@gmail.com>; netmod <netmod@ietf.org>
主题: [netmod] Re: vendor proprietary YANG modules: how are they named?
Mahesh Jethanandani <mjethanandani@gmail.com> wrote:
> Different vendors use different names/namespaces. See this folder for
> how different vendors have named their modules.
I'm trying to resolve the question of uniqueness in RFC8366bis' "extensions"
registry.
Here is what I've written now:
https://github.com/anima-wg/voucher/commit/ada220e5#diff-f2a46f5f7515ce785de390697118abc6ef7052d42b52ddc672828dc7c09d0b02L1158-R1156
Extension name strings for IETF process (standards track, experimental,
IRTF) documents are single words, given by the YANG Module Name: They do
not contain dots.
For vendor proprietary extensions, (including ISE submissions), the
resulting string still needs to be unique. This can be done by
making the YANG module unique, basing it on a fully-qualified domain
name (FQDN) [RFC3696], such as "fuubar.example.com-mud-thing" rather
than "fuubar-mud-thing"
--
Michael Richardson <mcr+IETF@sandelman.ca> . o O ( IPv6 IøT consulting )
Sandelman Software Works Inc, Ottawa and Worldwide
** My working hours and your working hours may be different. **
** Please do not feel obligated to reply outside your normal working hours **
- [netmod] vendor proprietary YANG modules: how are… Michael Richardson
- [netmod] Re: vendor proprietary YANG modules: how… Mahesh Jethanandani
- [netmod] Re: vendor proprietary YANG modules: how… Michael Richardson
- [netmod] Re: vendor proprietary YANG modules: how… tom petch
- [netmod] Re: vendor proprietary YANG modules: how… Michael Richardson
- [netmod] Re: vendor proprietary YANG modules: how… Qin Wu
- [netmod] Re: vendor proprietary YANG modules: how… Michael Richardson
- [netmod] Re: vendor proprietary YANG modules: how… Qin Wu