[netmod] Re: Mike Bishop's No Objection on draft-ietf-netmod-rfc8407bis-25: (with COMMENT)

Mike Bishop <mbishop@evequefou.be> Tue, 03 June 2025 15:11 UTC

Return-Path: <mbishop@evequefou.be>
X-Original-To: netmod@mail2.ietf.org
Delivered-To: netmod@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id 191ED303FA24; Tue, 3 Jun 2025 08:11:10 -0700 (PDT)
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -1.897
X-Spam-Level:
X-Spam-Status: No, score=-1.897 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_NONE=-0.0001, RCVD_IN_MSPIKE_H2=0.001, RCVD_IN_VALIDITY_RPBL_BLOCKED=0.001, RCVD_IN_VALIDITY_SAFE_BLOCKED=0.001, SPF_PASS=-0.001] autolearn=ham autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=pass (1024-bit key) header.d=evequefou.onmicrosoft.com
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id mgjd7ba9LHJ4; Tue, 3 Jun 2025 08:11:09 -0700 (PDT)
Received: from NAM10-MW2-obe.outbound.protection.outlook.com (mail-mw2nam10on2097.outbound.protection.outlook.com [40.107.94.97]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange ECDHE (P-384) server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id EDD4B303FA1D; Tue, 3 Jun 2025 08:11:08 -0700 (PDT)
ARC-Seal: i=1; a=rsa-sha256; s=arcselector10001; d=microsoft.com; cv=none; b=O9nix2zERlAn9WG8IkRgIvBIJJr8FnD8sBpHxUzJrMwu/GT+ZMH7fj7MDDG7pNDFmydu6Yc2myFDckqc8jKq8PQNmMvXcNueAl8YcMKIp3ptE5b+yNs7AUM7bWmNqgOoF508T/wbWSppVfGlDKJR6TWA3SERfE4YD9j3oGv/3rIOwTIo6EO9QxVj+7RXTD0yLPWif1ggM1wCiVJIHKb5HSSN171P6rbAoWmJFE7W0x/W+fr9i08EmhaOTi7JgexHKxKz7IeDoahzWe/CUFL6SrovqHTDMYSF9RRTyjjUn6KHaOUt6O+GvWowYNVveFxqgqRMs50+PsYFYPbj2UEKnQ==
ARC-Message-Signature: i=1; a=rsa-sha256; c=relaxed/relaxed; d=microsoft.com; s=arcselector10001; h=From:Date:Subject:Message-ID:Content-Type:MIME-Version:X-MS-Exchange-AntiSpam-MessageData-ChunkCount:X-MS-Exchange-AntiSpam-MessageData-0:X-MS-Exchange-AntiSpam-MessageData-1; bh=CyYFA/Dg8Nfm9fhlUpuwCjSREsvJviYNQ4xVk3kXTLA=; b=PipwcLmM2nJP83kEjCHhnYSmBgBUnJtb6Lj4AtB4jDEtFany8Hs0z7+YeYn8xu86p1I0PTqlk7It6//N65K8ACFcqRlo0gy3b0ynYXv9tRqE2IAcWjSj1QBSyF2kZ5y0h1yKl3YcnzKC6tkGztQIa16TKIZhDX1zFfJI0iQn1soQkVHomEzyYn4x7DfOz++4zbYHb0uQInf/rPALTbRn8ZDKh0N9PojiZXgRaj2pu9UW8AtyPM96J2k4S2SKErpB/zkw2mIujM/4Yk3f8N0TDQWOzQV7k899eMtWcxmV8mh01iGo5/wtemrOtmsQ1kynbN4+g+XjsoJuToFXfrezRw==
ARC-Authentication-Results: i=1; mx.microsoft.com 1; spf=pass smtp.mailfrom=evequefou.be; dmarc=pass action=none header.from=evequefou.be; dkim=pass header.d=evequefou.be; arc=none
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=evequefou.onmicrosoft.com; s=selector2-evequefou-onmicrosoft-com; h=From:Date:Subject:Message-ID:Content-Type:MIME-Version:X-MS-Exchange-SenderADCheck; bh=CyYFA/Dg8Nfm9fhlUpuwCjSREsvJviYNQ4xVk3kXTLA=; b=JxIl/FmfR160cANtKJQN+wUQQS8TQ8aHjo1jNbOsJVHIeeOCrebLDlNi0yrWJ2uKR1b4MLpNl4qbqa3DmgJeF1gegNEbAjf1Ic8wbhJ8YXmckXXZE4/InPRhIvbfaNqpPH1jw3JDHVcs5W3Qt232oxrn5xixfP6Gl3Rr0a2dyng=
Received: from IA0PPF726CD7A1F.namprd22.prod.outlook.com (2603:10b6:20f:fc04::d2b) by SJ0PR22MB3141.namprd22.prod.outlook.com (2603:10b6:a03:42d::7) with Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) id 15.20.8746.40; Tue, 3 Jun 2025 15:11:05 +0000
Received: from IA0PPF726CD7A1F.namprd22.prod.outlook.com ([fe80::c552:f531:59c0:7988]) by IA0PPF726CD7A1F.namprd22.prod.outlook.com ([fe80::c552:f531:59c0:7988%6]) with mapi id 15.20.8792.034; Tue, 3 Jun 2025 15:11:05 +0000
From: Mike Bishop <mbishop@evequefou.be>
To: "mohamed.boucadair@orange.com" <mohamed.boucadair@orange.com>, The IESG <iesg@ietf.org>
Thread-Topic: Mike Bishop's No Objection on draft-ietf-netmod-rfc8407bis-25: (with COMMENT)
Thread-Index: AQHb0+iUm93BelOTCUOJtV6T+0r4+bPw42aAgACoMPI=
Date: Tue, 03 Jun 2025 15:11:05 +0000
Message-ID: <IA0PPF726CD7A1F9C8173FB64B518EA7567DA6DA@IA0PPF726CD7A1F.namprd22.prod.outlook.com>
References: <174888737477.2642392.6994328686330354928@dt-datatracker-59b84fc74f-84jsl> <PR0P264MB2885F5DF91A46A05B7DD3B26886DA@PR0P264MB2885.FRAP264.PROD.OUTLOOK.COM>
In-Reply-To: <PR0P264MB2885F5DF91A46A05B7DD3B26886DA@PR0P264MB2885.FRAP264.PROD.OUTLOOK.COM>
Accept-Language: en-US
Content-Language: en-US
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
msip_labels:
authentication-results: dkim=none (message not signed) header.d=none;dmarc=none action=none header.from=evequefou.be;
x-ms-publictraffictype: Email
x-ms-traffictypediagnostic: IA0PPF726CD7A1F:EE_|SJ0PR22MB3141:EE_
x-ms-office365-filtering-correlation-id: 62a3e167-6f7c-494c-66b6-08dda2b0dc74
x-ms-exchange-senderadcheck: 1
x-ms-exchange-antispam-relay: 0
x-microsoft-antispam: BCL:0;ARA:13230040|376014|1800799024|10070799003|366016|38070700018|7053199007|8096899003|13003099007;
x-microsoft-antispam-message-info: kozC7oicS4UbAJq4B7pbNXUtOV4QmdvbO3zntxv4rmtR78Of/rgfzScjBtscMBHqMaI0LL6CdIKPR/E5bczSjU9vRuzjd2TKWhaLYcaoAlQtnJb0rlE7JK+OZDwQu55eG/8NMxnHnVenAbMkN36AIa9QWCw0pfIVHnVmKNfh0tMn1ze3rE4hPAiuXy25QnPrHgIP/WfvP3uGD/gTk5xPnuYj3kl0cB48VdwGJmpg3tioxW8I3KrWD2D29UGnprMzrARdLtJugK+bz5sHpdLu5foPiHPzs9ldXs36nbslVDwsF8OsMPHthpuXuTjt+4YUdoN/Dw2ObEwdmie8xM+cFDz/knFczDDBnNZzSwXiOeOw+u5xLWRRFOLlUzAcNfLEu9anEHJJpFP6waJ4kAx8L+xK9dDbyH3VbWn1qO53PxMXIWSM42JdKjL1CeOIXUP5IHvYZ5T+uttEH5bjjSSTJZAEhbCBxu9t75s5KMLU5cfEJMdoXHsytV2CDZ3deCp0joWVO65Sk+JvuzEU7ETJr46tj1fFaQSrqBYu3uWbHhRfad1Tr/njXAJHG92akoVF3+33h2tL9dBNyTCRncRJ2WHRpC6wRtBIp9JzZP+PZiF8kejn/4AZonL1LQ3iU7S0UANub/UkVJremhRrdJXIzBuYY/2YwX1efonc9HP9Fm0vmqIZX8H+wr8xtt2XsjC69RqgNSuCa92L0oQXNwhYlhBvJAyIIcgPU4xqsugYcl9ICfs/2IkMyzDeqNKvDTiwB5iKpLU5IYfF4QjHOapxVBS933Bce/W/O5O9EmI7KOpExrcMtY8OGxA/cS/V2yXAkmSJwUPQT0+c4+CGDefVZqkeE9aq7IhxHGor9VQ88fUhV7oVvbRTiaBV9XNQCG/uTbKNCc8EQIJeDqKUzFkz1okSDEMGiWB4f46Wh+4bDtlZB2QZibwMR/uZidwm1jUBqt3RdzIKdpgrjSjBL5rVjY112nnhE2Liqh71d6T6XBtdJ2WdCgKmZBMvBlGZ6NerllbnLmE6nj8A+yEPvIguKL4BuWgpfNnPYIDiOA/UgFfWQyBjsbnEIIWtUQMDhuaMHJnQd9g5h1fNdzxObAekB87lXlMu0ycR2ky35s9rEp4ezhgG/tuvrwdHdZXwUDQe3QgtDhH+KFoNxRFqkPSFdeOKSSZwi6Hxl1JQ2sEgBw8JsZ9UDMzHmul4loRE9wn6o2Q0XaZvl8u4Ko6usGp+SlbmgT7EbSxUP+PTGhx498doYRPjOofjyf8RW6KMp4YNYMtomXg5C7liTl87BFKp/d/J5xgNRIlcP3/Yl/6onkjqFHy/QzChlmgqRGvjEqV6hHIfaOustvQ6hwJ2KUFu/UVdY8HJ4IekUCQZDojOxIyQI/uPyfnkNGgdhI7g8KqrnnNFuiJ0k8o76S9guomQdt1ajKlfhWH7Nyuh/YWz7lA=
x-forefront-antispam-report: CIP:255.255.255.255;CTRY:;LANG:en;SCL:1;SRV:;IPV:NLI;SFV:NSPM;H:IA0PPF726CD7A1F.namprd22.prod.outlook.com;PTR:;CAT:NONE;SFS:(13230040)(376014)(1800799024)(10070799003)(366016)(38070700018)(7053199007)(8096899003)(13003099007);DIR:OUT;SFP:1102;
x-ms-exchange-antispam-messagedata-chunkcount: 1
x-ms-exchange-antispam-messagedata-0: NlXHgd0yc64fukWzaDsp8asa9H9Z1Q365deVRn71pDGH6gG69Gl/6mcwhBjkmGBMg2Re8Rf7XhLZ2itQ3BrIQlGP7RnRuK2r9F34q3PwxDjkEwM9aWrdZqAglULUeVY3+CBHyrw+db/jkTG8mQ/IujbALdRAjomjxN4eoPdLuh5zNJ3iBJw/GtejCfljWiUd2CiH7QeSVVYAr4YSKj0VZ/PXgTf4W9KPizpV2Lfc//mVrqW1ZY694fWOSQqs0VjmRR9lNsryqfYSb+F//tM82Zrjx1CVHzkUMj5lRJV/H/XlO5JzvOnPaaGdyYw4VIZmsW4RuFU/7zcX+11LTNkRuEKO8npyzYHTLTc8VIfDZzXDlQiZZknOXdO9q79YK2I9TKKqxKxy0eHCCmNN7mK2X0oE6HISderiC7faVrQRYb8cTS72poIEejq/KfgahWmFikjazWf5Qk+4ouFlK8LfRnDtyiKSEJx9NJt6vBD2tFa9FK75vbyw7ELNHQKT+L2lEEfxadC6io2RLtSyeLcrrfpQab2OKEWaZXEnbsqrIZlRYr1evY8GJsP1vgRqX1WCgbR/g1X+gpGygZCexhdG4QQ0RmAiyanLoS0e9tgMtSFcufwqq8YBJuDNIFVCgwZgR5RxSUyMkcrcAu3xOwKm/p3UWUuC+SxH5rcnQjSnB5dvuDfPmn+Jo9z1NEMPglYIDuxUEdbNrT1bYjDthQx0Ip6DLsOI8OR3g4FMsO7+21TweKP4KqqeJeMUpO/ImfsOsAMxpBcUgnyMwz5z9E84rn6BWXDXH5AcuwW6A4KDKNAGaWEygCZSfUV+HYS5E/a/ybsz3LcXOlxsiNV7+pSy2Tt80WvIR+mu8uCvY0VoYcfYRhLtqVR+5s2N4Fz0tbdxtghsKgz0kngAqQUZAxrluO6e6URkGJ3GWpB6QYjtnpiAwCYMfKSJmVOpkkPio2a+J1WojS0KCgx2cVXv2rdDZhd/XSMqLHrILi6/D6u55sWOwE57c6REnKuFLepff88s8e8iaF4+fx8BxKWNg5k3TMkkm0es1uqXF9H5bbPG051/tyvBx+XfentR6DzmY93oR0wucPNC2MtGSvH99ZCF+mm1oYSQ7EJcljV8PjfCYGC9G9Ig/x2p9B2nqLnWyXrrVa7Po3NcRM31mqPhz6Fb1zC044h2tleMnGfm4V5SsOEo83cQlB/qHGlw+69L7c9pdRq7IP3Y46BX5x6tWbCLG/g42J5NrPIVAKZ3cfTtRstSzRBuUnMS6FWQXy8oWsyRCrfwQwUhx43Zt+8WM9DaOhm4nHxPQxV1eQeb4o6CCwFyNVqmiaG/Wa3goGpGlgzJeWz+U1sMuhA5wXfYP5J031qi8AM+v8AqhHF7yIUkkJFvYItIN2BRElvoel6smroGp2pmSR4O3FARzQ28tZIV6cYvSme7649phnn/KXk2nuVLDJep1CSpwy7eP5jabAxCWnWzISPuEGNaHQxYSh3LCLAIE934Pc9RjRVX/mFCoC9R9yjb9kAgTfj51JUoMn6jhhPSMziiuIG25DgCBy3l6ycpmSMPbaeScfBq8e/pCiX/Y8/8dP6xRzMJuXQJK9TO5M9KKC1E7qukTWzRGpX0D5nmtC3V2ZgT3jLEzPVPplwT3HWAcbvvlBq+OXaRGQtC
Content-Type: multipart/alternative; boundary="_000_IA0PPF726CD7A1F9C8173FB64B518EA7567DA6DAIA0PPF726CD7A1F_"
MIME-Version: 1.0
X-OriginatorOrg: evequefou.be
X-MS-Exchange-CrossTenant-AuthAs: Internal
X-MS-Exchange-CrossTenant-AuthSource: IA0PPF726CD7A1F.namprd22.prod.outlook.com
X-MS-Exchange-CrossTenant-Network-Message-Id: 62a3e167-6f7c-494c-66b6-08dda2b0dc74
X-MS-Exchange-CrossTenant-originalarrivaltime: 03 Jun 2025 15:11:05.2993 (UTC)
X-MS-Exchange-CrossTenant-fromentityheader: Hosted
X-MS-Exchange-CrossTenant-id: 41eaf50b-882d-47eb-8c4c-0b5b76a9da8f
X-MS-Exchange-CrossTenant-mailboxtype: HOSTED
X-MS-Exchange-CrossTenant-userprincipalname: wr1qgxy9n8UnD2NcBz+qj3QS43igSCSTlk+AMScWahHUuIwu3Ab+Y8xHaMWpbIVKPZFbB83+/HOe/B0+8f+Ygw==
X-MS-Exchange-Transport-CrossTenantHeadersStamped: SJ0PR22MB3141
Message-ID-Hash: 2FHHQGIZMUG7LW7YMBRPNS37WBZCIKIG
X-Message-ID-Hash: 2FHHQGIZMUG7LW7YMBRPNS37WBZCIKIG
X-MailFrom: mbishop@evequefou.be
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-netmod.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: "draft-ietf-netmod-rfc8407bis@ietf.org" <draft-ietf-netmod-rfc8407bis@ietf.org>, "netmod-chairs@ietf.org" <netmod-chairs@ietf.org>, "netmod@ietf.org" <netmod@ietf.org>, "kent+ietf@watsen.net" <kent+ietf@watsen.net>
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [netmod] Re: Mike Bishop's No Objection on draft-ietf-netmod-rfc8407bis-25: (with COMMENT)
List-Id: NETMOD WG list <netmod.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/netmod/A-A3xB_khjZgpWy4KbykgO6jRtw>
List-Archive: <https://mailarchive.ietf.org/arch/browse/netmod>
List-Help: <mailto:netmod-request@ietf.org?subject=help>
List-Owner: <mailto:netmod-owner@ietf.org>
List-Post: <mailto:netmod@ietf.org>
List-Subscribe: <mailto:netmod-join@ietf.org>
List-Unsubscribe: <mailto:netmod-leave@ietf.org>

All looks good. Thank you!
________________________________
From: mohamed.boucadair@orange.com <mohamed.boucadair@orange.com>
Sent: Tuesday, June 3, 2025 1:08 AM
To: Mike Bishop <mbishop@evequefou.be>; The IESG <iesg@ietf.org>
Cc: draft-ietf-netmod-rfc8407bis@ietf.org <draft-ietf-netmod-rfc8407bis@ietf.org>; netmod-chairs@ietf.org <netmod-chairs@ietf.org>; netmod@ietf.org <netmod@ietf.org>; kent+ietf@watsen.net <kent+ietf@watsen.net>; maqiufang1@huawei.com <maqiufang1@huawei.com>
Subject: RE: Mike Bishop's No Objection on draft-ietf-netmod-rfc8407bis-25: (with COMMENT)

Hi Mike,

Thanks for the review. The changes made so far to address your comments can be seen at: https://author-tools.ietf.org/api/iddiff?url_1=https://netmod-wg.github.io/rfc8407bis/draft-ietf-netmod-rfc8407bis.txt&url_2=https://netmod-wg.github.io/rfc8407bis/mike-review/draft-ietf-netmod-rfc8407bis.txt.

Please see inline.

Cheers,
Med (as editor)

> -----Message d'origine-----
> De : Mike Bishop via Datatracker <noreply@ietf.org>
> Envoyé : lundi 2 juin 2025 20:03
> À : The IESG <iesg@ietf.org>
> Cc : draft-ietf-netmod-rfc8407bis@ietf.org; netmod-chairs@ietf.org;
> netmod@ietf.org; kent+ietf@watsen.net; maqiufang1@huawei.com;
> maqiufang1@huawei.com
> Objet : Mike Bishop's No Objection on draft-ietf-netmod-rfc8407bis-
> 25: (with COMMENT)
>
>
> Mike Bishop has entered the following ballot position for
> draft-ietf-netmod-rfc8407bis-25: No Objection
>
> When responding, please keep the subject line intact and reply to
> all email addresses included in the To and CC lines. (Feel free to
> cut this introductory paragraph, however.)
>
>
> -------------------------------------------------------------------
> COMMENT:
> -------------------------------------------------------------------
>
> I also share Gunter's initial reaction.
>
> While fine in this document, as it doesn't deal directly with the
> DNS, I would
> consider using a replacement token other than "AAAA" in future
> work, since this
> is a token that occurs somewhat frequently in IETF documents.
> (RFCAAAA is fine.)
>
> I was surprised by the change in 4.1 from RFC7950 to RFC6020, since
> the latter
> is older than the reference it replaces. However, the content looks
> correct in
> 6020, so I'm guessing this is deliberate and a fix to an error in
> RFC8407.

[Med] I confirm. For some reason, this bug seems to be inherited from draft-ietf-netmod-rfc6087bis-04.

 I
> didn't find anything in the list of changes to reflect this,
> however;

[Med] This is covered by this point:

CURRENT:
  *  Fixed a reference bug in Section 4.1.

 was there
> an erratum filed for this?
>
> In Section 5, the current practice is to list the IETF, rather than
> the IESG,
> as the change controller for our registrations.

[Med] Fair point. Note however that YANG specs have always listed IESG in their IANA requests (https://www.iana.org/assignments/xml-registry/xml-registry.xhtml shows that other registrations followed that pattern as well). I guess this is rooted in this part from RFC3688:

   Registrant Contact
      The individual/organization that is the registration contact for
      the component being registered.  Ideally, this will be the name
      and pertinent physical and network contact information.  In the
      case of IETF developed standards, the Registrant will be the IESG.

I will double check with IANA.

 IANA isn't
> revisiting old
> registrations to make this change proactively, but while you're
> updating these,
> consider updating that field as well.
>
> This may be excessive, but just for clarity, does Appendix B need a
> note to the
> RFC Editor clarifying that the notes to the RFC Editor in the
> template are part
> of the template and should not be acted upon during the processing
> of this
> document?

[Med] No sure we need that note.

>
> ===NITS FOLLOW===
>
> Section 2, "Some of the templates defined in the document uses" =>
> "Some of the
> templates defined in the document use"

[Med] OK

>
> Section 3.5, "noted following [RFC8792]" could be parsed as placing
> the note
> after RFC8792; consider "indicated with a reference to [RFC8792]"

[Med] Went with "indicated per the guidance in [RFC8792]"

>
> Section 3.7, "define exclusively modules following" => "exclusively
> define
> modules that follow"

[Med] Fixed.

>
> Section 3.7.1, consider "have to use" => "require" x2

[Med] Left the current text.

>
> Section 3.7.1, "as normative references." => "as a normative
> reference."
>

[Med] Fixed.


____________________________________________________________________________________________________________
Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.