[netmod] Re: AD review of draft-ietf-netmod-acl-extensions

Mahesh Jethanandani <mjethanandani@gmail.com> Mon, 13 January 2025 06:49 UTC

Return-Path: <mjethanandani@gmail.com>
X-Original-To: netmod@ietfa.amsl.com
Delivered-To: netmod@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id DA4B3C14F693; Sun, 12 Jan 2025 22:49:38 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -2.104
X-Spam-Level:
X-Spam-Status: No, score=-2.104 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, FREEMAIL_FROM=0.001, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_NONE=-0.0001, RCVD_IN_ZEN_BLOCKED_OPENDNS=0.001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001, T_SCC_BODY_TEXT_LINE=-0.01, URIBL_BLOCKED=0.001, URIBL_DBL_BLOCKED_OPENDNS=0.001, URIBL_ZEN_BLOCKED_OPENDNS=0.001] autolearn=ham autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (2048-bit key) header.d=gmail.com
Received: from mail.ietf.org ([50.223.129.194]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 0092m5yovQJY; Sun, 12 Jan 2025 22:49:35 -0800 (PST)
Received: from mail-pj1-x102c.google.com (mail-pj1-x102c.google.com [IPv6:2607:f8b0:4864:20::102c]) (using TLSv1.3 with cipher TLS_AES_128_GCM_SHA256 (128/128 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 4725EC14F6E1; Sun, 12 Jan 2025 22:49:35 -0800 (PST)
Received: by mail-pj1-x102c.google.com with SMTP id 98e67ed59e1d1-2ef72924e53so6636648a91.3; Sun, 12 Jan 2025 22:49:35 -0800 (PST)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20230601; t=1736750974; x=1737355774; darn=ietf.org; h=references:to:cc:in-reply-to:date:subject:mime-version:message-id :from:from:to:cc:subject:date:message-id:reply-to; bh=93gC1FKOtuV76M/MbdfrevKYwCm/Ta0LmEd4J/EvKg0=; b=AczyFjwauTR+hTbc2oK9gamPkRE5emNolR50tZyZxEbxuHJTX+ZCMDA4BOdcZ5Xz9z ZmeB5Psze4jMbrLlj2Pc6jDSNeBNEz6jCCOcYoqfz0RQJQvXWyOjHIP1HDGWlGEpA9Im rVgLUDb+GyzAg/5EWWIF/HAIqEOxuv3QZq9KcxaFs030WI1XWo630LGLUkbKjgqb5bkL B6KyTHXbUMzfr/DuxiPBvMJvV06ZfVpL2rCatEZ8GlGqRsTRmuPoR3EwADJlVPbpXnSh Gqc7KuX0wlRoxTAh9qofACVzpkre8HxOaP/TTnQXOzo14J226NnK01O85epwp9YN+2W5 nO+g==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20230601; t=1736750974; x=1737355774; h=references:to:cc:in-reply-to:date:subject:mime-version:message-id :from:x-gm-message-state:from:to:cc:subject:date:message-id:reply-to; bh=93gC1FKOtuV76M/MbdfrevKYwCm/Ta0LmEd4J/EvKg0=; b=Ghvo4MkANyJ1Ao1yQBAOo3xS1YlW/NBZwxEZAx0ff/z22AS9Ok+xfdPYYV1c+4VPJn tg+eKcT6sn+WwQIewUq9xJNija304nEMX3xnW34pE6LOJfgnTj7YSYoiy7v6wImsjm6I +ohKS+nB97VTa/t2MAdmwLyw5hf/wPIQHNNnm2io3mTjDTHTKg9rRE/FQgcSsSCcu37n rNpbYrVbUToaQy+hJkMInKhO29ozXKike8tQ/XoxXlvXddmbbTDL8Th1+05oO7JwbVxS rwK0XV93ojwJnXLZYd62t61VXInww1FviY8pnJu8g2L0tpCegLWYJVWvM7yuRO1ukA6E RsqQ==
X-Forwarded-Encrypted: i=1; AJvYcCWKS6WKfaM2M91pZ0ukwds4tp9vvX9kaD2MkcejMrILuy/fZEw58VFrlW/OLB81usdaT+JnL3o=@ietf.org
X-Gm-Message-State: AOJu0Yz817jPAhzyK+mM7n+qoXJ7pkp8e5kx/V7dFCrIiL/c8ipKk9BW QTnWqzZ29kiL6I0UJIyDRnVQ5QZqh9/69gGAAZEbUUEY4l/gNkq5
X-Gm-Gg: ASbGnctI0AOnlCnl149nhfTdoLa/6YWUP0huN1O5NNJCs3Lh/FA+5dQjtQp43AbQDHH 6uJvnzd1c2YeB+6zPEYfK4Y6sJJD5rLOrAcJjU3DlWnQOpFj7ALt612L87X72ika1VwbajjbBlU OLBENwFRxiQAH86c+QYaGyR5QDvILMWs8Y9kyoM2K31+9BVNIkeH4XmOrzcYADYu5/k1nA34/Yk KzXND+2H+9BWY/q1mjOAAPi3EQUTo11qlQXouohREQOLm9GVpNmke66Kh3sAmZxF1rOR8BpzkwK TUd96XZodCq0
X-Google-Smtp-Source: AGHT+IFifGhIVwni4TF7wxx444XfDCfuyT82CC5KADux6dfIxWQZSXQd38HOqDKY6FZYJ7p3YeBszQ==
X-Received: by 2002:a17:90b:5446:b0:2ee:8c98:a965 with SMTP id 98e67ed59e1d1-2f548f7fee8mr25007550a91.34.1736750974149; Sun, 12 Jan 2025 22:49:34 -0800 (PST)
Received: from smtpclient.apple ([2405:201:400b:7119:f02c:e669:ed1c:8b7e]) by smtp.gmail.com with ESMTPSA id 98e67ed59e1d1-2f54a2872e6sm9378685a91.14.2025.01.12.22.49.31 (version=TLS1_2 cipher=ECDHE-ECDSA-AES128-GCM-SHA256 bits=128/128); Sun, 12 Jan 2025 22:49:33 -0800 (PST)
From: Mahesh Jethanandani <mjethanandani@gmail.com>
Message-Id: <4AE8EAA9-12B5-4E76-8399-73BEAEBD3BE0@gmail.com>
Content-Type: multipart/alternative; boundary="Apple-Mail=_0019454F-250E-44D5-A600-EED17065693D"
Mime-Version: 1.0 (Mac OS X Mail 14.0 \(3654.120.0.1.15\))
Date: Mon, 13 Jan 2025 12:19:29 +0530
In-Reply-To: <MR1PPF6395AA9E60A9B6691DB567E27BB4A88112@MR1PPF6395AA9E6.FRAP264.PROD.OUTLOOK.COM>
To: Med Boucadair <mohamed.boucadair@orange.com>
References: <8C6D8446-6A1C-4670-84B7-FD4245A38152@gmail.com> <MR1PPF6395AA9E60A9B6691DB567E27BB4A88112@MR1PPF6395AA9E6.FRAP264.PROD.OUTLOOK.COM>
X-Mailer: Apple Mail (2.3654.120.0.1.15)
Message-ID-Hash: 74CD7HKSZ4G27BNEM3KFLDUJQPWQ2XKE
X-Message-ID-Hash: 74CD7HKSZ4G27BNEM3KFLDUJQPWQ2XKE
X-MailFrom: mjethanandani@gmail.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-netmod.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: "draft-ietf-netmod-acl-extensions@ietf.org" <draft-ietf-netmod-acl-extensions@ietf.org>, NETMOD Working Group <netmod@ietf.org>
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [netmod] Re: AD review of draft-ietf-netmod-acl-extensions
List-Id: NETMOD WG list <netmod.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/netmod/Sf_6v8E-IYrHxcOP6wUkXrW9AMs>
List-Archive: <https://mailarchive.ietf.org/arch/browse/netmod>
List-Help: <mailto:netmod-request@ietf.org?subject=help>
List-Owner: <mailto:netmod-owner@ietf.org>
List-Post: <mailto:netmod@ietf.org>
List-Subscribe: <mailto:netmod-join@ietf.org>
List-Unsubscribe: <mailto:netmod-leave@ietf.org>

Hi Med,

Thanks for addressing most of my comments as well as other *DIR reviews. I hope the SECDIR review comes through soon. 

See inline with [mj] for any follow-up.

> On Jan 7, 2025, at 9:44 PM, mohamed.boucadair@orange.com wrote:
> 
> Hi Mahesh,
>  
> Thank you for the review.
>  
> Samier kindly prepared an updated version that addresses most of your comments. The diff can be seen here: https://author-tools.ietf.org/api/iddiff?url_1=https://netmod-wg.github.io/enhanced-acl-netmod/draft-ietf-netmod-acl-extensions.txt&url_2=https://netmod-wg.github.io/enhanced-acl-netmod/Mahesh-comments/draft-ietf-netmod-acl-extensions.txt <https://author-tools.ietf.org/api/iddiff?url_1=https://netmod-wg.github.io/enhanced-acl-netmod/draft-ietf-netmod-acl-extensions.txt&url_2=https://netmod-wg.github.io/enhanced-acl-netmod/Mahesh-comments/draft-ietf-netmod-acl-extensions.txt>
>  
> Please see inline.
>  
> Cheers,
> Med
>  
> De : Mahesh Jethanandani <mjethanandani@gmail.com <mailto:mjethanandani@gmail.com>> 
> Envoyé : vendredi 3 janvier 2025 06:32
> À : draft-ietf-netmod-acl-extensions@ietf.org <mailto:draft-ietf-netmod-acl-extensions@ietf.org>
> Cc : NETMOD Working Group <netmod@ietf.org <mailto:netmod@ietf.org>>; Per Andersson <per.ietf@ionio.se <mailto:per.ietf@ionio.se>>
> Objet : AD review of draft-ietf-netmod-acl-extensions
>  
> 
> Hi Authors of  draft-ietf-netmod-acl-extensions,
>  
> Happy New Year!
>  
> One expert SECDIR review is still pending on the document, which I hope will be coming soon. Thanks to Per for providing the YANG Doctors review, to Tim for providing the INTDIR, and to David for the TSVART review. In the meantime, please find my AD review comments on the document. I hope these comments help to improve the document.
>  
> COMMENT:
>  
> "Abstract", paragraph 2
> >    RFC 8519 defines a YANG data model for Access Control Lists (ACLs).
> >    This document discusses a set of extensions that fix many of the
> >    limitations of the ACL model as initially defined in RFC 8519.
> > 
> >    The document also defines IANA-maintained modules for ICMP types and
> >    IPv6 extension headers.
>  
> This document provided important extensions to the base ACL YANG model defined in RFC8519.
>  
> However, nowhere in the document does it mention that these extensions augment the base model, except in the model itself. Reading the abstract and the introduction, a reader would be left wondering whether this model is replacing RFC 8519 or augmenting it. Can that be made clear?
>  
> [Med] A new sentence was added to the abstract.

[mj] Thanks.

>  
> Section 2, paragraph 4
> >    Defined set:  Refers to reusable description of one or multiple
> >       information elements (e.g., IP address, IP prefix, port number, or
> >       ICMP type).
>  
> Is it just a description? A better way to define it would be to say:
>  
> Elements in a defined set typically share a logical purpose or function, such as IP address, IP prefixes, port number, or ICMP type.
>  
> Similarly definition of 'payload-based filtering' could be added to define the term or referenced if defined somewhere else.
>  
> [Med] Done.

[mj] Thanks.

>  
> Section 3.5, paragraph 1
> >    The augmented ACL structure (Figure 1) includes new leafs
> >    'ipv4-fragment' and 'ipv6-fragment' to better handle fragments.
>  
> The document comments that RFC8519 does not do a good job of handling fragments and that this document addresses that issue. It would help to explain how the model defined in the document allows for better handling of fragments. For example, describe how the combination of operator and fragment type eases fragment handling.
>  
> [Med] We do explain this in https://datatracker.ietf.org/doc/html/draft-ietf-netmod-acl-extensions-13#name-partial-or-lack-of-ipv4-ipv <https://datatracker.ietf.org/doc/html/draft-ietf-netmod-acl-extensions-13#name-partial-or-lack-of-ipv4-ipv> and then illustrate the use of bitmask inhttps://datatracker.ietf.org/doc/html/draft-ietf-netmod-acl-extensions-13#name-fragments-handling-2 <https://datatracker.ietf.org/doc/html/draft-ietf-netmod-acl-extensions-13#name-fragments-handling-2>. Do you think we need to say more?  

[mj] I seem to have missed that somehow. I think it suffices, so no more edits needed.

>  
>  
> Section 4, paragraph 1
> >    This model imports types from [RFC6991], [RFC8519], and [RFC8294].
>  
> Thanks first of all to Per for providing YANG doctor review comments. I also tend to agree with him that as a practice reference to RFC 9293, 4443, 3032, 792, and IEEE 802.1Q, IEEE 802.1ah need to be added here, even if they are referenced or mentioned elsewhere.
>  
> [Med] I’m afraid that saying this module references REF1, REF2, etc. isn’t that useful. These refs are cited in their context.

[mj] I went looking for precedence to see if this has been followed but did not find any, which I think is sad. The interface YANG module and the Routing Policy module follow the practice, but NI or Routing modules do not. Citing RFCs without a square bracket is common in YANG modules, and the idtool does not pick up on it unless the square bracket is present. That means that RFCs referenced in the YANG module can be missed unless the RFC Editor catches them. The practice of referencing all YANG modules in the section that includes the YANG module was supposed to address it and why Per brought it up. The fact that you have made sure to reference them elsewhere in the document addresses the concern, but I wonder how to ensure the practice is followed.

Cheers..

>  
> "Appendix E.", paragraph 1
> >    This section provides a few examples to illustrate the use of the
> >    enhanced ACL module ("ietf-acl-enh").
>  
> Thank you for providing examples along with the module. The added feature in this module is payload-based filtering. An example configuration reflecting that, say for HTTP headers, would greatly enhance the understanding of this module.
> [Med] Will consider adding an example to illustrate this.
>  
> No reference entries found for these items, which were mentioned in the text:
>  [RFC3692].
>  
> [Med] ACK. 
>  
> -------------------------------------------------------------------------------
> NIT
> -------------------------------------------------------------------------------
>  
> All comments below are about very minor potential issues that you may choose to
> address in some way - or ignore - as you see fit. Some were flagged by
> automated tools (via https://github.com/larseggert/ietf-reviewtool <https://github.com/larseggert/ietf-reviewtool>), so there
> will likely be some false positives. There is no need to let me know what you
> did with these suggestions.
>  
> Section 3.6, paragraph 2
> >    A new feature, called 'match-on-payload', is defined in the document.
> >    This can be used, for example, for QUIC [RFC9000] or for tunneling
> >    protocols.  This feature requires configuring a data offset, a
> >    length, and a binary pattern to macth data against using a specified
> >    operator.
>  
> s/macth/match/
> [Med] ACK
>  
> Section 6.3.1, paragraph 15
> >    IANA is requested to updated the "Reference" in the "ICMP Type
> >    Numbers" registry as follows:
>  
> s/updated/update/
> [Med] ACK
>  
> Section 6.3.2, paragraph 15
> >    IANA is requested to updated the "Reference" in the "ICMPv6 "type"
> >    Numbers" registry as follows:
>  
> s/updated/update/
> [Med] ACK
>  
> Section 6.3.3, paragraph 15
> >    IANA is requested to updated the "Reference" in the "IPv6 Extension
> >    Header Types" registry as follows:
>  
> s/updated/update/
> [Med] ACK
>  
> Section 1.1, paragraph 10
> > ixes, port number, or ICMP type. Similarly definition of 'payload-based filt
> >                                  ^^^^^^^^^
> A comma may be missing after the conjunctive/linking adverb "Similarly".
> [Med] Don’t see where this one is used in the doc.
>  
> Section 4, paragraph 3
> >  { base tcp-flag; description "Acknowledgment TCP flag bit."; reference "RFC
> >                                ^^^^^^^^^^^^^^
> Do not mix variants of the same word ("acknowledgment" and "acknowledgement")
> within a single text.
>  
> [Med] ACK
> 
> Thanks.
> 
> Mahesh Jethanandani
> mjethanandani@gmail.com <mailto:mjethanandani@gmail.com>
>  
>  
>  
>  
> 
>  
> ____________________________________________________________________________________________________________
> Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
> pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
> a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
> Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.
> 
> This message and its attachments may contain confidential or privileged information that may be protected by law;
> they should not be distributed, used or copied without authorisation.
> If you have received this email in error, please notify the sender and delete this message and its attachments.
> As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
> Thank you.


Mahesh Jethanandani
mjethanandani@gmail.com