[OAUTH-WG] Mahesh Jethanandani's No Objection on draft-ietf-oauth-rfc7523bis-11: (with COMMENT)

Mahesh Jethanandani via Datatracker <noreply@ietf.org> Tue, 28 April 2026 21:55 UTC

Return-Path: <noreply@ietf.org>
X-Original-To: oauth@ietf.org
Delivered-To: oauth@mail2.ietf.org
Received: from [10.244.6.213] (unknown [4.156.85.76]) by mail2.ietf.org (Postfix) with ESMTP id B4C91E52743B; Tue, 28 Apr 2026 14:55:06 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=ietf.org; s=ietf1; t=1777413306; bh=ByHlRcEG9nvVCaqc8TLT6akcdcZZ9YCyYa72aHYVvF4=; h=From:To:Cc:Subject:Reply-To:Date; b=Gr6nu7tC2qNVC45C32othL0BQXw5P9CyAXm2Xp4FAmar9b9kuFbwSAw8lyEY1A9Sg cHHBaB10coHLb02BFbBWxZdU3b8PuLYoFPHLZv2han/C+RB9GtsP20YRaO2cj4lhN1 7pSTAo+F2OD0LDni2J4cJDRUzT/d4rfktnEgICIU=
MIME-Version: 1.0
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: 8bit
From: Mahesh Jethanandani via Datatracker <noreply@ietf.org>
To: The IESG <iesg@ietf.org>
X-Test-IDTracker: no
X-IETF-IDTracker: 12.62.0
Auto-Submitted: auto-generated
Precedence: bulk
Message-ID: <177741330663.130569.11571645647257739947@dt-datatracker-b45949c58-t72jx>
Date: Tue, 28 Apr 2026 14:55:06 -0700
Message-ID-Hash: LDL4XGGOBLCCT6DNTJ2NX7EEJE6EQXR4
X-Message-ID-Hash: LDL4XGGOBLCCT6DNTJ2NX7EEJE6EQXR4
X-MailFrom: noreply@ietf.org
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-oauth.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: draft-ietf-oauth-rfc7523bis@ietf.org, oauth-chairs@ietf.org, oauth@ietf.org
X-Mailman-Version: 3.3.9rc6
Reply-To: Mahesh Jethanandani <mjethanandani@gmail.com>
Subject: [OAUTH-WG] Mahesh Jethanandani's No Objection on draft-ietf-oauth-rfc7523bis-11: (with COMMENT)
List-Id: OAUTH WG <oauth.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/oauth/lcxPMVmlcvr4S2Z-LW83EPOysOk>
List-Archive: <https://mailarchive.ietf.org/arch/browse/oauth>
List-Help: <mailto:oauth-request@ietf.org?subject=help>
List-Owner: <mailto:oauth-owner@ietf.org>
List-Post: <mailto:oauth@ietf.org>
List-Subscribe: <mailto:oauth-join@ietf.org>
List-Unsubscribe: <mailto:oauth-leave@ietf.org>

Mahesh Jethanandani has entered the following ballot position for
draft-ietf-oauth-rfc7523bis-11: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)


Please refer to https://www.ietf.org/about/groups/iesg/statements/handling-ballot-positions/ 
for more information about how to handle DISCUSS and COMMENT positions.


The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-oauth-rfc7523bis/



----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Section 7, paragraph 1
>    This specification tightens token audience requirements to prevent
>    attacks that could result from exploiting audience ambiguities
>    previously allowed by [RFC7521], [RFC7522], [RFC7523], and [RFC9126].
>    These attacks are described in [private_key_jwt.Disclosure] and
>    [Audience.Injection].

Section 4a of this document updates the authorization grant audience
requirement to:

"An authorization server MAY be identified by either its issuer
identifier or its token endpoint URL."

The document history notes that this flexibility was retained to minimize
breaking changes. By allowing the token endpoint URL as a valid audience for
authorization grants, a subset of the attack surface described in the
referenced paper remains.

The document does not acknowledge this residual risk. This section
says that "This specification tightens token audience requirements
to prevent attacks" — a statement that is not fully accurate for
the authorization grant case. The Security Considerations should
state explicitly that: (a) the tighter restriction applies only
to client authentication JWTs; (b) authorization grant audience
requirements were relaxed relative to what full security would
require, for deployment compatibility reasons, and (c) implementers
seeking maximum security for authorization grants SHOULD prefer
the issuer identifier over the token endpoint URL.

The ARTART reviewer (Jim Fenton, thanks, Jim) touched on this
concern about strong typing, but the underlying grant case
residual risk deserves direct acknowledgment.

No reference entries found for these items, which were mentioned in the text:
[draft-jones-oauth-rfc7523bis-00].