[openpgp] Re: [Technical Errata Reported] RFC9580 (8814)
Daniel Huigens <d.huigens@protonmail.com> Wed, 18 March 2026 19:04 UTC
Return-Path: <d.huigens@protonmail.com>
X-Original-To: openpgp@mail2.ietf.org
Delivered-To: openpgp@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id 70E54CD37B2C for <openpgp@mail2.ietf.org>; Wed, 18 Mar 2026 12:04:43 -0700 (PDT)
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -2.796
X-Spam-Level:
X-Spam-Status: No, score=-2.796 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, FREEMAIL_FROM=0.001, RCVD_IN_DNSWL_LOW=-0.7, RCVD_IN_MSPIKE_H5=0.001, RCVD_IN_MSPIKE_WL=0.001, RCVD_IN_VALIDITY_CERTIFIED_BLOCKED=0.001, RCVD_IN_VALIDITY_RPBL_BLOCKED=0.001, SPF_PASS=-0.001] autolearn=unavailable autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=pass (2048-bit key) header.d=protonmail.com
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id lVrmHhdpdUci for <openpgp@mail2.ietf.org>; Wed, 18 Mar 2026 12:04:43 -0700 (PDT)
Received: from mail-10628.protonmail.ch (mail-10628.protonmail.ch [79.135.106.28]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id 6A3E3CD37AD7 for <openpgp@ietf.org>; Wed, 18 Mar 2026 12:04:40 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=protonmail.com; s=protonmail3; t=1773860671; x=1774119871; bh=21dHwKhoyElaseT3Zb6JqYiq3iqO7xJnmaWJ7FaoTbg=; h=Date:To:From:Cc:Subject:Message-ID:In-Reply-To:References: Feedback-ID:From:To:Cc:Date:Subject:Reply-To:Feedback-ID: Message-ID:BIMI-Selector; b=Uc0s5UFoZ+FmbpYJnLosMQOiFOaHAbkBv91+0zpZByXZkx2+GiIXo9QhR2jKzsOXa I4leqi7dZs0u5cy7fh+qmX9/AzbfCzvf34JBJIKAVRvCorHTN8z8OLO1Y/JeFuGvC8 JWl+Hg3kIbBcG58Dafu/AaFN7iqsyZdV9hWU0gttb8ZDDUtBneDKctAC5FSkP8n1B5 Kv82G7o60kz53/WvfGwE4xb/DbuCPanAJvaYwJq6M6aux3mGKVMYwjfxGM/GhqrMQU sVPnMKyYgm7KV4k+Wi5f3R9NrpEkWSOhtq9Gl20C8adUO0Z4nvGrIxjIv2kBUIN6qa mTVVgKnVfc3eA==
Date: Wed, 18 Mar 2026 19:04:27 +0000
To: RFC Errata System <rfc-editor@rfc-editor.org>
From: Daniel Huigens <d.huigens@protonmail.com>
Message-ID: <zYHaeL4dzH-3kycvBZ4GiSKMiJkrIAyuVQdsuAgqVbXmrto3VhHFrQCDl4P3rqqKeKiXtJt0ZWVsHVUq-rLC_KuejwEL23d0BxiQAY_KRmM=@protonmail.com>
In-Reply-To: <20260308224209.88D41C000CC3@rfcpa.rfc-editor.org>
References: <20260308224209.88D41C000CC3@rfcpa.rfc-editor.org>
Feedback-ID: 2934448:user:proton
X-Pm-Message-ID: 127d8a01345ef305d82aa87bca4ab6514bd10955
MIME-Version: 1.0
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: quoted-printable
Message-ID-Hash: CPXKH6V5ZIVFX3BN4V2ICNXH6EPIRCBV
X-Message-ID-Hash: CPXKH6V5ZIVFX3BN4V2ICNXH6EPIRCBV
X-MailFrom: d.huigens@protonmail.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-openpgp.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: paul.wouters@aiven.io, justus@sequoia-pgp.org, gniibe@fsij.org, debcooley1@gmail.com, stephen.farrell@cs.tcd.ie, dkg@fifthhorseman.net, dshaw@jabberwocky.com, openpgp@ietf.org
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [openpgp] Re: [Technical Errata Reported] RFC9580 (8814)
List-Id: "Ongoing discussion of OpenPGP issues." <openpgp.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/openpgp/vqDof7u4vtuFeTrLJBBtIaoeaDY>
List-Archive: <https://mailarchive.ietf.org/arch/browse/openpgp>
List-Help: <mailto:openpgp-request@ietf.org?subject=help>
List-Owner: <mailto:openpgp-owner@ietf.org>
List-Post: <mailto:openpgp@ietf.org>
List-Subscribe: <mailto:openpgp-join@ietf.org>
List-Unsubscribe: <mailto:openpgp-leave@ietf.org>
Hi all, This erratum looks correct to me. Between the two given options for corrected text, I'd vote for the first one. Best, Daniel On Sunday, March 8th, 2026 at 23:42, RFC Errata System <rfc-editor@rfc-editor.org> wrote: > The following errata report has been submitted for RFC9580, > "OpenPGP". > > -------------------------------------- > You may review the report below and at: > https://www.rfc-editor.org/errata/eid8814 > > -------------------------------------- > Type: Technical > Reported by: Daphne Shaw <dshaw@jabberwocky.com> > > Section: 5.6 > > Original Text > ------------- > A ZLIB-compressed series of packets is compressed with raw ZLIB-style > blocks [RFC1950]. > > Corrected Text > -------------- > A ZLIB-compressed series of packets is compressed using the ZLIB > compressed data format [RFC1950]. > > or > > A ZLIB-compressed series of packets is compressed with ZLIB-style > blocks [RFC1950]. > > (Or other words to that effect — the intent is to remove the > word "raw"). > > Notes > ----- > In OpenPGP, only ZIP compression uses raw blocks. The ZLIB and BZip2 algorithms both have headers present. A ZLIB stream without headers would be noncompliant to RFC-1950, section 2.3 ("A compliant compressor must produce streams with correct CMF, FLG and ADLER32..."). > > The "raw" was not present in RFC-4880. I believe it came in via https://gitlab.com/openpgp-wg/rfc4880bis/-/commit/c326b8d4b946b2d51eb9885677e0521fb0ecf1a9 > > Instructions: > ------------- > This erratum is currently posted as "Reported". (If it is spam, it > will be removed shortly by the RFC Production Center.) Please > use "Reply All" to discuss whether it should be verified or > rejected. When a decision is reached, the verifying party > will log in to change the status and edit the report, if necessary. > > -------------------------------------- > RFC9580 (draft-ietf-openpgp-crypto-refresh-13) > -------------------------------------- > Title : OpenPGP > Publication Date : July 2024 > Author(s) : P. Wouters, Ed., D. Huigens, J. Winter, Y. Niibe > Category : PROPOSED STANDARD > Source : Open Specification for Pretty Good Privacy > Stream : IETF > Verifying Party : IESG >
- [openpgp] [Technical Errata Reported] RFC9580 (88… RFC Errata System
- [openpgp] Re: [Technical Errata Reported] RFC9580… Daniel Huigens
- [openpgp] Re: [Technical Errata Reported] RFC9580… Stephen Farrell