[regext] Re: draft-ietf-regext-rdap-x-media-type-02 Feedback
Mario Loffredo <mario.loffredo@iit.cnr.it> Mon, 04 November 2024 10:49 UTC
Return-Path: <mario.loffredo@iit.cnr.it>
X-Original-To: regext@ietfa.amsl.com
Delivered-To: regext@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id C97F0C207970 for <regext@ietfa.amsl.com>; Mon, 4 Nov 2024 02:49:00 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -4.306
X-Spam-Level:
X-Spam-Status: No, score=-4.306 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_MED=-2.3, RCVD_IN_ZEN_BLOCKED_OPENDNS=0.001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001, T_SCC_BODY_TEXT_LINE=-0.01, URIBL_DBL_BLOCKED_OPENDNS=0.001, URIBL_ZEN_BLOCKED_OPENDNS=0.001] autolearn=ham autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (2048-bit key) header.d=iit.cnr.it
Received: from mail.ietf.org ([50.223.129.194]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id NucWVypohJva for <regext@ietfa.amsl.com>; Mon, 4 Nov 2024 02:48:56 -0800 (PST)
Received: from mx5.iit.cnr.it (mx5.iit.cnr.it [146.48.58.12]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 1A2A3C09E1BF for <regext@ietf.org>; Mon, 4 Nov 2024 02:48:55 -0800 (PST)
DKIM-Filter: OpenDKIM Filter v2.11.0 mx5.iit.cnr.it ED974C0A3C
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=iit.cnr.it; s=mx520231221; t=1730717333; bh=Rx6sw4vJIssX0wdkO67IcS+18F2yi8vROZEAky/CQxw=; h=Date:Subject:To:References:From:In-Reply-To:From; b=G5cIL6Zx5B5RBIsqvOaefIYaIjPa4YsdNp/Qo6gusN6TOTT2uNTevCvYuNbLHN5UB 7vzLDzOieJ3ogeGsJBvixTkZXXHoj7UinDRxI1WT9v9IRcUSH7uCZ56xOgMqZNcVGJ 3by9xHzcKsQZrv0KG05swbdpHgj5hThLKXAHK8LjbEnO0PzR+0by9q9pJ2hKZcdd4h qGZwNpAfa5rDCjcGvI48M6v1B3aPEc97JEG9iQu11gfReKt2g2eVHMkMslsYRNTdwV kl5+OOX9uPGlufJiURk8k/a1t64g3ehnsNpYDGPX0v4P+BUS6nuDr7RRIBU1ndJRJZ 8Bgka7IVGyebw==
Received: from localhost (localhost [127.0.0.1]) by mx5.iit.cnr.it (Postfix) with ESMTP id ED974C0A3C for <regext@ietf.org>; Mon, 4 Nov 2024 11:48:52 +0100 (CET)
X-Virus-Scanned: Debian amavisd-new at mx5.iit.cnr.it
Received: from mx5.iit.cnr.it ([127.0.0.1]) by localhost (mx5.iit.cnr.it [127.0.0.1]) (amavisd-new, port 10028) with ESMTP id ypfVBmOC86cG for <regext@ietf.org>; Mon, 4 Nov 2024 11:48:52 +0100 (CET)
X-Relay-Autenticated: yes
Content-Type: multipart/alternative; boundary="------------XqEiwBXSHp0Z7m0QzDbR6duk"
Message-ID: <1e56698a-02b9-4a2b-a301-05a5674083b8@iit.cnr.it>
Date: Mon, 04 Nov 2024 11:43:02 +0100
Mime-Version: 1.0
To: regext@ietf.org
References: <1DB77995-6416-47C4-8744-2970FD9E3BD5@verisign.com>
Content-Language: it
From: Mario Loffredo <mario.loffredo@iit.cnr.it>
In-Reply-To: <1DB77995-6416-47C4-8744-2970FD9E3BD5@verisign.com>
Message-ID-Hash: ZQWKBONTTW4KHHGWXMIGJXVMZUGRWGSK
X-Message-ID-Hash: ZQWKBONTTW4KHHGWXMIGJXVMZUGRWGSK
X-MailFrom: mario.loffredo@iit.cnr.it
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-regext.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [regext] Re: draft-ietf-regext-rdap-x-media-type-02 Feedback
List-Id: Registration Protocols Extensions Working Group <regext.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/regext/OaQ7w1Rpj_Jcbl1yJGovwmcG-JI>
List-Archive: <https://mailarchive.ietf.org/arch/browse/regext>
List-Help: <mailto:regext-request@ietf.org?subject=help>
List-Owner: <mailto:regext-owner@ietf.org>
List-Post: <mailto:regext@ietf.org>
List-Subscribe: <mailto:regext-join@ietf.org>
List-Unsubscribe: <mailto:regext-leave@ietf.org>
Hi, please find my comments inline prefixed with [ML]. Il 01/11/2024 12:49, Gould, James ha scritto: > > Upon a re-review of draft-ietf-regext-rdap-x-media-type with > draft-ietf-regext-rdap-x-media-type-02, I have the following feedback: > > *Section 2 "RDAP-X: The RDAP With Extensions Media Type" * > > Needs to be updated to support the Extension Version Identifier > implicitly or explicitly, defined in Section 3.1 "Extension Version > Identifier" of draft-ietf-regext-rdap-versioning. The mailing list > feedback > https://mailarchive.ietf.org/arch/msg/regext/L377YVNleqV7s7tJPWTGBLJIIG4/ provided > an implicit (compatible) recommendation with > draft-ietf-regext-rdap-versioning, and below is an explicit > recommendation as well. > > Implicit Support included in > https://mailarchive.ietf.org/arch/msg/regext/L377YVNleqV7s7tJPWTGBLJIIG4/ > > 1. In Section 2: Change "This media type has a parameter of > "extensions" which is a whitespace-separated list of RDAP > extensions as defined in the IANA RDAP Extensions registry" to > "This media type has a parameter of "extensions" which is a > whitespace-separated list of RDAP extensions, *such as* defined in > the IANA RDAP Extensions registry”. > 2. In Section 3: Change “the values in the media type's extension > parameter SHOULD match the values in the rdapConformance array in > the return JSON.” to “the extension identifier values in the media > type's extension parameter SHOULD match the values in the > rdapConformance array in the return JSON.” > > Explicit Support > > 1. Make "I-D.ietf-regext-rdap-versioning" a Normative Reference > instead of an Informative Reference > 2. Add RFC5234 as a Normative Reference to leverage ABNF to formally > define the format of the “extensions” parameter. > 3. Update Section 2 to be modeled after Section 3.2.1” Versioning > Query Parameter” in draft-ietf-regext-rdap-versioning, by using > ABNF and referencing the extension-versioning-identifier ABNF rule > from draft-ietf-regext-rdap-versioning, as in: > > The media type defined by this document is "application/rdap-x+json". > This media type has a parameter of "extensions" that is a list of one > or more Extension Version Identifiers, as defined in Section 3.1 of > [I-D.ietf-regext-rdap-versioning > <https://datatracker.ietf.org/doc/html/draft-ietf-regext-rdap-versioning-02>], > separated by whitespace. This media type, RDAP with Extensions, is > referred to as RDAP-X. The Augmented Backus-Naur Form (ABNF) grammar > <https://www.rfc-editor.org/info/rfc5234> [RFC5234 > <https://www.rfc-editor.org/info/rfc5234>] format for the "extensions" > parameter, using the "extension-version-identifier" rule from Figure 1 > of [I-D.ietf-regext-rdap-versioning > <https://datatracker.ietf.org/doc/html/draft-ietf-regext-rdap-versioning-02>], > is: > > extensions = "extensions=" DQUOTE extension-version-identifier *(WSP > extension-version-identifier) DQUOTE > > Examples of RDAP-X: > > applications/rdap-x+json;extensions="rdap_level_0 rdapx" > applications/rdap-x+json;extensions="rdap_level_0 rdapx fred" > > Note - It looks like the "rdapx" extension identifier is missing from > the example, so I added it. > [ML] Agreed. > > *Section 3 "Using The RDAP-X Media Type"* > > My initial thought upon re-review of this section was to reuse the > existing "application/rdap+json" media type by adding the optional > parameter "extensions", or better "rdapx" to the media type > registration, but then I got to Appendix B.1 that makes a good point > with the language in RFC 6838. I really don't want to include RDAP-X > in the content-type header of the response, since it duplicates the > rdapConformance member, and requires updating RFC 7480 with no real > positive value. Updating RFC 7480 may also trigger the need to bump > rdap_level_0 to rdap_level_1, which is certainly not desired. We > should re-evaluate the language of RFC 6838 in its application to an > RDAP extension. How about adding support for RDAP-X in the accept > header of the request and to have the response content-type header > remain using the existing media type of "application/rdap+json"? This > would meet the need of the client providing the RDAP extension hints > without the negative side effects of updating RFC 7480 and bumping > rdap_level_0 to rdap_level_1. > > *Section 4 "Usage of RDAP Links"* > > The point of this section is recursing the RDAP extension hints in the > links, which would also apply to the use of the query parameter of the > versioning extension. We can review for this applicability in the > versioning draft. > > *Section 6 "Security Considerations"* > > You can remove the second paragraph, since that would be covered in an > extension that supports query parameters, such as the versioning > extension. > [ML] Agreed (see below the comment on Appendix B.2 for more details). > > *Section 7 "IANA Considerations"* > > I would add an RDAP Extensions Registry registration for "rdapx". > [ML] I agree that this specification is itself an extension insofar it extends the "application/rdap+json" media type by adding a new optional media type. > > *Appendix A "Using the Vary Header"* > > Wouldn't this recommendation be covered in a different draft, such as > draft-ietf-regext-rdap-extensions since it's not specific to RDAP-X? > [ML] Have a different opinion about this point. The use of Vary header is strictly related to the presence of the Accept header. Hence IMO this recommendation should stay in this document since just this document describes an Accept-based method used by clients and servers to exchange information about extensions. > > *Appendix B.1 "Not Reusing the Existing Media Type"* > > This section helped me out since my thought was to reuse the existing > "application/rdap+json" media type instead of defining the new RDAP-X > media type. The language in RFC 6838 is clear and adding the > capability of providing hints of the RDAP extensions is new > functionality, but I really don't see that it's adding new > functionality for the media type itself. We could define the existing > "application/rdap+json" media type optional parameters as a form of > extension in the extensions draft, where it will become an extension > point without adding new functionality specific to the media type > itself. The response is still RDAP using JSON independent of the mix > of extensions that are used. If use of an optional media type > parameter of the existing "application/rdap+json" media type cannot be > done, can RDAP-X be used in the accept header and not returned in the > content-type header to get the value of RDAP-X without the negative > side effect of updating RFC 7480 and bumping rdap_level_0 to rdap_level_1? > [ML] Think it's worth investigating if this soultion could be feasible. > > *Appendix B.2 Inappropriate Use of Query Parameters* > > This section should be removed and any relevant content covered in > draft-ietf-regext-rdap-extensions. It adds confusion to the draft > since there are many RDAP extensions and RFCs that have used query > parameters with no issue. Specifying the value of living through an > HTTP redirect should be good enough without having to list how query > parameters are inappropriate, which will have a hard time finding > consensus. I don't agree with many of the arguments against the use > of query parameters, where I would leave the decision up to the client > based on their needs. > [ML] Totally agree on this point. If this document is finally published as RFC, we'll have a document discouraging the use of query parameter along with other existing documents presenting extensions that make use of query parameters. Moreover, talking generically about scenarios where redirection is more likely doesn't provide guidance about when query parameters are allowed and when they aren't. We should recognize that query parameters are the mostly used mean for clients to provide servers with values, other than options, to be used in queries. To make myself more clear, I'll make an example with RFC8977: - the count parameter might be replaced with a specific identifier that a client may include in the extensions parameter of rdap-x media type to signal the server that results counting should be applied; - conversely, we couldn't do likewise with the sort parameter since the client needs not only to signal that sort should be applied but also the sorting information, i.e. the sorting properties and, for each property, the sorting order. Best, Mario > -- > > JG > > > cid87442*image001.png@01D960C5.C631DA40 > > *James Gould > *Fellow Engineer > jgould@Verisign.com > <applewebdata://13890C55-AAE8-4BF3-A6CE-B4BA42740803/jgould@Verisign.com> > > 703-948-3271 > 12061 Bluemont Way > Reston, VA 20190 > > Verisign.com <http://verisigninc.com/> > > > _______________________________________________ > regext mailing list --regext@ietf.org > To unsubscribe send an email toregext-leave@ietf.org -- Dott. Mario Loffredo Senior Technologist Technological Unit “Digital Innovation” Institute of Informatics and Telematics (IIT) National Research Council (CNR) Address: Via G. Moruzzi 1, I-56124 PISA, Italy Phone: +39.0503153497 Web:http://www.iit.cnr.it/mario.loffredo
- [regext] draft-ietf-regext-rdap-x-media-type-02 F… Gould, James
- [regext] Re: draft-ietf-regext-rdap-x-media-type-… Mario Loffredo
- [regext] Re: draft-ietf-regext-rdap-x-media-type-… Andrew Newton (andy)
- [regext] Re: draft-ietf-regext-rdap-x-media-type-… kowalik
- [regext] Re: draft-ietf-regext-rdap-x-media-type-… Gould, James