[regext] Re: Comments Regarding draft-ietf-regext-rdap-extensions-04

"Andrew Newton (andy)" <andy@hxr.us> Mon, 07 October 2024 11:04 UTC

Return-Path: <andy@hxr.us>
X-Original-To: regext@ietfa.amsl.com
Delivered-To: regext@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 51A65C151527 for <regext@ietfa.amsl.com>; Mon, 7 Oct 2024 04:04:13 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -1.902
X-Spam-Level:
X-Spam-Status: No, score=-1.902 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_BLOCKED=0.001, RCVD_IN_ZEN_BLOCKED_OPENDNS=0.001, SPF_HELO_NONE=0.001, SPF_NONE=0.001, T_SCC_BODY_TEXT_LINE=-0.01, URIBL_BLOCKED=0.001, URIBL_DBL_BLOCKED_OPENDNS=0.001, URIBL_ZEN_BLOCKED_OPENDNS=0.001] autolearn=unavailable autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (2048-bit key) header.d=hxr-us.20230601.gappssmtp.com
Received: from mail.ietf.org ([50.223.129.194]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id vUiJqa89RsfA for <regext@ietfa.amsl.com>; Mon, 7 Oct 2024 04:04:08 -0700 (PDT)
Received: from mail-qk1-x735.google.com (mail-qk1-x735.google.com [IPv6:2607:f8b0:4864:20::735]) (using TLSv1.3 with cipher TLS_AES_128_GCM_SHA256 (128/128 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 8B801C15152C for <regext@ietf.org>; Mon, 7 Oct 2024 04:04:08 -0700 (PDT)
Received: by mail-qk1-x735.google.com with SMTP id af79cd13be357-7a9a30a0490so426664885a.3 for <regext@ietf.org>; Mon, 07 Oct 2024 04:04:08 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=hxr-us.20230601.gappssmtp.com; s=20230601; t=1728299047; x=1728903847; darn=ietf.org; h=in-reply-to:from:content-language:references:to:subject:user-agent :mime-version:date:message-id:from:to:cc:subject:date:message-id :reply-to; bh=+LBMsvOlfKB4iwfUUVpjgJtQspNABnHRW2S6VphxWvo=; b=qnc6NYFU2OUk1oMP0ZyMcS3FgYITzcq5/E1logPkViJSD8XVqtnb4Z9l26I+zaS2FL gGdmDN13JK7a0Mgy4RdkiaH58G112JsDO3ycSHkK5Z652iRSVc0aCZZ3y5zYExery758 mfAt3gGBN6Cc+UNxJiuYEKIFh0asPCriVGnIWjG7RtU/vxRw7XYYbj8rWeoOXWmu3O2l Juu93ZkHw2uA2QqOBnqgfxibxL5z+qNafBbP5+oBbkMUrouHVBuwhHoqNAjaHFF50cPA bSvRSPSA64MStZ+l201S1pXttU+aU91AICdhdqVVPa6xTzt+LQdO5ZTYePVYbjjlfFC9 XkNg==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20230601; t=1728299047; x=1728903847; h=in-reply-to:from:content-language:references:to:subject:user-agent :mime-version:date:message-id:x-gm-message-state:from:to:cc:subject :date:message-id:reply-to; bh=+LBMsvOlfKB4iwfUUVpjgJtQspNABnHRW2S6VphxWvo=; b=N3S0ARVN/FQ/G1fHM6x6cQLufPYfXSmr0iemjN8tWJh4mgiVQgcYLqfofPq1DqL53g VsQ7UqoO1EDEPD0asxUfoCx7aJdtvNTxRM7acshyA16NAUIhFg7kSke/v4Yz+5h7qaja +QcpQNmJMzQmuPwawhfryoYyTzqrK/fxI+nhLaneoopfOC25LZhEVfdlcXelSEhKzgD1 roEfi/eeSwdJr+tWrYP8iJ6QsW0T/kQ5TLuBr5youH0af+PPFGjmykM/La+Itg8dkb/d nDw+CwLh7X9mKV3NiBdcAp4cJTTu+iWynukBd3KhG0paQrXPRQI7mW0RW3/wbFV/eUjM nToQ==
X-Forwarded-Encrypted: i=1; AJvYcCVVX6NZI6o5lrs+2OJpKyhEnMfWffiyab3XFxWalN4gfAE0VDGm2BGL6r8pgQNjSmvN3dD2C1Q=@ietf.org
X-Gm-Message-State: AOJu0Ywh4Th285AkVQ48xeSy9b9hiJZpccRk2quQrpBUTGyuRFs7I/rM vjMqB8LyKh+UdOmOvnvdieT5KuWBfJ84k07RbMjg+troISYk21wf3SdsPt7WzJs=
X-Google-Smtp-Source: AGHT+IHNgZRbt3V/lJ8J6/XIvIIWowvVjQKzto3f+CxUOupAUBrikV+BJbls3x9tZN/BhCpJJMk6vA==
X-Received: by 2002:a05:620a:24cf:b0:7a9:a883:e22b with SMTP id af79cd13be357-7ae6f42e164mr1784676685a.7.1728299047175; Mon, 07 Oct 2024 04:04:07 -0700 (PDT)
Received: from [10.2.8.27] (pool-72-83-25-32.washdc.fios.verizon.net. [72.83.25.32]) by smtp.gmail.com with ESMTPSA id af79cd13be357-7ae75615a5esm244496085a.13.2024.10.07.04.04.06 (version=TLS1_3 cipher=TLS_AES_128_GCM_SHA256 bits=128/128); Mon, 07 Oct 2024 04:04:06 -0700 (PDT)
Content-Type: multipart/alternative; boundary="------------VEGcSJDjDusEdHCcIxq6D3T4"
Message-ID: <245a4948-0eb1-488e-9389-49e2c9b75763@hxr.us>
Date: Mon, 07 Oct 2024 07:04:06 -0400
MIME-Version: 1.0
User-Agent: Mozilla Thunderbird
To: "Gould, James" <jgould@verisign.com>, "shollenbeck=40verisign.com@dmarc.ietf.org" <shollenbeck=40verisign.com@dmarc.ietf.org>, "regext@ietf.org" <regext@ietf.org>
References: <5984276f606a4ba7b0c4838735a8eb8d@verisign.com> <f278164d-3738-4447-b676-ddbad96db616@hxr.us> <913EDE25-E293-485D-845F-F04C147E18F3@verisign.com>
Content-Language: en-US
From: "Andrew Newton (andy)" <andy@hxr.us>
In-Reply-To: <913EDE25-E293-485D-845F-F04C147E18F3@verisign.com>
Message-ID-Hash: BEK375OBTM6GQU5YA6JEIYXNNY3S5HE2
X-Message-ID-Hash: BEK375OBTM6GQU5YA6JEIYXNNY3S5HE2
X-MailFrom: andy@hxr.us
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-regext.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
X-Mailman-Version: 3.3.9rc5
Precedence: list
Subject: [regext] Re: Comments Regarding draft-ietf-regext-rdap-extensions-04
List-Id: Registration Protocols Extensions Working Group <regext.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/regext/rzgoty1XAXxNiAECDPG3IquMHXQ>
List-Archive: <https://mailarchive.ietf.org/arch/browse/regext>
List-Help: <mailto:regext-request@ietf.org?subject=help>
List-Owner: <mailto:regext-owner@ietf.org>
List-Post: <mailto:regext@ietf.org>
List-Subscribe: <mailto:regext-join@ietf.org>
List-Unsubscribe: <mailto:regext-leave@ietf.org>

On 10/3/24 08:26, Gould, James wrote:
>
> Andy,
>
> I view updating the base RFCs as being a material change that would 
> trigger the need for signaling for interoperability via use of 
> “rdap_level_1”. If what is defined maintains backward compatibility 
> with what is defined in the base RFCs, then can a case be made for not 
> having to update them?  I don’t believe we can have it both ways.
>

See my note to Scott, but these are all backwards-compatible changes. If 
there are any incompatibilities, specific examples would be helpful. 
Also note that changing "rdap_level_0" to "rdap_level_1" introduces its 
own compatibility issue. This document updates the core RDAP specs for 
two reasons: 1) they define the rules around extension registrations, 
many of which this working group has broken but have caused no harm, and 
2) there are areas of those documents concerning extensions that are 
very ambiguous. But this document changes nothing with regard to current 
interoperability between a client and server.


> I’m in the middle of re-reviewing draft-ietf-regext-rdap-extensions 
> and a good point is made related to the forms of RDAP extensions 
> supported by the base RFCs, based on section 2.3.2 “Usage of Query 
> Parameters”.  RFC 7480 with “used in JSON [RFC7159 
> <https://datatracker.ietf.org/doc/html/rfc7159>] data serialization 
> and URI path segments”, RFC 9082 with  “Custom path segments can be 
> created for objects not specified here using the process described in 
> Section 6 <https://www.rfc-editor.org/rfc/rfc7480#section-6>of "HTTP 
> Usage in the Registration Data Access Protocol (RDAP) 
> <https://datatracker.ietf.org/doc/html/rfc7480>" [RFC7480 
> <https://datatracker.ietf.org/doc/html/rfc7480>]”, and RFC 9083 with 
> “The full JSON name (the prefix plus the underscore plus the 
> meaningful name) *SHOULD* adhere to the character and name limitations 
> of the prefix registry described in [RFC7480 
> <https://datatracker.ietf.org/doc/html/rfc7480>]”, but does the lack 
> of definition implicitly prohibit other forms of RDAP extensibility 
> that we know of and that could be defined in the future?  Could 
> draft-ietf-regext-rdap-extensions be used to define all forms of RDAP 
> extensibility formally without requiring an update to RFC 9083 and 
> trigger the definition of “rdap_level_1”?  I see 5 forms of 
> extensibility that RFC 9083 only references two of the forms:
>
>  1. Path Segment
>      1. Path segment for defining a new object in the request, which
>         is covered by RFC 7480 and RFC 9082.
>  2. JSON Names
>      1. JSON names for defining new members in the response, which is
>         covered by RFC 7480 and RFC 9083.
>  3. Query Parameters
>      1. Query parameters for defining new request preferences and
>         features, which is NOT covered RFC 7480 and RFC 9082.  Many
>         RDAP extensions have leveraged extensibility of query
>         parameters, including RFC 8982, RFC 8977, RFC 9560,
>         draft-ietf-regext-rdap-versioning,
>  4. HTTP Headers
>      1. HTTP headers for defining new request preferences and
>         features, which is NOT covered RFC 7480 and RFC 9082.  The
>         draft-ietf-regext-rdap-x-media-type draft leverages
>         extensibility of HTTP headers.
>  5. “objectClassName” Member Value
>      1. Value of the “objectClassName” member for defining a new
>         object in the response, which is NOT covered RFC 7480 and RFC
>         9083.  I haven’t see this form of extensibility in a published
>         extension, but it certainly would be needed if the path
>         segment was extended to support a new object.
>
> Are there other forms of RDAP extensibility that should be considered 
> and formally defined?  Potentially draft-ietf-regext-rdap-extensions 
> could define a framework for extending the forms of extensions, since 
> it will hard for us to look in the crystal ball to enumerate all 
> possible forms of extensibility now.
>
That's a very good list. Maybe our summary section of the draft should 
do something similar.

I do not understand your suggestion but that maybe lack of imagination 
on my part. Doesn't such a framework exist in the form of the REGEXT 
working group?


-andy