Re: [sasl] I-D Action:draft-ietf-sasl-scram-08.txt

Nicolas Williams <Nicolas.Williams@sun.com> Thu, 08 October 2009 16:13 UTC

Return-Path: <Nicolas.Williams@sun.com>
X-Original-To: sasl@core3.amsl.com
Delivered-To: sasl@core3.amsl.com
Received: from localhost (localhost [127.0.0.1]) by core3.amsl.com (Postfix) with ESMTP id 9CE3E3A68E8 for <sasl@core3.amsl.com>; Thu, 8 Oct 2009 09:13:43 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -5.888
X-Spam-Level:
X-Spam-Status: No, score=-5.888 tagged_above=-999 required=5 tests=[AWL=0.158, BAYES_00=-2.599, HELO_MISMATCH_COM=0.553, RCVD_IN_DNSWL_MED=-4]
Received: from mail.ietf.org ([64.170.98.32]) by localhost (core3.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id SmPPybhpCaVu for <sasl@core3.amsl.com>; Thu, 8 Oct 2009 09:13:42 -0700 (PDT)
Received: from sca-ea-mail-2.sun.com (sca-ea-mail-2.Sun.COM [192.18.43.25]) by core3.amsl.com (Postfix) with ESMTP id B90923A6765 for <sasl@ietf.org>; Thu, 8 Oct 2009 09:13:38 -0700 (PDT)
Received: from dm-central-01.central.sun.com ([129.147.62.4]) by sca-ea-mail-2.sun.com (8.13.7+Sun/8.12.9) with ESMTP id n98GFG6I002107 for <sasl@ietf.org>; Thu, 8 Oct 2009 16:15:17 GMT
Received: from binky.Central.Sun.COM (binky.Central.Sun.COM [129.153.128.104]) by dm-central-01.central.sun.com (8.13.8+Sun/8.13.8/ENSMAIL, v2.2) with ESMTP id n98GFG7r004856 for <sasl@ietf.org>; Thu, 8 Oct 2009 10:15:16 -0600 (MDT)
Received: from binky.Central.Sun.COM (localhost [127.0.0.1]) by binky.Central.Sun.COM (8.14.3+Sun/8.14.3) with ESMTP id n98G3xqw005933; Thu, 8 Oct 2009 11:03:59 -0500 (CDT)
Received: (from nw141292@localhost) by binky.Central.Sun.COM (8.14.3+Sun/8.14.3/Submit) id n98G3xuo005932; Thu, 8 Oct 2009 11:03:59 -0500 (CDT)
X-Authentication-Warning: binky.Central.Sun.COM: nw141292 set sender to Nicolas.Williams@sun.com using -f
Date: Thu, 08 Oct 2009 11:03:59 -0500
From: Nicolas Williams <Nicolas.Williams@sun.com>
To: Simon Josefsson <simon@josefsson.org>
Message-ID: <20091008160359.GV887@Sun.COM>
References: <20091002174501.75F953A6855@core3.amsl.com> <87pr95r2q7.fsf@mocca.josefsson.org> <20091002200003.GM887@Sun.COM> <4ACD22AD.4000800@isode.com> <87eipe5t6y.fsf@mocca.josefsson.org>
Mime-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Content-Disposition: inline
In-Reply-To: <87eipe5t6y.fsf@mocca.josefsson.org>
User-Agent: Mutt/1.5.7i
Cc: Alexey Melnikov <alexey.melnikov@isode.com>, sasl@ietf.org
Subject: Re: [sasl] I-D Action:draft-ietf-sasl-scram-08.txt
X-BeenThere: sasl@ietf.org
X-Mailman-Version: 2.1.9
Precedence: list
List-Id: SASL Working Group <sasl.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/listinfo/sasl>, <mailto:sasl-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/sasl>
List-Post: <mailto:sasl@ietf.org>
List-Help: <mailto:sasl-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/sasl>, <mailto:sasl-request@ietf.org?subject=subscribe>
X-List-Received-Date: Thu, 08 Oct 2009 16:13:43 -0000

On Thu, Oct 08, 2009 at 07:51:49AM +0200, Simon Josefsson wrote:
> Alexey Melnikov <alexey.melnikov@isode.com> writes:
> 
> >>   o  Normalize(str): Apply a Unicode normalization algorithm to a UTF-8
> >>      [RFC3629] encoded "str".  The resulting string is also in UTF-8.
> >>      Implementations SHOULD use the SASLPrep profile [RFC4013] of the
> >>      "stringprep" algorithm [RFC3454] as the normalization algorithm.
> >>----> Note that, for SCRAM, passwords are "stored strings", which means
> >>----> that unassigned codepoints in SCRAM passwords are prohibited (see
> >>----> RFC3454, section 7).
> >>  
> >>
> > Applied to my copy. I've reworded the text not to say "password", as
> > this is a generic definition of the Normalize function.
> 
> I don't think that works, unassigned codepoints should only be
> disallowed for passwords, not for usernames.  Elsewhere SCRAM says
> 
>          Before sending the username to the server, the client SHOULD
>          prepare the username using the "SASLPrep" profile [RFC4013] of
>          the "stringprep" algorithm [RFC3454] treating it as a query
>          string (i.e., unassigned Unicode code points are allowed).

That's fine with me.  It's important that the server not re-encode the
client's first message when verifying the ClientSignature.

Nico
--