[secdir] Re: draft-ietf-pce-sid-algo-24 ietf last call Secdir review

"Samuel Sidor (ssidor)" <ssidor@cisco.com> Thu, 25 September 2025 16:52 UTC

Return-Path: <ssidor@cisco.com>
X-Original-To: secdir@mail2.ietf.org
Delivered-To: secdir@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id 66C2A68D1728; Thu, 25 Sep 2025 09:52:48 -0700 (PDT)
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -11.886
X-Spam-Level:
X-Spam-Status: No, score=-11.886 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIMWL_WL_HIGH=-0.001, DKIMWL_WL_MED=-0.001, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_MED=-2.3, RCVD_IN_MSPIKE_H4=0.001, RCVD_IN_MSPIKE_WL=0.001, RCVD_IN_VALIDITY_RPBL_BLOCKED=0.001, RCVD_IN_VALIDITY_SAFE_BLOCKED=0.001, SPF_NONE=0.001, T_SPF_HELO_PERMERROR=0.01, USER_IN_DEF_DKIM_WL=-7.5] autolearn=ham autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=pass (2048-bit key) header.d=cisco.com
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id tfooK-TL_G0k; Thu, 25 Sep 2025 09:52:47 -0700 (PDT)
Received: from alln-iport-8.cisco.com (alln-iport-8.cisco.com [173.37.142.95]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id 960FB68D171F; Thu, 25 Sep 2025 09:52:47 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=cisco.com; i=@cisco.com; l=7714; q=dns/txt; s=iport01; t=1758819167; x=1760028767; h=from:to:cc:subject:date:message-id:references: in-reply-to:mime-version; bh=pcxysuSp8kJJ8KVSXpe2rpIP6NqhgrWYf2gBerV1qtg=; b=MnR/zb+iLwwQ/Aes7p5y8PQUlqiqmAJG3dNS1RtAHIdGwbAurKvlrkEQ qxQQBB80O7M4IqejiG+87haCYpVTi8BnOM6qpitvO1bolyJaSoh4jlP3H hSeO2TkmYnkLGWUZVOjmhAVeLytMwliS1EjPMWdRbVZzYOijM0Zp/0+9U mYUgvZNu9zgPfPa4vdFy3MIgJ9G+452mZVvziZeV22sZSdjVvvhFaqGzq H195T/T800lWpWLZPjZhyPujS3kQxrGoDxovOqDVBsQ8ivf2q7PD3iNa4 kpbw5MZXivRWh731lKG2NVXXZvOKpGOuuV2nNWIXJd1hr7J8xPKql3c9W Q==;
X-CSE-ConnectionGUID: b/kthIVyQCOys6j9fbbEeQ==
X-CSE-MsgGUID: 4YzlSH/QSWWxDz2V6SAKlg==
X-IPAS-Result: A0ApAAB7ctVo/5AQJK1aHAEBAQEBAQcBARIBAQQEAQFAJYEaBwEBCwGBPDFSB4IXSYggA4RNX4h2A5dDhlcUgWsPAQEBDQJRBAEBhQcCjEMCJjQJDgECBAEBAQEDAgMBAQEBAQEBAQEBAQsBAQUBAQECAQcFgQ4ThlyGWgEBAQEDEmcQAgEIDgMDAQIvMR0IAgQOBQgahH5VAwECU6oIAYFAAooreIE0gQHgJoFJAYhPASqBNIQOhHcnG4FJRIEVQoJoPoQFQB6DdYIvBIINFUQ+FB2DOzaCKIFigl2FKwUGgQOBeYpMUnIiAyYzLAFVExcLBwWBIEMDgQ8jSwUtHYEnd4QUhB4rT4IccoF0V0GDUxIMBmsPBoEVGUkCAgIFAkM+gWsGHAYfEgIDAQICOlcNgXoCAgSCNIESgQdAAwttPRQjFBsFBIE1BZYbF0SDNmQBA4FSWwovARMFowyiQ4EzCoQcm1+GLheEBKYAZ5kGglimPgIEAgQFAhABAQaBNDQ8gVlwFRqDCFIZD44tFs1aeDwCBwsBAQMJk2cBAQ
IronPort-PHdr: A9a23:Jwwbch3NNnzaB5DGsmDPmlBlVkEcU/3cJAUZ7N8gk71RN/nl9JX5N 0uZ7vJo3xfFXoTevupNkPGe87vhVmoJ/YubvTgcfYZNWR4IhYRenwEpDMOfT0yuBPXrdCc9W s9FUTdY
IronPort-Data: A9a23:nkYx5aAKAu66oRVW/ybiw5YqxClBgxIJ4kV8jS/XYbTApDgg0zQFx mscWzvSP/aDM2bzco9yPN60o0wDu5+DxtFqOVdlrnsFo1CmBibm6XV1Cm+qYkt+++WaFBoPA /02M4eGdIZuCCaF/H9BC5C5xVFkz6aEW7HgP+DNPyF1VGdMRTwo4f5Zs7ZRbrVA357gU2thh fuo+5eCYA7/hmYoWo4pw/vrRC1H7ayaVAww5jTSVdgT1HfCmn8cCo4oJK3ZBxPQXolOE+emc P3Ixbe/83mx109F5gSNy+uTnuUiG9Y+DCDW4pZkc/HKbitq+kTe5p0G2M80Mi+7vdkmc+dZk 72hvbToIesg0zaldO41C3G0GAkmVUFKFSOuzXWX6aSuI0P6n3TEybJtEEEXA5wh0cFmGj9Mp PISIh0AV0XW7w626OrTpuhEj8AnKozveYgYoHwllW6fBvc9SpeFSKLPjTNa9G5v3YYVQ7CHO YxANWYHgBfoO3WjPn8ME5Mym/2AjXjkeDoeo1WQzUYyyzWNl1wpiOG1a7I5fPTWdNdRpWbfn 1n5wHTVEEskaue26j6KpyfEaujn2HmTtJgpPLGi//B2xVye2mJWEBYbEEC6rbywjkG5HdtbL 2QV9zYg668o+ySDStDmQ1izqXqAlh8RR9QWFPc1gCmVwaf84guFCC4DVDEpQMcrv8M3XxQr2 0OH2dTzClRSXKa9QHaZ8PKQ6Di1IyVQdTBEbi4fRgxD6N7myG0usi/yoh9YOPfdpvX+GCr7x HaBqy1WulnZpZdjO3mTlbwfvw+Rmw==
IronPort-HdrOrdr: A9a23:eSQdO6mGer+f0Pvlq1v76/9AX17pDfNRiWdD5ihNYBxZY6Wkfp +V7ZcmPE7P6Ar5BktApTnZAtj/fZq9z/JICYl4B8bFYOCUghrYEGgC1/qs/9SOIVyFygcw79 YFT0E6MqyOMbEYt7e13ODbKadc/DDvysnB7omurQYJcegpUdAd0+4TMHfjLqQCfng8OXNPLu vl2iMonUvGRV0nKu6AKj0uWe/Fq9fXlJTgTyInKnccgjWmvHeD0pK/NwKX8Cs/flp0rIvK91 KrryXJooGY992rwB7V0GHeq75MnsH699dFDMuQzuAINzTFkG+TFcRccozHmApwjPCk6V4snt WJiQwnJd5P53TYeXzwiQfx2jPnzC0l5xbZuBylaDrY0I7ErQABeo58bLFiA1zkAo0bzZdBOZ dwriekXlxsfEr9dWrGloD1vlpR5zqJSDIZ4J0uZjpkIMojgHs7l/1EwKuTe61wRx7S+cQpFv JjA9rb4+sTeVSGb2rBtm0q29C0WG8vdy32CHTql/blmwS+pkoJhHcw1YgahDMN5Zg9Q55L66 DNNblpjqhHSosTYbhmDOkMTMOrAiiVKCi8fF66MBDiDuUKKnjNo5n47PE84/yrYoUByN83lI 7aWF1VuGYucwblCNGI3pdM7hfRKV/NEAjF24Vb/dx0q7f8TL3kPWmKT00vidKpp7EFDsjSS5 +ISdtr6j/YXB3T8KpyrnrDssNpWAwjedxQvsx+QF6HqN/KLIrx39arAso7DICdZQoZZg==
X-Talos-CUID: 9a23:NKKbCG1rzPfjy+UsPXyyjrxfEIcmbn388mbpCGipEjhrGbOfQ3KdwfYx
X-Talos-MUID: 9a23:bqo6TghRtgr9kO6O7m9SvcMpaPZ655+OT3k2rqoWl9veC3JLEhSZg2Hi
X-IronPort-Anti-Spam-Filtered: true
Received: from alln-l-core-07.cisco.com ([173.36.16.144]) by alln-iport-8.cisco.com with ESMTP/TLS/TLS_AES_256_GCM_SHA384; 25 Sep 2025 16:52:46 +0000
Received: from rcdn-opgw-5.cisco.com (rcdn-opgw-5.cisco.com [72.163.7.169]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature RSA-PSS (2048 bits) server-digest SHA256) (No client certificate requested) by alln-l-core-07.cisco.com (Postfix) with ESMTPS id 7FDE7180001E2; Thu, 25 Sep 2025 16:52:46 +0000 (GMT)
X-CSE-ConnectionGUID: dVnGTGawR7WFqaoSm33Ydw==
X-CSE-MsgGUID: K2ZWidiHRXGMeQoEjiu7Qw==
Authentication-Results: rcdn-opgw-5.cisco.com; dkim=pass (signature verified) header.i=@cisco.com
X-IronPort-AV: E=Sophos;i="6.18,292,1751241600"; d="scan'208,217";a="34448000"
Received: from mail-ch4pr07cu00104.outbound.protection.outlook.com (HELO CH4PR07CU001.outbound.protection.outlook.com) ([40.93.20.100]) by rcdn-opgw-5.cisco.com with ESMTP/TLS/TLS_AES_256_GCM_SHA384; 25 Sep 2025 16:52:45 +0000
ARC-Seal: i=1; a=rsa-sha256; s=arcselector10001; d=microsoft.com; cv=none; b=w5ZN5P2InSNg3hVFGuCORSjV69I7ehAlACy5v5MEvb743L1Dd8tVAV/Mdiw656QqhUTE7c3T5ubUC/DjlX5BnskeDH6qWuzsb1lB3B6QzZuTrggM1eke8tV9hubBuJ3KhAobARCho4ySlQ0vMmmG687aHBQYLlMcZQ7HF4LfUPH60hnwB8MuABPAVmy6BZfAFYE1R0CO+10oWgbzRQHQSMIftbIqpiUY7rwa1Q9Zgmcsv58gywgK6zjbdVfXROmFrFBMaRWdq0Ao5D+xTrMC6dEMeWIXyNQMdQ37q9ShIAjNEj8CdW3Be3q6XtIA+iKZznlQOWJvT24ARQT/h/YQfg==
ARC-Message-Signature: i=1; a=rsa-sha256; c=relaxed/relaxed; d=microsoft.com; s=arcselector10001; h=From:Date:Subject:Message-ID:Content-Type:MIME-Version:X-MS-Exchange-AntiSpam-MessageData-ChunkCount:X-MS-Exchange-AntiSpam-MessageData-0:X-MS-Exchange-AntiSpam-MessageData-1; bh=pcxysuSp8kJJ8KVSXpe2rpIP6NqhgrWYf2gBerV1qtg=; b=ugv4F5tzIGL7jNC64ii/NUmYFwTSJvLGn+iiNWFRBVxlil3BFwjnpxued99/242FFvH4e3BMNYT16hEZ4jZLcSSpJALmFgUPEuq294PWF/wuTqObdZku25RZJE5WOqv2qDb7ftmE/jQFFgeLkAOF+LfKzA5flJcjytmUkGrZD8WWbZxJpXk8J6pv0NLh8i33oGa2GxxBIVnyZ+pGnmWDP9KR7w0GAjG7ekgKUeqtpC5isuxFBzkgT6Iu/TmfHVdaLKybGyeXM47fy/HGSnxmKGP9Gy9u8U9Ol4YEND44JKABIel5cXjo3R1BF+OwTIv05BtD+ZC1GPhHz2bH7OessA==
ARC-Authentication-Results: i=1; mx.microsoft.com 1; spf=pass smtp.mailfrom=cisco.com; dmarc=pass action=none header.from=cisco.com; dkim=pass header.d=cisco.com; arc=none
Received: from IA0PR11MB7792.namprd11.prod.outlook.com (2603:10b6:208:409::16) by PH7PR11MB6772.namprd11.prod.outlook.com (2603:10b6:510:1b6::21) with Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) id 15.20.9160.10; Thu, 25 Sep 2025 16:52:43 +0000
Received: from IA0PR11MB7792.namprd11.prod.outlook.com ([fe80::385b:609e:4289:5e04]) by IA0PR11MB7792.namprd11.prod.outlook.com ([fe80::385b:609e:4289:5e04%5]) with mapi id 15.20.9160.008; Thu, 25 Sep 2025 16:52:43 +0000
From: "Samuel Sidor (ssidor)" <ssidor@cisco.com>
To: Alexey Melnikov <aamelnikov@fastmail.fm>
Thread-Topic: draft-ietf-pce-sid-algo-24 ietf last call Secdir review
Thread-Index: AQHcLX0eOlvLrMjAg0yfg2JRiVzPkLSkHTtQ
Date: Thu, 25 Sep 2025 16:52:43 +0000
Message-ID: <IA0PR11MB77921C36D4FDFA3D185DADD8D01FA@IA0PR11MB7792.namprd11.prod.outlook.com>
References: <175873681636.1298707.10273605657697838289@dt-datatracker-6c6cdf7f94-h6rnn>
In-Reply-To: <175873681636.1298707.10273605657697838289@dt-datatracker-6c6cdf7f94-h6rnn>
Accept-Language: en-US
Content-Language: en-US
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
x-ms-reactions: allow
x-ms-publictraffictype: Email
x-ms-traffictypediagnostic: IA0PR11MB7792:EE_|PH7PR11MB6772:EE_
x-ms-office365-filtering-correlation-id: 6c9d1a07-c9b5-490a-63d8-08ddfc53f274
x-ms-exchange-senderadcheck: 1
x-ms-exchange-antispam-relay: 0
x-microsoft-antispam: BCL:0;ARA:13230040|1800799024|366016|376014|38070700021|8096899003;
x-microsoft-antispam-message-info: CixiGjBUDQcoKRtk9ZPfm81zqn/sJNCqA9/gd3Pc4mvyjDxR3HHapldAcmodFsE7WXcjOe2L6LvyDoL5tt66lJReltWJ6B2na6rYchFzOE1INsnjqUL9ODXrRxzrfUetRJhD19iaWdqH76ynU8iZIhsRPPm+BdFf5/6I1CGgWvosQMUG/Z7vyyN/Y5zr2CHBEk6xLG3YJ0q3MRp81xG/O/nquYRVIQaynzxwNfGQTgXYxYMZaGn8/EWzybgQvzGVeRs6zf34WZRWkEDxoMq0R4oJmqmERv11vOnDb3FdTdkQzPRIkfHt6afPPLdLbkuERB7ZJsFOr1ak79gyWEnA3xzTkKM19k8v6q1FoklCeOrLlvfWVPlrx85ARk4mgtDecvAtVe0TTN4i9t/vZ01jsJiQ7qWCN4v93Og37uVDfsUdND0+lDlnw1iCSSjcL+aXUgkp7s7HX51WD5subdOLVjhk+TUO4ymywigHvKWWvmSznxbmbVy6TjkrciA3pSO0MtTglUBAg5veHxpD4pSxVfYpyCrSyDSVioA40Eht/BBuCHO7Sypv0r7tkHIE6RSuTkbK2bDVUZgTems5F6BuFqVVmTKbgm5pCfGwdiEnZE0Gbx3P3DTIoGkS/foaSEYWIGLpIj0Al0EXbG0/MKnQ4c7tqROAceHJtQPPJ1XdKlST7mkR9BznuB7E7DbUow+CsJAtuVGmvTlXCXoF7Itudu1k/WdDxgskKDHn3TZ5EBR8p0RmoJ9ogIA3rRg98kmRPBa224kimQO8L3W02eimTsih74gvPFw8kBBuW6TbSUDxkoahM8wiCwoXg9eIm/8qvZJJ+cKu07ukLsBsrDiy0rvXixBfKlOLlVZMakfK2c2f3JxzSuqSPtxa3Hbnpv5LGrYy1griVfZQ1qEuzIZqC65EHQ4yxz758aNeo/Ga1DKTcAsJjiSmWP8PVyAJ4MdZc6q4JTilQCyxImopSP14rGpV6cyCTE4bWgEv1Q508mEu9Fes9beRQoOe5NqZyqaEmguEsKRWZN/zjdNad66r57bzn5xrSR0lRsgfzAEmpC2G1UTwwAWI9q0vGJuAT80JGnUfV6BfFC2dNiXamhHu5Vdw5kKmduEFPItsAuL9Ql6hMGHFURD6xgSQBWW/RRb+iunvJS49/AXlDDVupG4J4mXlO07FvNt5WVWCYp3/8s/h5uUQTpeHo5oM4JfwKsORAU1LCOyA7YRaqgmdK+PSEFnxAWCejrYkJGi/ccQnUh7aJ2OZ+ilc26BLPMxqx9/a+/kYiqjZFTA/J6D0w54+OLC57p3IzkBVr4/gwQ8O+Rt0xvyJsjOlQjXHoOI1I1J18ppxIB071Y05WHwtKzPmPv4KlFHKtaMQSLe5Nrs5O0mH/lToknfWDZMGdCT8GV3s3S7XW7+kq24gkBpVoPv3Aga1kb70syzxV+KH0VqBx5wvUPP2g56HqcyrW5RERn0C2Ys2YDFGfyN5OzEJfXkk+A==
x-forefront-antispam-report: CIP:255.255.255.255;CTRY:;LANG:en;SCL:1;SRV:;IPV:NLI;SFV:NSPM;H:IA0PR11MB7792.namprd11.prod.outlook.com;PTR:;CAT:NONE;SFS:(13230040)(1800799024)(366016)(376014)(38070700021)(8096899003);DIR:OUT;SFP:1101;
x-ms-exchange-antispam-messagedata-chunkcount: 1
x-ms-exchange-antispam-messagedata-0: JYHZxc9ByirCQLMF+j/55roWszSvEDbXLUR7qyuYayWzPQzfRzCJk+SG/W6wwrICZY7X78lVsTlPlBAqsPjXqwXytGvPY07C211jwDEdGswV1IbXWIYeNjet0k/biipSMa/32ClmiZeuklIqC+4bsjFU9HdJYXXeIntB/U0x6IvOpCjJ2yRSG6M7XT1TZRmz8FRCrv0QSl1MM01/8BphSelCaI9VhbvXaqC5cSi+3RV8gxeiH10AVut6Uaktc5aIab+XUSADWFKQJm1ntiwykZXbxagPTjDr9qZ3mT/Y9/qyBaClExRV3qoQYXx1zdCgUt+IJIrYW0bItAN98j9ui7P3hJ4TSnbNS3aZnL+3kBMRml0JozHLD7fYa4xxH4cfF59fgFEHPFZbKBm0xHL1WnZwPh1xnBYFVBYVvtM+TdPPtEIWJbe2Ab+nQIMBjCYEOVQhz/CQ79+3CmNG4uxFtYiMwEXONmlMydkhARjt/y6yRfvWNr29Q6OZqMTRrx6GkGAseNM2yp16bB4Q1JwMmbzaQhRq8brL7inqMjWXNQzUKA73sL/hVx+hcTUYrbdZA+FnvrQ/UW5SLC2qM+eKk1BRIWvSOvOIAzYMrzbYyBEVFHBbaj+Fykm0WvIyp3EQ7xWQRIvELlZ+UjnlMUFNO2CrWjMa+5t4MK3MNlpZoqbXwVaJvHF2fDtS7x+dx9cwEWG6/6Ffca4m3334/3wNkVyVd96MW5rFoc2XM/CFWLmdq9fJqpzsDiYpdcaD9SDIm3cYyZdIjjJ+Rt+ouZNu7KzxVqM80i2+d8whanbTl0sq94filDFsGCT26alcnM4PI9lKfDepXCpqZTWTG4sPteRmmVl3TwvHm8NDs014oSUVB/d1q8qnBZMcgjGA/L5DYf8feTkj81lLF/jr5vf/ALNWaKzrBBCp3LwUPCO4L/H/fwTnfTnNBX5mu/QggluS1Wh4u+8UqOUSg7mdpMXzC4EgcOCelUljgKNCebhBAG31W61Vx48OgMroXquWj6+GSZpAyEwtCsXNcm4QPkHjluN0Z1mxeawfV2ym1coUtXEJuXGFA6ruPtdQhVN4IMRwGYpICnPJBoDVyfuvk/Uv0rmu2uEXp8LJ1MQXYTvVyaFn/CGRQBFZIdDTJFda4WPe5K5KedjcdF1qHq0uWcZwN0iy2sDj2T3FIHwo3VOBcb9bDzr0NurNTjbv1/vWaQoXJaT/6dZ+dcPaNa3iBOd1x1GW+BM/LlVtuuiiHaKs+0A68cEEQitLc18UwfigFbRb47LTBqGohtfWxdXqdtjZexC/Z3lYqJgOxeRnaRfCuN+dyNtcsVj5IbWzNYHq8Zd9Fq6yPH1reFWAm3iabkidtb0wKaGEVrbT7V2L91nuzAGn7EVuvv2iW9C6ycLaELDldpwuriiaD/ARyen2HUAoMBrvwTi+AZsnkV7FzBdVYfV/k26X5y9QEPD0bgJ6ylyeLyUE3zg6JGsziJ8cQuSMLspnOhg9Mu6k0oIWJKuCNvMgSf/wdqowmpEDJ1/nhGO9yFLbBJrKgjX251GiXxb7Df6gLXvA2/LufnbT//806Y3sxCLr4Lg9yFboRJaEYtCSX+FnQQyFlxsrJUnBkVXPlQ==
Content-Type: multipart/alternative; boundary="_000_IA0PR11MB77921C36D4FDFA3D185DADD8D01FAIA0PR11MB7792namp_"
MIME-Version: 1.0
X-OriginatorOrg: cisco.com
X-MS-Exchange-CrossTenant-AuthAs: Internal
X-MS-Exchange-CrossTenant-AuthSource: IA0PR11MB7792.namprd11.prod.outlook.com
X-MS-Exchange-CrossTenant-Network-Message-Id: 6c9d1a07-c9b5-490a-63d8-08ddfc53f274
X-MS-Exchange-CrossTenant-originalarrivaltime: 25 Sep 2025 16:52:43.3570 (UTC)
X-MS-Exchange-CrossTenant-fromentityheader: Hosted
X-MS-Exchange-CrossTenant-id: 5ae1af62-9505-4097-a69a-c1553ef7840e
X-MS-Exchange-CrossTenant-mailboxtype: HOSTED
X-MS-Exchange-CrossTenant-userprincipalname: Kkvbzn6mxrzStkxzpQ12Oca1VsqCZxYwa5M9D1vE5rCLg2t5L+99nz+HyH2VzgnKsl6m/LXWgcrV304tyWi80g==
X-MS-Exchange-Transport-CrossTenantHeadersStamped: PH7PR11MB6772
X-Outbound-SMTP-Client: 72.163.7.169, rcdn-opgw-5.cisco.com
X-Outbound-Node: alln-l-core-07.cisco.com
Message-ID-Hash: 3YOADRPE3R4BQ3BA4PZGMNIV3MMZ7AOJ
X-Message-ID-Hash: 3YOADRPE3R4BQ3BA4PZGMNIV3MMZ7AOJ
X-MailFrom: ssidor@cisco.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-secdir.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: "draft-ietf-pce-sid-algo.all@ietf.org" <draft-ietf-pce-sid-algo.all@ietf.org>, "last-call@ietf.org" <last-call@ietf.org>, "secdir@ietf.org" <secdir@ietf.org>, "pce@ietf.org" <pce@ietf.org>
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [secdir] Re: draft-ietf-pce-sid-algo-24 ietf last call Secdir review
List-Id: Security Area Directorate <secdir.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/secdir/2eA7YSa80SCEWVB1Ri4mEkzAcv4>
List-Archive: <https://mailarchive.ietf.org/arch/browse/secdir>
List-Help: <mailto:secdir-request@ietf.org?subject=help>
List-Owner: <mailto:secdir-owner@ietf.org>
List-Post: <mailto:secdir@ietf.org>
List-Subscribe: <mailto:secdir-join@ietf.org>
List-Unsubscribe: <mailto:secdir-leave@ietf.org>

Thanks a lot, Alexey, for your review and for pointing out the nit.

I will update the statement as follows:

The security considerations described in [RFC5440], [RFC8231], [RFC8253], [RFC8281], [RFC8664], [RFC9603] and [RFC9350] apply to the extensions described in this document as well.

Regards,
Samuel

From: Alexey Melnikov via Datatracker <noreply@ietf.org>
Date: Wednesday, 24 September 2025 at 20:00
To: secdir@ietf.org <secdir@ietf.org>
Cc: draft-ietf-pce-sid-algo.all@ietf.org <draft-ietf-pce-sid-algo.all@ietf.org>, last-call@ietf.org <last-call@ietf.org>, pce@ietf.org <pce@ietf.org>
Subject: draft-ietf-pce-sid-algo-24 ietf last call Secdir review

Document: draft-ietf-pce-sid-algo
Title: Carrying SR-Algorithm in Path Computation Element Communication Protocol
(PCEP) Reviewer: Alexey Melnikov Review result: Ready

I reviewed this document as part of the Security Directorate's ongoing
effort to review all IETF documents being processed by the IESG.  These
comments were written primarily for the benefit of the Security Area
Directors.  Document authors, document editors, and WG chairs should
treat these comments just like any other IETF Last Call comments.

While this document pulls in lots of extensions (and their corresponding
Security Considerations), I think it is well-written and detailed enough
to implement.

It mostly references Security Considerations for other documents it depend
on:

[RFC5440] - Path Computation Element (PCE) Communication Protocol (PCEP)
[RFC8231] - Path Computation Element Communication Protocol (PCEP) Extensions
for Stateful PCE [RFC8253] - PCEPS: Usage of TLS to Provide a Secure Transport
for the Path Computation Element Communication Protocol (PCEP) [RFC8281] - Path
Computation Element Communication Protocol (PCEP) Extensions for PCE-Initiated
LSP Setup in a Stateful PCE Model [RFC8664] - Path Computation Element
Communication Protocol (PCEP) Extensions for Segment Routing [RFC9603] - Path
Computation Element Communication Protocol (PCEP) Extensions for IPv6 Segment
Routing [RFC9350] - IGP Flexible Algorithm

I think this is appropriate and sufficient.

Nit:
   The security considerations described in [RFC5440], [RFC8231],
   [RFC8253], [RFC8281], [RFC8664], [RFC9603] and [RFC9350] in itself.

This is not a sentence. I think you should change "in itself" to something like
"apply to this document as well" or the like.