[secdir] Re: Secdir last call review of draft-ietf-netmod-acl-extensions-13

Mahesh Jethanandani <mjethanandani@gmail.com> Wed, 29 January 2025 20:00 UTC

Return-Path: <mjethanandani@gmail.com>
X-Original-To: secdir@ietfa.amsl.com
Delivered-To: secdir@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 68C11C1CAE6D; Wed, 29 Jan 2025 12:00:12 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -2.108
X-Spam-Level:
X-Spam-Status: No, score=-2.108 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, FREEMAIL_FROM=0.001, HTML_MESSAGE=0.001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001, T_SCC_BODY_TEXT_LINE=-0.01] autolearn=ham autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (2048-bit key) header.d=gmail.com
Received: from mail.ietf.org ([50.223.129.194]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id w44v3sK3DKO9; Wed, 29 Jan 2025 12:00:11 -0800 (PST)
Received: from mail-pl1-x635.google.com (mail-pl1-x635.google.com [IPv6:2607:f8b0:4864:20::635]) (using TLSv1.3 with cipher TLS_AES_128_GCM_SHA256 (128/128 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 8D260C19ECBC; Wed, 29 Jan 2025 12:00:11 -0800 (PST)
Received: by mail-pl1-x635.google.com with SMTP id d9443c01a7336-2166022c5caso219255ad.2; Wed, 29 Jan 2025 12:00:11 -0800 (PST)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20230601; t=1738180811; x=1738785611; darn=ietf.org; h=references:to:cc:in-reply-to:date:subject:mime-version:message-id :from:from:to:cc:subject:date:message-id:reply-to; bh=zAZE/wMRkSgpS5acXphWq3lrq4GDlYlW7HaaDzzIxN4=; b=JRr4PvoCEzohjuuYDpX9GUAsZ950WdJfMnmqzujdl+97OWWUR9OqTXGgjDgWGg2IXZ +QbJe/I7t0pRzxAbVXO0bll+7EkSNeHlU28/fg3hEp9/0kKVS/OVuO2l23Kf7pYhS5yp rHDFGY2OcC+ubrW1qz5qm2pUFh/E2PhnU73rjaY8ayW1dVG6zi4H46yBJ0xCEVqZtAJJ ZeLobjK/GOC+oFm1QwuIhmmUx1USA9BpM4Tk5ydSK6iSvwqMKLfvnbKvGk3Z7dZbh890 RL70rEv1vjaPhWof1bRhBPFN9lmvsnWeV+qle/1FCI6WyGNdLiEiH+NAxyBAMqypqLNI 700Q==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20230601; t=1738180811; x=1738785611; h=references:to:cc:in-reply-to:date:subject:mime-version:message-id :from:x-gm-message-state:from:to:cc:subject:date:message-id:reply-to; bh=zAZE/wMRkSgpS5acXphWq3lrq4GDlYlW7HaaDzzIxN4=; b=xJJOP/O07Sox7+btjJ3gHkOE5C6C0i+ZLTijhAG+8+Wpt2A22eOU70T9ydxXXHjKsU QQRC+bJRG74W9oFpaYQtZLN1HfebkYxlzfeVU4NVmd1XZhLi26f8oXH8eBTKtrWc93au LSK9i1EmFWsjID51cQmZaBS/kdQSa83P3MWzG4VnsTqjIFItS52VZ4y2tqUD/rCfUhC5 i4QHgceheso43G2rsgWX8Ad/5AZ9P2YxPaf7V72MReHB76dTDpvfzzMsCSq/P2FRYrKh JA5CPQk+1e2POiiiJlSdb7YzEhrzIK7lKsvIsgtpZfiX6TChJ/dNvuvrZesRNzOsSucQ NL8Q==
X-Forwarded-Encrypted: i=1; AJvYcCUxWwWQMCXAEtBCU2+cdpYqjcGgR/7IsTiUrtwNkZet3JUXPJBaX0c+rgfEsYfWRBlqcChG4c1T/6C5KhYzucwsJ63Giut4gedX4kSV163T1GrH0TI=@ietf.org, AJvYcCVlWLQWbOlvPqgtQPb6IMApxDIlpxpDWvQ1b2Zrq6J3Yt81vN4TKMJSS3/6KtEICafTLhdoIcbv0wfa@ietf.org, AJvYcCX3vTKlCScL2vikWEBhzss0HL9kCygAskVynYOsMydT6EPXCvvkdfWcMd+BY1P3lC1VG6HEYVni@ietf.org, AJvYcCXZF8ojrhG90mCnaA0ojJaiwhVvg/XX/d01RHzJIzP9S8clhsmqaWVXh2ULip/5UCcCqI4QB+0G@ietf.org
X-Gm-Message-State: AOJu0YwdyXS9epph/6j/k0OlOCniew6bR8Rt+6AR2oJGzKC4otkj3Rue h1mLh/FNP0o7hoEYEKOFU/8q2bQiQIDUudOpURmaZs71N3UM96FZ
X-Gm-Gg: ASbGnctwodQq/nj1TclzTcfiS8e/nQgY/DkTXsrki80J0ESfnbWETTMawiuOPJLDGBO M1ESLWktcx41oTteoX5O3bkvasdvvSnb6wjs3lRqDBBxnX8j1/N4OMeH43r5vp5QhA97Sty/HDW TEvMgbJKFMuotWF+OZSRXsAC8N8lxC7ZjMhUpMsfcxvKHi1LwhBeXJUiq9bvXw7TACQ0vRd8BFu ZPjU9lZKRI5eCmixMwOedupfNTCQpEdPVI/SMur2QRtuo1pHJoWOra0bteBfil1AP1vAaVBenGr C66tN3wdy+0t1NFbTWnC+vh66ng7kBCudppnWg==
X-Google-Smtp-Source: AGHT+IEIcRJ1I/llbjtqAKgsM+tDZrnVeF4ip3tbw1phFWzOzvWrkXL3Sz+9Or6mEIXVUnnAYes8jQ==
X-Received: by 2002:a17:902:ce08:b0:216:18dc:43b3 with SMTP id d9443c01a7336-21dd7dbb6d4mr69661555ad.42.1738180810730; Wed, 29 Jan 2025 12:00:10 -0800 (PST)
Received: from smtpclient.apple ([70.234.233.187]) by smtp.gmail.com with ESMTPSA id d9443c01a7336-21da424ee47sm104831225ad.243.2025.01.29.12.00.08 (version=TLS1_2 cipher=ECDHE-ECDSA-AES128-GCM-SHA256 bits=128/128); Wed, 29 Jan 2025 12:00:09 -0800 (PST)
From: Mahesh Jethanandani <mjethanandani@gmail.com>
Message-Id: <3745EF55-0C07-4930-B8AE-B8D674F7F7E1@gmail.com>
Content-Type: multipart/alternative; boundary="Apple-Mail=_F33359F3-7BF8-4FC8-BC5C-8F809E3A840B"
Mime-Version: 1.0 (Mac OS X Mail 14.0 \(3654.120.0.1.15\))
Date: Wed, 29 Jan 2025 12:00:08 -0800
In-Reply-To: <CO1PR13MB49209C34F9B0A781EB6BB24485EE2@CO1PR13MB4920.namprd13.prod.outlook.com>
To: Linda Dunbar <linda.dunbar@futurewei.com>
References: <173808858840.1238511.4801922976708984394@dt-datatracker-5584d84fb4-tg2td> <MR1PPF6395AA9E614AAFA21370B501F5FD488EE2@MR1PPF6395AA9E6.FRAP264.PROD.OUTLOOK.COM> <CO1PR13MB49209C34F9B0A781EB6BB24485EE2@CO1PR13MB4920.namprd13.prod.outlook.com>
X-Mailer: Apple Mail (2.3654.120.0.1.15)
Message-ID-Hash: IM56KUXRNPAHYVAHEGAABLRBMLWLTI3M
X-Message-ID-Hash: IM56KUXRNPAHYVAHEGAABLRBMLWLTI3M
X-MailFrom: mjethanandani@gmail.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-secdir.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: "mohamed.boucadair@orange.com" <mohamed.boucadair@orange.com>, "secdir@ietf.org" <secdir@ietf.org>, "draft-ietf-netmod-acl-extensions.all@ietf.org" <draft-ietf-netmod-acl-extensions.all@ietf.org>, "last-call@ietf.org" <last-call@ietf.org>, "netmod@ietf.org" <netmod@ietf.org>
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [secdir] Re: Secdir last call review of draft-ietf-netmod-acl-extensions-13
List-Id: Security Area Directorate <secdir.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/secdir/mIH98gO516-YgZee7ObxJEB23bI>
List-Archive: <https://mailarchive.ietf.org/arch/browse/secdir>
List-Help: <mailto:secdir-request@ietf.org?subject=help>
List-Owner: <mailto:secdir-owner@ietf.org>
List-Post: <mailto:secdir@ietf.org>
List-Subscribe: <mailto:secdir-join@ietf.org>
List-Unsubscribe: <mailto:secdir-leave@ietf.org>

Hi Linda,

Thanks for your SECDIR review of the document. And thank you for jumping on the request to provide the review. Much appreciated.

I do have a few comments. Please see inline.

> On Jan 29, 2025, at 10:39 AM, Linda Dunbar <linda.dunbar@futurewei.com> wrote:
> 
> Med, 
>  
> You are right that  the risks associated with ACL manipulation are not unique to this draft and align with those in RFC 8519. However, the introduction of new features such as defined-sets, aliasing, and payload-based filtering expands the attack surface, warranting additional mitigation recommendations.

The document does cover defined-sets in the Security Considerations section of the document. Maybe some sentences could be added for aliasing and payload-based filtering.

>  
> While RFC 8341 provides a foundation for user and data access control, it does not explicitly address ACL-specific threats such as unauthorized modifications or tampering. Given the critical role ACLs play in security policy enforcement, it may be beneficial to reinforce best practices tailored to ACL configurations, such as:
>  
> Requiring digital signatures (e.g., PKI-based certificates, HMAC) for ACL modifications to ensure authenticity.
> Deploying anomaly detection mechanisms to detect and alert on unusual ACL modifications.
> Restricting ACL modifications to predefined maintenance windows to reduce exposure to accidental or unauthorized changes.

All good points. However, I believe they are not specific to ACL configuration. NETCONF/RESTCONF already requires secure authenticated sessions to be established to make any modifications or read the config. Repeating your first bullet item will be redundant in this document.

>  
> It doesn't look like that there is any BCP specifically addressing ACL integrity protections, perhaps referencing broader security best practices from RFC 2196 (Site Security Handbook) or RFC 4949 (Internet Security Glossary) could be helpful.

The last two bullet items are items that should be targeted for a BCP like RFC 2196.

Cheers.

>  <> 
> Linda
>  
> -----Original Message-----
> From: mohamed.boucadair@orange.com <mailto:mohamed.boucadair@orange.com> <mohamed.boucadair@orange.com <mailto:mohamed.boucadair@orange.com>> 
> Sent: Wednesday, January 29, 2025 12:52 AM
> To: Linda Dunbar <linda.dunbar@futurewei.com <mailto:linda.dunbar@futurewei.com>>; secdir@ietf.org <mailto:secdir@ietf.org>
> Cc: draft-ietf-netmod-acl-extensions.all@ietf.org <mailto:draft-ietf-netmod-acl-extensions.all@ietf.org>; last-call@ietf.org <mailto:last-call@ietf.org>; netmod@ietf.org <mailto:netmod@ietf.org>
> Subject: RE: Secdir last call review of draft-ietf-netmod-acl-extensions-13
>  
> Hi Linda, 
>  
> Thank you for the review. 
>  
> You are completely right about the risks, which are not specific to this I-D but are similar to RFC8519. This is why we do have the following:
>  
>       Similar to [RFC8519], unauthorized write access to these list can
>       allow intruders to modify the entries so as to permit traffic that
>       should not be permitted, or deny traffic that should be permitted.
>       The former may result in a DoS attack, or compromise a device.
>       The latter may result in a DoS attack. 
>  
> For sure, unauthorized access to configuration data (not only ACLs) will cause a lot of damage. Consider access to a routing configuration, address allocation, etc. So, if there are any robust measures to recommend, these should be applicable beyond ACL case. This is why we leverage common blocks such as RFC8341 for control of users/data access, mutual authentication, etc. 
>  
> I think that the guards in the spec are good ones. However, if you are aware of an ** authoritative BCP ** that we can consider, please let us know.
>  
> Thank you.
>  
> Cheers,
> Med
>  
> > -----Message d'origine-----
> > De : Linda Dunbar via Datatracker <noreply@ietf.org <mailto:noreply@ietf.org>> Envoyé : mardi 28 
> > janvier 2025 19:23 À : secdir@ietf.org <mailto:secdir@ietf.org> Cc : 
> > draft-ietf-netmod-acl-extensions.all@ietf.org <mailto:draft-ietf-netmod-acl-extensions.all@ietf.org>; last- call@ietf.org <mailto:call@ietf.org>; 
> > netmod@ietf.org <mailto:netmod@ietf.org> Objet : Secdir last call review of 
> > draft-ietf-netmod-acl-
> > extensions-13
> > 
> > Reviewer: Linda Dunbar
> > Review result: Not Ready
> > 
> > I have reviewed this document as part of the SEC area directorate's 
> > ongoing effort to review all IETF documents being processed by the 
> > IESG.  These comments were written primarily for the benefit of the 
> > Security area directors.
> > Document editors and WG chairs should treat these comments just like 
> > any other last-call comments.
> > 
> > Summary: The document defines extensions to the ACLs YANG Model 
> > specified in RFC 8519. While the description is clear, it lacks 
> > details on the mitigation methods for ACL Manipulation Risks.
> > 
> > New features such as defined-sets, aliasing, and payload-based 
> > filtering introduce potential security risks if not properly 
> > authenticated and authorized.  An attacker could: a) Modify ACL 
> > entries to bypass security policies (e.g., allow the malicious 
> > traffic); b) Introduce denial-of-service
> > (DoS) conditions by blocking legitimate traffic.
> > 
> > To mitigate these risks, the document should include recommendations 
> > for security best practices, such as,  requiring the ACL configuration 
> > changes to be digitally signed using PKI- based certificates or HMAC 
> > (Hash-based Message Authentication Code); maintaining a detailed log 
> > of ACL modifications; storing a hash of ACL configurations in a 
> > tamper-resistant database; implementing anomaly detection mechanisms 
> > to trigger alerts for unusual ACL modification; restricting ACL 
> > modifications only during maintenance windows to minimize accidental 
> > or unauthorized changes,  etc.
> > 
> > Adding these security controls would significantly enhance the 
> > document's robustness against ACL manipulation attacks.
> > 
> > Best Regards, Linda Dunbar
> > 
> > 
>  
> ____________________________________________________________________________________________________________
> Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.
>  
> This message and its attachments may contain confidential or privileged information that may be protected by law; they should not be distributed, used or copied without authorisation.
> If you have received this email in error, please notify the sender and delete this message and its attachments.
> As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
> Thank you.


Mahesh Jethanandani
mjethanandani@gmail.com