[sipcore] Doc Shepherd review of draft-ietf-sipcore-digest-scheme, cont.
"A. Jean Mahoney" <mahoney@nostrum.com> Mon, 01 July 2019 19:30 UTC
Return-Path: <mahoney@nostrum.com>
X-Original-To: sipcore@ietfa.amsl.com
Delivered-To: sipcore@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 31791120179 for <sipcore@ietfa.amsl.com>; Mon, 1 Jul 2019 12:30:44 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -1.98
X-Spam-Level:
X-Spam-Status: No, score=-1.98 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, T_SPF_HELO_PERMERROR=0.01, T_SPF_PERMERROR=0.01] autolearn=ham autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (1024-bit key) header.d=nostrum.com
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id kaenuA35ZCb0 for <sipcore@ietfa.amsl.com>; Mon, 1 Jul 2019 12:30:42 -0700 (PDT)
Received: from nostrum.com (raven-v6.nostrum.com [IPv6:2001:470:d:1130::1]) (using TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 780B2120178 for <sipcore@ietf.org>; Mon, 1 Jul 2019 12:30:42 -0700 (PDT)
Received: from mutabilis-2.local ([47.186.30.41]) (authenticated bits=0) by nostrum.com (8.15.2/8.15.2) with ESMTPSA id x61JUcZW087610 (version=TLSv1.2 cipher=ECDHE-RSA-AES128-GCM-SHA256 bits=128 verify=NO); Mon, 1 Jul 2019 14:30:39 -0500 (CDT) (envelope-from mahoney@nostrum.com)
DKIM-Signature: v=1; a=rsa-sha256; c=simple/simple; d=nostrum.com; s=default; t=1562009440; bh=aL0UAv5nB55IfnFcFgiLD6o4F4lEqnBtzXJlCAYl5wU=; h=To:From:Subject:Date; b=ofZcpDMHLFWG9X/4eaOCrYXuQtA3xsoDbXoIkK/6oFtNWJQn9s1/YopldskDaQ8Gq 2C+IVSJj+8Aj6RQ3s3/eTg7Mp93mHVpN+b2AIHxtvRC3YP3tCm5SF0nmh57fRvgUXj bOgLNhkgoUzw2bXXSQRZ3ZpqNMaVsnJH9qPmmkEE=
X-Authentication-Warning: raven.nostrum.com: Host [47.186.30.41] claimed to be mutabilis-2.local
To: Rifaat Shekh-Yusef <rifaat.ietf@gmail.com>, SIPCORE <sipcore@ietf.org>
From: "A. Jean Mahoney" <mahoney@nostrum.com>
Message-ID: <e7901509-0b8c-7706-69a7-ba5af67668b2@nostrum.com>
Date: Mon, 01 Jul 2019 14:30:38 -0500
User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:60.0) Gecko/20100101 Thunderbird/60.7.2
MIME-Version: 1.0
Content-Type: text/plain; charset="utf-8"; format="flowed"
Content-Language: en-US
Content-Transfer-Encoding: 7bit
Archived-At: <https://mailarchive.ietf.org/arch/msg/sipcore/LqcK9JL7TlP-LuN8OlQU1VS0kEI>
Subject: [sipcore] Doc Shepherd review of draft-ietf-sipcore-digest-scheme, cont.
X-BeenThere: sipcore@ietf.org
X-Mailman-Version: 2.1.29
Precedence: list
List-Id: SIP Core Working Group <sipcore.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/sipcore>, <mailto:sipcore-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/sipcore/>
List-Post: <mailto:sipcore@ietf.org>
List-Help: <mailto:sipcore-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/sipcore>, <mailto:sipcore-request@ietf.org?subject=subscribe>
X-List-Received-Date: Mon, 01 Jul 2019 19:30:44 -0000
Hi Rifaat,
Below are the rest of my Doc Shepherd review comments, mainly a few
minor issues and nits. I have a suggested rework of the Introduction to
clarify that MD5 is not collision resistant and that RFC3261 references
the RFC obsoleted by RFC7616.
Thanks!
Jean
General: There are some instances of "SIP protocol" and "HTTP protocol".
These should be replaced with either "SIP"/"HTTP" or "Session Initiation
Protocol"/"Hypertext Transfer Protocol".
Abstract: Should explicitly mention that the document updates RFC 3261
(idnits flagged this). Should mention that MD5 is still available for
backward availability.
Introduction: Suggested rewording -
The Session Initiation Protocol [RFC3261] uses the same mechanism
that the Hypertext Transfer Protocol (HTTP) uses for authenticating
users. This mechanism is called Digest Access Authentication, and
it is a simple challenge-response mechanism that allows a server
to challenge a client request and allows a client to provide
authentication information in response to that challenge. The
version of Digest Access Authentication that RFC 3261 references
is specified in [RFC2617].
The default hash algorithm for Digest Access Authentication is MD5.
However, it has been demonstrated that the MD5 algorithm is not
collision resistant, and is now considered a bad choice for a hash
function [RFC6151].
The HTTP Digest Access Authentication [RFC7616] document obsoletes
[RFC2617] and adds stronger algorithms that can be used with
the Digest Authentication scheme, and establishes a registry for
these algorithms, known as the "Hash Algorithms for HTTP Digest
Authentication" registry, so that algorithms can be added in the
future.
This document updates the Digest Access Authentication scheme used
by SIP to support the algorithms listed in the "Hash Algorithms
for HTTP Digest Authentication" registry defined by [RFC7616].
S2 p2: This section should also mention that the BNF for the URI
included in the challenge has been changed and now allows
more schemes than SIP and SIPS.
S2 p2: UAC and UAS should be expanded on first use.
S2 p2: s/"qop" option/"qop" parameter
S2.1 p2: s/any registered algorithm/any algorithm listed in
the "Hash Algorithms for HTTP Digest Authentication"
registry.
S2.4 p1: Remove the space in "Proxy- Authenticate"
S2.5 p1: s/introduces some clarification to that/clarifies that
S2.5 p2: s/proxy to the UA./proxy to the UAC.
S2.6: I suggest changing the title to "HTTP Digest Authentication
Scheme Modifications" to match better the section title
in RFC 3261.
S2.6 p1: There is also a change to the BNF in bullet 1 that allows
more URI schemes, so "... specified in bullets, 1, 7 and 8."
S2.6 p3: Add a reference to RFC7616 after HTTP.
S2.6 #8: s/handle "qop"/handle the "qop" (occurs twice)
S2.6 last p: s/continue/continues
S2.7 p1: Insert a reference to [RFC5234] after "Augmented BNF".
S3 p1: s/used to with/used with
S4 p1: Add an explicit statement such as, "This document has
no actions for IANA."
S6: Add references to RFC 5234 and RFC 6151.
- [sipcore] Doc Shepherd review of draft-ietf-sipco… A. Jean Mahoney
- Re: [sipcore] Doc Shepherd review of draft-ietf-s… Rifaat Shekh-Yusef
- Re: [sipcore] Doc Shepherd review of draft-ietf-s… A. Jean Mahoney
- Re: [sipcore] Doc Shepherd review of draft-ietf-s… Rifaat Shekh-Yusef