[lamps] Mike Bishop's No Objection on draft-ietf-lamps-rfc5273bis-08: (with COMMENT)

Mike Bishop via Datatracker <noreply@ietf.org> Fri, 12 September 2025 15:32 UTC

Return-Path: <noreply@ietf.org>
X-Original-To: spasm@ietf.org
Delivered-To: spasm@mail2.ietf.org
Received: from [10.244.8.59] (unknown [4.156.85.76]) by mail2.ietf.org (Postfix) with ESMTP id 8C8AF61A822C; Fri, 12 Sep 2025 08:32:38 -0700 (PDT)
MIME-Version: 1.0
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: 7bit
From: Mike Bishop via Datatracker <noreply@ietf.org>
To: The IESG <iesg@ietf.org>
X-Test-IDTracker: no
X-IETF-IDTracker: 12.49.0
Auto-Submitted: auto-generated
Precedence: bulk
Message-ID: <175769115851.1593603.10969566489802855510@dt-datatracker-f7c8fdcb7-pjx77>
Date: Fri, 12 Sep 2025 08:32:38 -0700
Message-ID-Hash: BRWFF55NQE4PH2SO2463APH6VEQF5KTQ
X-Message-ID-Hash: BRWFF55NQE4PH2SO2463APH6VEQF5KTQ
X-MailFrom: noreply@ietf.org
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-spasm.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: draft-ietf-lamps-rfc5273bis@ietf.org, lamps-chairs@ietf.org, spasm@ietf.org, housley@vigilsec.com
X-Mailman-Version: 3.3.9rc6
Reply-To: Mike Bishop <mbishop@evequefou.be>
Subject: [lamps] Mike Bishop's No Objection on draft-ietf-lamps-rfc5273bis-08: (with COMMENT)
List-Id: This is the mail list for the LAMPS Working Group <spasm.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/spasm/3sAsQ1Lto4ah0SbpZg3EiLpiTw8>
List-Archive: <https://mailarchive.ietf.org/arch/browse/spasm>
List-Help: <mailto:spasm-request@ietf.org?subject=help>
List-Owner: <mailto:spasm-owner@ietf.org>
List-Post: <mailto:spasm@ietf.org>
List-Subscribe: <mailto:spasm-join@ietf.org>
List-Unsubscribe: <mailto:spasm-leave@ietf.org>

Mike Bishop has entered the following ballot position for
draft-ietf-lamps-rfc5273bis-08: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)


Please refer to https://www.ietf.org/about/groups/iesg/statements/handling-ballot-positions/ 
for more information about how to handle DISCUSS and COMMENT positions.


The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-lamps-rfc5273bis/



----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

In Section 5 (was Section 3), the value of the smime-type parameter has changed
from "CMC-Request" to "CMC-request". Is this field case-insensitive or is this
a breaking change? The capitalized version appears to be what's currently
registered with IANA and is used in Section 8. There appears to be some case
variation in the use of CMC-[Rr]esponse as well, though that persists from the
original RFC.

Thank you for updating the [HTTP] reference to point to RFC 9110 -- I
appreciate the diligence. I don't see any version-specific considerations here,
so I think you're fine not mentioning particular flavors of HTTP further.
Informative references to Cookies (RFC 6265), Digest (RFC7616), and Basic
(RFC7617) might be warranted since you're mentioning them in a normative
statement, but they're marginal since your requirement is that the server not
assume the client implements them.

Please update HTTP headers to be "fields" in line with current terminology; see
Section 5 of RFC 9110. Not all fields are header fields.