[lamps] Re: New Liaison Statement, "LSout to IETF on “Certificate Management”"
"Brockhaus, Hendrik" <hendrik.brockhaus@siemens.com> Thu, 14 August 2025 16:29 UTC
Return-Path: <hendrik.brockhaus@siemens.com>
X-Original-To: liaison-coordination@mail2.ietf.org
Delivered-To: liaison-coordination@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id 705A2541B680 for <liaison-coordination@mail2.ietf.org>; Thu, 14 Aug 2025 09:29:14 -0700 (PDT)
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -2.099
X-Spam-Level:
X-Spam-Status: No, score=-2.099 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIMWL_WL_MED=-0.001, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, HTML_MESSAGE=0.001, SPF_NONE=0.001] autolearn=ham autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=pass (2048-bit key) header.d=siemens.com
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id MPNlGuL10gNN for <liaison-coordination@mail2.ietf.org>; Thu, 14 Aug 2025 09:29:13 -0700 (PDT)
Received: from PA4PR04CU001.outbound.protection.outlook.com (mail-francecentralazlp170130007.outbound.protection.outlook.com [IPv6:2a01:111:f403:c20a::7]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange ECDHE (P-384) server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id E3E66541B669 for <liaison-coordination@iab.org>; Thu, 14 Aug 2025 09:29:12 -0700 (PDT)
ARC-Seal: i=1; a=rsa-sha256; s=arcselector10001; d=microsoft.com; cv=none; b=tTM3ICSMl0UXL0as1JRsUikV5CwE902Xw7D9lhad9+hS5XFcUfAOKnZ4HeTZh6LBODc/hwXNpfzFGVYED8mWAH763uzwLsfssd+dMm3GsejpuOOC1DHby7ZhMsPKxsYmMSr5P9VSUqagNCvXBW4x86/caZxDW0LtEuB1PbvOPaeLliHBQMXoG5E72kvVqOfbHqRsBa2rP24IIYeEiz8d/QQGJQ1eP4t32djkmyodiml+C6FJUwMU9beXXXF526aLVpTkuLkkkuUvn6ivgR5bR9I3i80q01yjddblziBoXeFbX7nF5bOLpCTXdMWwLbvvevcuxeGfdKabS0eo2ctIsQ==
ARC-Message-Signature: i=1; a=rsa-sha256; c=relaxed/relaxed; d=microsoft.com; s=arcselector10001; h=From:Date:Subject:Message-ID:Content-Type:MIME-Version:X-MS-Exchange-AntiSpam-MessageData-ChunkCount:X-MS-Exchange-AntiSpam-MessageData-0:X-MS-Exchange-AntiSpam-MessageData-1; bh=1FbPHMVKEO3Tqa1docJGNiBoMriip237jdUXagWoKmA=; b=Vz5lsjkL/v68BpMTHxWw/9EEUwCyx1OUDi+wznK9M7ehvUPGNCgfO00LMg53JrlFVOovz7RnOgR+FVztyHUzuGjKwWpSY+FfKZ+I+4HVn+y+Cp06TPomzNnJcl5v9BVa/jenbczio0B09VEfdS3PZ5jUOIFxMbDq7AahhDv+HQ9A1lnreMYpDjiB+ES275QipVSxJxo0ItB+R9W/B+kP+Pb/ObONcFdsZL8xwm2qECRMJRFTvAFTLxV1KLlKWtuV1sZHw6k+vdSlUv6y0Ev4gQCu2GFMWEVDZWYYL/2qaxzdPdic/JEFOMYVqNE92ZIab99Xv5VkM/ijfK7T/Kbbzw==
ARC-Authentication-Results: i=1; mx.microsoft.com 1; spf=pass smtp.mailfrom=siemens.com; dmarc=pass action=none header.from=siemens.com; dkim=pass header.d=siemens.com; arc=none
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=siemens.com; s=selector2; h=From:Date:Subject:Message-ID:Content-Type:MIME-Version:X-MS-Exchange-SenderADCheck; bh=1FbPHMVKEO3Tqa1docJGNiBoMriip237jdUXagWoKmA=; b=ddnZxL9xVjE+OCuGAkFszZ1cuYMoikxw65eEFtj4ALoHEqMb5Sm5AbPB3siVtivBWtKcq9GYzQ/LFN1ZROX61+j2jcT7HMx+81TKBRIohx6UrQ1EUvulIM/9YowPbCaO3+YzH4did+7xVAnQSpTg++yhVR0gCcwvCVR0C25C4nWtZR1plD7BggtlPsySPaAVoIBhv6cTvNcFtxhtRus3T9SIyt9iQp2z/cND9ZzuS75Mj5Vvq6Vf4KBsS0TuZvFtbDNv7pXPZsrUjFN0kd/ATT3cLm3RmTGp/Xyfv/L8o30vK7VbN5CHMbon8AN7yVIHn4zyUNAREa9sGhWx1Ue+UA==
Received: from DB9PR10MB5715.EURPRD10.PROD.OUTLOOK.COM (2603:10a6:10:2ee::5) by DB9PR10MB6739.EURPRD10.PROD.OUTLOOK.COM (2603:10a6:10:3d1::14) with Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) id 15.20.9031.15; Thu, 14 Aug 2025 16:29:10 +0000
Received: from DB9PR10MB5715.EURPRD10.PROD.OUTLOOK.COM ([fe80::8b02:6852:93f4:50a]) by DB9PR10MB5715.EURPRD10.PROD.OUTLOOK.COM ([fe80::8b02:6852:93f4:50a%5]) with mapi id 15.20.9031.014; Thu, 14 Aug 2025 16:29:10 +0000
From: "Brockhaus, Hendrik" <hendrik.brockhaus@siemens.com>
To: Support Nvf <nfvsupport@etsi.org>
Thread-Topic: [lamps] Re: New Liaison Statement, "LSout to IETF on “Certificate Management”"
Thread-Index: AQHb3tr2kcDtXE3otES+bwKe6HUhMrRisiVQ
Date: Thu, 14 Aug 2025 16:29:10 +0000
Message-ID: <DB9PR10MB57151D52D1A2FD272E348675FE35A@DB9PR10MB5715.EURPRD10.PROD.OUTLOOK.COM>
References: <174553986463.339.2923004214798819471@dt-datatracker-7bd7b9d5d5-79vfh> <A992F9F3-F2B9-4BC3-BCA7-B82406C244C7@vigilsec.com>
In-Reply-To: <A992F9F3-F2B9-4BC3-BCA7-B82406C244C7@vigilsec.com>
Accept-Language: de-DE, en-US
Content-Language: de-DE
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
msip_labels: MSIP_Label_9d258917-277f-42cd-a3cd-14c4e9ee58bc_ActionId=c78ad905-7366-4006-a93c-9c76f4397f54;MSIP_Label_9d258917-277f-42cd-a3cd-14c4e9ee58bc_ContentBits=0;MSIP_Label_9d258917-277f-42cd-a3cd-14c4e9ee58bc_Enabled=true;MSIP_Label_9d258917-277f-42cd-a3cd-14c4e9ee58bc_Method=Standard;MSIP_Label_9d258917-277f-42cd-a3cd-14c4e9ee58bc_Name=restricted;MSIP_Label_9d258917-277f-42cd-a3cd-14c4e9ee58bc_SetDate=2025-08-14T16:24:38Z;MSIP_Label_9d258917-277f-42cd-a3cd-14c4e9ee58bc_SiteId=38ae3bcd-9579-4fd4-adda-b42e1495d55a;MSIP_Label_9d258917-277f-42cd-a3cd-14c4e9ee58bc_Tag=10, 3, 0, 1;
authentication-results: dkim=none (message not signed) header.d=none;dmarc=none action=none header.from=siemens.com;
x-ms-publictraffictype: Email
x-ms-traffictypediagnostic: DB9PR10MB5715:EE_|DB9PR10MB6739:EE_
x-ms-office365-filtering-correlation-id: 7b13bcd2-49fb-4ecc-4aab-08dddb4fb2c4
x-ms-exchange-atpmessageproperties: SA
x-ms-exchange-senderadcheck: 1
x-ms-exchange-antispam-relay: 0
x-microsoft-antispam: BCL:0;ARA:13230040|1800799024|366016|7416014|376014|13003099007|7053199007|38070700018|8096899003;
x-microsoft-antispam-message-info: ru57h/hVo9lbijLln/4H9JDaJ0OgjvQLR168WfccLl3uRAqhfitpS8m7J5QBGG/bO6iRW16j3s433nx4mHcRx360b74xzxK3ltYDpCJCZ455VPnnQiPYVwAh1S83Jmdk3XsgJgYrWd2ugjf4+MyFSEfGOakkAq4YjgJDCbQfrgXB6ndd44S/ukPpzCbahBfLRhx7adymxPiHfPkgdHvB5RdLaKapqSgV/P/CRvlhliBgkUYXAJz3NH91GOiShoA8LPPkFrv+qP7niCyZaG3m93WJEr/JULU/NR0/6GcK/b7bjR+IHrh2+04Gkfuit1L2e1/F8HzQTrCiuWzWzriC/czdT1keqA16e/QI1dKl7QD32cpVif9Qlnyrs5aiGgYEriaSzrFrHb76xVb4LYGM9wr+54VW/+XnQjhKo9BB4UGGIYKdhhsKcnyG+I2mk0KiMbERCTwpxqIJ521NmhWFL+eTLGUc+8wGkfNLvDZtM2YV4i2Kg2oC5zbMWbsaZDAgTvTIGtGejLmb1MI54vzdw4/+OOTDbNOxYdaeZujts+lgTgCvXPi1vsHpnHbtXJCdgUVFnK/iA2sbxVLfxgJAnqoC9l2hpc3k+1YNiQXIRIH540EfBcBJYPym7kMjfRCeq6QE2MD/vJVMrJcr3Gmfcox5cC3OsmOZmnkYiSfw6dJRk7zGrKC2pDeIkIaWnLaneO1o1FVXtXq/gprYHmfdvgdEDNFG0KmKzuzgdBwuaEC6wDFCoGOEp+wMzFQuuEdixkhPVfGpjr0+ajZqxihfxEnDVfSYJk1hrPdastt40FqIV5BKurb+iRvF0dn5V9b8pyXkbkTSGvyAEEg2FWP1tmcjd8api4whOxA91+njhqvJNeINJR8piK+6cq948vk6WfQe2/jRQ+6AyXEo0l3lZvN4iFgOoZGvBr7kehI3UMflQjCTXm+dbheLypmG5nEm0aZjQhlea3/OJAiBz0Z8jFnBsUMV4ccKQenXj0H2mtjaYmObWiNwSMKs6EJzX2v6qM9A7VE4hEV4d3kWJiuhOV3zoT4jfogklRqVayE6RCvWLrl5U+6Mtg+NH0sBUdC6emlchOPechMoWHOfg581Q4a2JeSM7PK2mwVa3TvybhI1iSc+4YKCKZLOYHR4QR3iya+VzAUbYn33mJjxeR4nkKbxhk9/Nhhza3S+pj/NFTCVq7obDm2VYWpRbXtAXxHRkhNqTGlbCOKk/XqiYZxB7h2xj6uHgjzGKo8woiOUyXBbQPMRfMGLf6dXCAw/quEvBQjzHQGQJjSumv0DrFoReMg5yNdekOm7q7w38k4muwHTj7nifcsJlJm8E4wuvnFqnDuzYAYwrVSil6HqRBNcqC4+issB4GyQaeeMefevBdWmhRimguU6Q9zLnIitCxEExdMo94q/SI2dgwxaOcaheBup9al3s8KhhHlztnAwdL8=
x-forefront-antispam-report: CIP:255.255.255.255;CTRY:;LANG:en;SCL:1;SRV:;IPV:NLI;SFV:NSPM;H:DB9PR10MB5715.EURPRD10.PROD.OUTLOOK.COM;PTR:;CAT:NONE;SFS:(13230040)(1800799024)(366016)(7416014)(376014)(13003099007)(7053199007)(38070700018)(8096899003);DIR:OUT;SFP:1101;
x-ms-exchange-antispam-messagedata-chunkcount: 1
x-ms-exchange-antispam-messagedata-0: r6AWBtMtCXxLou2T/2kU1h1F6ynYRldcKxRkgtsnYDaacH+pzNzHmkanjSLJ/m+rSyimsM7iy+qeqan0tVQipHAFPSRw+hdgcxEwPeiUd9wF9L5SJ+JfJz6zoY1HQSfZPcIlu6VClzujlkz+ZYGYpRoprOW5YONu5oxAYq84XVjx6GGHNz02UuGtM2s4s0LJS4BAKmoBeoiHA36Rv1JqNyxB6OiWh2ECEQH/w/R4OMFMcusTTpxz8h4VeMkwck8kruKnrVfykU1X1d/zx0hGa7qb18B+715AaXPSSwp7IXUI2+zl5fpXofvW19RHQM8ec61YNOguk0qFXPD0X71figPvSo5nQRiM2mzXZaGRIGnsZ8v6q4OfJP65j1nySgVWnsEvJ+1bwdV8WgHbvp3rXWZC3R3R6KeT3S8zuUWy9zsI76C/Zo46CqslEbr1yMExi9LnE6kqFyaOzD2jDNQqpXPVYtsspB9Ybp/ygb+vpphZwN4oA6+DpVy27yhmMRLZo+UzB+MUI7cEb63kj77F8TLMxgvh0Zfaym/VSeDxRxMM+wUBJJXzUXBK0hULbkYPe00T82V2eMgXAUBEZVSMVTLi+N4FOAWNpUQH6odKHhMxkkHoiEzlOhSKkpSOhAZ2xhi+BfYaKc8Dc+FVd27/HLAn9ChOLLqiCsmY17Zhs+ygGaVZNlfA8M9JWYBOyRVgr+ez36c/EiDjFnPqsLsC1MS9tpzHiB7Gt1h1Pkh/bxS9ZVUlbT1nBbr4uiiAANtjvtnMuOUTne3kQ1H+PD1hwWKu5mZj+SgiW+pIjBhLnoRSO6lgAyOmJJoW177jhRJpALK0UaLFUvXkfqaW8aqUC1fFP9yuPptluG4rZWz1edjGfGHraUlVZXa7JFiNlcwyxELhbVjOcRHyUptqIFUsJxUrB6S2qh2s4ippGy0CfTpg54fHy8TysLWEC+cQZxi9vMnW1h3WmMjOg6LX4kHdM5mpURkE7yQu0Fmb/dCiK6+CCKt0chd8JQp1KfBMwAFjmCXXPN5hOltty08IR3SWtFbHYvGH5DDvdPmjMfLFoutBUxsKI9qZ81AFAvVHkeCCD9OgS6GAzT3QQ+7IfGF6EkCYg4pu+JuO6/ZBjaYV/yDTj4uqHD8s2fHwH2XDcX7KdOIjTuLENOGTPJ6oWNPT7rZkOWLMjAsi6c5nddhsrHo8UHzhH2ltSv7izMa2yxsZ5lNWXORHLbDw7wjEnR9s+4vKgepDKF999hiWEOxWW7aGlhVIZ2GgiEB/NYLkjLMS6jHl6JzMZEfPBL3y+geGPAExLmlR/HKasxCtz1I5AwaVr3MbRU5U8LRg74t3058Di6Pef7a3HqYLxP5MRCDQjAhX0Qyjkm9MfOdOboRIyuehHYv9EZ2d/CZKATnx+C7EqxxDLjNLFu2mOlIuZSXXQrSzVHyQtVV9UiPYdqfTzFY7xlh4LjX+Bvqchza4jE4kZ7bjAx2KiTgdAiDSSmR+5uxyPgjVqJE8vro2LghamLLM1U82RxH09gbAqtUe8w6U2nWD2bhuWJD9pg4Uk7nObIL7yYY/EN8ykWZYDkRqpDmEdJSraWSvGv2E5Tt5yezgy/Ea7HXdIhoE5q7hGMDCAA==
Content-Type: multipart/alternative; boundary="_000_DB9PR10MB57151D52D1A2FD272E348675FE35ADB9PR10MB5715EURP_"
MIME-Version: 1.0
X-OriginatorOrg: siemens.com
X-MS-Exchange-CrossTenant-AuthAs: Internal
X-MS-Exchange-CrossTenant-AuthSource: DB9PR10MB5715.EURPRD10.PROD.OUTLOOK.COM
X-MS-Exchange-CrossTenant-Network-Message-Id: 7b13bcd2-49fb-4ecc-4aab-08dddb4fb2c4
X-MS-Exchange-CrossTenant-originalarrivaltime: 14 Aug 2025 16:29:10.4391 (UTC)
X-MS-Exchange-CrossTenant-fromentityheader: Hosted
X-MS-Exchange-CrossTenant-id: 38ae3bcd-9579-4fd4-adda-b42e1495d55a
X-MS-Exchange-CrossTenant-mailboxtype: HOSTED
X-MS-Exchange-CrossTenant-userprincipalname: 6+JbdMuCz5p5X2V68AS1Ygr/gtG5HUuHFlC9R1J8nH+gUCrE2H32/U5LMjKWFzZ7uC8wF/qpl20XOi6I8LDzbVL2JVp6wXPegq8SfdI8Vgc=
X-MS-Exchange-Transport-CrossTenantHeadersStamped: DB9PR10MB6739
X-MailFrom: hendrik.brockhaus@siemens.com
X-Mailman-Rule-Hits: max-recipients
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; nonmember-moderation; administrivia; implicit-dest; max-size; news-moderation; no-subject; digests; suspicious-header
Message-ID-Hash: CIDMVZFQGBTKC5CU5MLLTFAMD6BZ7DA2
X-Message-ID-Hash: CIDMVZFQGBTKC5CU5MLLTFAMD6BZ7DA2
X-Mailman-Approved-At: Thu, 14 Aug 2025 12:06:02 -0700
CC: Russ Housley <housley@vigilsec.com>, Kathleen Moriarty <Kathleen.Moriarty.ietf@gmail.com>, Ned Smith <ned.smith@intel.com>, Tim Hollebeek <tim.hollebeek@digicert.com>, Deb Cooley <debcooley1@gmail.com>, Limited Additional Mechanisms for PKIX and SMIME Discussion List <spasm@ietf.org>, Paul Wouters <paul.wouters@aiven.io>, Remote ATtestation ProcedureS Discussion List <rats@ietf.org>, "liaison-coordination@iab.org" <liaison-coordination@iab.org>, IETF Liaison Statements <statements@ietf.org>, "yoshihiro.nakajima.td@nttdocomo.com" <yoshihiro.nakajima.td@nttdocomo.com>, "denghui12@huawei.com" <denghui12@huawei.com>, "wangxl66@chinatelecom.cn" <wangxl66@chinatelecom.cn>, "u.manchang@zte.com.cn" <u.manchang@zte.com.cn>, "leslie.willis@bt.com" <leslie.willis@bt.com>, "brendan.t.hassett@huawei.com" <brendan.t.hassett@huawei.com>, "stere.preda@ericsson.com" <stere.preda@ericsson.com>, "xiahaitao@huawei.com" <xiahaitao@huawei.com>, "Katsalis@docomolab-euro.com" <Katsalis@docomolab-euro.com>, "unoyu@nttdocomo.com" <unoyu@nttdocomo.com>, "lishitao@huawei.com" <lishitao@huawei.com>
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [lamps] Re: New Liaison Statement, "LSout to IETF on “Certificate Management”"
List-Id: This is the mail list for the LAMPS Working Group <spasm.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/spasm/DAr7iRWiJD85Ly2xT5cyhcutPE0>
List-Archive: <https://mailarchive.ietf.org/arch/browse/spasm>
List-Help: <mailto:spasm-request@ietf.org?subject=help>
List-Owner: <mailto:spasm-owner@ietf.org>
List-Post: <mailto:spasm@ietf.org>
List-Subscribe: <mailto:spasm-join@ietf.org>
List-Unsubscribe: <mailto:spasm-leave@ietf.org>
I just wanted to let you know that RFC 9810 (https://datatracker.ietf.org/doc/rfc9810/) and RFC 9811 (https://datatracker.ietf.org/doc/rfc9811/) were published in July obsoleting RFC 4210, RFC 6712, and RFC 9480. Hendrik Von: Russ Housley <housley@vigilsec.com> Gesendet: Montag, 16. Juni 2025 18:22 An: Support Nvf <nfvsupport@etsi.org> Cc: Kathleen Moriarty <Kathleen.Moriarty.ietf@gmail.com>; Ned Smith <ned.smith@intel.com>; Tim Hollebeek <tim.hollebeek@digicert.com>; Deb Cooley <debcooley1@gmail.com>; Limited Additional Mechanisms for PKIX and SMIME Discussion List <spasm@ietf.org>; Paul Wouters <paul.wouters@aiven.io>; Remote ATtestation ProcedureS Discussion List <rats@ietf.org>; liaison-coordination@iab.org; IETF Liaison Statements <statements@ietf.org>; yoshihiro.nakajima.td@nttdocomo.com; denghui12@huawei.com; wangxl66@chinatelecom.cn; u.manchang@zte.com.cn; leslie.willis@bt.com; brendan.t.hassett@huawei.com; stere.preda@ericsson.com; xiahaitao@huawei.com; Katsalis@docomolab-euro.com; unoyu@nttdocomo.com; lishitao@huawei.com Betreff: [lamps] Re: New Liaison Statement, "LSout to IETF on “Certificate Management”" In January 2025, the documents https://datatracker.ietf.org/doc/draft-ietf-lamps-rfc6712bis/ and https://datatracker.ietf.org/doc/draft-ietf-lamps-rfc4210bis/ approved by the IESG. The two documents are expected to be published as RFCs in mid-2025. They will obsolete the current RFCs 4210, 6712 and 9480. RE: Action 1. In NFV-SOL023: https://docbox.etsi.org/ISG/NFV/Open/Drafts/SOL023/NFV-SOL023v0011.zip, it is crucial to understand that the delegation mode features distinct endpoints for TLS and CMP. The TLS endpoint is designated as the CMF acting as an RA forwarding a CMP request to the CA if the certificate request was approved. While the CMP endpoint on the CA requires the message-origin authentication of the request. This necessitates that the VNFM must be registered with both the CMF and the CA, making both authentications essential. It is important to note that the end-to-end authentication capability of CMP is crucial for the message-origin authentication at the CA. It cannot be replaced solely by the TLS client authentication as it offers only authentication on the first hop at the CMF. The senderKID facilitates identification of the CMP protection credentials. Leaving the senderKID empty only makes sense when omitting CMP message protection. This would lead to an unprotected certificate request message, meaning no proof-of-identity of the VNFM requesting the certificate, being transmitted from the CMF to the CA. Both TLS and CMP provide comprehensive authentication means. While TLS only provides authentication to the next TLS hop and CMP can provide end-to-end authentication to even further hops. For CMP, the two endpoints authenticating to each other are the VNFM requesting a certificate and the CA/RA. According to RFC 9483, CMP messages must be authenticated, meaning that the certificate request message will be generated by the VNFM requesting the certificate, and will be authenticated by the CA/RA. Authentication is non-negotiable and cannot be null or left empty; an unprotected CMP message will cause the message to be rejected by the CA/RA. This is because without message-origin authentication of the certificate request message the CA/RA has no reliable information to authorize the certificate request with. The senderKID is used to ease the identification of the CMP protection certificate and therefore is required to be set accordingly. While TLS provides server authentication, in cases of mutually authentication, both the client and server are authenticated. A single endpoint can utilize the same identity for both TLS and CMP. This allows an entity requesting the certificate to send the certificate request message using the same identity on TLS as well as on CMP level. It is essential to recognize that both TLS and CMP offer authentication based on certificates and pre-shared keys. RE: Action 2. The process of registering or de-registering during the provisioning phase involves CMP clients being registered with the Certification Authority (CA) to obtain certificates linked to their accounts. However, CMP does not exactly encompass this concept as described in ETSI-GS-NFV-IFA 026, which seems to be related to account management. Typically, these actions are carried out through proprietary APIs offered by the CA, and there are currently no intentions to standardize these APIs at the IETF. Consequently, it is highly unlikely that this will fall within the scope of LAMPS. When CMP mentions “registration” it is understood as the process where an entity applies for its first certificate at the PKI and this PKI issues it. Accordingly, the de-registration of an entity takes place through the revocation of all still valid certificates that this PKI has issued for this entity. Details on initial registration/certification using CMP can be found at https://datatracker.ietf.org/doc/html/draft-ietf-lamps-rfc4210bis-18#section-4.2 and https://datatracker.ietf.org/doc/html/rfc9483#section-4.1.1. De-registration might be implemented by revocation or expiration of the certificates. Details on revocation using CMP can be found in https://datatracker.ietf.org/doc/html/draft-ietf-lamps-rfc4210bis-18#section-5.3.9 and https://datatracker.ietf.org/doc/html/rfc9483#section-4.2. Because CMP is a flexible protocol, it can easily be extended. If you wish to perform the registration/de-registration exchanges inband CMP you could either profile the ir/cr/kur/p10cr/rr messages or specify additional general messages (genm/genp), see examples for how to extend general messages in https://datatracker.ietf.org/doc/html/draft-ietf-lamps-rfc4210bis-18#section-5.3.19 and https://datatracker.ietf.org/doc/html/rfc9483#section-4.4. Such extensions would require specification in an RFC. RE: Action 3. ACME offers the Token Authority as outlined in RFC 9447 and RFC 9448. A Token Authority acts as an RA performing authorization of a certificate request in a domain separate from the CA. However, the current architecture is tailored for specific tokens, which may not align with your particular needs. As said, CMP is quite flexible. An authorization token could either be carried in the generalInfo field of the CMP request message header (see https://datatracker.ietf.org/doc/html/draft-ietf-lamps-rfc4210bis-18#section-5.1.1) or in the regInfo field of the certificate request (see https://datatracker.ietf.org/doc/html/rfc4211#section-3, this does not work with PKCS#10). The respective new syntax would need to be specified in an RFC. When a CA does not use the Token Authority, note that it will also likely consider isolating internally the ACME server exposed to the Internet from its certificate issuing function. RE: Action 4. The IETF operates as an open standards organization, welcoming anyone to join and participate. Currently, the primary groups of concern are LAMPS https://datatracker.ietf.org/wg/lamps/about/ and ACME https://datatracker.ietf.org/wg/acme/about/. We strongly encourage you to participate actively in the LAMPS and ACME Working Groups. In case you plan to extend the CMP protocol based on the proposals above, there may be support regarding CMP ASN.1 syntax specification. Participation is the best way to represent the ETSI requirements in the IETF. In NFV-SOL023, accessible at https://docbox.etsi.org/ISG/NFV/Open/Drafts/SOL023/NFV-SOL023v0011.zip, we recognize that the CMP message is part of a specific protocol outlined in this document. It is important to clarify that CMP is not just message syntax. Like many protocols, it includes elements of procedure as well. We suggest that your protocol be divided into two components: one component is responsible for the registration/de-registration and the other component is responsible for the management of the certificates. If you are using CMP, the latter must be articulated by using RFC9483. On Apr 24, 2025, at 8:11 PM, Liaison Statement Management Tool <statements@ietf.org<mailto:statements@ietf.org>> wrote: Title: LSout to IETF on “Certificate Management” Submission Date: 2025-04-24 URL of the IETF Web page: https://datatracker.ietf.org/liaison/1992/ Please reply by 2025-06-16 From: Support Nvf <nfvsupport@etsi.org<mailto:nfvsupport@etsi.org>> To: Ned Smith <ned.smith@intel.com<mailto:ned.smith@intel.com>>,Kathleen Moriarty <Kathleen.Moriarty.ietf@gmail.com<mailto:Kathleen.Moriarty.ietf@gmail.com>>,Russ Housley <housley@vigilsec.com<mailto:housley@vigilsec.com>>,Tim Hollebeek <tim.hollebeek@digicert.com<mailto:tim.hollebeek@digicert.com>> Cc: Limited Additional Mechanisms for PKIX and SMIME Discussion List <spasm@ietf.org<mailto:spasm@ietf.org>>,Remote ATtestation ProcedureS Discussion List <rats@ietf.org<mailto:rats@ietf.org>>,Russ Housley <housley@vigilsec.com<mailto:housley@vigilsec.com>>,Deb Cooley <debcooley1@gmail.com<mailto:debcooley1@gmail.com>>,Paul Wouters <paul.wouters@aiven.io<mailto:paul.wouters@aiven.io>>,Kathleen Moriarty <Kathleen.Moriarty.ietf@gmail.com<mailto:Kathleen.Moriarty.ietf@gmail.com>>,Ned Smith <ned.smith@intel.com<mailto:ned.smith@intel.com>>,Tim Hollebeek <tim.hollebeek@digicert.com<mailto:tim.hollebeek@digicert.com>> Response Contacts: Yoshihiro Nakjima (ISG Chair) <yoshihiro.nakajima.td@nttdocomo.com<mailto:yoshihiro.nakajima.td@nttdocomo.com>> Deng Hui (ISG Vice-Chair) <denghui12@huawei.com<mailto:denghui12@huawei.com>> Wang Xuliang (ISG Vice-Chair) <wangxl66@chinatelecom.cn<mailto:wangxl66@chinatelecom.cn>> Ju Manchang (ISG Vice-Chair) <ju.manchang@zte.com.cn<mailto:ju.manchang@zte.com.cn>> Hassett Brendan (ISG Technical Manager) <brendan.t.hassett@huawei.com<mailto:brendan.t.hassett@huawei.com>> Leslie Willis (SEC WG Chair) <leslie.willis@bt.com<mailto:leslie.willis@bt.com>> Preda Stere (SEC WG Vice-Chair) <stere.preda@ericsson.com<mailto:stere.preda@ericsson.com>> Xia Haitao (IFA WG Chair) <xiahaitao@huawei.com<mailto:xiahaitao@huawei.com>> Kostas Katsalis (IFA WG Vice-Chair) <Katsalis@docomolab-euro.com<mailto:Katsalis@docomolab-euro.com>> Yuya Kuno (SOL WG Chair & feature prime) <kunoyu@nttdocomo.com<mailto:kunoyu@nttdocomo.com>> Li Shitao (SOL WG Vice-Chair) <lishitao@huawei.com<mailto:lishitao@huawei.com>> Technical Contacts: Purpose: For action Body: 1. Overall description: ETSI ISG NFV has been working on “Certificate Management” and has published the set of specifications. Main outcome of works is ETSI GS NFV-IFA 026, “Network Functions Virtualisation (NFV) Release 5; Management and Orchestration; Security Architecture enhancements for NFV Specification”, which introduces the main concept, architecture, use cases, and requirements, and ETSI GS NFV-IFA 033 “Reference points related to Security Manager and Certificate Management Function Interface and Information Model Specification”. Version 5.2.1 of ETSI NFV IFA026/IFA033 are available at the following location: • https://www.etsi.org/deliver/etsi_gs/NFV-IFA/001_099/026/05.02.01_60/gs_NFV-IFA026v050201p.pdf • https://www.etsi.org/deliver/etsi_gs/NFV-IFA/001_099/033/05.02.01_60/gs_NFV-IFA033v050201p.pdf ISG NFV is working on ETSI GS NFV-SOL 023, “Specification of protocol and data model solutions for CMF - NFV-MANO reference point”, that introduces the protocol and data model solutions for CMF - NFV-MANO reference point by use of profiling approach against IETF RFC 4210/9480/9483 CMP. One of the options within IFA026/ IFA033/ SOL023 is the use of the VNFM (VNF Manager) as a delegate for certificate request/renewal/revocation (delegation mode). The proof of ownership may not be available and therefore other concepts of authentication are being investigated. The following questions have been raised. • Where the transport for CMPv2 is using HTTP (RFC 6712) which itself is secured using TLS could client certificate-based authentication (mTLS) be used rather than authentication keys? If so, what exact values would be expected for the “senderKID” parameter? Or can the client skip or put null according to the chapter 3.1 of RFC 9483 for senderKID? • As described in ETSI GS NFV-IFA026/IFA033, the concepts of “Registration” and “De-registration” are introduced. ETSI NFV would like to ask or confirm that CMPv2 has the appropriate concept aligning with end entity registration / de-registration or whether there are any evolution plans to support similar kinds of concepts? • For the consideration of functions of ACME server (RFC 8555), ETSI NFV has been discussing if the ACME server can be realized as part of CA functionality or different functions. ETSI NFV would like to ask for thoughts on this matter and any background information. 2. Actions: ETSI ISG NFV kindly asks your organization to: 1) provide technical feedback on what exact values would be expected for the “senderKID” paramenter when the transport for CMPv2 is using HTTP (RFC 6712). 2) provide technical feedback on whether CMPv2 has the appropriate concept aligning with end entity registration / de-registration or whether there are any evolution plans to support similar kinds of concepts. 3) provide technical feedback on whether the ACME server can be realized as part of CA functionality or different function. 4) consider the possibility of collaboration on the harmonized and consolidated certificate related standards among SDOs who are working e.g. virtualization-platform for telco industry. ETSI ISG NFV aims to avoid potential overlapping work and fragmentation of the standards in close area/aspect of the industry. 3. Date of next meetings of the originator: 16-20 June 2025 NFV#50 plenary Shanghai, China In addition, NFV-IFA WG has weekly decision-making conference calls every Wednesday, NFV-SEC WG has bi-weekly decision-making conference calls every Thursday, and NFV-SOL WG has weekly decision-making conference calls every Thursday. Attachments: NFV(25)000052r2_LSout_on_ENH01_01_Certificate_Management_to_IETF https://www.ietf.org/lib/dt/documents/LIAISON/liaison-2025-04-25-etsi-isg-nfv-lamps-rats-lsout-to-ietf-on-certificate-management-attachment-1.docx
- [lamps] New Liaison Statement, "LSout to IETF on … Liaison Statement Management Tool
- [lamps] Re: New Liaison Statement, "LSout to IETF… Russ Housley
- [lamps] Re: [Rats] Re: New Liaison Statement, "LS… Daniel Migault
- [lamps] Re: [EXTERNAL] Re: [Rats] Re: New Liaison… Mike Ounsworth
- [lamps] Re: [EXTERNAL] Re: [Rats] Re: New Liaison… Tomas Gustavsson
- [lamps] Re: [Rats] Re: [EXTERNAL] Re: Re: New Lia… Kathleen Moriarty
- [lamps] Re: [Rats] Re: [EXTERNAL] Re: Re: New Lia… Daniel Migault
- [lamps] Re: [Rats] Re: [EXTERNAL] Re: Re: New Lia… Brockhaus, Hendrik
- [lamps] Re: New Liaison Statement, "LSout to IETF… Russ Housley
- [lamps] Re: New Liaison Statement, "LSout to IETF… ETSI NFVsupport
- [lamps] Re: New Liaison Statement, "LSout to IETF… Brockhaus, Hendrik