[spring] Re: WGLC Chair review of draft-ietf-spring-bfd-12
Greg Mirsky <gregimirsky@gmail.com> Mon, 24 February 2025 08:02 UTC
Return-Path: <gregimirsky@gmail.com>
X-Original-To: spring@ietfa.amsl.com
Delivered-To: spring@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id EE1FDC13193A; Mon, 24 Feb 2025 00:02:03 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -2.105
X-Spam-Level:
X-Spam-Status: No, score=-2.105 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, FREEMAIL_FROM=0.001, HTML_MESSAGE=0.001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001, T_SCC_BODY_TEXT_LINE=-0.01, URIBL_BLOCKED=0.001, URIBL_DBL_BLOCKED_OPENDNS=0.001, URIBL_ZEN_BLOCKED_OPENDNS=0.001] autolearn=ham autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (2048-bit key) header.d=gmail.com
Received: from mail.ietf.org ([50.223.129.194]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id HQA2kIpA9CrB; Mon, 24 Feb 2025 00:02:02 -0800 (PST)
Received: from mail-pj1-x1036.google.com (mail-pj1-x1036.google.com [IPv6:2607:f8b0:4864:20::1036]) (using TLSv1.3 with cipher TLS_AES_128_GCM_SHA256 (128/128 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 703CEC169428; Mon, 24 Feb 2025 00:02:02 -0800 (PST)
Received: by mail-pj1-x1036.google.com with SMTP id 98e67ed59e1d1-2fbf77b2b64so8333587a91.2; Mon, 24 Feb 2025 00:02:02 -0800 (PST)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20230601; t=1740384122; x=1740988922; darn=ietf.org; h=cc:to:subject:message-id:date:from:in-reply-to:references :mime-version:from:to:cc:subject:date:message-id:reply-to; bh=+QVKJmaFaaWlgNq1mj4PJHZ5lmW6Q22R0YSBPqierro=; b=UhaX2wD/OS3fNH4JNAGuL2U/vOe8+xiZiDe9AjSRhAJ5qsXIHga4WkubFLMAHpk77R HQyXT1k25dOCN3b/9eanDHwq2r3LS4siYRc4u2UA8WcIvADcU63v4aO3ToF858ow0WDC rsuwn79x5v8xmZu5FJRicxmpbRhVg4kZHtfH+61OuzEzye86pxVw0bCCbfFfOgisFBIY FH1Sij55HMzc4Ox53gOMTUjbYDArzbKWAA5/ldtIkTsAozc/NkVRDSA03Nl26XjSkSDp yQxcbeaOoB5aLTnWT8oVycWaAxGmg+3m2UPXqtV8kzrUzR3ko3NI+QOYj6yl1lt1zhIQ Zp9w==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20230601; t=1740384122; x=1740988922; h=cc:to:subject:message-id:date:from:in-reply-to:references :mime-version:x-gm-message-state:from:to:cc:subject:date:message-id :reply-to; bh=+QVKJmaFaaWlgNq1mj4PJHZ5lmW6Q22R0YSBPqierro=; b=JbtKxPBP8vhg/CUQWaML8M6pLLQvrVbC3KAvk+HBjc+sLi3Ht/i2hXiYPm4TIKXTmZ 2bFHPSHyELuoEM7v8HFknzftHAC13AKFSdMzB0iL1WX6prKAGuPqGCaL+DkNvBWDFdfZ gSAKNNU3Ti8CzHDa5CW+AKolJeoTuzWQGQfzP3dCyyET7ODgyNnhqNc3DbQqSsY91s9x 1vnlaxQ36kbywSsZyYKNyBeLBI6BYX007DwqWyEq1+fF6RCITxGkwhPMg3oLtHfYDqvQ 2JiIsbB2sZJi2FUqBN4YdYvrLj0+O+vKQE4TFai8+zuTE59lj1GJWFEiGKDzX/DGAoJZ 5yeg==
X-Forwarded-Encrypted: i=1; AJvYcCUUuvJEfJv7WD8Anw32XEcKz454pN5U5xyKPJfYa3b8MVA54tuC09ZE3zULshPFRzLlvLU5tyNvcg==@ietf.org, AJvYcCVQtreIQyvQIQqxRGBruAP9xcTOQKMrwVyr+HJGCXv5Fs2rMfOxDfshzSfh1iFPnsRvk8r3lg==@ietf.org, AJvYcCVn9VjkXsd1cltsgbL0+nwVeOKRe7RXtmsM59To7NOLer/UzQsZeseY+gcbs4s18QBtzx6BIM+ckX76QGgwwjf5VSV86nw=@ietf.org, AJvYcCXJAfnbUa1y/bLqLQusZC6orSlZ6Hc+oMdiw7BAsnbFKg6JUfBPId/BRQUsaZ5+98sbcCI7ZKWbmTf9IXB8ZA==@ietf.org
X-Gm-Message-State: AOJu0Yw7lU7MEP76t704Jwefgzn0zTSon72sJJ/Halg3QMgdmO2NnlAM ySxXieUcNK738EadbGhDcGUG/rNVoCohNYDneEpUm0F0WtI/exvlEhUNG28FQguMj1TH0O+RheP tX/aKUfucPZT1o+JKdKnPMWTNPgs=
X-Gm-Gg: ASbGncvbCCPVrXpxTBUlnGkUM62G5G4+VbWI5+EIZoXxMvAy3KaeJOGFkQ1C03naFu3 +awoHs+6tdG/pqTQ4f3EqFBjC4n5Oo0VONB8X2Qvm6GUnAgDzKCessSyb6XkBEvW7mRCmHQsrO+ 3gohatVTMx
X-Google-Smtp-Source: AGHT+IGbicp4GGKX+NbT3pkJcvadt3pY1L/HS+U7ep2iCOknBLMqZSkdFhsyQJx2gE3+SbhMZ6o+Vr7FMjZXUHntY1Y=
X-Received: by 2002:a17:90b:37c7:b0:2ee:edae:75e with SMTP id 98e67ed59e1d1-2fce78a97f2mr20769067a91.13.1740384121724; Mon, 24 Feb 2025 00:02:01 -0800 (PST)
MIME-Version: 1.0
References: <CAMMESsyA6EUOdzXKA5QY_vmMCaWSZJcwMRcvVkXUyF_ZH0TuNQ@mail.gmail.com> <CA+RyBmUZcSrBzTfs3ymAraQt+A-xviuWmG4XgAUo431nKEJBeA@mail.gmail.com> <CAMMESsyWGCs41RAJRrqqMYgNbMAUyC78nHm5Zhnu=rvrE2b_xw@mail.gmail.com>
In-Reply-To: <CAMMESsyWGCs41RAJRrqqMYgNbMAUyC78nHm5Zhnu=rvrE2b_xw@mail.gmail.com>
From: Greg Mirsky <gregimirsky@gmail.com>
Date: Mon, 24 Feb 2025 09:01:51 +0100
X-Gm-Features: AWEUYZlJ9dbGqXR0QP-igzoN9wQLcqlxdcWS62FMBYdD8V5kI0NZdieW5YNZE1E
Message-ID: <CA+RyBmWB1+gNwvLiN7nWNk-2UDEqwWkzN2Le2N7g+FJbZDHqOQ@mail.gmail.com>
To: Alvaro Retana <aretana.ietf@gmail.com>
Content-Type: multipart/alternative; boundary="000000000000592676062edec1bf"
Message-ID-Hash: AI6FFTYBAHLFV6ID2HI7IXS5E2XAXE6Y
X-Message-ID-Hash: AI6FFTYBAHLFV6ID2HI7IXS5E2XAXE6Y
X-MailFrom: gregimirsky@gmail.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-spring.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: SPRING WG <spring@ietf.org>, Ketan Talaulikar <ketant.ietf@gmail.com>, "spring-chairs@ietf.org" <spring-chairs@ietf.org>, IETF MPLS List <mpls@ietf.org>, rtg-bfd@ietf.org, draft-ietf-spring-bfd@ietf.org
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [spring] Re: WGLC Chair review of draft-ietf-spring-bfd-12
List-Id: "Source Packet Routing in NetworkinG (SPRING)" <spring.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/spring/Oxjq5ZEGzTXXVP_UtoR4pANLBq0>
List-Archive: <https://mailarchive.ietf.org/arch/browse/spring>
List-Help: <mailto:spring-request@ietf.org?subject=help>
List-Owner: <mailto:spring-owner@ietf.org>
List-Post: <mailto:spring@ietf.org>
List-Subscribe: <mailto:spring-join@ietf.org>
List-Unsubscribe: <mailto:spring-leave@ietf.org>
Hi Alvaro,
thank you for you detailed and helpful feedback. I'm working on addressing
your comments and resolving outstanding concerns.
Regards,
Greg
On Wed, Feb 19, 2025 at 1:30 AM Alvaro Retana <aretana.ietf@gmail.com>
wrote:
> On February 1, 2025 at 6:43:12 PM, Greg Mirsky wrote:
>
>
> Greg:
>
> Hi!
>
> Please see some responses inline.
>
> Thanks!
>
> Alvaro.
>
>
> ...
> > > 64 Table of Contents
> > > ...
> > > 76 4. Applicability of BFD Demand Mode in SR-MPLS Domain . . . . . 7
> > > 77 5. Using BFD to Monitor Point-to-Multipoint SR Policy . . . . . 8
> > > 78 6. Use of Echo BFD in SR-MPLS . . . . . . . . . . . . . . . . . 8
> > > 79 7. Use of S-BFD in SR-MPLS . . . . . . . . . . . . . . . . . . . 9
> > >
> > > [minor] This document describes several BFD options. What should an
> > > operator consider when selecting one over another? For example, are
> there
> > > differences related to the number of sessions? It would be nice if
> there
> > > were a short section talking about the pros/cons.
> >
> > GIM>> I agree that that is an important and helpful to operators topic.
> My
> > concern is that it might be challenging to separate technical and
> > non-technical arguments. It could be helpful if we collect feedback and
> > experiences from operators in a blind poll. WDYT?
>
> No, I don't think so.
>
> This is an experimental document that aims to experiment in the field.
> Asking for operator feedback/experiences would be something to be done once
> the experiment is over.
>
> Also, not all options are part of the experiment, so I would expect
> operators to have more experience with them, which would bring up the
> question of why we need another option.
>
>
> I would prefer it if you (authors) provided technical guidance instead.
> After all, this document proposes various options.
>
> Note that my comment is "minor". I can live with the experience being
> part of the experiment.
>
>
>
> ...
> > > 204 When LSP Ping is used to bootstrapping a BFD session for SR-MPLS
> > > 205 segment list the FEC corresponding to the last segment to be
> > > 206 associated with the BFD session MUST be as the very last sub-TLV
> > > 207 in the Target FEC TLV.
> ...
> > > [major] What if the last/destination segment is a BSID? I don't think
> > > there's a FEC defined for that...even if it should be possible to
> monitor
> > > the SL, at least up to that point. Is this case not supported?
> >
> > GIM>> A good question. Can we have a scenario in which BSID terminates
> an SR
> > Policy? I imagine that BSID might be used to control the depth of the
> label
> > stack, but I cannot come up with a case where BSID is the last in SR
> Policy
> > as, in my understanding, it will be replaced by a list of SIDs. Am I
> missing
> > something here?
>
> I guess it's a matter of interpreting where an SR Policy starts/ends.
>
> I'm thinking of it from the point of view of the definition in rfc8402:
>
> 5. Binding Segment
>
> In order to provide greater scalability, network opacity, and service
> independence, SR utilizes a Binding SID (BSID). The BSID is bound to
> an SR Policy, instantiation of which may involve a list of SIDs. Any
> packets received with an active segment equal to BSID are steered
> onto the bound SR Policy.
>
> This text implies (at least to me) that the BSID signals the entry into an
> SR Policy, which means that (for this draft) is the end of the previous SR
> Policy.
>
> IMO, it is important to clarify how a BSID is considered in this draft.
> If considered as you explained, then please add a sentence about a BSID not
> being able to be the last segment...or something to that effect.
>
>
>
> ...
> > > 214 3. Using BFD Reverse Path TLV over SR Policy's Segment List
> > >
> > > 216 For BFD over MPLS LSP case, per [RFC5884], egress LER MAY send BFD
> > > 217 Control packet to the ingress LER either over IP network or an MPLS
> > > 218 LSP. Similarly, for the case of BFD over p2p SR-MPLS segment list,
> > > 219 the egress LER MAY route BFD Control packet over the IP network, as
> > > 220 described in [RFC5883], or transmit over a segment list, as
> described
> > > 221 in Section 7 [RFC5884]. In some cases, there may be a need to
> direct
> > > 222 egress LER to use a specific path for the reverse direction of the
> > > 223 BFD session by using the BFD Reverse Path TLV and following all
> > > 224 procedures as defined in [RFC9612].
> > >
> > > [major] "For BFD over MPLS LSP case, per [RFC5884], egress LER MAY
> send BFD
> > > Control packet to the ingress LER either over IP network or an MPLS
> LSP."
> > >
> > > This behavior is already specified in RFC5884, so there should be no
> > > Normative language here -- unless it is to point at the other RFC in
> > > general. Also, note that the text above makes sending optional ("MAY
> > > send”), not the election.
> > >
> > > Suggestion>
> > >
> > > For the BFD over MPLS LSP case, the egress LER SHOULD send BFD
> > > Control packets to the ingress LER either based on the destination
> > > IP address or encapsulated in an MPLS label stack as specified in
> > > [RFC5884].
> > >
> >
> > GIM>> Thank you for bringing up this question. As I understand RFC 5884,
> > egress LER MUST use one of two encapsulations - IP/UDP or MPLS. It seems
> that
> > if we say SHOULD, then there might be yet another encapsulation option.
> > Perhaps the following update accurately reflects encapsulation options:
> >
> > OLD TEXT:
> > For BFD over MPLS LSP case, per [RFC5884], egress LER MAY send BFD
> > Control packet to the ingress LER either over IP network or an MPLS
> > LSP.
> >
> > NEW TEXT:
> > For BFD over MPLS LSP case, per [RFC5884], egress LER MUST send BFD
> > Control packet to the ingress LER using one of two encapsulations -
> > IP/UDP or MPLS.
>
> In this case, none of these suggestions (including mine!) work.
>
> I looked at rfc5884 again. In §7 (Encapsulation), it says that the egress
> "MAY be routed based on the destination IP address...or...MAY be
> encapsulated in an MPLS label stack". While I think your interpretation
> (using MUST) is what was probably meant by the two MAYs, all suggestions
> use text that differs from the original -- and we shouldn't reinterpret or
> respecify something that is specified elsewhere.
>
> Suggestion>
>
> For the BFD over MPLS LSP case, the egress LER MUST send BFD
> Control packets to the ingress LER as specified in [RFC5884].
>
>
>
> ...
> > > [nit] s/(...)/
> > GIM>> I couldn't find it.
>
> The text in parenthesis was: "(to be assigned by IANA as requested in
> Section 8.1)”—you don't need it.
>
>
>
> ...
> > > [major] §11 (The Scope of the Experiment) mentions the use of the
> "Non-FEC
> > > Path TLV in BFD Reverse Path TLV", which I interpret as the Non-FEC
> Path
> > > TLV is a sub-TLV of the BFD Reverse Path TLV. However, as defined in
> this
> > > document (see the request in §8.1), the Non-FEC Path TLV can't be used
> as a
> > > sub-TLV of the BFD Reverse Path TLV because §3.1/RFC9612 specifies:
> > >
> > > Only non-multicast Target FEC Stack sub-TLVs (already defined or
> > > to be defined in the future) for TLV Types 1, 16, and 21 in the
> > > "Multiprotocol Label Switching (MPLS) Label Switched Paths (LSPs)
> > > Ping Parameters" registry are permitted to be used in this field.
> > > Other sub-TLVs MUST NOT be used."
> > >
> > > If the intent is to use the "Non-FEC Path TLV in BFD Reverse Path
> TLV", the
> > > definition won't allow it.
> >
> > GIM>> Thank you for catching this major issue. I propose updating
> Section 8.1.
> > Non-FEC Path TLV as follows:
> >
> > OLD TEXT:
> > IANA is requested to assign new TLV type from the from 16384-31739
> > range of the registry "Multiprotocol Label Switching Architecture
> > (MPLS) Label Switched Paths (LSPs) Ping Parameters - TLVs" as defined
> > in Table 1.
> >
> > NEW TEXT:
> > IANA is requested to assign a new TLV type from the 31740-31743 range
> > of the registry "Multiprotocol Label Switching Architecture (MPLS)
> > Label Switched Paths (LSPs) Ping Parameters - Sub-TLVs for TLV Types
> > 1, 16, and 21" as defined in Table 1.
>
> The range doesn't need to be changed -- you can keep 16384-31739.
>
> Note that the 31740-31743 range is reserved for "Experimental Use",
> meaning a value will not be assigned. IOW, people are free to use any
> value for experiments. Even though this is an Experimental document, we
> want interoperability, so the value must be known/assigned.
>
> You could also request a value from the 31744-32767 range (First Come
> First Served), up to you.
>
>
>
>
> > > [major] How should the Non-FEC Path TLV interact with any other
> possible
> > > sub-TLVs in the BFD Reverse Path TLV? [rfc9612 is, unfortunately,
> silent
> > > about any interaction.]
> >
> > GIM>> A good question, thank you. Should this document make the use of
> > Non-FEC Path TLV mutually excluded any other sub-TLV that might be
> defined
> > in the future? I think that that must be explicitly specified in
> documents
> > introducing new sub-TLVs. Would you agree?
>
> I'm not thinking of future-defined sub-TLVs; what about the already
> defined ones?
>
> The question is because the definition of the BFD Reverse Path TLV in
> rfc9612 allows for "zero or more...non-multicast Target FEC Stack
> sub-TLVs", and several are already defined. IOW, what happens if another
> path is indicated along with the Non-FEC Path TLV?
>
> I'm not asking about all possible combinations (that should have been
> specified in rfc9612). I'm just asking about the combination of the
> Non-FEC Path TLV and other existing TLVs.
>
> See more below...
>
>
> > >
> > >
> > >
> > > 269 This document defines the SR Policy's Segment List sub-TLV that MAY
> > > 270 be used with the Non-FEC Path TLV. The format of the sub-TLV is
> > > 271 presented in Figure 2.
> > >
> > > [] Please put the specification of this sub-TLV in a new sub-section.
> > GIM>> Put it into the new sub-section titled SR Policy's Segment List
> sub-TLV
> > >
> > >
> > >
> > > ...
> > > 289 The SR Policy's Segment List sub-TLV Type is two octets in length,
> > > 290 and has a value of TBD2 (to be assigned by IANA as requested in
> > > 291 Section 8.1).
> > >
> > > [nit] s/(...)/
>
> Same as before: the text in parenthesis is not needed.
>
>
>
> ...
> > > [minor] The SR Policy's Segment List sub-TLV is an ordered list of
> labels.
> > > Several Type-A Segment Sub-TLVs
> [draft-ietf-mpls-spring-inter-domain-oam]
> > > could also be used in the BFD Reverse Path TLV to describe an ordered
> list
> > > of labels. Is there a functional difference between the two? [This
> question
> > > is related to the interaction question above.]
> >
> > GIM>> An excellent and thought-provoking question! AFAICS, Type-A Segment
> > sub-TLV allows only single label stack entry. Is that a useful way to
> specify
> > the return path in an SR domain? It seems like it could be used if the
> > sub-TLV carries B-SID. As for the interaction, since both sub-TLVs to be
> > listed in IANA's "Sub-TLVs for TLV Types 1, 16, and 21" sub-registry of
> the
> > "Multiprotocol Label Switching (MPLS) Label Switched Paths (LSPs) Ping
> > Parameters", they, as I understand it, are inherently mutually exclusive.
>
> Yes, it carries a single entry, but I'm asking about using several
> sub-TLVs. There's nothing that limits the number of TLVs so that it could
> describe the path the same way as one Non-FEC Path TLV. The question above
> was: If multiple Type-A Segment Sub-TLVs can be used, isn't that the same
> as a single Non-FEC Path TLV?
>
>
>
> No, they're not mutually exclusive, or at least no place says that. Note
> that rfc9612 allows "zero or more sub-TLVs", and rfc9716 doesn't say
> anything about the sub-TLVs not being allowed with others.
>
> Even if the TLVs were mutually exclusive, the behavior if both are present
> is not specified anywhere.
>
> For this document, I think that you don't want the Non-FEC Path TLV to
> interact with other sub-TLVs given the potential confusion and
> inconsistency. If that is true, you need to say something in the draft.
>
>
>
>
>
> > > 299 3.2. BFD Reverse Path TLV over SR Policy's Segment List with
> Dynamic
> > > 300 Control Plane
> > >
> > > 302 When Segment Routed domain with MPLS data plane uses distributed
> > > 303 computation of SR Policy's segment lists, BFD Reverse Path TLV MAY
> > > 304 use Target FEC sub-TLVs defined in [RFC8287].
> ...
> > > [major] "BFD Reverse Path TLV MAY use..."
> > >
> > > The BFD Reverse Path TLV already allows the use of *any* sub-TLV, so
> > > there's no need to specify this here. Even if needed, this document
> isn't
> > > Updating rfc9612 to change the behavior or limit what is already
> allowed.
> >
> > GIM>> Updated with using the normative words:
> >
> > OLD TEXT:
> > When Segment Routed domain with MPLS data plane uses distributed
> > computation of SR Policy's segment lists, BFD Reverse Path TLV MAY
> > use Target FEC sub-TLVs defined in [RFC8287].
> >
> > NEW TEXT:
> > Target FEC sub-TLVs defined in [RFC8287] are applicable in SR domains
> > that are in the scope of [RFC8287].
>
> This text says what? As I read it, it says that what was defined in
> rfc8287 applies to the context of rfc8287, which is not a false statement
> but also obvious and unnecessary.
>
>
>
>
>
> > > 306 4. Applicability of BFD Demand Mode in SR-MPLS Domain
> > >
> > > 308 Sections 6.6 and 6.18.4 of [RFC5880] define how Demand mode of BFD
> > > 309 can be used to monitor uni-directional MPLS LSP. Similar procedures
> > > 310 can be following in SR-MPLS to monitor uni-directional SR tunnels:
> > >
> > > [minor] "6.18.4 of [RFC5880]" doesn't exist.
> > GIM>> Strange because I find it here
> > https://datatracker.ietf.org/doc/html/rfc5880#section-6.8.14
> > (https://datatracker.ietf.org/doc/html/rfc5880#section-6.8.14)
>
> You found *6.8.14*, not *6.18.4*. :-)
>
>
>
>
> ...
> > > 343 An essential part of using p2mp BFD is the bootstrapping the BFD
> > > 344 session at all the leaves. The root, acting as the MultipointHead,
> > > 345 MAY use LSP Ping [I-D.ietf-pim-p2mp-policy-ping] with the BFD
> > > 346 Discriminator TLV. Alternatively, extensions to routing protocols,
> > > 347 e.g., BGP, or management plane, e.g., Path Computation Element
> > > 348 Protocol, MAY be used to associate the particular p2mp segment list
> > > 349 with MultipointHead's Discriminator. Extensions for routing
> > > 350 protocols and management plane are for further study.
> ...
> > NEW TEXT:
> > Also, the BGP-BFD Attribute [RFC9026] MAY be used to bootstrap a
> > multipoint BFD session on a tail. Furthermore, other extensions to
> > routing protocols or the management plane could be defined in the
> > future to serve similar purposes, but such work is out of the scope
> > of this document.
>
> There's no "BGP-BFD Attribute" in rfc9026. I assume you meant the BGP BFD
> Discriminator attribute.
>
> The new paragraph is fine.
>
>
>
> ...
> > GIM>> AFAICS, draft-ietf-pim-p2mp-policy-ping is not the Normative, but
> > Informational reference.
>
> §5 reads: "...MAY use LSP Ping [I-D.ietf-mpls-p2mp-bfd] and
> [I-D.ietf-pim-p2mp-policy-ping]..." Both drafts should be Normative
> references because they are associated with Normative behavior.
>
>
- [spring] WGLC Chair review of draft-ietf-spring-b… Alvaro Retana
- [spring] Re: WGLC Chair review of draft-ietf-spri… Alvaro Retana
- [spring] Re: WGLC Chair review of draft-ietf-spri… Greg Mirsky
- [spring] Re: WGLC Chair review of draft-ietf-spri… Alvaro Retana
- [spring] Re: WGLC Chair review of draft-ietf-spri… Greg Mirsky