[spring] Mike Bishop's No Objection on draft-ietf-spring-srv6-security-17: (with COMMENT)

Mike Bishop via Datatracker <noreply@ietf.org> Tue, 06 October 2026 21:05 UTC

Received: by mx.ietf.org (Postfix) id 1B9EE50; Tue, 06 Oct 2026 21:05:50 +0000 (UTC)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=ietf.org; s=mail; t=1791320750; h=from:from:reply-to:reply-to:subject:subject:date:date: message-id:message-id:to:to:cc:cc:mime-version:mime-version: content-type:content-type: content-transfer-encoding:content-transfer-encoding; bh=zRo4nMIPaeRQaqm02NEME0Jdv/H2htLEiFYMoGJMqJg=; b=Henz+qZxvvk0kIqU3jOHZ3XKThoBwrnW+1pvPZO+hNzH1uPSzwK38UGMwUxjyWDBd+5xMf WqQPAjVqaPQOVdhjsh7E8tmcZY/rPPoiT1olEUiehlU/gpn56qV/z44he6KELMsKhgMCJt lSKIMdnVpuPHQ/hcnzh5zw66IuPVdm0=
Authentication-Results: ORIGINATING; auth=pass smtp.auth=mail2@ietf.org smtp.mailfrom=noreply@ietf.org
Received: from [10.244.8.109] (gaia.k8s.ietf.org [4.156.85.76]) by mail2.ietf.org (Postfix) with ESMTP id D5B5E13A4488A; Tue, 6 Oct 2026 14:05:49 -0700 (PDT)
MIME-Version: 1.0
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: 7bit
From: Mike Bishop via Datatracker <noreply@ietf.org>
To: The IESG <iesg@ietf.org>
X-Test-IDTracker: no
X-IETF-IDTracker: 12.79.2
Auto-Submitted: auto-generated
Precedence: bulk
Message-ID: <179132074973.1016.10868217319970935789@dt-datatracker-678f7b55dd-z6pql>
Date: Tue, 06 Oct 2026 14:05:49 -0700
Message-ID-Hash: WTYDZSC7JCYKMQCU4BZ3NL5AH4N5RAVL
X-Message-ID-Hash: WTYDZSC7JCYKMQCU4BZ3NL5AH4N5RAVL
X-MailFrom: noreply@ietf.org
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; loop; banned-address; header-match-spring.ietf.org-0; emergency; member-moderation; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: aretana.ietf@gmail.com, draft-ietf-spring-srv6-security@ietf.org, spring-chairs@ietf.org, spring@ietf.org, zali@cisco.com
X-Mailman-Version: 3.3.10
Reply-To: Mike Bishop <mbishop@evequefou.be>
Subject: [spring] Mike Bishop's No Objection on draft-ietf-spring-srv6-security-17: (with COMMENT)
List-Id: "Source Packet Routing in NetworkinG (SPRING)" <spring.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/spring/fTN6yxiOrJULF72DzbnSbINq1DM>
List-Archive: <https://mailarchive.ietf.org/arch/browse/spring>
List-Help: <mailto:spring-request@ietf.org?subject=help>
List-Owner: <mailto:spring-owner@ietf.org>
List-Post: <mailto:spring@ietf.org>
List-Subscribe: <mailto:spring-join@ietf.org>
List-Unsubscribe: <mailto:spring-leave@ietf.org>

Mike Bishop has entered the following ballot position for
draft-ietf-spring-srv6-security-17: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)


Please refer to https://www.ietf.org/about/groups/iesg/statements/handling-ballot-positions/ 
for more information about how to handle DISCUSS and COMMENT positions.


The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-spring-srv6-security/



----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

# IESG review of draft-ietf-spring-srv6-security-17

CC @MikeBishop

## Comments

### Section 2, paragraph 8
```
     *  [RFC9256] : Segment Routing Policy Architecture

     *  [RFC9491] : Integration of the Network Service Header (NSH) and
        Segment Routing for Service Function Chaining (SFC)

     *  [RFC9524] : Segment Routing Replication for Multipoint Service
```
These RFCs are never mentioned again in the document. If they're relevant, why
not?

RFC 9524 Section 4 has SRv6-specific threats this taxonomy should discuss:
replication-segment loops that "create a storm until ... IPv6 Hop Limit ...
decrements to zero", ICMPv6 Parameter Problem storms toward a spoofed source via
a Replication-SID, the Hop Limit Threshold mitigation, and injection into a P2MP
service. RFC 9256 Section 10 adds SR Policy endpoint spoofing / duplicate
advertisement causing traffic diversion.

### Section 7.1.3, paragraph 11
```
     [RFC8754]'s description of packet filtering.  There are no known
     limitations with filtering on infrastructure addresses, and [RFC9099]
```
...other than the ones you point out in Section 7.1.1?

### Section 7.2, paragraph 1
```
     forwarding decisions within the domain never depend on header fields
     supplied by an untrusted source.  Decapsulating and forwarding the
```
Is this true of flow labels / ECMP?

### Section 7.3, paragraph 7
```
     *  For the lifetime of the pre-shared key validity, an internal
        attacker who does not have access to the pre-shared key can
```
Doesn't section 4 define an attacker without the keys to be external? "An
internal attacker" who is external by definition seems inherently contradictory.

## Nits

All comments below are about very minor potential issues that you may choose to
address in some way - or ignore - as you see fit. Some were flagged by
automated tools (via https://github.com/larseggert/ietf-reviewtool) so there
will likely be some false positives. There is no need to let me know what you
did with these suggestions.

### Typos

#### Section 5, paragraph 13
```
-          amplification by increasing the number hops that each packet is
+          amplification by increasing the number of hops that each packet is
+                                                 +++
```

#### Section 6.3.4.1, paragraph 1
```
-    PCE/PCCC in an SR domain, thereby increasing the risk of compromise
+    PCE/PCECC in an SR domain, thereby increasing the risk of compromise
+          +
```

#### Section 7.1.3, paragraph 8
```
-    making it more simple to filter traffic at the edge of the SR
-              -----
+    making it simpler to filter traffic at the edge of the SR
+                    +
```

#### Section 7.2, paragraph 1
```
-    directly from untrusted-facing interfaces.This is a specific case of
+    directly from untrusted-facing interfaces. This is a specific case of
+                                              +
```

### Section 2, paragraph 9

Who is "we"? The IETF? The WG? The authors? In general, first person should
be avoided.

## Notes

This review is in the ["IETF Comments" Markdown format][ICMF]. You can use the
[`ietf-comments` tool][ICT] to automatically convert this review into
individual GitHub issues. Review generated by the [`ietf-reviewtool`][IRT].

[ICMF]: https://github.com/mnot/ietf-comments/blob/main/format.md
[ICT]: https://github.com/mnot/ietf-comments
[IRT]: https://github.com/larseggert/ietf-reviewtool