[Suit] Re: Gorry Fairhurst's No Objection on draft-ietf-suit-trust-domains-10: (with COMMENT)

Brendan Moran <brendan.moran.ietf@gmail.com> Tue, 22 July 2025 12:23 UTC

Return-Path: <brendan.moran.ietf@gmail.com>
X-Original-To: suit@mail2.ietf.org
Delivered-To: suit@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id 792A04863231; Tue, 22 Jul 2025 05:23:37 -0700 (PDT)
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -2.099
X-Spam-Level:
X-Spam-Status: No, score=-2.099 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, FREEMAIL_FROM=0.001, RCVD_IN_DNSWL_NONE=-0.0001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001] autolearn=unavailable autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=pass (2048-bit key) header.d=gmail.com
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id nrQPjWTXvLZq; Tue, 22 Jul 2025 05:23:37 -0700 (PDT)
Received: from mail-pj1-x1031.google.com (mail-pj1-x1031.google.com [IPv6:2607:f8b0:4864:20::1031]) (using TLSv1.3 with cipher TLS_AES_128_GCM_SHA256 (128/128 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id 636E0486257D; Tue, 22 Jul 2025 05:20:21 -0700 (PDT)
Received: by mail-pj1-x1031.google.com with SMTP id 98e67ed59e1d1-311e2cc157bso4572398a91.2; Tue, 22 Jul 2025 05:20:21 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20230601; t=1753186820; x=1753791620; darn=ietf.org; h=content-transfer-encoding:cc:to:subject:message-id:date:from :in-reply-to:references:mime-version:from:to:cc:subject:date :message-id:reply-to; bh=rG8Cv16iKI5IVw9cfTQO4tuRTlU2axYwhFKQXyaNbIw=; b=flBWme9uNiB8hQeHRjQTP4UUwMEN5MSm5gbURJR4wC+FPmug9dUqg9qPpjssP9cYv9 U0B5MUohctAfVGGzwd5IRe1wsjAJD677Lmb1/pHqVdfBNrOePAZCZQRgkw7i676vo+L3 nF7HM7t9AQTZsTpXjwU1MUmCnxljctxVef9ota5yVdcfETZUNykZ18xXOoq5JHNX5tnp N3Z6abW2dSi08V4itg7clPgWL/9e5urRL2uik/dlsiyiaPocl9RGNizuW2ACHKebhYYu vmfSFNhJoD4dwnz+SGPSWz9dRpklBBjnh7Q9l2rpuKt6KW/9aiFRLvC18SQqSJ0XF2Q/ jhQA==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20230601; t=1753186820; x=1753791620; h=content-transfer-encoding:cc:to:subject:message-id:date:from :in-reply-to:references:mime-version:x-gm-message-state:from:to:cc :subject:date:message-id:reply-to; bh=rG8Cv16iKI5IVw9cfTQO4tuRTlU2axYwhFKQXyaNbIw=; b=htPOaDNw0O2GkhQm7LdWQ6i2aV3Ob0qPcqiIFSbuQPL2ibeEhN01kyJgjJInFomMJ9 2urkhkEpu7BANboqbctg20ZR9C1McsfhWIgEk+dEEbwh2oCHCYmJttXfz63nl8Zzv72C PsDp316qEaixOKlAZDS8YCm/bDgGKXdeh5yp6sXaOCJotfJuAoGPgrIBPCxQmD7HP7Hk RXlxyYR/qo+JsmAPz/FiEKcXmF3TdQNatp/ThVguLRgZskBnlGQnhCXk8K8te619nVdI tsDhK+I1tNdPQpILWnEFJczDQOrydknUV7qNuAmV8pPrBAkIXCXX7NFYUw7Nl56NQ6nw ky8w==
X-Forwarded-Encrypted: i=1; AJvYcCUI7ZtQVBWpMT5ijniX+7Wo2IH6BefgctWj+1yjSe8p8nsrryYVqCV5eY2ivjSqk9lhiaQvJQ==@ietf.org, AJvYcCWn8ISCnAzpWCxDnFtA2XE4XSx9fWTRriONCuz8FJQkBLqxbjQU/NSe419ShqQ8PeSYmpUm3E9HIA/2ibc=@ietf.org, AJvYcCXA0kEdlFJTysA9R2yzBf1ZNVCeGisrJMAd9/N/EE/HA7ucX0NekzhW1GNd48rAjav7bF1Xmu6bo6ymwxaZf3RvQ8mu0nmLGSbR2HbU+A==@ietf.org
X-Gm-Message-State: AOJu0YxUaqjMJVai/2C8qbqZzFgtA6T2J3eVmTZRjDC/17lFnJ+ezI9Q esq/GbGT/Jn3/p50OzsQq1aLoi7Gt54fCkIotNMvPEecLQOk4X6xwrLV6m006QfkRO/59YzYR8Q OTgRbwhWnIOzg3uIn3awuXrGZjRa3/uVdOfcm
X-Gm-Gg: ASbGncvhVEACyYBJbSYqod6CS5pRUvRW5GTxvxlf7IZIl1OVgfvoQugf4EqlPPkeM1y vNhJuWvfTC9YX/m+b4fCnJ7R8ftKt6tewg3N6Ju46anMDJ/t5JmP7h41iww00YHkCxmCYnDb4l+ +tT5rbDfeDs+8Ir1CURXRqiFUJntqZ9GwbPlpqmU0zHTQnEOJAGxqm5Q/nruGLnmoRwmnjr/5j5 eWLAjIxPYB+1EtXgRo=
X-Google-Smtp-Source: AGHT+IHPpS5oilnq6t5vrnr1S6kiKd8W84gdwvTMwQ5z1LQ04UxwKsrcbvSUR41/rIMpZMP50CtSjDqnejWGSKC9nFI=
X-Received: by 2002:a17:90b:2ecd:b0:313:20d2:c99b with SMTP id 98e67ed59e1d1-31c9e6f680emr30841256a91.9.1753186820273; Tue, 22 Jul 2025 05:20:20 -0700 (PDT)
MIME-Version: 1.0
References: <174478868450.1354916.15943053909594624224@dt-datatracker-64c5c9b5f9-hz6qg>
In-Reply-To: <174478868450.1354916.15943053909594624224@dt-datatracker-64c5c9b5f9-hz6qg>
From: Brendan Moran <brendan.moran.ietf@gmail.com>
Date: Tue, 22 Jul 2025 13:20:09 +0100
X-Gm-Features: Ac12FXyYOUrMVpwdiHSkONKxndN8UY3qHZP2VsCqJyNP3YvI-7LbADSyUjaHjDo
Message-ID: <CAPmVn1O16=TWjRVzj8m3VoU=awrEvhSDD3Tk4FKQ1AHDjdyUWg@mail.gmail.com>
To: Gorry Fairhurst <gorry@erg.abdn.ac.uk>
Content-Type: text/plain; charset="UTF-8"
Content-Transfer-Encoding: quoted-printable
Message-ID-Hash: PUFDLZAGZKDIN53RLYPEXR6K6PQYIOSN
X-Message-ID-Hash: PUFDLZAGZKDIN53RLYPEXR6K6PQYIOSN
X-MailFrom: brendan.moran.ietf@gmail.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-suit.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: The IESG <iesg@ietf.org>, draft-ietf-suit-trust-domains@ietf.org, suit-chairs@ietf.org, suit@ietf.org, dthaler1968@gmail.com, dave.thaler.ietf@gmail.com
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [Suit] Re: Gorry Fairhurst's No Objection on draft-ietf-suit-trust-domains-10: (with COMMENT)
List-Id: Software Updates for Internet of Things <suit.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/suit/2Bt7s13zK218RW2ce1ZdQnkFXoI>
List-Archive: <https://mailarchive.ietf.org/arch/browse/suit>
List-Help: <mailto:suit-request@ietf.org?subject=help>
List-Owner: <mailto:suit-owner@ietf.org>
List-Post: <mailto:suit@ietf.org>
List-Subscribe: <mailto:suit-join@ietf.org>
List-Unsubscribe: <mailto:suit-leave@ietf.org>

Hi Gorry,

Thank you for your review.

1. I believe the latest version corrects Thomas's one remaining nit.

2. CDDL is now a normative reference and it is referenced both at
first mention and in the appendix that details the full CDDL.

3. The TEEP Architecture (RFC9397) is now referenced in the
terminology section. This defines terminology such as TEE.

4. The latest version uses the explicit element name, rather than saying "this"

5. I have added captions to the tables in the latest version.

6. The CoSWID reference has been removed.

7. This section has been reworded to be clearer about the intended
restrictions: Future commands define their own restrictions.

8. A new line has been added that explains the consequences of not
checking that all components in a component set are specified.

Best Regards,
Brendan

On Wed, Apr 16, 2025 at 8:31 AM Gorry Fairhurst via Datatracker
<noreply@ietf.org> wrote:
>
> Gorry Fairhurst has entered the following ballot position for
> draft-ietf-suit-trust-domains-10: No Objection
>
> When responding, please keep the subject line intact and reply to all
> email addresses included in the To and CC lines. (Feel free to cut this
> introductory paragraph, however.)
>
>
> Please refer to https://www.ietf.org/about/groups/iesg/statements/handling-ballot-positions/
> for more information about how to handle DISCUSS and COMMENT positions.
>
>
> The document, along with other ballot positions, can be found here:
> https://datatracker.ietf.org/doc/draft-ietf-suit-trust-domains/
>
>
>
> ----------------------------------------------------------------------
> COMMENT:
> ----------------------------------------------------------------------
>
> Thank you for preparing this I-D. I do not see any transport-related concerns.
>
> I do have some comments which ought to be helpful in preparing the next
> revision of this document:
>
> 1. Thanks to Thomas Fossati, for the IoT directorate review. Please consider
> the comments in:
> review-ietf-suit-trust-domains-10-iotdir-telechat-fossati-2025-03-06-00.
>
> 2. CDDL: It would be helpful to readers to define “CDDL” in the definitions of
> section 2. I think this should be supported by a normative reference.
>
> 3. Definitions: I think it would be helpful to also define TEE here as Trusted
> Execution Environment in Section 2. I see there are discrepancies in the
> different SUIT documents, is it possible to ensure that all documents have a
> common set of definitions - this could be achieved by
>
> 4. RFC 1119: I’m quite a fan of RFC2119 requirements being clear when read as
> individual sentences - e.g., in the following I would suggest that you replace
> “This” by saying what is optionally to be implemented. “This element is
> OPTIONAL for Recipients to implement.”
>
> 5. Table: It is helpful to add a caption to tables to describe the table
> contents (see Table 1).
>
> 6. Figure: I appreciated the figure at the end of section 4. CoSWID is not
> defined, please define in caption or definitions. This figure would benefit
> from a caption.
>
> 7. RFC 1119: I couldn’t work-out what was intended to be permitted by the
> following:
>       “Commands defined outside of this document and
>       [I-D.ietf-suit-manifest] MAY have additional restrictions.”
> - Is this a “MAY” extend the command set - i.e. permitting extension in some
> way, if so please clarify this by other RFCs... or some other extension
> mechanism. - If this simply saying there might be further restrictions, then I
> think it ought to be a little more explained what this impacts. I expect this
> is just a need for better wording.
>
> 8. Finally, I do have a concern that I would like to see addressed on the text
> around this: “If a Recipient supports groups of interdependent Components (a
> Component Set), then it SHOULD verify “ - I appreciate the way that this I-D
> does already provide an explanation of the implication of not following all the
> other recommendations (SHOULDs). It would seem useful to also explain here what
> happens if an implementation does not verify this, or alternatively to motivate
> explicitly why it is good to verify.
>
>
>